Slideshow is not translated on Kubuntu 16.04 LTS

Bug #1512834 reported by Andrea Crescentini on 2015-11-03
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
High
Unassigned
ubiquity-slideshow-ubuntu (Ubuntu)
High
Unassigned

Bug Description

The installation slideshow on Kubuntu 16.04 is not translated to italian neither to any other translation.

Related branches

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1512834

tags: added: iso-testing

Also it says 15.10 in the 1st screen ;-)

Changed in ubiquity (Ubuntu):
status: New → Confirmed

Pls look at the Release-Schedule: https://wiki.ubuntu.com/XenialXerus/ReleaseSchedule

This is considered to be very early to demand it beeing translated in all available languages.

tags: added: kubuntu xenial
affects: ubiquity (Ubuntu) → ubiquity-slideshow-ubuntu (Ubuntu)
description: updated
Brian Murray (brian-murray) wrote :

The po file does exist:

[ 2:46PM 10377 ] [ bdmurray@impulse:/tmp/ubiquity-slideshow-ubuntu-107 ]
 $ ls po/kubuntu
ace.po bn.po cs.po en_CA.po fi.po gv.po is.po ku.po ne.po ps.po shn.po sr.po ug.po zh_TW.po
af.po br.po cy.po en_GB.po fr_CA.po he.po it.po lt.po nl.po pt_BR.po si.po sv.po uk.po
am.po bs.po da.po eo.po fr.po hi.po ja.po lv.po nn.po pt.po sk.po ta.po ur.po
ar.po ca.po de.po es.po fy.po hr.po kl.po ml.po ny.po ro.po slideshow-kubuntu.pot tg.po uz.po
ast.po <email address hidden> dv.po et.po gd.po hu.po km.po mr.po oc.po ru.po sl.po th.po vi.po
be.po ce.po el.po eu.po gl.po hy.po kn.po ms.po pa.po sd.po sn.po tl.po zh_CN.po
bg.po csb.po en_AU.po fa.po gu.po id.po ko.po nb.po pl.po se.po sq.po tr.po zh_HK.po

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
importance: Undecided → High

Ubiquity is a newer version in Xenial -> https://bugs.launchpad.net/ubuntu/+source/ubiquity than in Wily

but Ubiquity-slideshow is still in the wily's version (107) for xenial ->

http://packages.ubuntu.com/search?keywords=ubiquity-slideshow-kubuntu&searchon=names&suite=all&section=all

This means obvoiously still in the merged status?

It's also possible to look at the translation status -> https://translations.launchpad.net/ubuntu/xenial/+source/ubiquity-slideshow-ubuntu/+pots/ubiquity-slideshow-kubuntu

Should this bug get assigned to "Ubuntu translators"?

@ Andrea: Could you take a look at ->
https://translations.launchpad.net/ubuntu/xenial/+source/ubiquity-slideshow-ubuntu/+pots/ubiquity-slideshow-kubuntu/it/8/+translate

"KDE Software Compilaation" was the naming for KDE-4 - now it's called KDE Frameworks5 (in short KF5) which contains the Applications. My italian is not good enough for proper translation give it a try ;-) This was unrecognized in Wily.

Jiri Grönroos (jiri-gronroos) wrote :

This probably affects all the languages listed above, at least the current Finnish Xenial po refers to 15.04:

https://translations.launchpad.net/ubuntu/xenial/+source/ubiquity-slideshow-ubuntu/+pots/ubiquity-slideshow-kubuntu/fi/+translate?batch=10&show=all&search=thank+you

Please update the pot file as it's still possible to get the installer translated before the release of 16.04 LTS.

summary: - Missing italian slideshow on Kubuntu 16.04
+ slideshow-kubuntu.pot in Xenial is not updated to refer 16.04 LTS

@Flames_in_Paradise: Earlier in December you said that it was "very early" for a report of this kind. What about now? I looked at Xenial translation statistics of ubiquity-slideshow-kubuntu into Italian and it looks like all the strings are translated and the last change was in October 2015.

When is the time when those translations should start to appear in the installer of Kubuntu 16.04 daily build? Or what needs to happen or be done before that happens?

Actually I’m a localizer of another language. And I just tried the latest daily build of Kubuntu 16.04 and found out that I could not get the slide show to appear in any other language than English even though I tried a few languages (Italian, German, French and Finnish) where the slide show was fully or almost fully translated according to translation statistics.

Earlier there have been similar reports for Kubuntu 15.04[1] and Kubuntu 15.10[2] and those don't seem to have been solved. That means that for example in the release build of Kubuntu 15.10 the slide show isn't properly translated and the issue seems technical rather than an issue of untranslated strings. It would be nice if this situation could be avoided in Kubuntu 16.04.

[1] https://bugs.launchpad.net/ubuntu/+source/ubiquity-slideshow-ubuntu/+bug/1429475
[2] https://bugs.launchpad.net/ubuntu/+source/ubiquity-slideshow-ubuntu/+bug/1478910

Is there any way I can help to make sure that the slide show appears translated in the final 16.04 build?

description: updated

@ Lasse:

The issue seems to be fixed for Xenial:

https://translations.launchpad.net/ubuntu/xenial/+source/ubiquity-slideshow-ubuntu/+pots/ubiquity-slideshow-kubuntu

I'll just cross-reference our other bug on this subject #1530213

> Is there any way I can help to make sure that the slide show appears translated in the final 16.04 build?

Just go for the translation suggestions ;-)

Lasse Liehu (lliehu) wrote :

To fix the reported issue ”The installation slideshow on Kubuntu 16.04 is not translated to italian neither to any other translation.” it's not enough to update the pot file and complete translations on Launchpad. Anyway, I tracked and fixed the issue. Here is a tested patch. Seems funny that the fix is so simple, but sometimes these things happen.

summary: - slideshow-kubuntu.pot in Xenial is not updated to refer 16.04 LTS
+ Slideshow is not translated on Kubuntu 16.04 LTS
Lasse Liehu (lliehu) wrote :

It seems this bug was introduced while mass adjusting coding style in http://bazaar.launchpad.net/~ubuntu-installer/ubiquity/trunk/revision/6194

tags: added: patch

Thanks Lasse, that's a wonderfulk Easter-🎁.

Now we only have to wait for someone from the Kubuntu-Devs to pick that up.

I've stopped doing translations on this subject for Kubuntu, as many others too - since it's worthless w/o the change.

Anyway there is other acitivity in the bazaar-branch, which seems to be proposed for merge.

Martin Pitt (pitti) wrote :

Unsubscribing ~ubuntu-release, there is nothing to review/approve here.

Sorry, I am trying. I don't understand this package at all. I have never worked with it. All I get is failure, but I am certain it is me and not the patch. Will probably have to wait for Philip to return.
Scarlett

@ Scarlett

Did Yofel/Philip have some spare time to look into that yet?

I also think the kubuntu-team can probably ask for some assistance @ IRC ubuntu-installer. They are familiar with the code behind and look human-friendly to me, as well as higly competent.

If they can't help, pls assign this to 16.04-milestone-updates.

>OT< Just assigned Jon to that bug, as I saw he is still registered wt LP <OT>

* correction: not assigned but, subscribed Jon. *

Timo Jyrinki (timo-jyrinki) wrote :

I've prepared an update, both bzr and PPA, but I'm currently unable to test myself (for some reason, in my qemu at least I can't go "Forward" from the second page of installer).

If you're able to test it, can you test it from ppa:timo-jyrinki/grilo (don't mind the PPA name). That is, get a Kubuntu live image, add the PPA, upgrade (check that you get ubiquity packages with version 2.21.55) and then launch the installer and go far enough you get the slideshow - in your own language.

The debdiff is at https://launchpadlibrarian.net/253401826/ubiquity_2.21.54_2.21.55.diff.gz - there was one change already brewing in lp:ubiquity, and I added a changelog entry for that too.

Lasse Liehu (lliehu) wrote :

I was able to test the update with VMware Player. Slideshow appeared translated in Finnish apart from a few messages that were changed in 16.04. Otherwise I didn't see anything abnormal. Installation also seemed to finish successfully.

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Triaged
Andrea Crescentini (cresh-it) wrote :

I've tested the new versione 2.21.55 with Parallels 11 and now slideshow is working fine. Some translation is missing but I think that is not related to this problem.
Installation also finish successfully.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 2.21.56

---------------
ubiquity (2.21.56) xenial; urgency=medium

  * Update translations from Launchpad. (LP: #1569232)
  * debian/ubiquity.ubiquity.service: Start console ttys for debugging during
    an installation. (LP: #1567194)
  * data/oem-config.target: also enable console TTYs for the OEM configuration
    target/service.

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 12 Apr 2016 21:42:50 -0400

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

(2.21.55 was included in the .56)

ubiquity (2.21.55) xenial; urgency=medium

  [ Jean-Baptiste Lallement ]
  * autopilot: Merged autopilot tests fixes from Chris Lee. Thanks

  [ Timo Jyrinki ]
  * Fix Kubuntu slideshow not translated, thanks to Lasse Liehu for the
    patch (LP: #1512834)
  * Automatic update of included source packages: netcfg 1.135ubuntu3.

  [ Luke Yelavich ]
  * Automatic update of included source packages: console-setup
    1.108ubuntu14.

 -- Luke Yelavich <email address hidden> Wed, 13 Apr 2016 09:38:21 +1000

Timo Jyrinki (timo-jyrinki) wrote :

The translations should also be updated now: https://launchpad.net/ubuntu/+source/ubiquity-slideshow-ubuntu/111

Please test with the next daily-image but also check the version number of the slideshow package(s). The 111 migrated to the release pocket 1 hour ago, but the daily image creation may or may not have started before that.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Released
Lasse Liehu (lliehu) wrote :

Seems to work fine here with daily build of today, 2016-04-14.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers