Kubuntu Vivid Ubiquity slideshow is missing translations

Bug #1429475 reported by Skyman on 2015-03-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubiquity-slideshow-ubuntu (Ubuntu)
Low
Unassigned

Bug Description

During copying and installing the users sees a slideshow which is missing german translation.
Screenshot attached.

Skyman (sskyman) wrote :
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

This looks a bit odd, because the string itself seems to have been translated long ago (https://translations.launchpad.net/ubuntu/vivid/+source/ubiquity-slideshow-ubuntu/+pots/ubiquity-slideshow-kubuntu/de/+translate?batch=10&show=all&search=designed+to+be+easy)

I took a quick look at some of the other translation bugs you've filed recently, and while I don't think they belong to the xorg package, I don't know where to move them either.

Changed in xorg (Ubuntu):
status: New → Confirmed
affects: xorg (Ubuntu) → ubiquity-slideshow-ubuntu (Ubuntu)
tags: added: vivid
Skyman (sskyman) wrote :

It is not only the string on the bottom, it is the whole side(s of the slideshow).
And there is a german translation missing. For example: https://translations.launchpad.net/ubuntu/vivid/+source/ubiquity-slideshow-ubuntu/+pots/ubiquity-slideshow-kubuntu/de/+translate?batch=10&show=all&search=Thank+you+for+choosing

How can I see the translations for previous versions? Maybe I can help by translating ...

To which packages all the bugs in the installation process belong wasn't and isn't really sure for me. Most the time the package search during the bug filing tells me there are to many hits (for example if i search for "installer").

Hans Joachim Desserud (hjd) wrote :

> It is not only the string on the bottom, it is the whole side(s of the slideshow).

Oh, you're right. I only saw the big bold text at first. Is this also the case for the other slideshow pages?

> To which packages all the bugs in the installation process belong wasn't and isn't really sure for me.
No problem, I've done some digging and will leave comments on a couple of them. Found them by searching for the strings to see which translation templates they were stored in, so presumably they are the strings in question.

>How can I see the translations for previous versions? Maybe I can help by translating ...

If you click on translations on the top of the page you will see the various Ubuntu releases with translation templates in all languages for that particular package. For instance https://translations.launchpad.net/ubuntu/+source/ubiquity-slideshow-ubuntu. When starting out, you'll be able to add suggestions for translations which a member of one of the translation teams will the review (and hopefully approve).

If you want to get started translating, you might want to take a look at http://community.ubuntu.com/contribute/translations/ and seek out the german translation team here on Launchpad (https://launchpad.net/~ubuntu-l10n-de).

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
importance: Undecided → Low
Changed in ubuntu-translations:
importance: Undecided → Low
status: New → Confirmed
importance: Low → Undecided
Skyman (sskyman) wrote :

>> It is not only the string on the bottom, it is the whole side(s of the slideshow).
> Oh, you're right. I only saw the big bold text at first. Is this also the case for the other slideshow pages?
AFAIR this also applies for the following slides.

> >How can I see the translations for previous versions? Maybe I can help by translating ...
> If you click on translations on the top of the page you will see the various Ubuntu releases with translation templates in all languages for that particular package. For instance https://translations.launchpad.net/ubuntu/+source/ubiquity-slideshow-ubuntu. >When starting out, you'll be able to add suggestions for translations which a member of one of the translation teams will the review (and hopefully approve).
I added translation for two untranslated strings. But the rest seems to be translated. But maybe I'm looking at the wrong place.

Hans Joachim Desserud (hjd) wrote :

>I added translation for two untranslated strings. But the rest seems to be translated. But maybe I'm looking at the wrong place.

Don't worry, that should be the right place. The strings are translated on Launchpad and then every once in a while the latest translations are collected and added to the software packages. (I'm not familiar with that part of the process though, so I don't know the frequency or the details.) What I do know, is that I managed to find the directory with the various translations for the kubuntu-slideshow in the source code [1]. And from what I can see, among these are the german file which seems to contain translations for most the strings [2]. So if they don't show up it might look like something is wrong somewhere.

If the rest of the installation was in german as expected but the slideshow was in the original language, it might be something to do when switching to the slideshow. When I get the time, I'll run the Vivid installation in a virtual machine to see if I can reproduce the issue (and also see whether it affects other languages)

[1] http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/vivid/ubiquity-slideshow-ubuntu/vivid/files/head:/po/kubuntu/
[2] http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/vivid/ubiquity-slideshow-ubuntu/vivid/view/head:/po/kubuntu/de.po

Hans Joachim Desserud (hjd) wrote :

>When I get the time, I'll run the Vivid installation in a virtual machine to see if I can reproduce the issue (and also see whether it affects other languages)

Checked with kubuntu daily image from today, and both German and Norwegian will display the original version of the slideshow. Presumably more/all languages are affected. The installer itself displays translated strings so it seems to be when switching to the slideshow locale information is "lost" or not applied.

Checked with the an Ubuntu image (slightly older but from after this bug report was filed), and there the slideshow was translated as expected*. So it looks like either something is slightly different with the kubuntu-slideshow or it is loaded in a different way.

*Well, except the welcome banner, but I found some other bug reports on this one, like bug 1288077.

Jonathan Riddell (jr) on 2015-03-22
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
milestone: none → ubuntu-15.04
tags: added: kubuntu
Jonathan Riddell (jr) on 2015-03-26
summary: - Kubuntu Vivid 1 Beta 15.04 installation: Slideshow is missing german
- translation
+ Kubuntu Vivid Ubiquity slideshow is missing translations
Martin Pitt (pitti) wrote :

Translations got updated in https://launchpad.net/ubuntu/+source/ubiquity-slideshow-ubuntu/97 . If that doesn't fix it, then the translations need to be done on Launchpad first. Please reopen in that case.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Released
Skyman (sskyman) wrote :

Bug still exists in release Kubuntu 15.04 amd64.

Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Fix Released → Confirmed
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
milestone: ubuntu-15.04 → vivid-updates
Changed in ubuntu-translations:
importance: Undecided → Low
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
milestone: vivid-updates → none
no longer affects: ubuntu-translations
Changed in ubiquity-slideshow-ubuntu (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers