Plural strings not translated in Transmission

Bug #760761 reported by Hendrik Knackstedt on 2011-04-14
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Transmission
Fix Released
Low
Unassigned
Ubuntu Translations
Low
Unassigned
transmission (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: transmission

Please see attached screenshot. The words »minutes«, »seconds« (not shown in screenshot, but would appear behind »minutes« of course) and »pieces« in transmission cannot be translated in Launchpad and therefore show up in English.

The attached screenshot is just an example. This issue exists for the whole program.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: transmission (not installed)
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Thu Apr 14 16:43:02 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta i386 (20110405)
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: transmission
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Hendrik Knackstedt (hennekn) wrote :
Hendrik Knackstedt (hennekn) wrote :

I found some other strings that are translated but are only displayed in English.

I believe it should be reported upstream at http://www.transmissionbt.com/

David Planella (dpm) on 2011-04-18
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Low
Charles Kerr (charlesk) wrote :

Christian: I'm one of the upstream devs and would be happy to resolve this issue but am not sure what the cause is. It looks like somehow the strings being passed to g_dngettext() via Transmission's gtr_negettext() wrapper aren't being translated. Perhaps the function is being called incorrectly...

Gabor Kelemen (kelemeng) wrote :

jordan: if you use a custom function for plurals, you also need to tell intltool to expect that, and treat it accordingly. To do this, you need to have a Makevars file in po/ and it should contain the following line:

XGETTEXT_OPTIONS = --keyword=_ --keyword=N_ --keyword=Q_ --keyword=gtr_ngettext:1,2

Charles Kerr (charlesk) wrote :

Gabor, thanks for the pointer. Looking through the Transmission code, it looks like simple ngettext() calls would work everywhere the gtr_ngettext() calls are now, so it seems more straightforward to get rid of the wrapper instead of propping it up.

Does this look right to you?

https://trac.transmissionbt.com/changeset/12412/

Gabor Kelemen (kelemeng) wrote :

jordan: that's also good, thanks!

Charles Kerr (charlesk) on 2011-05-03
Changed in transmission (Ubuntu):
status: New → Confirmed
Changed in transmission:
status: New → Fix Committed
importance: Undecided → Low
Gabor Kelemen (kelemeng) wrote :

Can we get this backported to Natty?

El dj 05 de 05 de 2011 a les 20:09 +0000, en/na Gabor Kelemen va
escriure:
> Can we get this backported to Natty?
>

It just needs someone who cares about this particular bug to file an SRU
request:

https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Gabor Kelemen (kelemeng) on 2011-05-28
summary: - »Minutes« and »seconds« as well as »pieces« not translateable
+ Plural strings not translated in Transmission
Sebastien Bacher (seb128) wrote :

the issue is fixed in the Oneiric version

Changed in transmission (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Released
Changed in transmission:
status: Fix Committed → Fix Released
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers