transmission-daemon have rpc disabled by default

Bug #571739 reported by Krzysztof Klimonda on 2010-04-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
transmission (Ubuntu)
Low
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: transmission

The recent fix for bug 542194 has disabled RPC by default for transmission-daemon for new users. It requires them to enable rpc manually which is further complicated by the bug 571097 as changing /etc/transmission-daemon/settings.json doesn't work as expected.

TEST CASE:
1) With transmission-daemon 1.92-0ubuntu2 installed you can see that running transmission-remote -n transmission:transmission -l will result in:
    [15:21:03.394] transmission-remote: (localhost:9091) Couldn't connect to server
2) purge package transmission-daemon (it will remove user configuration but that problem only affects users who do a clean install)
3) install transmission-daemon from lucid-proposed, running transmission-remote -n transmission:transmission -l should result in:
    ID Done Have ETA Up Down Ratio Status Name
    Sum: None 0.0 0.0

Changed in transmission (Ubuntu):
status: New → Triaged
importance: Undecided → Low
tags: added: regression-release
description: updated
Nick Cave (njcave) wrote :

It can be enabled manually from the Transmission GUI:

Edit > Preferences > Web > Enable web client

Charles Kerr (charlesk) wrote :

> It can be enabled manually from the Transmission GUI

This ticket is about the daemon though...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.93-2ubuntu1

---------------
transmission (1.93-2ubuntu1) maverick; urgency=low

  * Merge from Debian unstable (LP: #574435), remaining changes:
    - debian/control:
      + Added liblaunchpad-integration-dev and lsb-release to Build-Depends
    - debian/rules:
      + create a po template during package build.
    - debian/patches/01_lpi.patch:
      + integrate transmission with launchpad
    - debian/patches/20_add_x-ubuntu-gettext-domain.diff:
      + add x-ubuntu-gettext-domain to .desktop file.
    - debian/control, debian/rules:
      + build transmission gtk+ client with both gconf and libcanberra support.
    - debian/patches/dont_build_libevent.patch:
      + disable libevent in configure.ac and Makefile.am because we use autotools
        to regenerate build files.
    - debian/patches/updateminiupnpcstrings_double_escape_slash.patch:
      + Deleted as the bug is fixed upstream
  * Fixes bugs:
    - Fix a bug in transmission-daemon that caused it to overwrite symlink to
      settings.json and in the result ignore changes made to
      /etc/transmission-daemon/settings.json (LP: #571097)
    - A fix for LP #542194 disabled rpc in transmission-daemon by default. Make
      it enabled for new users (LP: #571739)
  * Refreshed 99_autoreconf.patch
 -- Krzysztof Klimonda <email address hidden> Sun, 16 May 2010 21:20:39 +0200

Changed in transmission (Ubuntu):
status: Triaged → Fix Released

Accepted transmission into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in transmission (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed

transmission-cli and transmission-daemon 1.93 from -Proposed on 10.04 appears to fix the problem.

$ transmission-remote -n transmission:transmission -l
ID Done Have ETA Up Down Ratio Status Name
Sum: None 0.0 0.0

Martin Pitt (pitti) on 2010-06-20
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package transmission - 1.93-0ubuntu0.10.04.1

---------------
transmission (1.93-0ubuntu0.10.04.1) lucid-proposed; urgency=low

  * Merge from Debian unstable (LP: #574435), fixes bugs:
  * debian/patches/follow_symlinks.patch
    - Fix a bug in transmission-daemon that caused it to overwrite symlink to
      settings.json and in the result ignore changes made to
      /etc/transmission-daemon/settings.json (LP: #571097)
  * debian/patches/enable_rpc_by_default.patch
    - A fix for LP #542194 disabled rpc in transmission-daemon by default. Make
      it enabled for new users (LP: #571739)
  * debian/transmission-daemon.{postinst,postrm}:
    - Fix permissions for /etc/transmission-daemon/ directory.
  * Refreshed 99_autoreconf.patch
 -- Krzysztof Klimonda <email address hidden> Sun, 16 May 2010 20:32:16 +0200

Changed in transmission (Ubuntu Lucid):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers