totem-mozilla claims RTSP mime type but can't play them

Bug #66902 reported by James Troup on 2006-10-19
42
Affects Status Importance Assigned to Milestone
Totem
Unknown
Medium
totem (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

In Edgy, if you go to: http://www.bbc.co.uk/radio/aod/radio2.shtml

totem-mozilla will pop up a dialog informing you that it doesn't know how to play RTSP streams. Which is nice, but I don't want it to, I (ok, the user) has realplayer installed and it does know how to play RTSP. This is a regression from dapper.

Sebastien Bacher (seb128) wrote :
Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → High
status: Unconfirmed → Confirmed
Changed in totem:
status: Unknown → Rejected
Daniel Holbach (dholbach) wrote :

 Comment #1 from chpe (developer, points: 25)
2006-10-26 20:39 UTC [reply]

IMHO you simply shouldn't ship the complex plugin (--disable-complex-plugin).

Comment #2 from Bastien Nocera (totem developer, points: 24)
2006-10-26 22:05 UTC [reply]

The complex plugin doesn't work with the currently released GStreamer, but does
with xine-lib. GStreamer CVS has RTSP support.

IMO, this is a packaging bug.

Isn't there an issue here with the removal of totem-mozilla as well?

When I attempted to remove the totem-mozilla plugin my entire ubuntu-desktop dissappeared. Seems like the packaging needs to be fixed, no?

-- PASTED TEXT: --
The following packages will be REMOVED:
  totem-mozilla ubuntu-desktop
-- END --

Sebastien Bacher (seb128) wrote :

That upload fixes the bug:

 totem (2.17.3-0ubuntu2) feisty; urgency=low
 .
   * debian/rules:
     - don't build the complex plugin for gstreamer to not take over rtsp
       which can't be played by totem-gstreamer yet (Ubuntu: #66902)

Changed in totem:
status: Confirmed → Fix Released

But what about us running edgy - can we have this fix as well?

On Thursday 21 December 2006 21:25, Sebastien Bacher wrote:
> That upload fixes the bug:
>
> totem (2.17.3-0ubuntu2) feisty; urgency=low
> .
> * debian/rules:
> - don't build the complex plugin for gstreamer to not take over rtsp
> which can't be played by totem-gstreamer yet (Ubuntu: #66902)
>
> ** Changed in: totem (Ubuntu)
> Status: Confirmed => Fix Released

Le jeudi 21 décembre 2006 à 12:49 +0000, Michael Truscott a écrit :
> But what about us running edgy - can we have this fix as well?

The change needs some time to be tested on the new version before being
considered for backport

Ernst Sjöstrand (ernstp) wrote :

It seems to be working very good now, IMHO. Backport?

Sebastien Bacher (seb128) wrote :

might be a candidate for a backport, low priority though

Ernst Sjöstrand (ernstp) wrote :

Of cource the whole feisty package should not be backported, only adding --disable-complex-plugin to the edgy build of totem as a bugfix.

Ernst Sjöstrand (ernstp) wrote :

Since realplayer was added do edgy commercial today it's really time to put out a totem update for edgy with --disable-complex-plugin!

If you don't do some kind of divert or alternatives thing with the plugin of cource...

app-install-data-commercial (6.1)

    * added channels/opera.desktop
    * added channels/realplayer.desktop

Does Feisty's GStreamer have RTSP support, if so, the Complex plugin be re-enabled.

Changed in totem:
importance: Unknown → Medium
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.