[totem-gstreamer] wont play vcd for "unknown reason"

Bug #43589 reported by jens_acamedia on 2006-05-08
202
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Kaffeine
Confirmed
Undecided
Unassigned
MPlayer
Invalid
Undecided
shiva
Mozilla Firefox
Confirmed
Undecided
Unassigned
Totem
Fix Released
Unknown
VLC media player
Invalid
Undecided
Unassigned
gxine
Confirmed
Undecided
Unassigned
totem (Ubuntu)
Medium
Unassigned
Nominated for Lucid by PRADEEP KOUNDAL

Bug Description

In karmic, one of the actions for a VCD is to open it with totem. This results in an error message.

The command totem is launched with is something like 'totem /media/cdrom0'.

The command 'totem vcd://' gets the VCD playing alright.

dawn@dawn-desktop:~$ LANGUAGE=en_US totem /media/cdrom0
** Message: no file info
** Message: Error: Could not open resource for reading.
vcdsrc.c(421): gst_vcdsrc_start (): /GstPlayBin2:play/GstURIDecodeBin:uridecodebin0/GstVCDSrc:source:
system error: Inappropriate ioctl for device

The command 'totem vcd:///' also gives an error.

Sebastien Bacher (seb128) wrote :

Thanks for your bug. What version of Ubuntu do you use? Could you make a screenshot of the dialog? How do you open the vcd? From the command line? From the menu item?

Changed in totem:
assignee: nobody → desktop-bugs
status: Unconfirmed → Needs Info

i use dapper #5.

totem opens automatically when the vcd is inserted but error happens however which way i start totem. even with "totem vcd://" from terminal.

i can send a screenshot if you want but the error message is the bog-standard and very unhelpful -"can not play disc for unknown reason"

Onkar Shinde (onkarshinde) wrote :

I am having similar problem. But I am using totem-gstreamer.
I have set the option to open totem automatically upon insertion of VCD. The option has command 'totem vcd://'
I have also tried playing disc from Movie->Play disc <disc_name>

In my case the error is
'No URI handler implemented for "vcd".'

gxine playes VCD fine.

totem-gstreamer can not play VCD.

Changed in totem:
status: Needs Info → Confirmed

Just for the record: this also affects Edgy (as of Knot 3)

Onkar Shinde (onkarshinde) wrote :

This is still on edgy. Can someone look into it. It's priority should be high, IMHO. This single problem will make user install totem-xine or mplayer.

Is this really a totem problem? Or is this gnome-vfs problem?

Onkar Shinde (onkarshinde) wrote :

This looks more like gstreamer problem than totem problem.

In gstreamer0.8-misc package there is a lib libgstvcdsrc.so. Also the description of package says that it provides VCD support.

But in all the plugins of gstreamer0.10 there is no such library.

$ gst-inspect-0.8 |grep -i vcd
vcdsrc: vcdsrc: VCD Source
typefindfunctions: video/x-vcd: dat
cdxaparse: cdxastrip: vcd parser

$ gst-inspect-0.10 |grep -i vcd
cdxaparse: cdxaparse: (S)VCD parser
typefindfunctions: video/x-vcd: dat

So it looks like VCD support hasn't been ported from gstreamer 0.8 to 0.10. The status of plugins can be found here, http://gstreamer.freedesktop.org/documentation/plugins.html

This bug is definitively not restricted to gstreamer as it also affects totem-xine.

Changed in totem:
status: Unknown → Unconfirmed

Higher the severity then, please.
I use Edgy and may not play VCDs with totem-gstreamer either.

Feistybird (bryanjen-tw) wrote :

I'm using Fesity, I can't play (s)vcds with totem-gstreamer, totem-xine, gxine, and (G)mplayer/Kmplayer.

totem-xine error: "vcd:///media/cdrom0′ There is no input plugin to handle the location of this movie"
gxine error: segment fault. (and crashed)
mplayer error: Error opening/initializing the selected video_out (-vo) device.

So far only "mplayer vcd://2" works.

Another problem is that ubuntu detects the VCD, mounts automatically to right path (/media/cdromX), but there is no desktop icon appears, and I can't 'eject' the device unless typing commands.

gxine used to work with my previous 6.10 to play (S)VCDs, but not any more after the recent upgrade to Feisty.

Thanks.

Simos Xenitellis  (simosx) wrote :

The upstream bug report at GNOME (http://bugzilla.gnome.org/show_bug.cgi?id=340986) has technical information on adding back VCD support to GStreamer.
Sadly noone has picked up the task yet.

Dapper and Edgy doesn't have any problems playing Video CDs and DVDs. After Feisty upgrade, DVD still plays but not VCDs... on all players (Xine, Kaffeine, MPlayer, VLC, etc). A similar bug has been filed Bug #72737 in kaffeine (Ubuntu) | Kaffeine crashes when trying to play Video CD

Confirming status

Changed in gxine:
status: Unconfirmed → Confirmed
Changed in kaffeine:
status: Unconfirmed → Confirmed
Changed in vlc:
status: Unconfirmed → Confirmed
Changed in mplayer:
status: Unconfirmed → Confirmed

And another thing, I guess this is related to Bug #82307 since Feisty lost the ability to copy .dat files to the hard disk.

Hi all,

I'm having the same problem also in Debian (sid/unstable) here in my IBM Thinkpad T43.

I thought it was a kernel issue, since it happened sometime after I upgrade to a certain kernel version (sorry, can't remember the exact version, about 1 year ago).

After searching for more details last weekend, I found out that this may be a GNOME issue. Not really sure 'though.

But I do able to make VCD play again by doing this before playing:

/etc/init.d/dbus stop

To play the VCD in totem (-xine) run this: totem vcd:// (since without dbus, totem seems to failed to get the Play button to work, so we need to tell totem directly)

To play with xine or gxine is the same (xine vcd:// or gxine vcd://) but (g)xine has VCD selection from the menu, so you should be able to start it directly without any parameter.

I think this info should answer Question #1624, too.

Now, it'd be really great if someone could just fix this issue correctly :-)

Although I haven't found out why we cannot copy .dat files directly from file browser (nautilus) and VCD seems to always failed automounted in my machine here. Things use to worked just fine long time ago.

@Arief Mulya Utama
Stopping dbus didn't affect anything. I still can't play VCDs.
Also, I tried each and every last tip above but none would really work. I'm attaching the latest backtrace from Kaffeine.
I'm also changing this bugs' Importance to Medium.

I got the VCD working, but only on GXine and Xine. We need to install the vcdtools package from universe. Unfortunately, it'll only play if we select VCD0 or VCDO which is available on Xine and GXine. vlc, mplayer, kaffeine, and kmplayer still can't play it (no VCD0). Also, how come the vcdtools package isn't installed by default like in Dapper and Edgy (never had problems playing VCD on them).

Onkar Shinde (onkarshinde) wrote :

The latest version of gstreamer 'bad' plugins contains the VCD plugin ported form gstreamer 0.8. This will be mostly included in Gutsy. So this VCD problem will settle once for all.
Check http://gstreamer.freedesktop.org/releases/gst-plugins-bad/0.10.5.html

Changed in totem:
status: Confirmed → Triaged
suoko (suoko) wrote :

hope the fix will be backported to feisty soon

Barretta (barrett979-gmail) wrote :

Same problem here in Arch

This doesn't seem fixed, even in hardy. Am I wrong?

> This doesn't seem fixed, even in hardy. Am I wrong?

I can't check, since Hardy is too rough right now, doesn't quite work on my machine.

Well, I gave hardy another try in the end.
Result: nothing has changed : the file chooser recognizes the local ISO file as "supported" type, but it fails to play it, complaining that it "Could not determine type of stream".

Onkar Shinde (onkarshinde) wrote :

The VCD plugin has been ported from gstreamer 0.8 to 0.10. But it is not yet available in a gst-plugins-bad release. It is there in CVS. Once it is available in a release, it will land up in hardy and hopefully the VCD problem will be solved.

julio (julioe) wrote :

To resolve the issue follow this steps:

1. Open the "Configuration Editor"
2. Expand "Desktop"
3. Expand "gnome"
4. Highlight "volume_manager"
5. Go to the right panel and find out the entry: autoplay_vcd_command
6. and change %m for "vcd:///dev/cdrom"

That's all

Enjoy it!

PD: Creo que el opinar sin tener pleno conocimiento, lejos de ayudar, lo unico que crea es desorientacion.

Saludos

The above suggestion doesn't appear to work for me on Gutsy: when trying to play DVD ISO from the hard disk, Totem still complains that it "Could not determine type of stream" ...

julio (julioe) wrote :

Vincent,

I'm talking about to play VCDs from the cdrom . They have a type of file AVSEQxx.DAT, where xx can be 01, 02,03...

Follow the above steps, insert a VCD in your CDROM, and please let me know if you have success.

Regards

>Vincent,
>I'm talking about to play VCDs from the cdrom .

Ah, sorry. It's just that my bug was marked as a duplicate of this one, so I assumed your fix would work too.

> Follow the above steps, insert a VCD in your CDROM, and please let me know if you have success.

I don't even know what a "VCD" really is (don't laugh). What does "VCD" stand for ?
All I have is a couple of documentaries on a DVD, with a menu to select chapters, a bit like a movie then.
Does that coun't as a "VCD" ? I guess no, otherwise your fix would have worke ! ;-)

I wonder why my bug (#122635) got marked as a duplicate of this one then, if it's not the same problem.... :-/

>Vincent,
>I'm talking about to play VCDs from the cdrom .

Ah, sorry. It's just that my bug was marked as a duplicate of this one, so I assumed your fix would work too.

> Follow the above steps, insert a VCD in your CDROM, and please let me know if you have success.

I don't even know what a "VCD" really is (don't laugh). What does "VCD" stand for ?
All I have is a couple of documentaries on a DVD, with a menu to select chapters, a bit like a movie then.
Does that count as a "VCD" ? I guess no, otherwise your fix would have worked ! ;-)

I wonder why my bug (#122635) got marked as a duplicate of this one then, if it's not the same problem.... :-/

julio (julioe) wrote :

Totem has 2 "modes" in which it can work

with lib-xine or with gstreamer0.10, I encounter that with gstreamer0.10 is really a headache.

In order to know with which one your Totem is working on, follow this steps:

1. Open Totem
2. Click the menu "Help"
3. Click "About"

You wil encounter something like this:

"Totem Movie Player 2.XX.X"
Movie Player using xine-lib version X.X.X and GNOME" ( I take this from my system, the "x" means any number")

If you encounter that your Totem Movie Player is working with gstreamer, I suggest you to install Totem-Xine from Synaptics. It will remove automatically the Totem-Gstreamer and will install Totem with the libraries of xine.

Regards

Don't know what a VCD is?

http://en.wikipedia.org/wiki/Vcd

There you go, they were quite big just before DVD. They were popular outside
of Europe and I think The States. I think that they were probably abandoned
because DVD's are able to be controlled by region and DVD encryption etc.
VCD's are simpler.

On 20/01/2008, julio <email address hidden> wrote:
>
> Totem has 2 "modes" in which it can work
>
> with lib-xine or with gstreamer0.10, I encounter that with gstreamer0.10
> is really a headache.
>
> In order to know with which one your Totem is working on, follow this
> steps:
>
> 1. Open Totem
> 2. Click the menu "Help"
> 3. Click "About"
>
> You wil encounter something like this:
>
> "Totem Movie Player 2.XX.X"
> Movie Player using xine-lib version X.X.X and GNOME" ( I take this from my
> system, the "x" means any number")
>
> If you encounter that your Totem Movie Player is working with gstreamer,
> I suggest you to install Totem-Xine from Synaptics. It will remove
> automatically the Totem-Gstreamer and will install Totem with the
> libraries of xine.
>
> Regards
>
> --
> [totem-gstreamer] wont play vcd for "unknown reason"
> https://bugs.launchpad.net/bugs/43589
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Ah, I was still using the defaut Gstreamer version of totem, it appears.
So I installed Totem-xine (including the "w32codecs" package), but it still fails to play DVD ISO images from the hard disk. It complains that there is "no plugin to handle this movie".

> Don't know what a VCD is?
>http://en.wikipedia.org/wiki/Vcd
>There you go, they were quite big just before DVD. They were popular outside
>of Europe and I think The States.

Ah, ok... yes, now I remember seeing these here in France, 15 years ago... they were mega large discs, the size of a vynil audio disc.
But they were not successful at all, and so were quickly abandonned, after only a year or so if I remember well..

julio (julioe) wrote :

Vincent,

If the file is an ISO you can burn it on cd or dvd.

Regards

Justin (justinemmanuel) wrote :

I do remember the record size disks, but they weren't VCD's. VCD's are still
available and they are CD size. Those big disks were called laser disks over
here in the UK and didn't take off because they were SO expensive. Pretty
though.

On 20/01/2008, Trouilliez vincent <email address hidden> wrote:
>
> > Don't know what a VCD is?
> >http://en.wikipedia.org/wiki/Vcd
> >There you go, they were quite big just before DVD. They were popular
> outside
> >of Europe and I think The States.
>
> Ah, ok... yes, now I remember seeing these here in France, 15 years ago...
> they were mega large discs, the size of a vynil audio disc.
> But they were not successful at all, and so were quickly abandonned, after
> only a year or so if I remember well..
>
> --
> [totem-gstreamer] wont play vcd for "unknown reason"
> https://bugs.launchpad.net/bugs/43589
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

> Vincent,
> If the file is an ISO you can burn it on cd or dvd.

I did buy the documentaries on a physical DVD medium, but I made an ISO file from it, precisely so as to be able to read it from the hard disk, which I find muuuuch more convenient than using the actual DVD/disc. This was the point of my bug ;-)

Mark Brannan (markbrannan) wrote :

I think I'm seeing the same problem as Trouilliez vincent. I want to be able to load dvd iso's from the hard drive rather than the physical dvd drive...

This seems to be fine with xine:
$ gxine dvd:/media/my.iso

But totem-gstreamer is unable to handle this. I get one of the following depending on how I form the command:

$ totem dvd:/media/my.iso
** Message: Error: Invalid URI "/media/my.iso".

OR (with two slashes...)

$ totem dvd://media/my.iso
** Message: Error: Could not open DVD
dvdreadsrc.c(229): gst_dvd_read_src_start (): /play/source:
DVDOpen(/dev/dvd) failed: No medium found

I haven't found a way to open the ISO from the gui in totem (also not seeing a way to open it if I mount the iso as a directory first)

Do Vincent and I need a new/separate bug or should his original bug be unmarked as a duplicate?
I'm using Gutsy with Totem 2.20.0 and GStreamer 0.10.14

Shujah (shujah-alam-malik) wrote :

There are some alternatives.

1. Open VLC, File > Open Disc > Disc Type VCD --- Advanced Options > Customize "change vcdx to vcd2"
i.e. Customize will read like > vcd2:///dev/--- :audio-track=0. If you have more then one dvdrom/cdrom give the right address. VLC will then play the files but the voice may be distorted. If it works ok then you can make a custom command in file > properties > open with | so that when VCD is inserted VLC will autoplay with the custom command.

2. For mplayer. open terminal > mplayer ://vcd --- press 'F' for sullscreen.

3. Install gxine, which will play VCDs.

4.Install smplayer. Which is what i use and works perfectly.

Reinhard Tartler (siretart) wrote :

not a vlc bug

Changed in vlc:
status: Confirmed → Invalid
aravindvb (vb-aravind) on 2009-01-12
Changed in mplayer:
assignee: nobody → hemu
edoedo (oldhame) wrote :

i am newbie , so why is my totem working well with different dvd and other not? Can anyone help me?

Changed in totem:
assignee: desktop-bugs → oldhame
status: Triaged → New
Sebastien Bacher (seb128) wrote :

don't change bug settings this way

Changed in totem:
assignee: oldhame → desktop-bugs
status: New → Triaged
Walter Cheuk (wwycheuk) wrote :

I fixed the problem this way (I am using Xubuntu 8.10 upgraded from 8.04):

1. Remove 'totem-gstreamer' and install 'totem-xine'
2. Go to Menu -> Applications -> Settings Manager -> File Manager -> Advanced -> Volume Management -> Configuire -> Multimedia, under 'Video CDs/DVDs, change 'totem dvd:/' to 'totem vcd:/' (without the quote. I tried the gconf-editor but can't find the volume_management tag)
3. Now insert a VCD, totem launches automatically and starts playing! The bad news is that totem will complain when inserting DVD now. The two media type should have different handler.

Walter Cheuk (wwycheuk) wrote :

The two disc types should use different handler programs. Maybe we should open another bug report for this.

Changed in firefox:
status: New → Confirmed
Changed in totem:
status: New → In Progress
status: In Progress → Confirmed
Changed in totem:
status: Confirmed → New
Reinhard Tartler (siretart) wrote :

This bug report mentions mplayer as alternative, but not as part of this problem.
I therefore believe that hemu was assigned this bug to in error and this bug as such does not apply to mplayer upstream.

Changed in mplayer:
assignee: hemu agrawal (hemu) → nobody
status: Confirmed → Invalid
Shahar Or (mightyiam) wrote :

Can anyone test this in Lucid, please?

Shahar Or (mightyiam) wrote :

I've updated the description based on my findings. Hope it's OK.

Now the question is, is this a bug in totem? Should totem be expected to play it given the 'totem /media/cdrom0' command?

In any case, can the default command be changed as a workaround?

description: updated
Shahar Or (mightyiam) on 2009-12-14
description: updated
Shahar Or (mightyiam) on 2009-12-14
description: updated
Walter Cheuk (wwycheuk) wrote :

Lucid alpha 1 tested. The disc is recognised as Video CD correctly upon inserting, and a prompt will ask which application to open. The error message is now 'No URI handler implemented for "vcd".' within Totem.

Shahar Or (mightyiam) wrote :

Thanks Walter. Can you try the following commands in Lucid and provide the outputs, please?

'totem vcd://'
'totem vcd:///'
'totem /media/cdrom0/'

Onkar Shinde (onkarshinde) wrote :

@Walter,

vcd plugin is part of gstreamer0.10-plugins-bad package.

Walter Cheuk (wwycheuk) wrote :

@Shahar,

totem vcd:// will play the first .dat only and stopped. However adding a digit like vcd://1, vcd://2 will play each of them. Both vcd:/// and totem /media/cdrom0/ gives 'Could not open location; you might not have permisssion to open the file.'

@Onkar,

Software Center can't launch so can't check. However this is a fresh setup I just install flash and some other web brower plugins.

Walter Cheuk (wwycheuk) wrote :

@Onkar, again

gstreamer0.10-plugins-bad is installed. Thanks.

Walter Cheuk (wwycheuk) wrote :

I have made the understanding wrong. The above problems and error messages happen EVEN AFTER gstreamer0.10-plugins-bad was installed.

Alexander Kiel (alexanderkiel) wrote :

I have the same problem in a fresh 9.10 installation on amd64. I have all the bad and ugly gstreamer plugins + w64codecs from medibuntu. Opening totem (gstreamer) from nautilus fails as it fails to open via "totem /media/cdrom0/". But it works via "totem vcd://". The VCD is created with Windows Movie Maker.

I added some screenshots showing the various opening methods.

shiva (chauhanpress) on 2010-02-10
Changed in mplayer:
assignee: nobody → shiva (chauhanpress)
Walter Cheuk (wwycheuk) wrote :

Lucid alpha 2 with most-recent-updates tested. A VCD is detected and played by Totem automatically, but only the license declaration (most VCD comes with serveral .dat files under \MPEGAV, the first being the license declaration, and the second or the last being the real movie content).

To add to Walter's comments: some vcds are multitrack as well.

On 21 February 2010 08:25, Walter Cheuk <email address hidden> wrote:

> Lucid alpha 2 with most-recent-updates tested. A VCD is detected and
> played by Totem automatically, but only the license declaration (most
> VCD comes with serveral .dat files under \MPEGAV, the first being the
> license declaration, and the second or the last being the real movie
> content).
>
> --
> [totem-gstreamer] wont play vcd for "unknown reason"
> https://bugs.launchpad.net/bugs/43589
> You received this bug notification because you are a direct subscriber
> of the bug.
>

AG (gore-amit) wrote :

The problem with not able to move to next track is Gstreamer plugin track. The VCD plugin does not have seek support. Please check http://netgear.co.in/upload/product/dgn2000/dgn2000_ds_25sep09.pdf

AG (gore-amit) wrote :

Bad link in last comment. :-( The correct link is https://bugzilla.gnome.org/show_bug.cgi?id=547661

Changed in totem:
status: New → Fix Released
Changed in totem:
importance: Unknown → Critical
Omer Akram (om26er) wrote :

totem issue should be fixed in 2.32 as per upstream bug report. if this is still an issue please comment on the upstream bug to get to re-opened

Changed in totem (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Released
Walter Cheuk (wwycheuk) wrote :

The ability to detect VCD has gone in Lucid release edition and Maverick. Now VCDs are only detected as data CDs and file list is shown.

Shahar Or (mightyiam) wrote :

That's a shame - can anyone find the code responsible?

Blessings,
Shahar

Changed in totem:
importance: Critical → Unknown
status: Fix Released → Unknown
Changed in totem:
status: Unknown → Fix Released
Walter Cheuk (wwycheuk) wrote :

Recently played with Maverick (with updates) and found that it is able to detect VCD on insertion, and I was prompted to install a plugin if Totem is selected. But the inability to move to next track is still there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.