totem no longer detects varios languages.

Bug #21660 reported by comeon on 2005-09-14
20
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
totem (Ubuntu)
Medium
Sebastien Bacher

Bug Description

Totem can't change the language of the video it's playing. I've tried this with
dvd's & divx with more than one language & it doesn't work.
The menu sound->language is greyed out. I'm using totem-xine since
totem-gstreamer is choppy for video files.
In a dvd there's a workaround by using the dvd native option to change the
language, but in divx movies there isn't that option. This worked in hoary. Now
in breezy it doesn't work.

http://bugzilla.gnome.org/show_bug.cgi?id=316836: http://bugzilla.gnome.org/show_bug.cgi?id=316836

Sebastien Bacher (seb128) wrote :

Thanks for your bug. That works fine for me. Does it happen with all the DVD? Do
you have any message about this if you start totem from a command line?

(In reply to comment #1)
> Thanks for your bug. That works fine for me. Does it happen with all the DVD? Do
> you have any message about this if you start totem from a command line?

Ok, the DVD i've tried was broken, si I've tried it with others & work, but
with divx films with 2 audio streams doesn't work. I've launched tomtem with the
--debug option. I'm attaching the output.

Created an attachment (id=3810)
totem --debug --play output

(In reply to comment #3)
> Created an attachment (id=3810) [edit]
> totem --debug --play output
>

Ok, new info about this, I've changed totem's backend
to gstreamer & while playback is worst (especially with
divx & DVD) the languages are detected, so I think this
is a issue with xine's library & not totem. At least that's what I'm
beginning to think.

Sebastien Bacher (seb128) wrote :

This bug is quite confusing. What version of totem do you use and what issue do
you get. If you have different issues please open differents bugs and
descriptions one of them here

(In reply to comment #5)
> This bug is quite confusing. What version of totem do you use and what issue do
> you get. If you have different issues please open differents bugs and
> descriptions one of them here

I'm using breezy. totem 1.2.0 with totem-xine (lastest in repo).
The bug is simple: when I load a divx file with 2 audio streams,
totem doesn't detect them & plays the video with the default
stream. The language menu in totem is disabled.

Sebastien Bacher (seb128) wrote :

I've forwarded this issue upstream: http://bugzilla.gnome.org/show_bug.cgi?id=316836

Sebastien Bacher (seb128) wrote :

upstream asked if you could provide a file example

(In reply to comment #8)
> upstream asked if you could provide a file example

The only files I have are backup of films, so I'm afraid
I can't provide any of them. Any divx or xvid file with
2 audio streams would be a good example. Also, I'm using
xine backend.

I'll search in google to see if I can find an example
with no copyright issues.

(In reply to comment #9)
> (In reply to comment #8)
> > upstream asked if you could provide a file example
>
> The only files I have are backup of films, so I'm afraid
> I can't provide any of them. Any divx or xvid file with
> 2 audio streams would be a good example. Also, I'm using
> xine backend.
>
> I'll search in google to see if I can find an example
> with no copyright issues.

I'm downloading a cd iso from http://www.divxtest.com
This site appears to have a divx cd with varios files
with various streams & subtitles to see if they work
with home cinema dvd-divx players.

I'm downloading the file from here:
http://pandora.essentkabel.com/divxtest/
(more ways to download the test cd are listed here:
http://www.mpeg-playcenter.com/modules.php?name=Forums&file=viewtopic&t=4071)

I'll post my experiences with this test. It says it has test for bivx files
which is a short term for divx videos with various streams (or at least that's
what I've interpreted from google's results) so this could be a good
example to try.

Ok, I've finished downloading the divx test cd.
This cd comes with a folder called 08_BivX. Inside this
folder there are varios short divx movies with multiple
audio streams. I have a home dvd with divx support. This
player correctly detects the different audio streams & I
can select them (the sample files are in english & french)

Totem doesn't detect them & only the english stream is
reproduced. Again, using lastest breezy up to date with totem-xine
since gstreamer doesn't work very well with many of my divx/xvid files.

Sebastien Bacher (seb128) wrote :

That bug is fixed upstream now

Changed in totem:
status: Unconfirmed → Fix Released
status: Unconfirmed → Fix Committed

And appears to be uploaded

Changed in totem:
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.