The Totem Firefox plugin loads fine but doesn't play

Bug #107050 reported by Tim Fuchs on 2007-04-16
46
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Totem
Fix Released
Medium
totem (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: totem

I'm using Totem-xine version 2.18.1-0ubuntu3

The standalone player works fine but the plugin doesn't work at all.

When I open a website the plugin loads and the control bar is shown together with a black field where the video is supposed to be (sometimes it also displays the totem icon in this field).

The player doesn't crash (I can still change the volume) but it doesn't play either.

This happens with every video and audio format possible.

Sebastien Bacher (seb128) wrote :

Thank you for your bug, that's know upstream, http://bugzilla.gnome.org/show_bug.cgi?id=416582

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → High
status: Unconfirmed → Confirmed
Changed in totem:
status: Unknown → Unconfirmed

Confirmed on Ubuntu Feisty. totem-xine's firefox plugin doesn't work, and totem-gstreamer doesn't support DVD playback. I recommend mozilla-mplayer for a reliable firefox playback plugin, to fill the gap of totem-xine temporarily.

Sebastien Bacher (seb128) wrote :

totem-gstreamer works great nowadays and totem-mozilla also when using it, the easier way is to install xine-ui to read DVDs rather and to keep the gstreamer version

Stian24 (stiantorgersen) wrote :

I use totem-gstreamer and have the same problem if i reinstall it it works for one or two files before stop working again

Sebastian Urban (surban) wrote :

Same problem here, using totem-gstreamer. Reinstallation does not help. However right clicking on plugin and selecting "Open with movie player" works and plays the movie correctly.

Test on website: http://bcs.whfreeman.com/lodish5e/pages/bcs-main.asp?v=chapter&s=01000&n=00020&i=01020.02&o=|00510|00610|00520|00530|00540|00560|00570|00590|00600|00700|00710|00010|00020|00030|00040|00050|01000|02000|03000|04000|05000|06000|07000|08000|09000|10000|11000|12000|13000|14000|15000|16000|17000|18000|19000|20000|21000|22000|23000|99000|&ns=0

Jason (jasonxh) wrote :

I confirm this bug, with xine backend. Quite annoying. Yet I don't think gstreamer is mature enough.

Sebastien Bacher (seb128) wrote :

that's fixed in gutsy, the gstreamer variant works nicely you should try it

Changed in totem:
status: Confirmed → Fix Released
Changed in totem:
status: New → Fix Released
Brian (brianbaulsir) on 2009-10-22
Changed in totem (Ubuntu):
status: Fix Released → Fix Committed
Sebastien Bacher (seb128) wrote :

don't reopen bugs closed for years

Changed in totem (Ubuntu):
status: Fix Committed → Fix Released
Changed in totem:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.