Totem's menu entry should read "Totem Movie Player"

Bug #105685 reported by Peter Berry on 2007-04-11
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
Totem
Invalid
Medium
totem (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: totem

Calling Totem simply "Movie Player" in the GNOME menus makes it more difficult to find for users who have several movie players installed. The word "Totem" should be added to make it transparent.

I understand that "Movie Player" is present because otherwise newbies wouldn't know what it was, and wouldn't be able to find any movie player. But we don't have "CD Extractor" or "Music Player" or "Web Browser" - we have "Sound Juicer CD Extractor", "Rhythmbox Music Player" and "Firefox Web Browser". Doing differently for Totem is inconsistent.

Sebastien Bacher (seb128) wrote :

Thank you for your bug, upstream request

Changed in totem:
assignee: nobody → desktop-bugs
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

Was already opened upstream and rejected, on can read about it on http://bugzilla.gnome.org/show_bug.cgi?id=331919

Changed in totem:
status: Confirmed → Rejected
status: Unconfirmed → Unknown
Peter Berry (pwberry) wrote :

The bug being rejected upstream doesn't invalidate it here, at least not with the given justification. Firefox _is_ the default web browser, Gaim _is_ the default instant messenger; that Totem might happen to be the default video player in stock GNOME as well as in Ubuntu doesn't make the naming in Ubuntu any more consistent.

Peter Berry (pwberry) on 2007-04-17
Changed in totem:
status: Rejected → Unconfirmed
Sebastien Bacher (seb128) wrote :

It's coherent with some items like "Text Editor", the naming could be discussed, the bug is not specific to totem though, closing this task, discussion can be moved to ubuntu-devel-discuss list

Changed in totem:
status: Unconfirmed → Rejected
Changed in totem:
status: Unknown → Rejected
Conrad Knauer (atheoi) wrote :

Sebastien Bacher said on 2007-04-17:"discussion can be moved to ubuntu-devel-discuss list"

OK ;)

https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2007-June/001084.html

Conrad Knauer (atheoi) wrote :

As per https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2007-June/001090.html

---
Unless Ubuntu is deliberately diverging from Gnome here (and I don't know why we would), the bug is valid. From <http://urlx.org/gnome.org/53594>: "In the menu item name, include a description of functionality in addition to the proper name of the application. This is especially useful [to] novice users, and to users of systems where numerous applications are installed by default." It goes on to discuss a few exceptions, none of which apply to Totem.
---

I'm going to reopen this bug.

Conrad Knauer (atheoi) wrote :

See the ubuntu-devel-discuss comment; it appears that, as per Gnome guidelines, it should be called "Totem Movie Player"

Changed in totem:
status: Rejected → Confirmed
Alexander Jones (alex-weej) wrote :

Can we just do this and get it over with? It's like a 30 second job for anyone with commit access...

Alexander Jones (alex-weej) wrote :

How about now?

Sebastien Bacher (seb128) wrote :

still not convinced that ubuntu should do a distribution specific change there, the use is rather inconsistent

I think it would benefit Ubuntu to have a strict policy on menu naming. What
we have right now is a mess of "Generic Name", "Name Generic Name" and
"Name" all over the menus.

Sebastien Bacher (seb128) wrote :

right, it would benefit all the distributors and should better be done upstream than breaking all the translations

Alexander Jones (alex-weej) wrote :

GNOME are tight shut on this, as far as Bastien is concerned in Totem's
case, Totem is the single application in the software world that plays
movies.
Is it really that much work for Ubuntu translators to do this to the few
Desktop Entry files distributed with GNOME?

Sebastien Bacher (seb128) wrote :

not really that many translations to update but it has to be done early to allow all the translation team to do the changes, and it would better to do a menu review and change everything that needs to be updated

Alexander Jones (alex-weej) wrote :

Do you think this is worth pursuing? If so, I can open another, more general
bug for it so we can aim to get it done for Hardy+1. Or would a Blueprint be
more suitable?

Sebastien Bacher (seb128) wrote :

Could be a good idea to mail the ubuntu-devel list about that rather

Peter Berry (pwberry) wrote :

Any progress?

Alexander Jones (alex-weej) wrote :
  • unnamed Edit (160 bytes, text/html; charset=ISO-8859-1)

I don't have the time to make a case for this right now as I have exams to
get through. If you want to start the discussion on ubuntu-devel, please do!

Conrad Knauer (atheoi) wrote :

Alexander Jones: It *was* discussed on ubuntu-devel-discuss a year ago and the consensus (see quotes from that thread above in this bug report) was that it should be "Totem Movie Player".

Sebastien Bacher (seb128) wrote :

that's not a bug and should rather be discussed on a mailing list if you disagree

Changed in totem (Ubuntu):
status: Confirmed → Invalid
Conrad Knauer (atheoi) wrote :

Sebastien Bacher wrote on 2009-06-03: "that's not a bug and should rather be discussed on a mailing list if you disagree"

??? This *WAS* discussed on the appropriate ML *two years ago* and the decision was that it *IS* indeed a bug. Please stop reverting the status and if you have the authority, just fix the bug!

Changed in totem (Ubuntu):
status: Invalid → Confirmed
Sebastien Bacher (seb128) wrote :

The upstream bug state they will not change the name and we will not do it in an ubuntu specific way

Changed in totem (Ubuntu):
status: Confirmed → Invalid
Conrad Knauer (atheoi) wrote :

Sebastien Bacher: please stop setting the status to Invalid; just because upstream will not fix, doesn't mean that Ubuntu shouldn't, especially since ubuntu-devel-discuss decided that it *is* a problem for Ubuntu. Also, PLEASE stop repeating yourself; your objection regarding upstream was already answered by Peter Berry *two years ago* in the comments to this very bug when you last mentioned it! Please see https://bugs.launchpad.net/ubuntu/+source/totem/+bug/105685 if you are replying by e-mail.

P.S. Please reassure me that you are not a bot, as I am not sure you would pass a Turing test with your responses thus far ;)

Changed in totem (Ubuntu):
status: Invalid → Confirmed
Siegfried Gevatter (rainct) wrote :

Thanks for your interest in helping improve Ubuntu. I agree with you that this is a bug, but, as Sebastien stated, it's inconvenient to do this change in Ubuntu because of the additional translation work and divergence from upsteam rit creates.

This doesn't mean it can't be done, but it'd really be better if this could be achieved upstream; maybe raising the topic on GNOME's desktop-devel-list, as suggested in the last comment of http://bugzilla.gnome.org/show_bug.cgi?id=331919, would move the matter forward and help reach a distribution-wide consensus.

Upstream has /absolutely/ no intention of doing this. Their interpretation
of the Desktop Entry Spec is basically along the lines of "how we want the
menu to look", which is the reason we have applications named such delights
as "Take Screenshot".

The only way this is ever gonna be fixed is if Ubuntu decides to enforce an
actual, coherent application naming policy. People including myself have
been wanting this for years but it is clear our translation framework is not
as efficient as, say, Facebook's (they have a full translation into Pirate,
for god's sake!), so we're just admitting defeat and saying "it's too much
translation work".

Frankly, it's a minor annoyance at best and while little warts of ugly like
this do threaten the overall polished feel of our OS, we do indeed have
bigger fish to fry and arguing with the gods that be about this is just a
waste of breath.

Sebastien Bacher (seb128) wrote :

you really think that this confrontational behaviour on bug status will make you convince somebody? I don't intend to fight over a launchpad bug which let user reopen bugs closed by whoever is working on a component and simply ignore this bug from now rather, the rational is clear:

- those discussions should happen on a list and a not a bug tracker
- GNOME stated they will not change it
- lot of menu items use the same naming scheme (gedit is "Text Editor" for example), the rational is that the entry without a name is implicitely the default software for this category, other softwares have their names to make clear they are a different choice

Conrad Knauer (atheoi) wrote :

Sebastien Bacher:

- Why do you ignore the fact that "those discussions" have already taken place "on a list"? Is it because the answer that was concluded there (two years ago!) was not the one you wanted to hear?
- Why do you ignore the fact that Ubuntu does sometimes make changes from upstream?
- VLC, Mplayer and Gxine are important alternate choices to Totem; thus by your arguments, doesn't this *require* Totem be explicitly named?

Sebastien Bacher (seb128) wrote :

- I don't ignore anything but it would be nice if people would stop spamming everybody subscribed to this bug and would take the discussion to the user forum or list of their choice
- I don't ignore it and I'm doing a number of those changes for desktop component, we stated we will not be doing that change though
- you didn't understand the argument, they are not the default player so the name need to be specified to make clear they are an another option

Conrad Knauer (atheoi) wrote :

>>> lot of menu items use the same naming scheme (gedit is "Text Editor" for example), the rational is that the entry without a name is implicitely the default software for this category, other softwares have their names to make clear they are a different choice

>> VLC, Mplayer and Gxine are important alternate choices to Totem; thus by your arguments, doesn't this *require* Totem be explicitly named?

> you didn't understand the argument, they are not the default player so the name need to be specified to make clear they are an another option

Wait... so why does Ubuntu specifically have named entries such as:

GIMP Image Editor
Firefox Web Browser
Pidgin Internet Messenger
Transmission BitTorrent Client
Brasero Disc Burner

These are the defaults, yet they are named... Are you implying that if they are not the GNOME defaults then they need names?

*confused*
Rhythmbox Music Player

Sebastien Bacher (seb128) wrote :

rhythmbox, pidgin, firefox are not GNOME applications but right the naming is not really coherent and it would be nice to fix it but adding totem in one title is not the way to do that

Peter Berry (pwberry) wrote :

It is being discussed on ubuntu-devel-discuss, see https://lists.ubuntu.com/archives/ubuntu-devel-discuss/2009-June/008539.html. I second not spamming the CC list, just comment by email.

Setting this to "triaged" since it is being discussed on the mailinglist and we can't do anything else for the bug.

Changed in totem (Ubuntu):
status: Confirmed → Triaged
Changed in totem:
importance: Unknown → Medium
Vish (vish) wrote :

This is not a bug and not something we are going to change in Ubuntu or in Upstream GNOME, for more detailed info kindly read : http://blogs.gnome.org/mccann/2009/08/08/whatchamacallit/

In short, Even though GNOME is built from several individual apps, the user should not be made to feel that these are separate, it's just that we want the apps to be part of the OS and a unified user experience.

If any other GNOME app is displaying the name, that would need to be fixed.

Judging by the tone on this bug report, I'm pretty sure that I'd just get flamed now.. ;-)
But, try to read that blog and try to understand why we are doing this..

Changed in hundredpapercuts:
status: New → Won't Fix
Changed in totem (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Won't Fix
Robert Roth (evfool) wrote :

@Vish: and where should I report the list of apps that show their names, like Aislerot Solitaire, Banshee Media Player, Brasero Disc Burner, Empathy Internet Messaging, Evolution Mail and Calendar, Gwibber Social Client, Synaptic Package manager, Transmission Bittorrent Client and Tomboy notes, to name just a few.

Vish (vish) wrote :

Just to be clear, in case people have not read that blog or the links in it.
Its not just plain removing the app brand name. It's also about giving the right app brand name which user can better identify with.
Displaying just "totem" makes no sense of it being a movie player.
Most of the bugs are being fixed > https://live.gnome.org/GnomeGoals/CorrectDesktopFiles
If they are not fixed then we need to file bugs in individual apps mainly in GNOME/relevant bugzillas.

Now, this takes effect in Shell, this probably makes it also a bug in Unity which is still depending on the panel naming specs and since it is not looking at the right name field.

Robert Roth (evfool) wrote :

@Vish: thanks for your answer. I have read the blog post before, but still it doesn't seem consistent to me. But that's only an opinion. If I come up with a better solution though, I'll propose it.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.