Ubuntu

Please backport tomcat5.5 from gutsy (was: tomcat5.5 won't start b/c of catalina.out named pipe)

Reported by Thomas Achtemichuk on 2007-03-27
40
Affects Status Importance Assigned to Milestone
Feisty Backports
Undecided
Unassigned
tomcat5.5 (Debian)
Fix Released
Unknown
tomcat5.5 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tomcat5.5

With a fresh Feisty install with tomcat5.5 installed, $LOGFILE as defined in /etc/init.d/tomcat5.5, points to /var/lib/tomcat5.5/logs/catalina.out which is a named pipe. Starting tomcat with the init script seems to work fine, but tomcat will not actually start until the pipe is read from. If the pipe is replaced with a normal file, everything works fine.

ProblemType: Bug
Architecture: i386
Date: Tue Mar 27 14:49:15 2007
DistroRelease: Ubuntu 7.04
Uname: Linux t40 2.6.20-13-generic #2 SMP Sun Mar 25 00:21:25 UTC 2007 i686 GNU/Linux

Simon Pang (hksimon) wrote :

I can reproduce the problem. The sample webapps does not run until I tail the catalina.out file. This is weird.

tail -f /var/lib/tomcat5.5/logs/catalina.out

Changed in tomcat5.5:
status: Unconfirmed → Confirmed
Michael Moore (stuporglue) wrote :

Here's a workaround:

Edit the tomcat startup script (/etc/init.d/tomcat5.5).

At the very end of the start) block there is an else statement.

Insert the following line immediately before the first else:
tail /var/log/tomcat5.5/catalina.out > /dev/null &

Save and close the file.

Restart Tomcat5.5

Now the file will be tailed by the startup script and Tomcat should work fine. If it doesn't, you can try replacing the "tail" with "cat".

Brian Cassidy (brian-cassidy) wrote :

I'd like to add that I'm experiencing the exact same issue -- Michael's proposed workaround seems to resolve the issue.

Claus Nielsen (clanie) wrote :

I also got this problem after upgrading to Feisty.

GSMD (gsmdib) wrote :

What I did when installed tomcat5.5 in Feisty Beta was to remove catalina.out and then created a "normal" file instead.
This approach won't work in the final version I just installed, nor tail /var/log/tomcat5.5/catalina.out does.
nmap reports on Tomcat not listening on localhost:8180, yet listening on 8009.

That's sooo weird!

GSMD (gsmdib) wrote :

In my case a workaround was to change http port from 8180 to 8080.

David Sowerby (david-sowerby) wrote :

Same problem, workaround fixed it, many thanks

I can confirm this problem as well.

Thom Pischke (thom-pischke) wrote :

Another confirmation, for both the problem and the workaround. Weird indeed.

Thom Pischke (thom-pischke) wrote :

It seems that the catalina.*.log files are not being written. I assume this is related to the pipe problem.

Since this bug amounts to 'Tomcat broken in feisty', hope this gets a priority and assignee soon.

Or maybe someone could suggest a workaround to restore the logs too. Could probably just redirect the tail output, but what about log rotation?

Thom Pischke (thom-pischke) wrote :

So has anyone gotten logs working? Having no logs to investigate server problems is proving crippling, and I'm thinking I'll have to either switch to glassfish or install tomcat manually from apache sources.

Thom Pischke (thom-pischke) wrote :

Found a 'workaround' for the missing logs.

If I delete catalina.out and recreate as a normal file, the logs get written there. Of course, there is no log rotation, but at least I can get the information I need until this issue gets a proper fix.

Thom Pischke (thom-pischke) wrote :

This bug is well documented upstream in Debian, and it appears they even have a fix prepared. This also explains why logs aren't being rotated.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=402603

I used the workaround and tomcat worked properly for few times.

But now it does not work at all. When i start tomcat-5.5 using /etc/init.d/tomcat5.5 start it doe show status as OK.

But when I use , status command with /etc/init.d/tomcat5.5 it displays status as serve not running!!!

This is fixed in Debian.

tomcat5.5 (5.5.20-5) unstable; urgency=low
  .
  * Messages are now logged to the system log instead of the pipe
    "/var/log/tomcat5.5/catalina.out". (Closes: #402603, #402879)

Matti Lindell (mlind) wrote :

Also fixed in gutsy: tomcat5.5 (5.5.20-5ubuntu1)
Add a backport request for feisty.

Changed in tomcat5.5:
status: Confirmed → Fix Released
Changed in tomcat5.5:
status: Unknown → Fix Released
Thom Pischke (thom-pischke) wrote :

Yeah, let's get this backported, this is a really annoying bug...

Alperen Yusuf Aybar (alperen) wrote :

I can confirm this bug, please backport it.

Bill Robinson (airbaggins) wrote :

I too hit on this one. I have added the backports just for this and tried to update, but still no. Or can i download the specific package from somewhere for this?

Matti Lindell (mlind) wrote :

Bill, the backport task is still pending for approval from backport admins, so there's no backported package yet.
You can help the backporters by going through the process and confirm if the result works or not.

https://wiki.ubuntu.com/BackportRequestProcess
http://ubuntuforums.org/showthread.php?t=268687
http://ubuntuforums.org/showthread.php?p=1720696

Sam (sam-halliday) wrote :

This is a really bad bug... I just spent all day trying to upgrade to tomcat5.5 to be bitten by this. Looking forward to the official fix, but in the meantime I've used the workaround mentioned here.

Sam (sam-halliday) wrote :

Is there going to be a fix for this soon? It's been months since somebody committed a change. Current workarounds are:-

1. delete /var/log/tomcat5.5/catalina.out and create a file with the same permissions
2. edit the startup script to cat the contents into a file or (argh) /dev/null

I'd like to reiterate that this bug stops tomcat from starting up! It should be marked HIGH PRIORITY.

Sam (sam-halliday) wrote :

This report has claimed for over a month that "Fix Released"... but as of today, there is no sign of it. So I'm moving this back to "Confirmed". Could somebody in the know please comment on the status of this fix?

Changed in tomcat5.5:
status: Fix Released → Confirmed
Thom Pischke (thom-pischke) wrote :

Fix Released? I sure never saw it. It may be fixed in Gutsy (it having been fixed in Debian), but not in Feisty AFAIK

Sam (sam-halliday) wrote :

I also don't see why the "Importance" tag of this bug hasn't been bumped up to the highest level... this bug means that *tomcat5.5 does not start up*!

Matti Lindell (mlind) wrote :

Sam, this is fixed in current development release (gutsy). Feisty Backports task is for feisty.

Changed in tomcat5.5:
status: Confirmed → Fix Released
Changed in feisty-backports:
status: New → Incomplete
pacote08 (fmdelao) on 2009-11-11
Changed in tomcat5.5 (Ubuntu):
status: Fix Released → Confirmed
Thierry Carrez (ttx) on 2009-11-12
Changed in tomcat5.5 (Ubuntu):
status: Confirmed → Fix Released
Changed in feisty-backports:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.