'Search All Notes' dialog not working in Windows 7

Bug #770307 reported by Redsandro
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
tomboy (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

Binary package hint: tomboy

I use Tomboy for Ubuntu and Windows 7 Pro 64. On Windows 7, the 'Search All Notes' dialog is not working.

This was using Tomboy Notes 1.4.2.0 and Gtk# for .NET 2.12.10. Meanwhile, I updated up to Tomboy Notes 1.6.0.0 and the dialog still won't appear. I am not sure why this happens, but any info I can find on the subject is Ubuntu related. The Windows installer is on the Tomboy Gnome Project page though.

Revision history for this message
Redsandro (redsandro) wrote :

[screenshot added]

The actual dialog/window doesn't show, but the Windows 7 popup miniature shows there is a problem:
http://stuff.rednet.nl/rommel/trash/tomboy1600win.png

Revision history for this message
Redsandro (redsandro) wrote :

(Just figured I can upload attachments here, this is the same screenshot for future reference.)

Revision history for this message
Shrenik (shrenik-bhura) wrote :

Facing this same problem with exactly the same scenario above. Tried re-installing as well as but to no avail. Can anyone suggest a workaround to be able to actually list all existing notes or by removing some configuration file which may have corrupted.

Redsandro, have you figured out anything?

Revision history for this message
Redsandro (redsandro) wrote :

No, unfortunately.

A very lame workaround right now is to add all notes in the "Start Here" note which is accessable through a shortcutkey, but that will just let you ACCESS notes, not SEACH them in bulk.

I hope this gets fixed soon.

Changed in tomboy (Ubuntu):
status: New → Confirmed
Revision history for this message
Aaron D Borden (adborden) wrote :

Can you run tomboy from the windows console? Please run:
Tomboy.exe --debug &> tomboy-debug.log

And then upload the log file produced?

Revision history for this message
Redsandro (redsandro) wrote :

Sure, although the logfile was empty so I just copied what was in the terminal, hope that's okay.

I started tomboy, tried search, and exited. The only message that showed up on search was:

[DEBUG 20:54:04.335] Loading notebooks

So I thought, maybe using a notebook triggers the error. I created a new user, ran Tomboy, added some notes and a notebook with some notes, exit, start, but the search-window still works.

I conclude that at a certain point something happens in the personal configuration (AppData) that triggers this error for that user specifically.

Unfortunately, since I have a lot of personal notes in my user config I don't really feel like sharing my AppData/Tomboy folder.

@Shrenik maybe this error is new enough for you that you can still remember at what point the search dialog didn't work anymore?

Revision history for this message
Shrenik (shrenik-bhura) wrote :

Sorry guys for not checking back in. And yes, I did forget to subscribe thinking it would auto-subscribe once I post a comment. :)

Anyways, my log too does not look much different. Don't know if this is of much consequence -
ERROR: There was an error while scanning assembly: c:\Program Files (x86)\Tomboy\MonoPosixHelper.dll (The module was expected to contain an assembly manifest.(Exception from HRESULT: 0x80131018))

And yes, there was nothing in particular that I remember doing when this mishap happened. I was just setting up everything on my new system and ensuring that everything sync's between my trustworthy Ubuntu and this new bloke.

Installed cygwin, unison, etc. amongst several other windows regulars when all of a sudden, the "Search All" went kaput. Doesn't look like a cross-dependency but something integral to Tomboy itself.

Revision history for this message
Shrenik (shrenik-bhura) wrote :

@Redsandro 'add all notes in the "Start Here" note which is accessable through a shortcutkey' - Couldn't figure out how to move the existing notes into Start Here as well as the short-cut keys don't work for me. Please confirm and may be then it should be opened as a separate bug. Currently for me, Tomboy is complete defunct on Windows.

Revision history for this message
Redsandro (redsandro) wrote :

@Shrenik like I said, lame workaround, you 'move your existing notes into -Start here-' by editing that note and typing in the titles of all your other notes.

As for the shortcutkeys, be sure to configure them properly. They work for me.

Preferences > Hotkeys >
[check] Listen for Hotkeys
Open "Start Here" > Alt + F12 (or sth)

(Ofcourse, if the window is already open, albeit in the background, nothing happens.)

Revision history for this message
Shrenik (shrenik-bhura) wrote :

@Redsandro, thanks but the 'lame workaround' would only work if I readily remember the names of all the notes and I have several of them. :) Yeah I think I can get all of them by opening each of *.note file.

As for the shortcuts, they too don't work for me. Have tried various combinations since the default ones did not work. Herein is attached a screenshot.

Revision history for this message
Redsandro (redsandro) wrote :

@Shrenik: I know, the workaround is barely acceptable for me because I work a lot in Linux anyway and I hope it gets fixed soon.

As for the shortcuts, some say Alt and some say <Alt> in your screenshot, I think you're supposed to actually press the shortcut in stead of typing it. Be alert: For me only left Alt/Ctrl work, the keys on the right of my keyboard don't.

Another workaround, if you're a fan of the cross platform Opera browser and use it everywhere anyway, is to use Opera Notes in stead. Get an Opera Unite account and every browser will be synced. In the browser sidepane (F4 by default) there's a note taking area that auto-saves and auto-syncs that never failed me before. I used it back in the time that Tomboy didn't work in Windows yet.

Revision history for this message
Patrick (pwespi) wrote :

I had the same problem on Windows 7 with Tomboy 1.6.0. It was caused by the two following lines in
%USERPROFILE%\AppData\Roaming\Tomboy\config\prefs.xml:

    <search_window_x_pos>-32000</search_window_x_pos>
    <search_window_y_pos>-32000</search_window_y_pos>

The solution that worked for me was:
- quit tomboy
- open %USERPROFILE%\AppData\Roaming\Tomboy\config\prefs.xml in a text editor and replace the two lines mentioned above with:

    <search_window_x_pos>150</search_window_x_pos>
    <search_window_y_pos>150</search_window_y_pos>

- save, close, restart tomboy and everything worked again :)

I recently worked with two monitors, don't know if that might have caused the problem.
Good luck!

Revision history for this message
Shrenik (shrenik-bhura) wrote :

@Patrick, thanks a ton for the solution.
Yes, me too worked with multiple monitors but not in the faintest did I think it could be related to that. Will work again and confirm if that could be the cause.

@Redsandro
Can you also please confirm the cause?

Revision history for this message
Redsandro (redsandro) wrote :

@Shrenik: Confirmed, my prefs.xml had:

    <search_window_x_pos>-32000</search_window_x_pos>
    <search_window_y_pos>-32000</search_window_y_pos>

Change values to 200 (default on new install I believe) and all works again!
@Patrick: Thanks for sharing.

Note that I have a single monitor layout so something else must have triggered Tomboy to write these values.

Revision history for this message
Øby (stian-oby) wrote :

My prefs.xml also had

    <search_window_x_pos>-32000</search_window_x_pos>
    <search_window_y_pos>-32000</search_window_y_pos>

Can confirm that the fix mentioned in post #13 and #14 works. I also have a single monitor layout, like commenter #14.

Revision history for this message
Robyn Smith (rtasmith05) wrote :

My prefs.xml also had:

<search_window_x_pos>-32000</search_window_x_pos>
<search_window_y_pos>-32000</search_window_y_pos>

Like the previous users, I changed the value to something that worked for me (using 1000 for x and 1000 for y worked for me) and the issue was fixed.

Notes:

- I'm running Windows 7 Enterprise, 32 Bit - Dell E6320
- The issue was created when I had my system perform a dirty reboot
- I'm using a multi-monitor set up (this is a laptop) and I regularly go from using a dock at work (multi monitors) to using the laptop's monitor at home

Revision history for this message
Robyn Smith (rtasmith05) wrote :

Sorry for the double post, but I experienced the issue again and I figured my workaround might be useful to someone out there:

- I regularly dock and undock my laptop...so it regularly goes from using dual screens to using the laptops monitor.
- When I booted back up at home, undocked, my prefs.xml went back to:

<search_window_x_pos>-32000</search_window_x_pos>
<search_window_y_pos>-32000</search_window_y_pos>

- As a workaround, I picked an x and y location that works for both my dual monitor setup, and my laptop monitor, and then I made the prefs.xml read-only (on a Windows 7 machine, right click on the prefs.xml file, click Properties, check the "Read-only" box, and then click "Apply").

Note: The ramifications of this workaround (I would think) are that I can no longer make changes to my preferences. If I want changes to take effect, I would have to deselect the Read-only box, and then proceed to make those changes.

Revision history for this message
kevingill (kevin-movieextras) wrote :

@Patrick, Thanks for the info - was pulling my hair out

Revision history for this message
Holger Keibel (1olger) wrote :

Thanx, Patrick!
Your solution fixed it.

(It is so much more convenient to search notes through the Tomboy dialog than via grep commands...)

Changed in tomboy (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Felipe De la Puente (fdelapuente) wrote :

Hey! This is not invalid.

The solution suggested is just a workaround.

I have the latest version of Tomboy running on Windows 7 with multiple monitors, and the issue is there.

Tomboy should be to realize the saved coordinates are out of the current viewport and assign a new default position for the window when. Keeping the window out of display can't be accepted as a default behavior.

Thanks and Regards, Felipe.

Revision history for this message
NeoAndersen (garotobossanova) wrote :

Hello!
Can we know in which version this bug will be solved on windows 7?
I was using the 1.6 and I just installed the 1.10.2 but the problem remains...

Revision history for this message
Shrenik (shrenik-bhura) wrote :

Neo,

Seems it has been fixed in the Development release 1.11.1 -
  http://git.gnome.org/browse/tomboy/plain/NEWS?id=1.11.2

One may try it from -
 http://download.gnome.org/binaries/win32/tomboy/1.11/Tomboy-1.11.2.msi

Note, it is just the development version, so may have a few bugs as well.

Revision history for this message
NeoAndersen (garotobossanova) wrote :

Thank you very much indeed, Shrenik!
I can see the "search all notes" window now...

Revision history for this message
NeoAndersen (garotobossanova) wrote :

Well, the problem came back... But I could solve it just right clicking on the "Search All Notes" tab and then in the "Maximize" square...

Revision history for this message
NeoAndersen (garotobossanova) wrote :
Revision history for this message
rs232 (vincenco) wrote :

Thanks NeoAndersen, that is a good workaround!

Hope it gets fixed, it is quite annoying. It actually looks like it writes out to -32000 for some reason then gets stuck.

Changing it in the file did nothing. I realized I had to edit it as Admin, but still no dice.

Your fix worked for now, thanks!

Revision history for this message
Alemann Massho (armistice-con-deactivatedaccount) wrote :

what the fsck? I don't remember purposefully marking this as invalid, and I can't think of how I ever would have previously come to that conclusion. I think I had multiple bugs open in the same window and clicked on the wrong one. Changing the status back to 'confirmed'

Changed in tomboy (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
Fyk (stephane-benchimol) wrote :

Thanks a lot for re-taking care of this ticket. Actualy I stopped using Tomboy on Windows7 because of that !!

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers