Tomboy tries to load fuse module in Jaunty...and can't

Bug #345166 reported by Martin Jackson on 2009-03-19
126
This bug affects 15 people
Affects Status Importance Assigned to Milestone
tomboy
Fix Released
Low
tomboy (Ubuntu)
Medium
Ubuntu Desktop Bugs
Jaunty
Medium
Ubuntu Desktop Bugs

Bug Description

In the new 2.6.28 kernels, fuse is built in instead of a loadable modules (CONFIG_FUSE_FS=y).

When configuring Tomboy to sync over the network, it apparently does lsmod (or its equivalent) and asks to load the fuse module. Since fuse is no longer a module, this fails and so fails to configure network synchronization of notes.

Tomboy should not assume that fuse is a module because it may in fact be built-in to the kernel.

Version tested: 0.14.0-0ubuntu1

John Reese (jreese) wrote :

I found a bug report upstream that matches this problem: http://bugzilla.gnome.org/show_bug.cgi?id=500524

However, the bug report says that Tomboy still works fine, but from my experience, it indeed fails and refuses to synchronize with the remote system. This is a rather large showstopper in my opinion, now that Ubuntu ships kernels with FUSE integrated by default.

Luis Díaz (piponazo) wrote :

I have the same problem with the last version of Ubuntu Jaunty. In older versions of Ubuntu, the synchronization rans correctly.

Changed in tomboy (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Joey Stanford (joey) wrote :

I have the same problem on Jaunty 64-bit. This means that I cannot remotely sync my tomboy notes across my work computers.

Joey Stanford (joey) wrote :

[DEBUG]: SyncThread using SyncServiceAddin: SSH (sshfs FUSE)
[DEBUG]: Could not find 'fuse' in lsmod output
[DEBUG]: Could not find 'fuse' in lsmod output
[WARN]: Couldn't enable fuse
[DEBUG]: User canceled or something went wrong enabling FUSE
[DEBUG]: Exception while creating SyncServer: FUSE could not be enabled.
  at Tomboy.Sync.FuseSyncServiceAddin.MountFuse (Boolean useStoredValues) [0x00000]
  at Tomboy.Sync.FuseSyncServiceAddin.CreateSyncServer () [0x00000]
  at Tomboy.Sync.SyncManager.SynchronizationThread () [0x00000]
[DEBUG]: SyncThread using SyncServiceAddin: SSH (sshfs FUSE)
[DEBUG]: Could not find 'fuse' in lsmod output
[DEBUG]: Could not find 'fuse' in lsmod output
[DEBUG]: User canceled or something went wrong enabling FUSE
[DEBUG]: Exception while creating SyncServer: FUSE could not be enabled.
  at Tomboy.Sync.FuseSyncServiceAddin.MountFuse (Boolean useStoredValues) [0x00000]
  at Tomboy.Sync.FuseSyncServiceAddin.CreateSyncServer () [0x00000]
  at Tomboy.Sync.SyncManager.SynchronizationThread () [0x00000]

Juha Siltala (topyli) wrote :

The upstream bug now has a patch to check /proc/filesystems instead of lsmod.

Changed in tomboy:
status: Unknown → Confirmed
Martin Jackson (mhjacks) wrote :

The upstream patch has been updated:

http://bugzilla.gnome.org/attachment.cgi?id=132154&action=view

Any chance of cherrypicking it for the Jaunty release?

Dan Ballard (haplo) wrote :

I second that, this is kind of required functionality for my laptop, to sync notes, so I'd appreciate if it didn't stop working with Jaunty :) Thanks

yy2kk (kangyu29) wrote :

me too, I used this feature everyday, and tomboy makes all of my note for work and life. Please!!!!!!!

Dan Ballard (haplo) wrote :

Having Tomboy sshfs sync work every other Ubuntu release is no fun.
And what's the worry of picking this patch? I mean its not like you might break something because it doesn't work to begin with so it'd be hard to have a regression from here. :)

Bryan (brywilharris) wrote :

I have applied the patch, built a new package, and uploaded it to my PPA. For anyone who would like to test the fix, my PPA is here:
https://edge.launchpad.net/~brywilharris/+archive/ppa

It should be available in 30 minutes or so as of: Wed, 15 Apr 2009 09:33:59 -0400

The build worked on my machine: 2.6.28-11-generic #41-Ubuntu SMP Wed Apr 8 04:38:53 UTC 2009 i686 GNU/Linux

Pedro Fragoso (ember) wrote :

  tomboy (0.14.0-0ubuntu1.1) jaunty-proposed; urgency=low

    * 02_bugzilla_500524.patch:
      - Tomboy tries to load fuse module in Jaunty...and can't
        grep /proc/filesystem instead (LP: #345166)

     -- Pedro Fragoso <email address hidden>Wed, 15 Apr 2009 14:08:59 +0100

https://code.edge.launchpad.net/~ember/tomboy/ubuntu

Pedro Fragoso (ember) wrote :

Please test and provide feedback. Thanks

Bryan (brywilharris) wrote :

The package from my PPA on i386 and it works.
All I did was apply the suggested patch: http://bugzilla.gnome.org/attachment.cgi?id=132154&action=view

I can't figure out how to get at your code Pedro. when I checked out your branch with 'bzr branch lp:~ember/tomboy/ubuntu' I got no code. What are you suggesting we test?

Pedro Fragoso (ember) wrote :

Hi Bryan.

That branch only contains the debian code to upload the package to Ubuntu and the package is in my PPA https://edge.launchpad.net/~ember/+archive/ppa

You're using the same patch so it's fine.

On Wed, 2009-04-15 at 13:36 +0000, Bryan wrote:
> I have applied the patch, built a new package, and uploaded it to my PPA. For anyone who would like to test the fix, my PPA is here:
> https://edge.launchpad.net/~brywilharris/+archive/ppa

Your patched Tomboy syncs fine over sshfs for me. If further use reveals no regressions, this would be a good way to go :)

Dan Ballard (haplo) wrote :

works for me too, awesome, thanks.

markgalassi (mark-galassi) wrote :

    Dan> works for me too, awesome, thanks.

It's great that the patch works, but 9.04 is out and tomboy was not
fixed.

Martin Pitt (pitti) wrote :

http://launchpadlibrarian.net/25491640/tomboy_0.14.0-0ubuntu1_0.14.0-0ubuntu1.1%7Eppa1.diff.gz looks a bit brittle. Please update it to be something like "\s+fuse$" and test again.

Thanks for the suggestion Martin. Fixed upstream, will be in 0.15.1 development release and 0.14.2 maintenance release (0.14.2 will actually have a lot of good fixes, I will be pushing for it to go into an update for Jaunty).

Changed in tomboy:
status: Confirmed → Fix Released
wgacquer (wgacquer) wrote :

I definitely need it in the main repository but I don't see the fixed package coming in the upgrades. Can you please provide an official fixed package? and thanks a lot for you help!

My understanding is that 0.14.2 is going to be in an upcoming Jaunty update. I'm not really involved in Ubuntu packaging, though.

Loïc Minier (lool) wrote :

This was included in tomboy 0.15.1 and hence was fixed by this upload to karmic:
tomboy (0.15.2-0ubuntu1) karmic; urgency=low

  * Upload to Karmic from Debian's git repository due to delays (lp: #381101)
  * New upstream release 0.15.1:
   - New WebSync add-in syncs to any server that implements the Tomboy Web REST API,
     such as Snowy [http://live.gnome.org/Snowy]. Baby-eating preview release.
   - Require Mono 1.9.1 to *build* Tomboy. Should still run on older Mono.
   - Prevent PATH problems on Windows from breaking Tomboy.
   - Search for phrases by quoting search text.
   - Fix drag&drop & middle-click paste of linked text.
   - Save width of notebook pane in Search window.
   - Disable sync menu items until backend configured.
   - Close note find bar on escape, even when not focused.
   - Support FUSE being built-in to kernel.
   - Prevent crashes when reading unexpected note XML.
   - Change "Open New Note Template" LinkButton to Button to prevent error.
   - Focus search field every time Search window summoned.
   - Only show Start Here note on first run if not running as applet.
   - HIG compliance in Sync preferences.
   - Use correct "info" icon in add-in info windows.
   - Use relative path to load help.
   - Cache frequently-used text tags in one place instead of five.
   - Documentation updates.
   - Translation updates: el, es, et, gl
  * New upstream release 0.15.2:
   - Fix HTML Export on Mac OS X.
   - Translation updates: es, et, nb, sv, zh_CN
  * debian/control: Add help/ as GFDL 1.1+.
  * debian/rules: Remove --repack; not necessary as upstream is a .tar.gz and
    could cause rule to be nondeterministic

 -- Iain Lane <email address hidden> Wed, 24 Jun 2009 09:44:48 +0100

Changed in tomboy (Ubuntu):
status: Triaged → Fix Released
Loïc Minier (lool) wrote :
Loïc Minier (lool) wrote :

I'm not 100% convinced that this warrants a SRU and I heard that a 0.14.2 SRU might be prepared soonish, since I don't run tomboy myself I'll leave this alone for now.

markgalassi (mark-galassi) wrote :

    Loic> I'm not 100% convinced that this warrants a SRU and I heard
    Loic> that a 0.14.2 SRU might be prepared soonish, since I don't
    Loic> run tomboy myself I'll leave this alone for now.

I confess I don't know what an SRU is, but if you mean that you don't
think it's worth adding the fixed tomboy to 9.04 then I disagree.

The world moves toward net-based syncing of such information (see
foxmarks/xmarks), and sadly with GNOME we did not introduce an early
strategy for separating out "to be saved/synced" stuff. So the fact
that Tomboy allows such syncing should be encouraged.

Iain Lane (laney) wrote :

Here's the new SRU diff to update to 0.14.3, as agree with seb128. Only changes in the interdiff are to debian/changelog:

laney@chicken> interdiff -z -p1 tomboy_0.14.0-0ubuntu1.diff.gz tomboy_0.14.3-0ubuntu1.diff.gz
diff -u tomboy-0.14.0/debian/changelog tomboy-0.14.3/debian/changelog
--- tomboy-0.14.0/debian/changelog
+++ tomboy-0.14.3/debian/changelog
@@ -1,3 +1,27 @@
+tomboy (0.14.3-0ubuntu1) jaunty-proposed; urgency=low
+
+ * New upstream release 0.14.3:
+ - Fix build for those with gnome-sharp < 2.23.90 (Stefan Schweizer).
+ - Fix HTML Export add-in on Mac OS X.
+ - Translation updates: el, es
+
+ * New upstream release 0.14.2:
+ - Improve startup time by only rebuilding add-in registry when passing --debug.
+ - Fix random startup crash caused by using GConf before GTK+ was initialized.
+ - Fix over-zealous URL matching.
+ - Support FUSE being built-in to kernel. (LP: #345166)
+ - Prevent crashes when reading unexpected note XML.
+ - Change "Open New Note Template" LinkButton to Button to prevent error.
+ - Upgrade Windows to Mono.Addins 0.4 (no more console window).
+ - Support console logging on Windows (Benjamin Podszun).
+ - Documentation text now cross-platform (Paul Cutler).
+ - Translation updates: ca, el, es, et
+
+ * New upstream release 0.14.1:
+ - Translation updates: ar, ca, el, es, he, kn, nb, tr
+
+ -- Iain Lane <email address hidden> Wed, 15 Jul 2009 22:26:32 +0100
+
 tomboy (0.14.0-0ubuntu1) jaunty; urgency=low

   * New upstream release (LP: #344001)

Iain Lane (laney) wrote :

See bug 399982 for SRU now

Changed in tomboy (Ubuntu Jaunty):
status: Triaged → Invalid
Martin Pitt (pitti) on 2009-07-17
tags: added: regression-release
Martin Pitt (pitti) wrote :

Reopening jaunty task (see bug 399982). Please supply a test case for verification.

This bug is a regression from intrepid (just marked as such) and thus eligible for an SRU. However, the currently proposed upstream version upgrade is not appropriate for an SRU in several ways (please check https://wiki.ubuntu.com/StableReleaseUpdates):

 * It is not a minimally intrusive patch to fix this bug
 * It changes user-visible strings and thus breaks string freeze and translations
 * Unrelated changes which are unnecessary for Ubuntu (like the MacOS or WIN32 changes)
 * Changes other parts of the code without referring to bug reports

I suggest to just backport the change for Tomboy/Synchronization/SyncUtils.cs instead.

Changed in tomboy (Ubuntu Jaunty):
status: Invalid → Incomplete
Iain Lane (laney) wrote :

See minimal debdiff posted by lool previously for the patch to be uploaded

Changed in tomboy (Ubuntu Jaunty):
status: Incomplete → Triaged
Download full text (3.3 KiB)

As an upstream GNOME guy, who works for Novell and uses openSUSE, and still does his best to keep on top of stuff that appears in LaunchPad, I'm starting to get extremely frustrated with the back-and-forth on this SRU stuff.

Every single person who touches this or other Tomboy 0.14.x bugs has something different to say.

Tomboy 0.14.3 is a release in the *stable* series. I follow the GNOME policies related to freezes. Tomboy 0.14.2 has several fixes *specifically* targeted at *your* distribution, based on real problems experienced by *your* users.

> It is not a minimally intrusive patch to fix this bug

This is correct, it fixes a bunch of other bugs specifically reported by your users (all in minimally-intrusive ways).

> It changes user-visible strings and thus breaks string freeze and translations

Nope, this is not correct, unless you refer to documentation updates, in which case, well, duh. This is pretty common practice in GNOME.

> Unrelated changes which are unnecessary for Ubuntu (like the MacOS or WIN32 changes)

And which have absolutely zero effect on Ubuntu, because either the changed files are not in the Linux tarball, or they changes do not build on Linux.

> Changes other parts of the code without referring to bug reports

Because your users had yet to file any bug reports for them and I was too busy working my ass off to get you a release to do it for them. They probably exist now, given that your users have been dealing with some pretty shitty bugs for a few months now. I'm a little tired of wasting my time on you guys right now, though. If you give me some indication that you will ever accept this release which was basically created FOR YOU, with some specific criteria, then I'll happily find (or file if necessary) the corresponding bugs.

+ * New upstream release 0.14.3:
+ - Fix build for those with gnome-sharp < 2.23.90 (Stefan Schweizer).

Self-explanatory.

+ - Fix HTML Export add-in on Mac OS X.

Change to a file that is not part of the Linux tarball.

+ - Translation updates: el, es
+
+ * New upstream release 0.14.2:
+ - Improve startup time by only rebuilding add-in registry when passing --debug.

I highlighted the startup time improvement, but this is also a crash fix on Jaunty.

+ - Fix random startup crash caused by using GConf before GTK+ was initialized.

Reported by Jaunty users.

+ - Fix over-zealous URL matching.

A serious usability bug accidentally introduced just prior to the 0.14.0 release. We make mistakes sometimes.

+ - Support FUSE being built-in to kernel. (LP: #345166)

Self-explanatory.

+ - Prevent crashes when reading unexpected note XML.

Self-explanatory. Part of a non-Tomboy bug which I can look up later.

+ - Change "Open New Note Template" LinkButton to Button to prevent error.

Reported by Jaunty users.

+ - Upgrade Windows to Mono.Addins 0.4 (no more console window).

Does not affect Linux tarball.

+ - Support console logging on Windows (Benjamin Podszun).

Does not affect code that builds on Linux.

+ - Documentation text now cross-platform (Paul Cutler).

If these string changes frighten you, patch them out, as they obviously aren't needed on your platform.

+ - Translation u...

Read more...

> As an upstream GNOME guy, who works for Novell and uses openSUSE

I feel the need to clarify that my work at Novell has nothing to do with Tomboy, I just brought it up to emphasize that I care about users, not distros. I don't want to waste my nights and weekends arguing about distro-specific policies.

Martin Pitt (pitti) wrote :

We got burned by too liberal stable updates before, several times, so we learned to be very cautious and conservative. I am sorry if you spent work with creating a point release "for us" (well, some changes are obviously for other distros/platforms), which contains too many changes. Perhaps in the future we can discuss this beforehand? In general we prefer backporting minimal patches, i. e. throwing git commit IDs into bug reports is usually the best approach. The kinds of fixes which are appropriate for stables are outlined in
https://wiki.ubuntu.com/StableReleaseUpdates#When.

> > It changes user-visible strings and thus breaks string freeze and translations

> Nope, this is not correct, unless you refer to documentation updates, in which case, well, duh. This is pretty common practice in GNOME.

I did refer to the documention, yes. It might be common practice in GNOME to break existing translations in stables, but it's not in Ubuntu.

> > Changes other parts of the code without referring to bug reports
> Because your users had yet to file any bug reports for them

My (with my SRU hat on) general POV for that is that if nobody filed a bug about something, it can hardly be so bad to justify a SRU in the first place. However, if someone (like Iain) wants to include (some of) these fixes, he can just open bugs for them and supply the necessary SRU information (justification, test cases, etc.) I wasn't saying that _you_ (Sandy) are supposed to do this work, just that we use bugs to document SRUs.

> - Translation updates: el, es

These are fine, of course (and I didn't complain about them before).

Iain, I leave it to you whether you prefer taking the new upstream release, restore the old documentation strings, and file bugs for the other changes, or just cherrypick the SRU worthy fixes (which is a lot easier to do, to review and safer, FWIW).

Martin Pitt (pitti) wrote :

Ah, sorry, I just got told that apparently help xml files aren't rebuilt on package build. This is obviously a problem on itself, but at least it removes this particular bit of SRU problem. So if that's really the case (translated documentation isn't generated on build), the change is bearable.

nkk (kambouroglou-nikolas) wrote :

I just want to mention as a user that the synchronization bug in Tomboy is serious enough to prevent some users from upgrading to 9.04 (myself included). I understand that backporting is preferable for obvious reasons and I will not ague for this but the sooner you release a backport fix for 9.04 the better. I hope the upcoming karmic release will have the newer version of tomboy with all the new features. Once you start using Tomboy it becomes a very important tool.

Martin Jackson (mhjacks) wrote :

@nkk: For what it's worth, Karmic currently includes tomboy 0.15.4, which includes the fix for this problem.

ubuntuslave (ubuntuslave) wrote :

After so much frustration trying to sync my tomboy notes via sshfs, I ended up unistalling tomboy:
    $ sudo apt-get remove tomboy
And getting the latest Tomboy tarball, and compiling and installing it:
1) untar the package
2) cd into it
3) Make sure you have the monodevelop package installed (you can get it from the repo)
4) $ ./configure
5) $ make
6) $ sudo make install

It all works as wanted now!

This IS a show stopper. This is what makes users change distributions.

I spent one hour trying to find out why sshfs in tomboy didn't work, but sshfs from the shell did.
Could at least someone please(!) remove the code that checks the output of lsmod for the fuse-module, if nothing else. That can not be an intrusive change. This bug make a major feature of Tomboy nonfunctional.

I love all people that put so much work into Ubuntu. But this red tape issu is not any good for encourage people helping out with Ubuntu bug reporting and other stuff.

Anyway, what is the name of the C++-version of Tomboy, so I can get a working version of Tomboy in Ubuntu 9.04?

Bryan (brywilharris) wrote :

Add this to to your /etc/apt/sources.list:

sudo gedit /etc/apt/sources.list
#add this at the end
deb http://ppa.launchpad.net/brywilharris/ppa/ubuntu
#close and update
#System->Administration->Update Manager

--
Bryan Harris
Research Engineer
Structures and Materials Evaluation Group
<email address hidden>
http://www.udri.udayton.edu/
On Tuesday 08 September 2009 13:30:44 A Jackson wrote:
> This IS a show stopper. This is what makes users change distributions.
>
> I spent one hour trying to find out why sshfs in tomboy didn't work, but
> sshfs from the shell did. Could at least someone please(!) remove the code
> that checks the output of lsmod for the fuse-module, if nothing else. That
> can not be an intrusive change. This bug make a major feature of Tomboy
> nonfunctional.
>
> I love all people that put so much work into Ubuntu. But this red tape
> issu is not any good for encourage people helping out with Ubuntu bug
> reporting and other stuff.
>
> Anyway, what is the name of the C++-version of Tomboy, so I can get a
> working version of Tomboy in Ubuntu 9.04?

A Jackson,

The C++ port of Tomboy (called Gnote) does not support synchronization, so this bug would not be fixed for you by switching to Gnote.

You could simply build the latest stable Tomboy from source (it builds fine in Jaunty), or upgrade to Karmic, which ships a development version of Tomboy that does not have this bug.

I share your frustration with the lack of package updates given that I fixed this bug in a stable bugfix release many months ago. If anybody is interested in maintaining a PPA, let me know.

Bryan (brywilharris) wrote :

Correction!
Add this to to your /etc/apt/sources.list:

sudo gedit /etc/apt/sources.list
#add this at the end (including the jaunty main)
deb http://ppa.launchpad.net/brywilharris/ppa/ubuntu jaunty main
#close and update
#System->Administration->Update Manager
Bryan
--
Bryan Harris
Research Engineer
Structures and Materials Evaluation Group
http://www.udri.udayton.edu/

On Tuesday 08 September 2009 13:57:08 Bryan wrote:
> Add this to to your /etc/apt/sources.list:
>
> sudo gedit /etc/apt/sources.list
> #add this at the end
> deb http://ppa.launchpad.net/brywilharris/ppa/ubuntu
> #close and update
> #System->Administration->Update Manager
>
>
> --
> Bryan Harris
> Research Engineer
> Structures and Materials Evaluation Group
> <email address hidden>
> http://www.udri.udayton.edu/
>
> On Tuesday 08 September 2009 13:30:44 A Jackson wrote:
> > This IS a show stopper. This is what makes users change distributions.
> >
> > I spent one hour trying to find out why sshfs in tomboy didn't work, but
> > sshfs from the shell did. Could at least someone please(!) remove the
> > code that checks the output of lsmod for the fuse-module, if nothing
> > else. That can not be an intrusive change. This bug make a major feature
> > of Tomboy nonfunctional.
> >
> > I love all people that put so much work into Ubuntu. But this red tape
> > issu is not any good for encourage people helping out with Ubuntu bug
> > reporting and other stuff.
> >
> > Anyway, what is the name of the C++-version of Tomboy, so I can get a
> > working version of Tomboy in Ubuntu 9.04?

Bryan, this will not save next person from spending lots of hours on a bug that is found, solved but not implemented.
Sandy Armstrong, but Gnote doesn't falsly annonuce that there is such working feature like synchronizing notes, when in fact it is not.

A Jackson,

In software there are such things as bugs, which are fixed as they are found. I am sorry for you that Ubuntu ships an old version of Tomboy that still has this bug, but to claim that anyone is lying to you is pretty insulting.

We are going to start maintaining a Tomboy PPA with stable and development releases for situations like this where the distribution is unresponsive to update requests. There are no packages yet, but they will be available here: https://launchpad.net/~tomboy-packagers

Hopefully the Ubuntu guys will patch their package as Bryan has done (thanks Bryan!).

Sandy, please calm down. I uses and care about TomBoy, that is why I bother writing here.

I wrote that the SOFTWARE TomBoy falsly announce a feature that doesn't work any longer becouse of a bug in the Ubuntu package (but it has worked previously in 8.10). With the Ubuntu package of TomBoy, there is no difference between TomBoy or Gnote, neither software has a working synchronization. And that TomBoy falsly report this feature in the context of Ubuntu package. If not, this would have been an issue for upstream, wouldn't it?

Ordinary Ubuntu users uses Ubuntu becouse it is easy to use and a friendly distribution. They do not know, and don't want to know, how to add a repository to be able to use TomBoy as it was ment to be used. They want it to just work, better than software in bug #1. To achive this, small bugs like this should be fixed. Perhaps in a simpler way than in the pathches, so not to introduce new bugs, as that was one argument against fixing the bug in 9.04.

But to demand that users of Ubuntu should read this forum and/or add another repository is not a propper fix, it's a (social) hack around this bug.

I am greatfull for people putting work into solving problems in software I like to use, like you and Bryan does. But repository hacks like Bryans should only be needed for back ports of new features, not fixing existing bugs in existing software in released versions of Ubuntu. Espesially when a bug is properly reported, identified and has some patches solving it. I would agree that backporting new features is a bad idea. But not fixing the error is not a good idea either.

I am suggestion Ubuntu to my students, as a better working system. But small bugs like this is not helping me doing my part fixing bug #1.

Any way, as there looks like there is no responces from package owners, I will not write any more about this.

Martin Pitt (pitti) on 2010-02-04
Changed in tomboy (Ubuntu Jaunty):
status: Triaged → Won't Fix
Changed in tomboy:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.