Please make install of timidity automatic

Bug #59092 reported by Timothy Miller on 2006-09-05
22
Affects Status Importance Assigned to Milestone
timidity (Ubuntu)
Wishlist
Lionel Porcheron

Bug Description

This should be a wishlist item, but I also think it's important that it get into Edgy.

My sound hardware doesn't directly support MIDI, so I have to use timidity. I don't know how to manually set it up, so I'm still reading through stuff to get it working.

To be considered a proper OS for multimedia, I think Ubuntu should handle this automatically. If it detects that the sound hardware does not support MIDI, then appropriate emulation software should be installed and correctly hooked into all other apps that would use it.

Related branches

Vincenzo Ciancia (vincenzo-ml) wrote :

Timidity can be enabled as a sequencer by just changing

TIM_ALSASEQ=true
TIM_ALSASEQPARAMS="-Os"

in /etc/default/timidity and restarting the timidity service or rebooting the system. Could this be made the default so that installing timidity automatically enables the virtual midi interface?

I think this will never harm if not used.

Timothy Miller (theosib) wrote :

Ubuntu has a philosophy that it's okay to install something that isn't necessarily going to be used, because it maximizes usability and minimizes problems. For anyone using Ubuntu, the small amount of extra disk space isn't going to be a problem, and for anyone else, there are distros that cater to people with limited system resources.

That being said, I don't see a problem with always installing timidity by default. All network driver kernel modules, for instance, are on the disk by default, so this isn't any worse.

Just make sure that the system is smart enough to disable it when real MIDI hardware is detected. But some MIDI hardware sucks, so people might want to use timidity anyhow. I think, therefore, in GNOME and KDE "System Preferences" panels, there should be a facility for managing this (turing it on and off, etc.).

What do you think?

I think the effort is worth it, because this is one of those things that users typically expect to "just work," and there aren't any license issues that stand in the way like there are with certain multimedia formats.

eppy 1 (choppy121212) wrote :

I agree with this. I've had very few Linux distros automatically set up MIDI (Xandros and SUSE in previous versions did, now they don't, sadly) so this is just extra icing on the cake for me :) It's worth pointing out that Windows sets up MIDI automatically.

Changed in timidity:
status: Unconfirmed → Confirmed
Luca Falavigna (dktrkranz) wrote :

Attached debdiff should fix this.

Format: 1.7
Date: Sat, 16 Jun 2007 03:32:50 +0200
Source: timidity
Binary: timidity-el timidity timidity-interfaces-extra
Architecture: source
Version: 2.13.2-13ubuntu2
Distribution: gutsy
Urgency: low
Maintainer: Ubuntu MOTU Developers <email address hidden>
Changed-By: Luca Falavigna <email address hidden>
Description:
 timidity - Software sound renderer (MIDI sequencer, MOD player)
 timidity-el - An Emacs front end to Timidity++
 timidity-interfaces-extra - TiMidity++ extra user interfaces
Launchpad-Bugs-Fixed: 59092 82860
Changes:
 timidity (2.13.2-13ubuntu2) gutsy; urgency=low
 .
   * Enable MIDI sequencer by default (LP: #59092)
   * Disable buffer fragments (LP: #82860)
Files:
 20b16d848b3a2c24a681cf5ab3a3c0c8 1179 sound optional timidity_2.13.2-13ubuntu2.dsc
 6dc42a211536722544a3651c67124a0b 105133 sound optional timidity_2.13.2-13ubuntu2.diff.gz
Original-Maintainer: Debian Multimedia Team <email address hidden>

Changed in timidity:
assignee: nobody → lionel.porcheron
importance: Undecided → Wishlist
status: Confirmed → Fix Committed
Luca Falavigna (dktrkranz) wrote :

timidity (2.13.2-13ubuntu2) gutsy; urgency=low

  * Enable MIDI sequencer by default (LP: #59092)
  * Disable buffer fragments (LP: #82860)

 -- Luca Falavigna <email address hidden> Sat, 16 Jun 2007 03:32:50 +0200

Changed in timidity:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers