[Gutsy] timidity install fails when timidity is already running

Bug #120810 reported by Scott Beamer on 2007-06-17
170
This bug affects 5 people
Affects Status Importance Assigned to Milestone
timidity (Ubuntu)
Medium
Emmet Hikory
Hardy
Undecided
Unassigned

Bug Description

Setting up timidity (2.13.2-13ubuntu2) ...
 * Starting timidity * Starting TiMidity++ ALSA midi emulation... [fail]
invoke-rc.d: initscript timidity, action "start" failed.
dpkg: error processing timidity (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 timidity
E: Sub-process /usr/bin/dpkg returned an error code (1)

Related branches

A more complete reason:

* Starting TiMidity++ ALSA midi emulation...
ALSA lib confmisc.c:769:(parse_card) cannot find card ''
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_card_driver returned error: No such device
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_concat returned error: No such device
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:3510:(_snd_config_evaluate) function snd_func_refer returned error: No such device
ALSA lib conf.c:3982:(snd_config_expand) Evaluate error: No such device
ALSA lib pcm.c:2144:(snd_pcm_open_noupdate) Unknown PCM default
                                                                         [fail]
invoke-rc.d: initscript timidity, action "start" failed.
dpkg: error processing timidity (--configure):
 subprocess post-installation script returned error exit status 1

This will start working if you reload your sound card information:
'sudo asoundconf list' to find the name of the card, and 'sudo asoundconf set-default-card' to set that card as default. Then, run '/etc/init.d/alsa-utils restart' to reload alsa, and then finish the installation. Everything should be fixed then.

Gonzhauser (gonzhauser) wrote :

Install failed while gutsy update today.

Joe Pimentel (joe-b-pimentel) wrote :

The above solution does not work for me.

'sudo asoundconf list' output:
========
Please note that you are attempting to run asoundconf as a privileged superuser, which may have unintended consequences.

Names of available sound cards:
SB
========

then 'sudo asoundconf set-default-card SB' output:
========
Please note that you are attempting to run asoundconf as a privileged superuser, which may have unintended consequences.

========

then 'sudo /etc/init.d/alsa-utils restart' output:
========
 * Shutting down ALSA... [ OK ]
 * Setting up ALSA... [ OK ]
========

and then 'sudo apt-get -f install' output:
========
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
2 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up timidity (2.13.2-15ubuntu1) ...
 * Starting timidity * Starting TiMidity++ ALSA midi emulation... [fail]
invoke-rc.d: initscript timidity, action "start" failed.
dpkg: error processing timidity (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of timidity-interfaces-extra:
 timidity-interfaces-extra depends on timidity (= 2.13.2-15ubuntu1); however:
  Package timidity is not configured yet.
dpkg: error processing timidity-interfaces-extra (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 timidity
 timidity-interfaces-extra
E: Sub-process /usr/bin/dpkg returned an error code (1)
========

fanboy3445 (fanboy3445) wrote :

Worked like a charm for me, CKruse! Thx

Joe Pimentel (joe-b-pimentel) wrote :

It is working now. Don't now why, but is working.
Tks.

Steve MacDonald (sjmacd) wrote :

this can be solved (at least in my case) by killing timidity before installation. If timidity is running, the timidity++ ALSA midi emulation will fail.

Steve MacDonald (sjmacd) wrote :

But shouldn't this be killed during installation? by the way, I'm not sure if this has any bearing whatsoever for anyone, but the above suggestion to reload the soundcard didn't fix my problem. Could this be some kind of conflict between the timidity package in Ubuntu Studio and the package in Ubuntu? Because I ran into this problem while trying to install the ubuntustudio-audio package.

nabdan (nabil2) wrote :

Hi all,

Same problem as Steve MacDonald.

Not solved until now :(

Bye.

nabdan (nabil2) wrote :

Hi all,

Solved by completely removed timidity from synaptic.

Bye

Mark Preston (emarkpreston) wrote :

I tried the reconfig described above. No luck here.

Emmet Hikory (persia) on 2008-08-08
Changed in timidity:
assignee: nobody → persia
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package timidity - 2.13.2-19ubuntu2

---------------
timidity (2.13.2-19ubuntu2) intrepid; urgency=low

  * Don't try to start the daemon if /dev/snd is missing (LP: #235515)
  * Stop the server on preinst (LP: #120810)

 -- Emmet Hikory <email address hidden> Sat, 09 Aug 2008 01:34:45 +0900

Changed in timidity:
status: In Progress → Fix Released

It seems to be an ALSA problem more than a TiMidity++ problem. I fixed it by editing ~/.asoundcfg and commenting the uncommented line.
This also fixed a lot more problems involving ALSA.

stryd_one (stryd-one) wrote :

Not fixed in LTS release (hardy)

Changed in timidity:
status: Fix Released → Confirmed
Emmet Hikory (persia) wrote :

If a bug is fixed, but not in an older supported release, please nominate the release in which it is not fixed, rather than marking the bug unfixed.

Changed in timidity:
status: Confirmed → Fix Released
status: New → Confirmed
__aux (nab-bopland) wrote :

The bug still remains for computers without a sound card.

I found this workaround that worked for me.

1. sudo apt-get install timidity
2. sudo /etc/init.d/timidity stop
3. sudo mv /etc/init.d/timidity /tmp/
4. sudo apt-get install -f
5. sudo mv /tmp/timidity /etc/init.d/

Razi (razi91) wrote :

OK, i've "solved" it. I turned Firefox and Amarok off and installation was wiyh no errors.
sry for my eng:p

Rolf Leggewie (r0lf) wrote :

Hardy has seen the end of its life and is no longer receiving any updates. Marking the Hardy task for this ticket as "Won't Fix".

Changed in timidity (Ubuntu Hardy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers