tilda stays like a gray window

Bug #144175 reported by Kurt Kraut on 2007-09-23
166
This bug affects 16 people
Affects Status Importance Assigned to Milestone
tilda (Debian)
Fix Released
Unknown
tilda (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: tilda

Tilda stays like a gray window with compiz enabled, from the Appearence menu. See the following screenshot.
Compiz is not relevant (and misleading as well).

I can confirm this issue on latest Gutsy, even without Compiz.
Tilda appears all right for the first time, but later only a gray window is shown all the time (similarly as on the screenshot by Kurt).

Changed in tilda:
assignee: nobody → asisak
importance: Undecided → Medium
status: New → Confirmed
Áron Sisak (asisak) wrote :

Maintainer have been mailed about this issue.

Changed in tilda:
status: Confirmed → Triaged
livingtarget (renekok) wrote :

Same for me, also without compiz.

Thomas Mader (tezem) wrote :

me too and all the guys in this -> http://ubuntuforums.org/showthread.php?t=556932 thread

Bram Bonné (brambonne) wrote :

Same here, with compiz enabled.

François Ingelrest (athropos) wrote :

It's not because of Compiz, it's caused by XGL. For some reason, the code must do something wrong, because it uses the VTE component just like the Gnome terminal which has no problem with XGL.

Áron Sisak (asisak) wrote :

After an upstream hint I tested the CVS version and it is fixed already in that.

Changed in tilda:
status: Triaged → Fix Committed

I made another report about this but that will probably be deleted.

Same thing. No compiz here.

Áron Sisak (asisak) on 2007-10-01
description: updated
Zet (zetman-pwr) wrote :

I have the same problem, either on feisty or on gutsy.

Still having the problem with newest Gutsy (all post-beta updates included). Is the fixed version going to be in Gutsy Final? Because with this bug Tilda is unusable.

I don't see why not, Janne. I don't think the dependencies changed and it's just a fix in the code.

They must be busy crossing the i's and dotting the t's of the core packages or else they would have fixed this by now.

I'm so lost without my little Tilda. I hope they get it updated soon.

whilter (nikt123) wrote :

sorry for the question not entirely matching the current bug-connected-subject but....
Allan MacKinnon - what do you mean by "crossing the i's and dotting the t's of the core packages" ?
becouse i think its a joke unfortunately i dont get it ;/

It was a joke.

All I'm saying is that Tilda is a very low-priority program and they are more concerned with getting Gutsy finalized.

Hopefully the change will be made soon. I've already noticed a few non-essential programs I've submitted bug reports to have been fixed.

Áron Sisak (asisak) wrote :

As I also have written in a previous comment this issue has been fixed in the CVS Tilda.
However, this incorporates quite a few changes so that it is not a trivial task to commit the fix to our package as well.

kubuntux (markus-designity) wrote :

I can't agree! I compiled the current CVS-Version. True transparency works fine but the known issue with the gray windows is still there :(

Áron Sisak, can you tell us the changes specifically that could be problematic? Maybe that will explain why you compile 'works' but kubuntux's does not (although the true transparency is good news).

I thought Tilda was only dependent on libconfuse (which was pretty much an independent library).

D4nielfree (d4nielfree) wrote :

i have the same problem in Gutsy with all packages up-to-date.
can we just have the committed patch so we can compile ourselves

Áron:
Can you revert then to the old (feisty) version for gutsy? Because, really what's the point of having some software in the archive that's broken. And I saw no big flaws or bugs in the old version anyways.

Áron Sisak (asisak) wrote :

Linking Debian bug / raising imporatance. Working together with the Debian package maintainer to get a fix.

Changed in tilda:
importance: Medium → High

Easy workaround:

Enable animated pulldown from Right or Left, set delay to 1 usec. The result is about the same as without pulldown animation and it works correctly.

I can confirm that this works.

Also it's interesting to see that Tilda has become a matter of 'High' importance ;)

Changed in tilda:
status: Unknown → New
Áron Sisak (asisak) wrote :

Actually it is "Low" now because of the easy workaround.

Changed in tilda:
importance: High → Low
Thomas Pifer (zero456) wrote :

The workaround is a bit finicky though: Although it works most of the time it sometimes reverts back to the gray window.

Hugo Josefson (hugojosefson) wrote :

I agree. The workaround only works some of the times. Then, when it's grey again, it stays grey until tilda is completely restarted.

Previously I added some details about when tilda works and breaks for me, as a comment on a duplicate of this bug.
https://bugs.launchpad.net/ubuntu/+source/tilda/+bug/148694/comments/5

However, after a bit more testing, I can conclude that I really can't give any really certain statements about when the bug occurs and not... :) It's just more likely not to appear with some of the settings...

Yeah, it's not a dependable workaround so it's hardly a fix. I suggest putting the importance up to medium.

Also, why is Debian's version of Tilda being linked to this bug report?

Paul Ivanov (pivanov) wrote :

I'd just like to pitch in and confirm the issues outlined here (and the lack of a reliable workaround). It's amazing how many times a day I press F1, and how frustrating this bug is.

Daan Davidsz (daandavidsz) wrote :

I've become so frustrated I've just switched to Yakuake. At least that one works.

I think I'll use yakuake too (even if it does need all those kde libs).

Mantas Zimnickas (sirex) wrote :

I have same problem, and probably will switch to yakuake too... :(

The proposed workaround solved the issue for me ! No more gray window.
Will do till next version of Tilda is released ;-)

Yes, Sébastien,but will it work ofter multiple bootups?

Mine worked at first but after a reboot it went back to the blank screen. So the workaround isn't reliable and this package should have it's importance put back to 'High' or at least 'Medium'.

I just tried rebuilding the feisty package for gutsy but that doesn't solve this. The problem is really related to the interaction with the dependencies.

manatlan (manatlan) wrote :

Found a better workaround !!!

Remove the tilda which come from gutsy (it is bugged)
and install this one :
http://macsim.labolinux.net/upload/tilda_0.09.4-0ubuntu2.1_i386.deb
(it was builded (not me!!) in the past, when "true transparency patch" was tested in tilda)

for me : it's work like a charm .... hope for you too ;

Thomas Pifer (zero456) wrote :

In regards to what manatlan wrote, that package is bugged as well. I also agree with the motion to at least push the importance to medium.

I agree with Thomas. The above package failed to work for me and I reiterate that the importance be turned up a notch.

With this version Tilda crashes just after first run. Only if I remove
configuration (~/.tilda) then Tilda's configuration window appears, but after
that, again, no Tilda window and even no process.

I trying to use Tilda for a half year, but during this time I have never seen it
working properly. Have it worked at all? :/

On 2007-10-22 21:14, manatlan wrote:
> Found a better workaround !!!
>
> Remove the tilda which come from gutsy (it is bugged)
> and install this one :
> http://macsim.labolinux.net/upload/tilda_0.09.4-0ubuntu2.1_i386.deb
> (it was builded (not me!!) in the past, when "true transparency patch" was tested in tilda)
>
> for me : it's work like a charm .... hope for you too ;
>
> --
> tilda stays like a gray window
> https://bugs.launchpad.net/bugs/144175
> You received this bug notification because you are a direct subscriber
> of the bug.

--
Mantas aka sirex
http://sirex.raguvele.lt/
Ubuntu - Linux for human beings

"Don't write a test plan. Instead, test." -- Bret Pettichord

Thomas Pifer (zero456) wrote :

Is there any way the CVS version could be built and packaged for Gutsy, seeing as it is already fixed in that version?

Mantas Zimnickas (sirex) wrote :

I was happy, when Tilda on fresh Gutsy install runs even that it became gray and unusable. But now after a week of using Gutsy Tilda doesn't shows up at all... :(

This is what I get:

$ tilda --version
tilda 0.09.4

Copyright (c) 2005,2006 Tristan Sloughter (<email address hidden>)
Copyright (c) 2005,2006 Ira W. Snyder (<email address hidden>)

This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.
$ dpkg -l tilda |grep tilda
ii tilda 0.09.4-4 terminal emulator with first person shooter console likeness
$ rm -r ~/.tilda
    # After this, configuration window shows up.
    # I do not made any changes and just press „OK“.
    # For less than a second Tilda window flashes and immediately disappears.
    # After that fallowing output appears:

** (tilda:6484): WARNING **: Invalid borders specified for theme pixmap:
        /home/sirex/.themes/Leopard_GTK_v0.2/gtk-2.0/Tabs/notebook_top_flat.png,
borders don't fit within the image

** (tilda:6484): WARNING **: Invalid borders specified for theme pixmap:
        /home/sirex/.themes/Leopard_GTK_v0.2/gtk-2.0/Frame-Gap/frame1.png,
borders don't fit within the image

** (tilda:6484): WARNING **: Invalid borders specified for theme pixmap:
        /home/sirex/.themes/Leopard_GTK_v0.2/gtk-2.0/Buttons/button-default.png,
borders don't fit within the image

(tilda:6484): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed

(tilda:6484): Gdk-CRITICAL **: gdk_window_set_geometry_hints: assertion `GDK_IS_WINDOW (window)' failed

(tilda:6484): Gtk-CRITICAL **: gtk_window_resize: assertion `height > 0' failed

   # Then I switch back Ubuntu's GTK Human theme.
$ tilda
$ ps -e | grep tilda
$
   # All output disappears, but Tilda is still crashing.

   # After that I switched off all visual affects and changed not only GTK theme but changed whole theme to Human (with window borders, mouse cursors and so on..). And this is what I get:
$ tilda

(tilda:6572): Gdk-CRITICAL **: gdk_window_set_geometry_hints: assertion `GDK_IS_WINDOW (window)' failed
$ ps -e | grep tilda
$
     # Then changed whole theme to Clearlooks, and Visual Effects is still turned off.
$ tilda

(tilda:6605): Gdk-CRITICAL **: gdk_window_set_geometry_hints: assertion `GDK_IS_WINDOW (window)' failed
$ tilda
$ tilda
$ tilda
$ ps -e | grep tilda
$

Hope that this helps some how to finally fix Tilda.

roma (roma-nerto) wrote :

I solve it!!!!

For it remove the .tilda folder in home.
and run shell
sudo apt-get remove tilda libconfuse0

and

sudo apt-get install tilda

try it!!

Mantas Zimnickas (sirex) wrote :

Unfortunately it doesn't work for me:

$ rm -r ~/.tilda
$ sudo apt-get remove tilda libconfuse0
    [ ... ]
Removing tilda ...
Removing libconfuse0 ...

$ sudo apt-get install tilda
    [ ... ]
Need to get 0B/61.5kB of archives.
After unpacking 291kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Selecting previously deselected package libconfuse0.
(Reading database ... 140394 files and directories currently installed.)
Unpacking libconfuse0 (from .../libconfuse0_2.5-3_i386.deb) ...
Selecting previously deselected package tilda.
Unpacking tilda (from .../tilda_0.09.4-4_i386.deb) ...
Setting up libconfuse0 (2.5-3) ...

Setting up tilda (0.09.4-4) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
$ ps -e | grep tilda
sirex@sirex-laptop:~$ tilda

(tilda:6549): Gdk-CRITICAL **: gdk_window_set_geometry_hints: assertion `GDK_IS_WINDOW (window)' failed

(tilda:6549): Gtk-CRITICAL **: gtk_window_resize: assertion `height > 0' failed
$ ps -e | grep tilda
$

Christopher (captain-c) wrote :

roma's solution worked for me! Thanks roma! I really didn't want to have to continue using Yakuake; Tilda is awesome.

Christopher (captain-c) wrote :

Ok, I spoke too soon. The bug reappeared after it was working for a while. It happened after I unchecked animated pull down as it was choppy with more than 1 tab.

Thomas Pifer (zero456) wrote :

germania from the Ubuntu forums has kindly put together a package containing the current CVS version of Tilda (as of October 22) that seems to have the problem fixed. You can get it here: http://benclarke.ca/tilda_0.9.5pre-1_i386.deb.

And the forum post is here: http://ubuntuforums.org/showpost.php?p=3605907&postcount=10

Mantas Zimnickas (sirex) wrote :

I installed this .deb via gdebi. After first run I got this:

    tilda: error while loading shared libraries: libconfuse.so.0: cannot open
    shared object file: No such file or directory

After installing libconfuse0:

    sudo apt-get install libconfuse0

Tilda started to work and it seems, that Tilda doesn't crashes as before, but
still doesn't work. I see blinking cursor at the very top left corner of Tilda's
window, but I can't enter any thing. When I starting to type, cursor stops
blinking, but entered letters doesn't appears. So at this point Tilda is
unusable...

I fix that by setting „Run custom command instead of shell“ to my shell.

Also, „Always on Top“ doesn't work correctly too. Currently I use compiz, so it
is possible that „Always on Top“ problem is related to compiz. When I press a
key to show up Tilda window, it pulls down below currently active window, but if
I click on Tilda window with mouse, then it stays on top as needed...

Any way, at least Tilda started to work! :) Hope those bugs soon disappears too.

On 2007-10-31 06:21, Thomas Pifer wrote:
> germania from the Ubuntu forums has kindly put together a package
> containing the current CVS version of Tilda (as of October 22) that
> seems to have the problem fixed. You can get it here:
> http://benclarke.ca/tilda_0.9.5pre-1_i386.deb.
>
> And the forum post is here:
> http://ubuntuforums.org/showpost.php?p=3605907&postcount=10
>
> --
> tilda stays like a gray window
> https://bugs.launchpad.net/bugs/144175
> You received this bug notification because you are a direct subscriber
> of the bug.

--
Mantas aka sirex
http://sirex.raguvele.lt/
Ubuntu - Linux for human beings

Premature optimization is the root of all evil Tony Hoare Though often attributed to Donald Knutt.

Tried the .deb too, but no changes. The Bug is still existing. Maybe the Problem is not Tilda itself? Compiz isn't installed on my System....

Feng Chao (chaofeng) wrote :

Enable animated pulldown from Right or Left, set delay to 1 usec. The result is about the same as without pulldown animation and it works correctly.
=========================================
This worked for me . But tilda should be start manully instead of automatic start after bootup.

Feng Chao (chaofeng) wrote :

Enable animated pulldown from Right or Left, set delay to 1 usec. The result is about the same as without pulldown animation and it works correctly.
=========================================
This worked for me . But tilda should be started manully instead of automatic start after bootup.

Thomas Pifer (zero456) wrote :

I should've mentioned that the package does not download any of it's needed dependencies, so it's a good idea to first install the broken package in the repos, then install the package put together by germania.

I can get mine to work when I start it manually but not when I set it to run at boot.

crash (crash369) wrote :

Just wanted to chime to say that enabling animated pulldown does not fix the problem for me. With it enabled, it does take longer for the grey-window-effect to appear, but eventually it comes back.

accipiter (tommasoscarelli) wrote :

I confirm the bug using Ubuntu Gutsy Gibbon with compiz...

P.S. = Tilda is a good program

Changed in tilda:
status: New → Fix Released
Kev (ukev) wrote :

nearly 4 month later and the bug is still existing...

Diego Alcántara (diego-faz) wrote :

I've deleted de .tilda directory, and started tilda manually, it seems to be working. I've changed just a few things respect the default configuration, see attached file.

After I upgraded to Ubuntu 8.04 alpha , there is no the gray window anymore.
So I think this bug is fixed in the new release.

D4nielfree (d4nielfree) wrote :

this bug is fixed in tilda version 0.9.5
I'm using 7.10 with compiz fusion
no more gray window now

daniel@mars:~$ tilda --version
tilda 0.9.5

Copyright (c) 2005,2006 Tristan Sloughter (<email address hidden>)
Copyright (c) 2005-2007 Ira W. Snyder (<email address hidden>)

This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

Samuel Kroslak (samopal) wrote :

in my case, I tried Ubuntu 7.10 with Tilda 0.9.4 with grey window issue as descibed here. Downloaded and compiled 0.9.5, but the issue is still here! Does it mean I have to wait until 8.04? Isn't there any other way out?

D4nielfree (d4nielfree) wrote :

Samuel Kroslak ,
did u uninstall the old tilda completely?
try to delete ur old .tilda dir and run tilda again,
or try to keep ur whole system up-to-date using apt-get upgrade,
hope this would help

Samuel Kroslak (samopal) wrote :

I had previous version 0.9.4 installed through apt, so I uninstalled it there, then I deleted .tilda in my home dir and tried to recompile and reinstall new tilda 0.9.5 from source. My OS is up to date as of today. I missed the point with .tilda deletion, so now I will wait a little and see if bug is gone... I'll write then here.

Mantas Zimnickas (sirex) wrote :

I just downloaded Tilda sources, 0.9.5 version and compiled them. When I tried to run it, I saw this:

 % tilda
Unable to open lock directory: /home/myhome/.tilda/locks
Unable to open lock directory: /home/myhome/.tilda/locks
zsh: segmentation fault (core dumped) tilda
 %

 % tilda --version
tilda 0.9.5

Copyright (c) 2005,2006 Tristan Sloughter (<email address hidden>)
Copyright (c) 2005-2007 Ira W. Snyder (<email address hidden>)

This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it
under certain conditions. See the file COPYING for details.

Probably there is some thing wrong with compilation. I try to check that.

Áron Sisak (asisak) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Hardy Heron.

If you need a fix for the bug in previous versions of Ubuntu, please follow the instructions for "How to request new packages" at [WWW] https://help.ubuntu.com/community/UbuntuBackports#request-new-packages

Changed in tilda:
assignee: asisak → nobody
status: Fix Committed → Fix Released
amias (amias) wrote :

still not working in hardy 64bit either , random grey screens and session crashing
no textual output

Thomas Pifer (zero456) wrote :

Agreed: The problem still persists on the latest Hardy Alpha 6.

+1 Using an updated Hardy A6, the Bug is still existing. I have tested this with Compiz enabled/disabled but the result is the same as under Gutsy.

Nick B. (futurepilot) wrote :

Confirming, this still happens on Hardy.

Philipe Farias (philipefarias) wrote :

Still the bug and there's nothing of the 0.9.5 version in the repos...at least for Hardy 64bit...

I have Hardy 32bit, and Tilda 0.9.5pre.

The bug doesn't occur for me anymore, even with animated pulldown disabled. I am using compiz.

Same here on hardy heron 64bits with version from repository : tilda 0.9.5pre
Solved by creating a dummy config_0 file in ~/.tilda

Sorry i was talking about this bug :

% tilda
Unable to open lock directory: /home/myhome/.tilda/locks
Unable to open lock directory: /home/myhome/.tilda/locks
zsh: segmentation fault (core dumped) tilda

I'm using zsh too :/

FND (ace-noone) wrote :

This bug persists with Hardy and tilda version 0.9.5.
See bug #223723 (request for upstream release).

AwarenesS (voidplayer) wrote :

My tilda version is: 0.09.6-1ubuntu1

And still goes gray from time to time. I just close it and opened again

Changed in tilda (Ubuntu):
status: Fix Released → Confirmed
Aquilai (yho2005) wrote :

Still have gray screen using 0.09.6-1ubuntu1 version. I have to restart it too exactly like Awareness.

Dimitrios Symeonidis (azimout) wrote :

The bug on Debian seems closed since 2007, but also there people are reporting to still have this issue...

Mr. Blonde (mr.blonde) wrote :

I can't believe this is still happening after 3 years, but it is.

AwarenesS (voidplayer) wrote :

I confirm this still happen in maverick

koy (k0y073) on 2011-01-03
description: updated

I can confirm that I still get this bug in Ubuntu (Mint) 11.04... Any ideas what causes it? using Tilda 0.9.6

Roland Hieber (rohieb) wrote :

I have the feeling that it has something to do with the animated pulldown feature. I have been using it for almost a month now without animation, and greying did never happen. As soon as I enable animated pulldown, after a few (about 10 to 20) hides and unhides it goes gray. And then it dowsn't help to disable the animation again, it stays grey until I restart it.

Michael Day (manveru-alma) wrote :

I just wanted to add that in Ubuntu 11.10 / Tilda 0.9.6, disabling the animation fixed the problem. Since I read Roland Hieber's comment above, I haven't had it go blank on me once. However, I have the width set to 100%, and it now stops about 100 pixels short of the left of the screen. It's not the most attractive thing with the lack of animation and the incorrect width, but at least it works.

Michael Day (manveru-alma) wrote :

Update to my last post: it wasn't cut off 100 pixels from the left, it was actually positioned 100 pixels from the left of the screen. I went into the preferences and centered it horizontally, and now it is fine. Because the width is set to 100%, it also stayed in the same position when I unchecked the box to center it horizontally.

Bit-Man (victor-bit-man) wrote :

I also can confirm that in Ubuntu 12.10 and Tilda 0.09.6 the issue is still there.
Also unchecking animation seems to fix the problem.

Andreas Kern (kerna) wrote :

12.04.2 LTS
I just ran into this bug
as in #80 disabling "animated pulldown" fixed it

Sebastian Geiger (lanoxx) wrote :

Hi, I am pretty sure this is fixed in the latest version. Can anyone confirm?

Sebastian Geiger (lanoxx) wrote :

From what I have seen in the duplicated and the referenced Debian bug this should have been fixed recently, so I am closing this bug. Please reopen if you still experience this issue.

Changed in tilda (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.