text in the quickfilter toolbar disappear

Bug #959823 reported by Sven Romeike on 2012-03-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Confirmed
Low
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

When you deactivate and activate the quickfilter bar in mozilla thunderbird the text next to the icons in the quickfilter bar disappears until you restart the program

reproduce:

1) start thunderbird
2) uncheck "quickfilter" and check it again in the toolbar
3) notice that the text written next to the icons disappeared
4) restart thunderbird and the text will appear again.

this bug is reproducable and occurs every time.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: thunderbird 11.0+build1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
NonfreeKernelModules: nvidia
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: lun4tic 2102 F.... pulseaudio
BuildID: 20120313203910
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf9ff8000 irq 45'
   Mixer name : 'Realtek ALC888'
   Components : 'HDA:10ec0888,14627345,00100001'
   Controls : 45
   Simple ctrls : 21
Channel: release
Date: Tue Mar 20 01:21:43 2012
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
IncompatibleExtensions:
 EDS Contact Integration - <email address hidden>, Version=0.3.9, minVersion=7.0, maxVersion=11.0a1, Location=app-global, Type=extension, Active=Yes
 German Dictionary - <email address hidden>, Version=2.0.2, minVersion=1.9a8pre, maxVersion=2.0.*, Location=app-profile, Type=extension, Active=Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
IpRoute:
 default via 192.168.1.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.6 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Profiles: Profile0 (Default) - LastVersion=11.0/20120313203910 (Running)
RfKill:

RunningIncompatibleAddons: True
SourcePackage: thunderbird
UpgradeStatus: Upgraded to precise on 2012-03-14 (5 days ago)
WifiSyslog:

dmi.bios.date: 11/06/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.4
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: MS-7395
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.4:bd11/06/2008:svnMICRO-STARINTERNATIONALCO.,LTD:pnMS-7395:pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnMS-7395:rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: MS-7395
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO.,LTD

Created attachment 495466
screenshot

STR:
1. toggle to show quick filter bar;
2. select a filter by tags;
3. select one messages into resulset;
4. toggle to hide quick filter bar;
5. here I see a "corrupt" layout (no icons) as show in attached screenshots.

Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101205 Thunderbird/3.3a2pre

Created attachment 495467
screenshot (default mode, not "corrupt")

Aureliano do you really mean "no icons" or "no text"? If you mean no icons, then it's a dupe of Bug 616932. When no text, had the window the same width?

I think it's the same as your other bug. Once the available width for the quick-filter bar is getting too small, the text labels disappear on purpose. Since no icon is available for the "Tag" selector button, it looks empty.

(In reply to comment #2)
> Aureliano do you really mean "no icons" or "no text"? If you mean no icons,
> then it's a dupe of Bug 616932. When no text, had the window the same width?

Sorry Richard I mean "no text".
And yes the window has the same width.

That seems to be a borderline case where the threshold to switch between "icons+text" and "icons only" is crossed depending on the qfb state.

Moving to "Search" component as this is not a theme issue.

(In reply to comment #3)
> I think it's the same as your other bug. Once the available width for the
> quick-filter bar is getting too small, the text labels disappear on purpose.
> Since no icon is available for the "Tag" selector button, it looks empty.

I rsx11m.
I disagree, but it's possible that I'm wrong.
I disagree because this reason: if I start TB on my laptop and then I select my Inbox and toggling to show quick filter bar I see with "text + icons" mode.
When I execute STRs in comment #0, I see quick filter bar in "icons only" mode.
For me this sound as incongruent behavior.

Ciao.

I may not understand your STR correctly, but I get either icons only or icons+text when modifying the window width, and when toggling the QFB with
the handle on the tab (your step #4), it disappears as intended...

Aureliano can you try to move the folderpane splitter a little bit to the right or left with open QFB. How much have you to move until the text collapses, or after a search, appears?

(In reply to comment #8)
> Aureliano can you try to move the folderpane splitter a little bit to the right
> or left with open QFB. How much have you to move until the text collapses, or
> after a search, appears?

yes, this fixes the issue... but I dont understand why. During execution of STRs in comment #0 window width don't change.
Then I think this issue can close as dupe of any other.

(In reply to comment #8)
> Aureliano can you try to move the folderpane splitter a little bit to the right
> or left with open QFB. How much have you to move until the text collapses, or
> after a search, appears?

Another workaround is to enable\disable messages pane (hitting F8)

Sven Romeike (lun4tic) wrote :
Sven Romeike (lun4tic) wrote :

definately upstream cause its on windows as well and also reproducable

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

i deactivated and then activated the quickfilter button through the bar in thunderbird 11. I tested this in the Ubuntu 12.04 version as well as in the windows version.

Actual results:

when you deactivate the quickfilter bar and then activate it again the icon text in the quickfilter bar disappears until you restart the program

Expected results:

the text should not have disappeared.

What exactly do you mean with "icon text"? You mean the text under the icon on the toolbar to deactivate the quick filter bar? Can you attach a screenshot?

I mean the icon texts like "unread, marked, contact, ..." that are the actual quickfilter bar.

Created attachment 607561
before the bug occured

Created attachment 607562
after the bug occured

I attached before and after screenshots so you see what i mean

Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → New

This is still not solved even in TB14, Win XP. Just toggling the quick filter bar on/off/on makes the text disappear. TB window is maximized all the time.

Thanks, I see it now. It is already reported.

*** This bug has been marked as a duplicate of bug 616933 ***

*** Bug 737420 has been marked as a duplicate of this bug. ***

Changed in thunderbird:
status: New → Invalid

*** Bug 569614 has been marked as a duplicate of this bug. ***

I can't seem to reproduce this on current trunk (TB32), but I can with TB24. Does anybody still see it on current trunk?

I can still reproduce in Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Thunderbird/29.0

*** Bug 1043555 has been marked as a duplicate of this bug. ***

Steps to reproduce on trunk and release:
1. Have Inbox selected.
2. Select account name in folder pane
3. Switch back to Inbox.
It's possible that one needs several tries to reproduce the issue.

Details:
When selecting the account, onOverflow will run
http://mxr.mozilla.org/comm-central/source/mail/base/content/quickFilterBar.js#333
and collapse the buttons:
http://mxr.mozilla.org/comm-central/source/mail/base/content/quickFilterBar.js#359

The expansion of the labels should be done by onWindowResize
http://mxr.mozilla.org/comm-central/source/mail/base/content/quickFilterBar.js#371
but that only runs for window resizes:
http://mxr.mozilla.org/comm-central/source/mail/base/content/quickFilterBar.js#34

I had this issue for a while and then installed the extension "expression-search" which is also handling the quick filter bar. The developer of this extension fixed the disappearing-text-issue years ago, maybe his code could help. The reason of this bug is, in his words, "the shrink value depends on the total length of the search bar and the length contains the (hidden) 'quick search filter' text box".

Maybe someone who understands what this means could compare the extension's and Mozilla's code and fix this for those who don't use this extension.

This bug reappears in Thunderbird 52.0 Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.0 (and I believe also in its most previous version).

Steps to reproduce:
1.) Use the classic view of TB's window-layout.
2.) Deactivate message (preview) pane by pressing F8 on your keyboard.
3.) Activate and deactivate (toggle) Quick Filter Toolbar, which you can do in any given manner.
4.) The text will disappear, due the fact, that the "search this message CTRL + SHIFT + K" searchbar gets a little bit bigger, instead of staying the same size.

Workaround:
Keep the message pane always activated.

Also restarting TB or opening a new tab will clean up the layout and show the text Quick Filter Toolbar again.

> 4.) The text will disappear, due the fact, that the "search this message
> CTRL + SHIFT + K" searchbar gets a little bit bigger, instead of staying
> the same size.

Sorry, I made a small translation failure; it really should say "search these messages CTRL + SHIFT + K" instead of "search this message CTRL + SHIFT + K"

BTW: Where's the edit button for bugzilla comments? ;-)

gf (gf-interlinks) wrote :

Hello Sven,
Thank you for submitting this bug and reporting a problem with Thunderbird.

You made this bug report in 2012 and there have been several versions of Ubuntu and Thunderbird since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
Or, if it is still a problem, could you run the following (only once):
apport-collect BUGNUMBER

and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu and Thunderbird better.

G

Changed in thunderbird (Ubuntu):
status: New → Incomplete
Paul White (paulw2u) wrote :

I can confirm this issue with Thunderbird 60.2.1 and Ubuntu 18.04
Upstream bug is a duplicate of #616933 so changing

Changed in thunderbird (Ubuntu):
status: Incomplete → Confirmed
Changed in thunderbird:
importance: Medium → Unknown
status: Invalid → Unknown
tags: added: bionic
removed: precise
Changed in thunderbird:
importance: Unknown → Low
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.