Thunderbird asks three times for my master password

Bug #940631 reported by Pierre Rudloff on 2012-02-24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
thunderbird (Ubuntu)

Bug Description

When Thunderbird is launched it asks for the master password three times in a row. Only one password prompt needs to be completed. The remaining prompts can be dismissed with the escape key.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunderbird 10.0.2+build1-0ubuntu0.11.10.1
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic i686
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: i386
 /dev/snd/controlC0: pierre 1609 F.... pulseaudio
                      pierre 1636 F.... xfce4-volumed
BuildID: 20120216123548
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
 Card hw:0 'Intel'/'HDA Intel at 0x50440000 irq 43'
   Mixer name : 'SigmaTel STAC9221 A1'
   Components : 'HDA:83847680,106b2200,00103401'
   Controls : 21
   Simple ctrls : 13
Channel: release
Date: Fri Feb 24 22:18:53 2012
ForcedLayersAccel: False
 auto lo
 iface lo inet loopback
 Timezone Definitions for Mozilla Calendar - <email address hidden>, Version=1.2011n, minVersion=2.0, maxVersion=10.0, Location=app-system-share, Type=extension, Active=Yes
 Provider for Google Calendar - ID={a62ef8ec-5fdc-40c2-873c-223b8a6925cc}, Version=0.11, minVersion=8.0a1, maxVersion=10.0, Location=app-system-share, Type=extension, Active=Yes
 default via dev wlan0 proto static dev wlan0 scope link metric 1000 dev wlan0 proto kernel scope link src metric 2
Profiles: Profile0 (Default) - LastVersion=10.0.2/20120216123548 (Running)
RunningIncompatibleAddons: True
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install) 06/27/07
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB21.88Z.00A5.B07.0706270922
dmi.board.asset.tag: Base Board Asset Tag Mac-F4208CAA
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F4208CAA
dmi.modalias: dmi:bvnAppleInc.:bvrMB21.88Z.00A5.B07.0706270922:bd06/27/07:svnAppleInc.:pnMacBook2,1:pvr1.0:rvnAppleInc.:rnMac-F4208CAA:rvrPVT:cvnAppleInc.:ct10:cvrMac-F4208CAA: MacBook2,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Pierre Rudloff (rudloff) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed

I found some very old bugreports about a similar issue but nothing new since TB 38.0.1.
Since my addons and my accounts did not change between TB31 and 38 I consider this a direct regression.

With TB31 I got one master password prompt at startup.
With TB38.0.1 I get immediately 4 of them overlapping each other so I need to enter my master password four times in a row.

I have 3 IMAP accounts, 2 NNTP and 1 XMPP on that system.

we have several reports of this in support forum and such.
Do you have calendar installed?

I see the same behaviour on two systems. But the one cited above with the numbers does NOT have Lightning/Calendar activated.

We're seeing quite a few posts in SUMO about password prompts, and also comments in crash reports which are hangs.

But not much new stuff being reported in bugzilla - most in this query don't fit the mold of this bug

*** Bug 1192414 has been marked as a duplicate of this bug. ***


I have the same problem here: some calendars and some email accounts configured and my passwords "protected" with master password (because LaZagne showed how the default set up is insecure!). And multiple pop ups to ask for master password at Thunderbird's opening.

And I have even more dramatic problems:

1. I use AwesomeWM and open automatically ThB at startup and on a specific "desktop" ("tag"). If I do not fill/cancel at least 1 of the popups quickly, and if move around between the "desktops", and then come back to the "desktop" where ThB is opened, I cannot validate/cancel the pop ups (even if I can fill the "password" field!). The only available option I found is to kill ThB with "pkill thunderbird"

2. I encountered the situation above (and removed the .lock & .parentlock files) at the same time (Ubuntu) as my system was updating ThB's package. Now, everytime I try to open ThB, I see the pop ups, but when I fill/cancel a few of them, the main ("Mail") ThB window as well as the remaining popups just disappear... So I have no way to do anything in any GUI.
However, I've tried starting ThB from command-line, and when this occurs, the process does not end, so I know ThB is still running, but with no GUI to control it :{

I would welcome any advise to get back at least a minimal control over ThB...

This bug might be duplicate of:

For the record, if it can help someone: I managed to get access again to ThB:
1. $ mv ~/.thunderbird{,OLD} # rename config dir
2. $ thunderbird # just open it, configure nothing & quit
3. $ mv ~/.thunderbird{OLD,} # rename config dir back

With this I can now run ThB. I still have the millions of popups, but I can see the "main" GUI, go to "Preferences->Security", uncheck the 'Master Password", enter my password to definitively unlock the keychain.

Indeed, enabling again the master password results in ThB faulting back to it erroneous behavious: closing down randlomly when password-asking pop-ups are validated/cancelled. This means one cannot use a "Master Password" in this release at all if some calendar are in use. This means all the passwords for all email/news/IM/calendar are exposed!

PS: I'm using 38.2.0

Confirmed for 38.2.0 on Gentoo Linux amd64.

Three popups in a row, of which only one has to be filled in. TB unlocks the password store even if the other two are cancelled.

I confirm this problem with TB 38.3.0 (regression) + Windows 7
Same problem with TB41
No problem with TB31.2.0
(sorry for the translation :-( )
Je confirme ce problème avec TB38.3.0 ( régression !) + Windows 7
Meme problème avec TB41
Pas de problème avec TB31.2.0
(désolé pour la traduction :-( )

Using gmail OAUTH? Dupe of bug 1176399?

Bonjour / Hello
@ Magnus Melin - Using Gmail OAuth?
By disabling Gmail OAuth (TB38) is ok
The solution with the Startup Master extension also works well
@ Magnus Melin - Using gmail OAUTH?
En désactivant OAUTH de Gmail (TB38) c'est ok
La solution avec l'extension Startup Master fonctionne aussi très bien

GMail oauth is not the trigger for me.
I do not use a Google mail account in my Thunderbird installations. In one I probably have Google calendar in Lightning but the other does not even have Lightning enabled. Therefore oauth is not the only issue.

Same here,
It looks to me that Lightning could be triggering this too, the Lightbird add-on and possibly the EWS Exchange Calendar add-on (Sorry, I have not tested the case here).


Results of my tests:
With Lightning = ok (no multiple window starting TB)
With Lightning + Provider for Google Calendar +1 Google calendar = Multiple Windows startup TB
The extension master startup does not change the problem = Multiple Windows startup TB
with Imap account google + 1 OAuth2 = Multiple Windows startup TB
With the extension Startup Master = ok (no multiple window starting TB)

With Lightning + Delete Google Calendar = ok (no multiple window starting TB)
With the extension Google Calendar Tab = ok (no multiple window starting TB)
This extension displays Google Calendar in a tab

(sorry for the translation :-( )
Résultat de mes essais:
Avec Lightning = ok (pas de fenêtre multiples au démarrage de TB)
Avec Lightning + Provider for google calendar + 1 agenda Google = Fenêtres multiples au démarrage de TB
L'extension startup master ne change rien au problème = Fenêtres multiples au démarrage de TB
Avec 1 compte imap google + OAuth2 = Fenêtres multiples au démarrage de TB
Avec l'extension Startup Master = ok (pas de fenêtre multiples au démarrage de TB)

Avec Lightning + Suppression de l'agenda Google = ok (pas de fenêtre multiples au démarrage de TB)
Avec l'extension Google Agenda Tab = ok (pas de fenêtre multiples au démarrage de TB)
Cette extension affiche l'agenda de Google dans un onglet

A short regression range would really be helpful - from anyone who has post here and first seeing the problem in version 38

I had really intended this question for L.I.A.R., j2m06...

(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #15)
> A short regression range would really be helpful - from anyone who has post
> here and first seeing the problem in version 38

Guys/gals, this would be a good first step to getting a solution for your issue

I run in the same problem with TB 38.5.1 on Mac OSX after changing my Google account to OAuth2. The dialogue for the master password pops up four times. I thought this is because I have four password protected accounts and it's related to the last TB update, as this happened at the same time when I changed Google to OAuth2. But reading this bug, it seems, this is related to the Google account. For accessing the Google IMAP store I applied the "third party application password" so OAuth2 shouldn't interrupt in any way. Using the same config without master password protection there is no problem (which don't wonder as the master password dialogue doesn't appear at all).

(In reply to Wolfgang Rosenauer [:wolfiR] from comment #0)
> I found some very old bugreports about a similar issue but nothing new since
> TB 38.0.1.
> Since my addons and my accounts did not change between TB31 and 38 I
> consider this a direct regression.
> With TB31 I got one master password prompt at startup.
> With TB38.0.1 I get immediately 4 of them overlapping each other so I need
> to enter my master password four times in a row.
> I have 3 IMAP accounts, 2 NNTP and 1 XMPP on that system.

Do you still see these multiple prompts?
And are any of them gmail accounts?

I still have that issue with 38.7. And I have a GMail account configured but only for XMPP/Google Talk.

Yes, with 38.6.0 on Mac OSX the problem is still problem. Prompts for the master password appear as many times as accounts with passwords are set up. On a system with the same accounts but no master password is set to unlock the accounts, there are no problems. Seem's the issue is in unlocking the password data base.

I still see this on TB 28.6.0. I'm not using Gmail in TB. I am using the Lightning calendar, and I believe that is what is causing the dual password prompting for me. I use a master password.

*** Bug 1269188 has been marked as a duplicate of this bug. ***

*** Bug 1300737 has been marked as a duplicate of this bug. ***

Download full text (60.3 KiB)

I am not sure what is meant by "duplicate by [some closed bug]"
I must say I experience it for several years on one particular workstation.
I have only one account, bu I have to enter master password six (6) times.
Only first entry is necessary, pressing OK on five others is sufficient.

I have only one account.

  This contains sensitive information which shouldn't be forwarded or published without permission.

  Application Basics

    Name: Thunderbird
    Version: 45.3.0
    User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.3.0
    Profile Directory: /home/konst/.thunderbird/bnj44ytb.default
              (Local drive)
    Application Build ID: 20160916153542
    Enabled Plugins: about:plugins
    Build Configuration: about:buildconfig
    Memory Use: about:memory

  Mail and News Accounts
      INCOMING: account2, Local Folders, (none) Local Folders, plain, passwordCleartext

      INCOMING: account3, <email address hidden>@IMAP, (imap), alwaysSTARTTLS, passwordEncrypted
      OUTGOING: Konstantin Kivi <email address hidden>,, alwaysSTARTTLS, passwordEncrypted, true
      OUTGOING: Konstantin Kivi <email address hidden>,, alwaysSTARTTLS, passwordEncrypted, false

      INCOMING: account6, XMPP - <email address hidden>, (im) prpl-jabber, plain, 0

  Crash Reports (06/23/16) (02/09/15) (08/21/13) (08/13/13) (10/24/11)

    Lightning, 4.7, true, {e2fda1a4-762b-4020-b5ad-a41df1933103}
    Messaging Menu and Unity Launcher integration, 1.3.1, true, <email address hidden>
    Provider for Google Calendar, 3.1, true, {a62ef8ec-5fdc-40c2-873c-223b8a6925cc}
    Send Later, 6.1, true, <email address hidden>
    Todoist for Thunderbird: To-Do list and Task Manager, 4.3, true, {88f55c90-a688-11e1-b3dd-0800200c9a66}
    ReminderFox,, false, {ada4b710-8346-4b82-8199-5de2b400a6ae}

  Important Modified Preferences

    Name: Value

      accessibility.typeaheadfind.flashBar: 0
      browser.cache.disk.capacity: 358400
      browser.cache.disk.filesystem_reported: 1
      browser.cache.disk.smart_size_cached_value: 358400
      browser.cache.disk.smart_size.first_run: false
      browser.cache.disk.smart_size.use_old_max: false
      extensions.lastAppVersion: 45.3.0
      font.internaluseonly.changed: true
      gfx.blacklist.suggested-driver-version: <Anything with EXT_texture_from_pixmap support>
      mail.openMessageBehavior.version: 1 f4e15f17-9b82-47e6-86b9-4cf36d4f961 {"threadCol":{"visible":true,"ordinal":"1"},"flaggedCol":{"vi...

*** Bug 1322841 has been marked as a duplicate of this bug. ***

*** Bug 1277497 has been marked as a duplicate of this bug. ***

Sorry for cross-posting (584014)
Hi there,
Am experiencing similar problem.
TB 52.1.1. Release update channel, I update within a few days of being prompted. Three add-ons: Lightning, Provider for Google Calendar, Dictionnaire français "classique".
TB is configured for four addresses. I get four Master password prompts each time I launch TB. The prompts appear in the same position rapidly one after the other. I type the pw in the prompt that has the focus (i.e. the last one to show). Weirdly, the correct pwd is refused, the prompt comes up again and when I type the correct pwd a second time it's accepted. The other three prompts can then be closed using Esc.
This started happening a couple of months ago (probably after an update but I couldn't sware to that!) A bit of a bind. I use hibernation extensively, which minimizes the problem since I often only have to relaunch TB after an update.
I tried changing the pwd but that didn't help.

Wolfgang, Markus,
Please check this when 52.2.0 comes out.
(or the current beta channel at )

Checked with 52.2.0 now and unfortunately exactly the same wrong behaviour as before.

Running 52.2.0 and have the same issue. Multiple password prompts - add-ons are below:

Adblock Plus
Awesome Auto Archive
Google Search
Lightning calendar tabs
Provider for Google Calendar
Simple Search-For Extension

(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #28)
> Wolfgang, Markus,
> Please check this when 52.2.0 comes out.
> (or the current beta channel at
> )

Unfortunately still same behaviour with 52.2.0 from the release channel.

3 IMAP accounts (but NO OAuth)
Lightning (but NO Google Calendar)
3 Master password prompts (if StartupMaster Addon disabled)

I'm now at TB v52.2.1 (32 bit on 64 bit Win 10 v1703 latest updates applied). With 4 pop3 accounts, Google calendar via Lightening and Provider for Google Calendar (as well as DictionarySearch, FoxClocks, Mail Merge, QuoteCollapse and Recover deleted messages). With StartupMaster now disabled, I am finally getting just one prompt for the master password from TB. Thanks for all who worked on this. My issue is now solved, though it appears others are still seeing it.

Something like 1 or 2 weeks ago I got an update for thunderbird, and all of the sudden I only had 1 instead of 9 prompts. I was happy and I thought it was fixed. Then within days I got another update, and I was back to 9 prompts once more. I am currently on 52.2.1 32 bit on a 64 bit Windows 7 laptop, but I don't know what version number the temporary working version had because I didn't expect the bug to come back so soon. I hope this info helps finding the bug!

bug 1176399 was backed out of releases. So, yes, the multiple password prompts issue has returned. And presently there is not ETA for resolving this.

I spoke too soon. Something kept bugging me that I'd forgotten something I'd done to make this issue go away beside using StartupMaster, which I've always felt was a poor solution for TB. What I'd done was changed each e-mail account in TB so that under Server Settings, the "Check for new messages at startup" box was unchecked. I just unchecked that box for all my TB accounts, and sure enough, I'm now getting multiple prompts for the master password. So, problem is still unfixed for me. I'm back to my work-around and unchecking that box in all accounts again.

By the way, having TB NOT check for messages at startup is a completely acceptable solution for me. I have the mail account servers set to check for mail every 5 minutes, so at most I'm only 5 minutes from getting any new mail. Because there is no check on startup, I only get one master password prompt when starting TB. I normally only restart TB after a reboot, so it's really not a big deal for me. Of course others have other needs for which this solution is unacceptable.

*** Bug 1449069 has been marked as a duplicate of this bug. ***

I'm going to look at this, specifically the "multiple IMAP, but no OAuth" case...

I couldn't reproduce a situation where the password prompt would occur multiple times when I didn't use *something* from Google (OAuth). Therefore, I would prefer to fix bug 1176399 for now.

Fixed for me in 52.9.1 (64-bit)

Fixed for me as well - 52.9.1 (32-bit) - Sweet!

Still an issue on latest TB 60.0 build 20180731173940 (32-bit). Multiple master password prompts overlay each other for each account (5 in my case). You can enter the master password once, and then simply click "OK" on the other 4 windows. Irritating that this has been a problem for years.

Paul White (paulw2u) wrote :

Pierre and anyone else affected,

We are sorry that we do not always have the capacity to review all reported bugs in a timely manner. You reported this bug some time ago and there have been many changes in Ubuntu and Thunderbird since that time.

Do you still see a problem related to the one that you reported? Please let us know if you do as I cannot reproduce the issue using Ubuntu 18.04 and Thunderbird 52.9.1.

If we do not hear from you this bug report will automatically expire in approximately 60 days time.

Thank you for helping make Ubuntu better.

Paul White
[Ubuntu Bug Squad]

Changed in thunderbird (Ubuntu):
status: Confirmed → Incomplete
Pierre Rudloff (rudloff) wrote :

I can still reproduce with Thunderbird 52.9.1+build3-0ubuntu0.18.04.1.
I suppose it only happens when there are several email/calendar accounts.

Paul White (paulw2u) wrote :

Thanks Pierre. I don't see this bug myself although I also have three accounts set up.

Do you have multiple Google accounts? If so, it could be this bug: which should be fixed in Thunderbird 60.1 according to comment #138 in the bug report.

If you don't have multiple Google accounts then there are a couple of other upstream bug reports which could be relevant.

Changed in thunderbird (Ubuntu):
status: Incomplete → Confirmed
Pierre Rudloff (rudloff) wrote :

I only have one Google account. I also have two Caldav accounts and two IMAP accounts.

Paul White (paulw2u) wrote :

Pierre, I now have two IMAP, one CalDav and one Google account and still cannot reproduce your issue.

Bug suggests that only one password prompt needs to be completed. The others can be dismissed with the escape key. Is that what you see?

Pierre Rudloff (rudloff) wrote :

Yes, it seems I can dismiss the other prompts and it still works. It is just a bit annoying.

Paul White (paulw2u) wrote :

Thanks for your reply. I've linked the upstream report to this one. Hopefully Thunderbird's developers will find the cause and fix the bug soon.

description: updated

Just for your info, I'm helping a user who has been seeing this issue since Thunderbird 10 and still does with 52.9.1 on Ubuntu 18.04.1. User currently has one Google account, two CalDav accounts and two IMAP accounts.

Launchpad bug report:

Patches are coming in a week or two via 60.1.0 (not 60.0) which will help the vast majority of users. Most users are still on 52.x which is not yet updating to version 60, so to get the 60.1.0 fix you will want to download the installer from (Users who install from linux distro might be delayed) Note: some add-on may not work - see

(Those who got relief in version 52.x can count themselves lucky.)

Paul White (paulw2u) wrote :

Pierre, the upstream bug report has just been updated to say that a fix for this problem should land in Thunderbird 60.1. If it does and it fixes your problem please feel free to close this bug report by changing the status to "Fix Released".

Unfortunately, I have no information on when version 60.1 or later might reach the Ubuntu repositories.

C de-Avillez (hggdh2) wrote :

Setting to Triaged/Low per request in #ubuntu-bugs

Changed in thunderbird (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged

Please tell us your situation now, when running a newer version of Thunderbird.

Currently running 60.4.0 on Linux

The problem persists and gets worse with every account that is added. Currently, I get 6 prompts when starting TB.
6 is the exact number of authentications it needs to perform:

3 IMAP accounts
1 CalDav calendar
2 CarDav address books

As before, only one actually needs to be filled in correctly, the others can be cancelled.
None of the accounts uses OAuth.

I think that without the StartupMaster extension I would not be using TB anymore.

Hi all, and Wayne in particular,
Running 60.5 on Windows 10. I've not experienced this problem for several months. **Well done**!

Paul White (paulw2u) wrote :

Further to comment #10, is this still an issue now that Thunderbird 60.4 is the currently supported release?

Changed in thunderbird:
importance: Unknown → High
status: Unknown → Confirmed

Still issue. 60.5.0 on Windows and OSX. Multiple logins required.

Running 60.5.0 on Windows 10, no longer have this problem

(In reply to Wayne Mery (:wsmwk) from comment #45)

> Please tell us your situation now, when running a newer version of Thunderbird.

Wayne, I just tried restarting TB with all account server settings having the "Check for new messages at startup" box checked. My work-around to this problem had been to have this box unchecked so only the Google calendar would be prompting for my TB password. With this box checked now for all accounts, messages are checked for all accounts at startup and I'm only getting one password prompt.

So, works for me on TB 60.5.0.

On Linux with 60.5.0 I still get a bunch of authorization requests at startup.

Still a problem on 60.4.0 (Ubuntu 18.04.1)

There is one master password request per google-related thing - cardbook plugin for carddav, calendar - plus an extra one.

Cancelling the first master password box results in the error:

[Exception... "User canceled master password entry" nsresult: "0x80004004 (NS_ERROR_ABORT)" location: "JS frame :: jar:file:///usr/lib/thunderbird/omni.ja!/components/crypto-SDR.js :: decrypt :: line 177" data: no]

Correction to #52:

Cardbook plugin is NOT used with a google account.

I've never seen this issue myself but none of the users that I reported this problem for have responded to my request for an update. So nothing to add at this stage.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.