Thunderbird asks three times for my master password

Bug #940631 reported by Pierre Rudloff on 2012-02-24
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Unknown
Unknown
thunderbird (Ubuntu)
Low
Unassigned

Bug Description

When Thunderbird is launched it asks for the master password three times in a row. Only one password prompt needs to be completed. The remaining prompts can be dismissed with the escape key.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: thunderbird 10.0.2+build1-0ubuntu0.11.10.1
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic i686
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu4
Architecture: i386
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: pierre 1609 F.... pulseaudio
                      pierre 1636 F.... xfce4-volumed
BuildID: 20120216123548
CRDA: Error: [Errno 2] Aucun fichier ou dossier de ce type
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x50440000 irq 43'
   Mixer name : 'SigmaTel STAC9221 A1'
   Components : 'HDA:83847680,106b2200,00103401'
   Controls : 21
   Simple ctrls : 13
Channel: release
Date: Fri Feb 24 22:18:53 2012
ForcedLayersAccel: False
IfupdownConfig:
 auto lo
 iface lo inet loopback
IncompatibleExtensions:
 Timezone Definitions for Mozilla Calendar - <email address hidden>, Version=1.2011n, minVersion=2.0, maxVersion=10.0, Location=app-system-share, Type=extension, Active=Yes
 Provider for Google Calendar - ID={a62ef8ec-5fdc-40c2-873c-223b8a6925cc}, Version=0.11, minVersion=8.0a1, maxVersion=10.0, Location=app-system-share, Type=extension, Active=Yes
IpRoute:
 default via 192.168.0.1 dev wlan0 proto static
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.0.0/24 dev wlan0 proto kernel scope link src 192.168.0.10 metric 2
Profiles: Profile0 (Default) - LastVersion=10.0.2/20120216123548 (Running)
RunningIncompatibleAddons: True
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/27/07
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB21.88Z.00A5.B07.0706270922
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F4208CAA
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F4208CAA
dmi.modalias: dmi:bvnAppleInc.:bvrMB21.88Z.00A5.B07.0706270922:bd06/27/07:svnAppleInc.:pnMacBook2,1:pvr1.0:rvnAppleInc.:rnMac-F4208CAA:rvrPVT:cvnAppleInc.:ct10:cvrMac-F4208CAA:
dmi.product.name: MacBook2,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

Pierre Rudloff (rudloff) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Paul White (paulw2u) wrote :

Pierre and anyone else affected,

We are sorry that we do not always have the capacity to review all reported bugs in a timely manner. You reported this bug some time ago and there have been many changes in Ubuntu and Thunderbird since that time.

Do you still see a problem related to the one that you reported? Please let us know if you do as I cannot reproduce the issue using Ubuntu 18.04 and Thunderbird 52.9.1.

If we do not hear from you this bug report will automatically expire in approximately 60 days time.

Thank you for helping make Ubuntu better.

Paul White
[Ubuntu Bug Squad]

Changed in thunderbird (Ubuntu):
status: Confirmed → Incomplete
Pierre Rudloff (rudloff) wrote :

I can still reproduce with Thunderbird 52.9.1+build3-0ubuntu0.18.04.1.
I suppose it only happens when there are several email/calendar accounts.

Paul White (paulw2u) wrote :

Thanks Pierre. I don't see this bug myself although I also have three accounts set up.

Do you have multiple Google accounts? If so, it could be this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1176399 which should be fixed in Thunderbird 60.1 according to comment #138 in the bug report.

If you don't have multiple Google accounts then there are a couple of other upstream bug reports which could be relevant.

Changed in thunderbird (Ubuntu):
status: Incomplete → Confirmed
Pierre Rudloff (rudloff) wrote :

I only have one Google account. I also have two Caldav accounts and two IMAP accounts.

Paul White (paulw2u) wrote :

Pierre, I now have two IMAP, one CalDav and one Google account and still cannot reproduce your issue.

Bug https://bugzilla.mozilla.org/show_bug.cgi?id=1180374 suggests that only one password prompt needs to be completed. The others can be dismissed with the escape key. Is that what you see?

Pierre Rudloff (rudloff) wrote :

Yes, it seems I can dismiss the other prompts and it still works. It is just a bit annoying.

Paul White (paulw2u) wrote :

Thanks for your reply. I've linked the upstream report to this one. Hopefully Thunderbird's developers will find the cause and fix the bug soon.

description: updated
Paul White (paulw2u) wrote :

Pierre, the upstream bug report has just been updated to say that a fix for this problem should land in Thunderbird 60.1. If it does and it fixes your problem please feel free to close this bug report by changing the status to "Fix Released".

Unfortunately, I have no information on when version 60.1 or later might reach the Ubuntu repositories.

C de-Avillez (hggdh2) wrote :

Setting to Triaged/Low per request in #ubuntu-bugs

Changed in thunderbird (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.