Default Thunderbird icons in Oneiric unusable with Greybird

Bug #856939 reported by elguavas on 2011-09-23
64
This bug affects 11 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Medium
Chris Coulson

Bug Description

the name says it all. i'll try to attach a screenshot to this report.

the new default thunderbird icons in oeneric are just plain white and they show up very poorly, looking ugly and having very poor usability on the grey toolbar background of the xubuntu greybird theme.

they probably look fine in unity, but xubuntu will have to do something about this before oeneric release.

cheers,
stephen.

affects: xubuntu-artwork → murrine-themes
Changed in murrine-themes:
importance: Undecided → High
status: New → Confirmed
affects: murrine-themes → null
Changed in null:
status: Confirmed → New
status: New → Invalid
Changed in murrine-themes (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Pasi Lallinaho (knome) on 2011-09-23
summary: - default thunderbird icons in oeneric unusable with greybird theme
+ Default Thunderbird icons in Oneiric unusable with greybird theme
summary: - Default Thunderbird icons in Oneiric unusable with greybird theme
+ Default Thunderbird icons in Oneiric unusable with Greybird
Simon Steinbeiß (ochosi) wrote :

thanks stephen,
this is a known problem. i can only tell you that i'm working on it and i'll try to find out what radiance does differently so that thunderbird's icons look ok. we'll see whether i manage before the release *knockonwood*

elguavas (elguavas.) wrote :

ok Simon, glad to know it's known and in hand.

if 'radiance' is the unity default theme, then the reason it would work there is because that has a very dark toolbar background, meaning the white icons have decent contrast.

however on the light grey background of the default xubuntu theme the contrast is appallingly bad... apart from looking very ugly and unprofessional, it could be a real usability / accessibility problem for some users.

cheers,
stephen.

Simon Steinbeiß (ochosi) wrote :

hi again,
well "radiance" is the bright variant of "ambience" (the dark default theme), so it could help looking at that.
i know that this is problematic, i'll see what i can do.

elguavas (elguavas.) wrote :

ahh i see,

well hope you find a pointer there in how to fix it...

thanks for the efforts,
stephen.

Simon Steinbeiß (ochosi) wrote :

hi again,
unfortunately i don't have good news. i looked into various other themes and it seems like thunderbird bases the icon-color on the menu-background color. other bright themes with dark menus have the same problem and i even found a theme that has the opposite setting (dark theme with bright menus) and it had the opposite outcome (dark icons on dark toolbar).

so all in all i believe this has to be fixed in thunderbird and i'm sorry that there's nothing much i can do about it in the theme. as a workaround you can install a different thunderbird theme in the meantime. (i don't have enough experience with that, but maybe it's possible to do a thunderbird theme that only replaces those few monochrome icons...)

elguavas (elguavas.) wrote :

well, thanks for trying. ;)

it's not the end of the world for me personally but it sure looks ugly and has poor usability... will the issue get pushed upstream then?

as for other thunderbird themes, that was why i first posted this bug against xubuntu artwork, since i use xubuntu and one place this problem has a bas effect is with the default xubuntu theme. it seems like the best solution would be for xubuntu-artwork to include a modified thunderbird icon theme if you ask me.

cheers,
stephen.

Simon Steinbeiß (ochosi) wrote :

the issue will (have to) be taken care of upstream. i think that's better than shipping a modified thunderbird icon-theme, as it is only a workaround, not a real fix. (and who knows what tb-devs will come up in the next release...)

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
Stefan Reinhard (guetux) wrote :

Thumbs up for fixing this thing upstream! Until then, for those of you looking for a nice theme for tb i suggest using the adwaita thunderbird theme: https://addons.mozilla.org/en-US/thunderbird/addon/adwaita-thunderbird/

Micah Gersten (micahg) wrote :

The bug is actually in thunderbird, so adding a task.

Changed in murrine-themes (Ubuntu):
status: Confirmed → Triaged
Changed in thunderbird (Ubuntu):
importance: Undecided → Medium
Micah Gersten (micahg) wrote :

I've assigned this to me as I have proof of the issue and just need to upstream it. I won't be fixing the issue personally.

Changed in thunderbird (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
status: New → In Progress
Chris Coulson (chrisccoulson) wrote :

The fix for bug 925907 should improve this

Changed in thunderbird (Ubuntu):
assignee: Micah Gersten (micahg) → Chris Coulson (chrisccoulson)
status: In Progress → Fix Committed
no longer affects: murrine-themes (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 11.0~b1+build2-0ubuntu1

---------------
thunderbird (11.0~b1+build2-0ubuntu1) precise; urgency=low

  * New upstream release from the beta channel (THUNDERBIRD_11_0b1_BUILD2)

  * Update messagingmenu to 0.9.2
    - Fix a failure to initialize in some cases
  * Update globalmenu-extension to 2.0.3
  * Drop patches fixed upstream:
    - remove debian/patches/fix-build-failure-without-yarr-jit.patch
    - remove debian/patches/fix-cursor-handling.patch
    - update debian/patches/series
  * Refresh patches:
    - update debian/patches/theme-refresh-messenger-toolbar-icons.patch
  * Ensure we include locales in the tarball if they are in shipped-locales
    but not in all-locales
    - update debian/build/create-tarball.py
  * Always set the update channel - not setting it at build-time on release
    builds breaks the extensions.checkCompatibility pref. The only things
    using it at runtime are nsBlocklistService, Test Pilot (beta + aurora)
    and the about dialog (where the channel is hidden anyway)
    - update debian/rules
    - update debian/thunderbird.install.in
  * Fix LP: #898883 - IPC xpcshell tests hang the buildd's. Give all
    xpcshell tests an X display, as plugin-container won't work without one
    - update debian/build/testsuite.mk
  * Turn on all IPC xpcshell tests again (only applicable when the testsuite
    is enabled in the future)
    - update debian/build/testsute.mk
  * Drop the default-apps xml file from lucid and maverick
    - remove debian/firefox.xml.in
    - update debian/firefox-gnome-support.install.in
    - update debian/rules
  * Don't build with --disable-gconf on precise and newer. There won't be
    a hard runtime requirement on this from Firefox 12 anyway, and this
    keeps us closer to the upstream configuration
    - update debian/config/mozconfig.in
    - update debian/rules
  * Update theme-refresh-messenger-toolbar-icons.patch to work with
    tabs-on-top, where the toolbar isn't styled like the menubar
    - update debian/patches/theme-refresh-messenger-toolbar-icons.patch
  * Refresh shipped locales for beta (addition of Armenian and Croatian)
    - refresh debian/config/locales.shipped
    - refresh debian/config/locales.all
    - refresh debian/control
  * Fix LP: #925907 - 12.04 Thunderbird colour theme is unreadable. Use
    -moz-menubartext rather than MenuText for elements with menubar styled
    backgrounds. Should also fix LP: #856939
    - add debian/patches/use-menubar-text-colour-on-tabbar.patch
    - update debian/patches/theme-refresh-compose-toolbar-icons.patch
    - update debian/patches/theme-refresh-addressbook-toolbar-icons.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden> Fri, 03 Feb 2012 20:20:18 +0000

Changed in thunderbird (Ubuntu):
status: Fix Committed → Fix Released
Photon (michael-kogan) wrote :

As of beta4 there is still a little glitch: Non-active tabs still have white font color. How to report it to the Thunderbird devs?

Chris Coulson (chrisccoulson) wrote :

We've fixed the text in the tabs so that they use the correct colour from the theme. If it's still not right, then it sounds more like a bug in your gtk theme

Simon Steinbeiß (ochosi) wrote :

I can't confirm this bug. I just tested Thunderbird in Precise (with all updates installed) and Greybird. See the attached screenshot.

Lioh (lioh) wrote :

I still got that issue on subwindows (like compose new message).

Simon Steinbeiß (ochosi) wrote :

This issue has only been fixed in Precise (also works for me with subwindows like compose), on Oneiric you can use the thunderbird-next PPA to test the fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints