Thunderbird crashes with segmentation fault

Bug #571308 reported by Joe Collins on 2010-04-28
72
This bug affects 13 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: thunderbird

Description: Ubuntu 10.04 LTS
Release: 10.04

^^Release candidate.

My (jcollins) home directory is sshfs mounted to a remote server on my network using pam_mount. This is what happens when I try to run thunderbird:
jcollins@joewks:~$ thunderbird
Segmentation fault
jcollins@joewks:~$

When I log in as a user (jcollins-local) without a sshfs mounted home directory, thunderbird runs fine.

Other apps seem to run fine for both jcollins and jcollins-local

Thanks,

- Joe

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: thunderbird 3.0.4+nobinonly-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed Apr 28 11:37:05 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: thunderbird

Joe Collins (jgc26) wrote :
Joe Collins (jgc26) wrote :

One additional thing to note... the same problem occurs if i NFS4 mount my home directory w/o pam_mount - so it doesn't appear to be a SSHFS or pam_mount related.

Joe Collins (jgc26) wrote :

Since I filed this bug report, I installed the final version of Ubuntu 10.04 LTS onto my laptop. I tested Thunderbird in the same configuration as above and it worked fine. I installed the final version of Ubuntu 10.04 LTS onto my desktop, the one that I filed this bug report on, and thunderbird now works fine there too. Must have been something specific to the release candidate.

This bug report can be closed.

Thanks!

Kevin Hunter (hunteke) wrote :

Not sure how to close directly, but marking invalid per Joe's comment #3.

Changed in thunderbird (Ubuntu):
status: New → Invalid
jhaig (josephhaig) wrote :

I am seeing this with the released version. I have the home directory mounted over NFS and thunderbird fails with a Segmentation Fault. Is it possible to find out what changed on your system, to see if there is something I can try?

Arie Skliarouk (skliarie) wrote :

I have exactly the same situation as jhaig and thunderbird segfaults.
My home directory is also NFS mounted.

Changed in thunderbird (Ubuntu):
status: Invalid → New
Arie Skliarouk (skliarie) wrote :

For test sake, I have moved my .mozilla-thunderbird to local storage (not NFS), but the problem persisted. So it might not be NFS related after all. Time to open new bug?
In any case find attached the strace from the thunderbird.

jhaig (josephhaig) wrote :

For the sake of actually reading emails, I moved .thunderbird to a local user and it works. I think this is an NFS problem.

Joe Collins (jgc26) wrote :

I'm not sure it is NFS specific as I originally had the same problem mounting my home directory (and thus, .thunderbird) using SSHFS and pam_mount.

I wish I knew what caused the problem on my machine originally... the only thing I can think of is when I burned the RC ISO, the burning software reported a bad burn (as it often does, erroneously). Foolishly, I installed anyway. When I burned the RTM ISO, no burn error was reported. That's the only difference I can think of.

- Joe

Michael Hartman (hartmms) wrote :

I too get a seg fault on thunderbird launch. My home dir is NFS mounted as well. Attached is an strace.

Joe Collins (jgc26) wrote :

I just thought of something that's different between my previous "bad" setup and my current "good" setup (aside from the RC vs RTM aspect): the version of Lightning.

The 10.04 RC had a Lightning package in there, so I was running Thunderbird and Lightning from the RC.

I couldn't find Lightning in 10.04 RTM, so I installed a binary I found on the web.

Any of you other guys having this problem using Lightning as well?

tobias d (tobias-launchpad) wrote :

Just upgraded my ubuntu from 9.10 to 10.04 lts (final version). my thunderbird 3 crashes with a segment fault failure message now. the profile is on the local disc (ext4) / standard installation. everything worked fine with ubuntu 9.10 and thunderbird 2.*. i am not sure, but i believe that i didn't have lightning installed with the previous version.

Jason Kendall (coolacid) wrote :

I have home DIRs on NFS although all my mail accounts are IMAP. My issue which I was hoping was going to be fixed stems from LDAP being run with PAM - see upstream bug https://bugzilla.mozilla.org/show_bug.cgi?id=292127 has been open since 2006 and still effects 10.09 (Needed to do the work around after I upgraded)

Robert (baumgaro) wrote :

I installed 10.04 (no upgrade). Everything worked fine. Thunderbird as well, but just for two days. Today I get the segment fault message as well. My system has no NFS, everything is installed locally on EXT4.

John Vivirito (gnomefreak) wrote :

Joe,
we dont provide lightning for tb3 yet.

Robert,
It seems your bug is not the same as this one, but without anyones crash info here its impossible to tell.
 I am going on info provided by you that it is not the same.
Please file your own bug using the following command:
ubuntu-bug thunderbird

Robert (baumgaro) wrote :

John - you are right. It is another bug. I installed the Funambol Mozilla Sync Client Extension (V 1.0b3) and this one causes the crash.
Steps to fixed the problem:
1.) Start thunderbird from the command line (bash) with safe-mode option: thunderbird -safe-mode
2.) Then thunderbird starts again. Deactivate the extension. thunderbird works fine again.

I will file the bug at the extensions bug place (not sure were just now).

Arie Skliarouk (skliarie) wrote :

for me "thunderbird -safe-mode" crashes the same way. (Lucid 32bit, LDAP, NFS)

Mike (michburt) wrote :

I have the same problem:

Home directory of LDAP user is connected via NFS -> Thunderbird do not start: Segmentation fault.
If I start thunderbird with a local user with a local home directory -> Tunderbird starts without any problems.

jhaig (josephhaig) wrote :

I tried running "thunderbird -safe-mode" but I also get a segmentation fault with that. It hadn't occurred to me before but I am also using LDAP for the user with an NFS home directory in the case where thunderbird is failing, and local authentication with a local home directory where it works properly

ngerima (negasi) wrote :

I can confirm that I too have seen this particular error. My setup is very similar to everyone else´s, home directories are attached to the workstations from a NFS server, and user authentication is done by LDAP.

I´ve been able to duplicate the segmentation fault errors with thunderbird. I have also seen the same problem with gtkpod (of all applications?).

Surprisingly enough, I was able to resolve this issue by installing the nscd package. Once it was installed, the segmentation fault error messages (miraculously) went away. I was immediately able to load thunderbird without issue and gtkpod also ran without a hitch. Years of system administration have taught me to be cautious, so I rebooted each workstation several times to confirm that the fix would continue working, and sure enough it did.

I hope this helps.

Thanks.

Mike (michburt) wrote :

Thanks for the infomation.

Installing nscd also solves the problem on my PC. Thunderbird is working now.

Dmik (dmik-for-maillists) wrote :

Same problem, same solution (installing nscd) helped.

jhaig (josephhaig) wrote :

Thunderbird requires nscd? That would be the Name Service Cache Daemon? That makes a lot of sense. :-)

Anyway, that has fixed it for me too. Thanks.

Giovanni G. (giovanni-g) wrote :

My situation looks like a mix of the prevouosly reported:
Authenticating via ldap = thunderbird crashes
Installed nscd = thunderbird works
"apparently i didnt change anything" = thunderbird abruptly statrs to crash (on a freshly booted system)
Started with -ProfileManager = displays profile selection but crashes as soon as I choose a profile and click on continue
Removed nscd and started with -ProfileManager = it crashes before displaying anything
Reinstalled nscd and started with -ProfileManager = it displays profile selection but crashes as soon as I choose a profile and click on continue
Started in safe-mode = it works
Disabled Funambol Mozilla Sync Client 1.0b3 = It works

SO, the problem with ldap is still present, but installing nscd still fixes it
On the other side, Funambol makes it crash, but i think it could still be somewhat relate to ldap because the last operation I see in strace is a getgroups

Dmik (dmik-for-maillists) wrote :

Actually, nscd does NOT fix the problem here as Thunderbird still crashes. What happens in my case is exactly what described in Bug #556829 (found it with gdb) and the solution posted there (installing the fixed thunderbird package from PPA) helped. So probably this bug is simply a duplicate.

Christian (c-pradelli) wrote :

This problem still exist in Thunderbird 3.0.5 and in latest version of ppa, so it's not a duplicate of #556829
Instaling nscd works for me too.
could ncsd cause any problem to other applications?, I don't what exactlly nscd do.

Václav Šmilauer (eudoxos) wrote :

I am confirming the bug with current lucid's packages (3.0.5+build2+nobinonly-0ubuntu0.10.04.1) on amd64, with home mounted over NFS and nsswitch pointing to LDAP. Installing nscd helped.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Arie Skliarouk (skliarie) wrote :

The bug is not fixed on maverick (10.10) beta. Installing nscd helped.

tags: added: maverick
ruslan_ka (r-kalakutsky) wrote :

The same problem. Ubuntu 10.10, users via LDAP, home folder - on local disk.
uname -a
Linux ll-sta-005 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux

thunderbird -v
 Thunderbird 3.1.6

Install nscd fix problem.

schlady (schlady) wrote :

Same problem here. Ubuntu 10.04, LTSP setup with LDAP.

thunderbird -v
 Thunderbird 3.0.10

Installation of "nscd" also fixed the problem.

Wim (wim-yedema) wrote :

Even with ncsd I have a crash. For me it crashes right after it completes an email address. I've attached a backtrace from gdb

Wim (wim-yedema) wrote :

Here's a core dump of the crash.

Phil M (unmobile+ubuntu) wrote :

Looks like a dupe of #507089

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.