Comment 270 for bug 52667

Revision history for this message
In , Mkmelin+mozilla (mkmelin+mozilla) wrote :

(From update of attachment 378664)
>- let buttonToShow = showReplyAll ? "replyAll" : "reply";
>+ let showReplyList = aUrl && aUrl.mimeHeaders &&
>+ aUrl.mimeHeaders.extractHeader("List-Post", false);
>+ let buttonToShow = showReplyList ? "replyList" :
>+ showReplyAll ? "replyAll" : "reply";

While it might be correct, this sure is almost unreadable... use an if clause to improve readability?

>+ let replyListCommand = document.getElementById("cmd_replylist");
>+ replyListCommand.disabled = !showReplyList;

I think you're supposed to return true/false for the list commands when they get checked in mail3PaneWindowCommands.js+messageWindow.js isCommandEnabled()

>+ <key id="key_replylist" key="&replyToListMsgCmd.key;" oncommand="goDoCommand('cmd_replylist')" modifiers="accel, shift"/>

Nit: Alignment is off here, though it's a very long line so you can also wrap it and align oncommand with the id on the previous line.

>+ <menuitem id="menu_replyToList" label="&replyToListMsgCmd.label;"
>+ accesskey="&replyToListMsgCmd.accesskey;"
>+ key="key_replylist"
>+ command="cmd_replylist"/>

Nit: Align accesskey with the id on the previous line here too although the surrounding stuff isn't well aligned.

BTW, please submit these too patches as one for the next round, as they will go in together anyway.