Thunderbird starts in a full-screen mode and cannot be restored

Bug #196058 reported by trybik on 2008-02-27
178
This bug affects 39 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
New
Medium
thunderbird (Ubuntu)
Undecided
Mozilla Bugs

Bug Description

WORKAROUND:
1. Edit ~/.thunderbird/*/xulstore.json
2. Search for: "sizemode":"fullscreen"
3. Change it to: "sizemode":"normal"

OLD WORKAROUND:
1. Edit ~/.thunderbird/*/localstore.rdf
2. Search for: sizemode="fullscreen"
3. Change it to: sizemode="normal"

ORIGINAL DESCRIPTION:
Binary package hint: thunderbird

I've tried clicking F11 in various of places and even all the rest of F-buttons, with Alt/Shift/Ctrl, and still no result. I've scrolled throughout the whole advanced configuration and there was nothing about full-screen mode. I don't have any extensions yet installed on my Thunderbird and I don't know what to do next.

The problem has it basics because the profile that I've switched to, comes from previous Windows installation.

I'm begging for Your help. It is stupid but really frustrating.

ProblemType: Bug
Architecture: i386
Date: Wed Feb 27 10:05:55 2008
Dependencies:

DistroRelease: Ubuntu 8.04
Package: mozilla-thunderbird None [modified: /var/lib/dpkg/info/mozilla-thunderbird.list]
PackageArchitecture: allSourcePackage: thunderbird
Uname: Linux 2.6.24-10-generic i686

Matthew Tighe (tighem) wrote :

A couple of things to try:

Alt+F8 is the keyboard shortcut for resize.
Try opening it without the old profile. could be something in that needs to removed. You can do this with:

thunderbird -ProfileManager

Thanks

Matthew Tighe pisze:
> A couple of things to try:
>
> Alt+F8 is the keyboard shortcut for resize.
>
I'm sure I clicked all the F-buttons from left to right (and I even
remember that I clicked Alt+F4 by mistake :P) and it didn't work :/
After this post, although, I switched to Win there I restored app and
switched back to Linux. It worked but not completely. Next few days
past it came back in full screen and I don't know how. The same
procedure as above and it works till now. I will tray to produce such
situation one more time (I think it has some connection with maximizing
app window in Win) and post a bug on Thunderbird forum because it isn't
an Ubuntu bug.
> Try opening it without the old profile. could be something in that needs to removed. You can do this with:
>
I tried. The state of window is somehow stored in profiles files and
that's why in other profiles window looks right and in that specific one
it is a full screen.

Thanks for a response :-)
Jasiek

Örs Apor Horváth (0rs) wrote :

Same situation here...

John Vivirito (gnomefreak) wrote :

Can you please attach screenshots of this issue i have a feeling i know what you mean but i would like to be sure

Changed in thunderbird:
assignee: nobody → mozilla-bugs
status: New → Incomplete

Same issue here:

Dualmonitor after latest gtk update or something like this fullscreen...
very annoying...
worked before...
guess that it has something to do with gtk....

Joe Kearns (jkearns) wrote :

Same issue here...
Created a new profile... worked like normal....
Then, opened previous profile... tainted thunderbird again.

My solution [hack] was to create new profile and delete the old one:
Creating a new profile means you need to set up your mail accounts again. *Please back up all of your email messages before doing this! I'm not responsible for any mail lost during this procedure.

1) `thunderbird -ProfileManager`
2) Create new Profile
4) Start Thunderbird using new profile
5) You will then have to type in your setting again.

Note: If you get thunderbird working normally, you will taint thunderbird if you open your previous profile and will have to start again. Because of this, I ended up deleting my previous profile.

Hope this hack helps.

Mokellebungo (flame2000) wrote :

I found a very simple and safe workaround.

1) Open Tbird.
2) Change Windowmanger (e.g. compiz to metacity). You can do this easily utilizin Compiz Fusion Icon.
3) Now should be able to resize the window.
4) Change back to your original Windowmanager.

This worked fine for me, hope it will work for others, too.

stumpy001 (garry-stewart) wrote :

I had the same problem. I went into Advanced Desktop Settings > Window Management > Extra WM Actions and turned the "Toggle Fullscreen" option on, assinging it to Alt-F11. I then simply pushed Alt-F11 while Thunderbird was highlighted and everything was fine.

Matt Reynolds (mreynolds) wrote :

I have a possible solution to this problem. The following worked for me :
* Go into your ${HOME}/.mozilla-thunderbird/<profile> directory
* Move localstore.rdf to localstore.rdf.original

It appears that some of the screen sizing information is kept in this file. Moving the file worked for me, but it may be possible to excise the offending XML directly. I didn't try this, however.

John Vivirito (gnomefreak) wrote :

Matt Reynolds wrote:
> I have a possible solution to this problem. The following worked for me :
> * Go into your ${HOME}/.mozilla-thunderbird/<profile> directory
> * Move localstore.rdf to localstore.rdf.original
>
> It appears that some of the screen sizing information is kept in this
> file. Moving the file worked for me, but it may be possible to excise
> the offending XML directly. I didn't try this, however.
>
>
this sounds like it was caused by a upgrade example gutsy to hardy
upgrade since you run tbird after moving the .rdf and once renamed
starting tbird again will generate that file again, Ive seen this type
of issue alot and thats why im thinking its a corrupt profile due to
upgrade ubuntu versions.

For everyone that saw this bug can you please confirm the process that
Matt did fixes this. Matt can you please post or attach here the old
profile so i can determine what happened.

--
Sincerely Yours,
    John Vivirito

https://launchpad.net/~gnomefreak
https://wiki.ubuntu.com/JohnVivirito
Linux User# 414246

Ax (ax-modra-ovce) wrote :

Yes, moving localstore.rdf out of the way worked.

Ax (ax-modra-ovce) wrote :

This is example of localstore that triggers this behavior. I tried to keep it small.

Sven Rieke (sven-rieke) wrote :

Exactly, the problem lies in the ~/.mozilla-thunderbird/xyz1234.default/localstore.rdf settings file.

I can reproduce the problem quickly on Ubuntu Hardy with Dual Monitor.
My right monitor has a higher resolution than the left one.
I start Thunderbird, maximize it on the right monitor (that with the higher resolution), close Thunderbird.
When I open Thunderbird again, it opens in fullscreen on the left monitor and gets stucked in this setup. Nothing helps to change that outfit.

You can restore the windows border with these steps:
# Close Thunderbird
# Edit the file ~/.mozilla-thunderbird/xyz1234.default/localstore.rdf
# Search the entry
  <RDF:Description RDF:about="chrome://messenger/content/messenger.xul#messengerWindow"
                   width="800"
                   height="600"
                   sizemode="normal"
                   screenX="5"
                   screenY="5" />
# Change the width, height and screenXY entries to the ones you see here
# Restart Thunderbird and it should have its borders again.

I can confirm this problem for lucid with thunderbird 3.1.3

Kim Bak (kim-bak-hotmail) wrote :

I can confirm this is still a problem in the most recent Ubuntu version.
Happened to me after dist-upgrade to Ubuntu 10.10

Changing the sizemode and height/width in localstore.rdf worked for me, thanx for the tip :)

Removing the localstore.rdf file solves the problem, but in my case it's not related to an upgrade. When I apply the fix, the problem reappears after a while. Right now it happens about 2-3 times a week. It can also be different windows that have the problem, sometimes it's the main window, sometimes it's the write mail window.

I'm working on a laptop with the second monitor changing often with different resolutions. Sometimes I have the impression that restoring the TB window on a screen that is different (smaller?) then the one where it used to be results in the full screen behaviour.

Versions:
Ubuntu 10.04.1 LTS
Thunderbird 3.1.6

User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13) Gecko/20101206 Ubuntu/10.04 (lucid) Firefox/3.6.13
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.13)

When a Mozilla window (normal mode) is closed and later restored on a screen which is smaller than the windows saved size, the window is restored in fullscreen mode.

Reproducible: Always

Steps to Reproduce:
Pre: This test assumes a dual-monitor setup, where one monitor is smaller than the other.

1. Open a Firefox (Thunderbird behaves the same) window,
2. Drag it to the bigger screen and enlarge it. It should be bigger than the size of the smaller screen.
3. Close Firefox.
4. Open Firefox, make sure the window is created on the smaller screen (e.g. with the setting 'Create new windows on screen of mousepointer' in Compiz)
Actual Results:
Firefox opens the window in fullscreen mode, so the window has no window decoration.
NB. This fullscreen mode is not exactly the same as the Firefox fullscreen mode achieved by pressing F11. The menubar and location bar still show. Pressing F11 first puts the window in FF fullscreen mode (menubar and locationbar disappear). Pressing F11 again restores the window to normal mode.

Expected Results:
The window is created in normal mode and resized to fit within the screen it is created on. Preferrably respecting system toolbars on that screen.

Tested on Ubuntu 10.04 with GNOME, Xinerama and Compiz.

While the problem is easy to work around with Firefox, with Thunderbird there's no easy way to solve it. Editing or removing localstore.rdf is the only way to get it to behave normal again.

Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → New
Jeremy Nickurak (nickurak) wrote :

Hit this. You can find the location in localstore.rdf where sizemode="fullscreen", and set it back to "normal", instead of just blowing away the thing.

Changed in thunderbird (Ubuntu):
status: Incomplete → Confirmed

Just hit this. You can find the location in localstore.rdf where sizemode="fullscreen", and set it back to "normal", which (other than deleting the file entirely) seems to be the only way to address this in thunderbird.

description: updated
Sean DS (se4n-1) wrote :

I'll bite, changing the size mode in local store from fullscreen to normal solves the problem, Unfortunately I'm not sure what caused it in the first place..

Neil Myrick (neil-myrick) wrote :

Here is what I have found. First of all, I have Ubuntu 10.04 with GLX-Dock (Cairo Dock with Open-GL) installed on my system. My issue was caused when I installed the Cairo Dock add-on in Thunderbird 16.0.1, then I right clicked on my Thunderbird icon in my GLX-Dock and selected 'other actions - fullscreen'

After that, I did not get the option in the GLX-Dock, or in Thunderbird, to change it back to normal screen. What I found was that this changed the screen size settings in localstore.rdf to the following settings:

<RDF:Description RDF:about="chrome://messenger/content/messenger.xul#messengerWindow"
                   width="700"
                   height="403"
                   screenX="0"
                   screenY="3"
                   sizemode="maximized" />

I then changed filename of localstore.rdf to localstore.rdf.old and restarted Thunderbird. Thunderbird created a new localstore.rdf file on startup with the following default settings, which were correct settings to eliminate the issue.

<RDF:Description RDF:about="chrome://messenger/content/messenger.xul#messengerWindow"
                   width="1024"
                   height="711"
                   screenX="0"
                   screenY="3"
                   sizemode="normal" />

note: screenY="3" on my system because I have a hidden panel on top that is set to 3 pixels wide until I scroll over it. ScreenY would probably be "0" on most systems.

Consumology (hgms72-4oneway) wrote :

I just experienced this bug in current 13.04 alpha and solved it also by going to my profile folder to switch sizemode="fullscreen" back to "normal" in localstore.rdf.

John Kuang (xiphosurus) wrote :

This just happened to me on 13.04, I believe due to unity crashing. Editing sizemode="fullscreen" to "normal" solved the problem too.

Also affects Thunderbird 17. I think Thunderbird shouldn't ever go to fullscreen, since there is no way to restore the normal view besides editing the localstore.rdf file.

I'm on Gnome Shell 3.6.2, using Thunderbird 17. Modifying the localstore.rdf inplace did not help: Thunderbird kept resetting the values. However, renaming localstore.rdf to localstore.rdf.old and rebooting TB solved this issue for me, as suggested in https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/196058/comments/21

A brand new localstore.rdf file was created, without the "fullscreen" setting.

Colan Schwartz (colan) on 2013-06-15
tags: added: quantal raring

Same here,
and lot of documentation here : https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/196058

Solution to get out of blocked state here :
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/196058/comments/13
(replace "fullscreen" with "normal" and adapt coordinates and sizes)
but this probably doesnt prevent the blocked situation to come back.

KoRnKloWn (kornklown) wrote :

Well, I just had the same issue in Ubuntu 13.04, of course it didn't occur after a distro upgrade, I believe Thunderbird just updated, and I noticed compiz also crashed and restarted (updated @ night while I was asleep, and woke to find the error report about the crash, and all my windows were in a single workspace, which happens when compiz restarts). Then when I went to open Thunderbird it was fullscreen.

To fix this you can actually just delete localstore.rdf in the Thunderbird profile, if you want to be on the safe side just rename it to localstore.rdf.bak or localstore.rdf.old or something, then when you restart it and it creates the new file, and you're comfortable with it, delete the old file.

It is totally safe to delete though, because if it doesn't exist when Thunderbird opens it automatically creates it with default values (which is basically no values at all). Then when you change the size of the window to what you prefer, it will update the file with the appropriate values to remember how the window was.

And this is what's so amazing about text based configuration, in Window$ with a program that uses the registry for everything, you'd have to find the specific registry entry, and deleting it would likely break the program (and maybe even cause BSoD), so you'd likely have to find out what the key is and what value it's supposed to have.

Same here.
During upgrade from 13.04 to 13.10 I had some problems in compiz/3d acceleration/desktop elements (panel disappeared) and so on.
I was using thunderbird and it remembered the "wrong fullscreen" position.
After some tricks and updates my desktop was ok but thunderbird always started fullscreen, no matter what.
Editing the localstore.rdf from:
                    width="1539"
                    height="847"
                    sizemode="fullscreen" />
to
                    width="800"
                    height="600"
                    sizemode="normal" />
solved the problem.
Thanks all for the hints

Rafael Reiter (mfil) wrote :

Just happened here - Thunderbird 24, Gnome 3.6.2. sizemode="fullscreen" -> "normal" worked.

Cristian Klein (cristiklein) wrote :

I just encountered this bug with today's Ubuntu 12.04 LTS

Kojo Kumah (40tx) wrote :

Just happened to me too. Ubuntu 14.04, Thunderbird 24.6.0. The workaround worked for me, but jeez what a frustrating and annoying bug!

mythsmith (mythsmith) wrote :

Happened to me also. Ubuntu 14.04, Thunderbird 31.3.0. Workaround ok.

Things changed, now setting is in xulstore.json

description: updated
Gary B (gar37bic) wrote :

Marco's note was the key for me. In my case some conflict between Compiz and Mate caused my desktop to go completely crazy. One of the effects was to make every application go full screen. After cleaning up the mess, all the apps went back to more-or-less normal but Thunderbird. I had already tried the localstore.rdf method without success. But Marco's note about using xulstore.json did the trick!

Until then, while I tried to get this working, the only way I could get to my Panel was by hitting F12, which brought up the miniterminal and coincidentally showed the Panel. But then I could only minimize Thunderbird. (And I ended up with a dozen or so miniterminal windows...) The right-click options on the Thunderbird button in the task list did not show Thunderbird as maximized. So the easiest thing was to just use File->exit in Thunderbird each time I tried things.

Changed in thunderbird:
status: New → Unknown
Changed in thunderbird:
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.