Thunderbird 78.2.2-ubuntu does not show folders etc.

Bug #1895898 reported by Derk Willem te Bokkel on 2020-09-16
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Unknown
thunderbird (Ubuntu)
Critical
Olivier Tilloy

Bug Description

Happened on upgrade from 78.2.1 to 78.2.2 lost all folder views .. Groovy .. regular updates via proposed..etc. (xubuntu flavour)

Installed thunderbird 78.2.2 from thunderbird.net into personal home directory works properly..

 so it is an ubuntu regression issue .. something has gone missing from the UI that puts folders on the screen (LH column)

.. view toggles do nothing in the ubuntu version ..

  Also F8 split view (RHS) also is not functioning

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: thunderbird 1:78.2.2+build1-0ubuntu1
ProcVersionSignature: Ubuntu 5.8.0-19.20-generic 5.8.8
Uname: Linux 5.8.0-19-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.20.11-0ubuntu45
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: derk 921 F.... pulseaudio
 /dev/snd/controlC0: derk 921 F.... pulseaudio
BuildID: 20200908210243
CasperMD5CheckResult: skip
Channel: Unavailable
CurrentDesktop: XFCE
CurrentDmesg: Error: command ['dmesg'] failed with exit code 1: dmesg: read kernel buffer failed: Operation not permitted
Date: Wed Sep 16 17:30:48 2020
DefaultProfileExtensions: extensions.sqlite corrupt or missing
DefaultProfileIncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
DefaultProfileLocales: extensions.sqlite corrupt or missing
DefaultProfilePrefErrors: Unexpected character ',' before close parenthesis @ /usr/lib/thunderbird/omni.ja:greprefs.js:732
DefaultProfilePrefSources: prefs.js
DefaultProfileThemes: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
InstallationDate: Installed on 2020-05-19 (120 days ago)
InstallationMedia: Xubuntu 20.10 "Groovy Gorilla" - Alpha amd64 (20200519)
IpRoute:
 default via 192.168.4.1 dev wlp2s0 proto dhcp metric 600
 169.254.0.0/16 dev wlp2s0 scope link metric 1000
 192.168.4.0/24 dev wlp2s0 proto kernel scope link src 192.168.4.141 metric 600
MostRecentCrashID: bp-8c597886-302c-42d4-af10-23ca20200612
Profile1Extensions: extensions.sqlite corrupt or missing
Profile1IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
Profile1Locales: extensions.sqlite corrupt or missing
Profile1PrefErrors: Unexpected character ',' before close parenthesis @ /usr/lib/thunderbird/omni.ja:greprefs.js:732
Profile1PrefSources: prefs.js
Profile1Themes: extensions.sqlite corrupt or missing
Profile2Extensions: extensions.sqlite corrupt or missing
Profile2IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
Profile2Locales: extensions.sqlite corrupt or missing
Profile2PrefErrors: Unexpected character ',' before close parenthesis @ /usr/lib/thunderbird/omni.ja:greprefs.js:732
Profile2PrefSources: prefs.js
Profile2Themes: extensions.sqlite corrupt or missing
Profiles:
 Profile2 - LastVersion=78.2.2/20200908210243
 Profile1 - LastVersion=78.2.2/20200908210243
 Profile0 (Default) - LastVersion=78.2.2/20200908210243
RunningIncompatibleAddons: False
SourcePackage: thunderbird
SubmittedCrashIDs:
 bp-8c597886-302c-42d4-af10-23ca20200612
 bp-8fe41ba0-2507-41a8-977f-d75540200406
 bp-d6cc8f6f-72e6-48d0-a23a-a395b0200330
 bp-cb0c8ae9-db5c-4043-acc6-29a0b0191209
 bp-35463351-2c6b-416d-90ec-31f880191021
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/03/2019
dmi.bios.release: 15.42
dmi.bios.vendor: AMI
dmi.bios.version: F.42
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 85B3
dmi.board.vendor: HP
dmi.board.version: 91.42
dmi.chassis.type: 10
dmi.chassis.vendor: HP
dmi.chassis.version: Chassis Version
dmi.ec.firmware.release: 91.42
dmi.modalias: dmi:bvnAMI:bvrF.42:bd07/03/2019:br15.42:efr91.42:svnHP:pnHPLaptop17-ca1xxx:pvr:rvnHP:rn85B3:rvr91.42:cvnHP:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV HP Notebook
dmi.product.name: HP Laptop 17-ca1xxx
dmi.product.sku: 4LX67UA#ABL
dmi.sys.vendor: HP

78.2.1 was fine, 78.2.2 has the account wizard broken at startup, or message pane empty, etc.. in the error console this message is shown:

```
Uncaught TypeError: Cc['@mozilla.org/updates/update-manager;1'] is undefined
```
https://hg.mozilla.org/releases/comm-esr78/rev/ec20676c465e72ce5a35db0f4df995f4a508a24c#l1.78 doesnt check if the update-manager is available ?

In addition apparently the "Check for updates" button also appears even if built w/o updater:
ac_add_options --disable-updater
which is another regression.

wait a sec and forget my last comment for now. Did some test mistake.

```
Uncaught TypeError: Cc['@mozilla.org/updates/update-manager;1'] is undefined
    showWhatsNewPage chrome://messenger/content/specialTabs.js:1051
    openSpecialTabsOnStartup chrome://messenger/content/specialTabs.js:799
    OnLoadMessenger chrome://messenger/content/msgMail3PaneWindow.js:617
    onload chrome://messenger/content/messenger.xhtml:1
```
is the complete error message.

From my understanding, other similar callers do call `.activeUpdate` after getting the potential updatemanager component, eg https://searchfox.org/comm-esr78/source/mail/components/preferences/general.js#1484 ? or that should be withing some #ifdef updater-is-enabled ?

missing check for AppConstants.MOZ_UPDATER maybe ?

looking at the showWhatsNewPage() method in .1 and .2, previously there was a try/catch to gracefully handle non-existent update-manager component, which isnt the case anymore. Dunno what's the best fix for all cases, but for now adding a local hack.

(In reply to Wayne Mery (:wsmwk) from comment #6)
> like bug 1664590 ?

cant say that the exact same bug but seems similar

*** Bug 1664590 has been marked as a duplicate of this bug. ***

Created attachment 9175384
Bug 1664607 - Don't try to load what's new page when built with updater disabled. r=mkmelin

When Thunderbird is built with --disable-updater, as it done by most Linux
distributions, accessing the nsIUpdateManager service will throw an error
resulting in a broken UI. Check AppConstants.MOZ_UPDATER when using
nsIUpdateManger to prevent errors.

I did a local build with this patch and --disable-updater and verified that it works as intended. Try jobs at:
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=b0c4a8521444fea8af25aee1f9619818a7e5b7a5
https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=aa4b9d60192ae7f1ca9f39c0cdedb7fa6c19f28a

I also quickly checked to see what happens when updates are disabled via enterprise policies. In that case, activeUpdate should just return null so there should not be any problems.

*** Bug 1664721 has been marked as a duplicate of this bug. ***

Pushed by <email address hidden>:
https://hg.mozilla.org/comm-central/rev/6379c3b860f7
Don't try to load what's new page when built with updater disabled. r=mkmelin DONTBUILD

Comment on attachment 9175384
Bug 1664607 - Don't try to load what's new page when built with updater disabled. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): 1563411
User impact if declined: This issue affects users that use various Linux distribution builds which are built with --disable-updater. The bug causes portions of the UI to not load resulting in an unusable interface. Users of "official" builds are not affected, and the fix would have no impact as it just wraps the what-new loading code in a conditional based on the value of MOZ_UPDATER which is set at build time automatically.
Testing completed (on c-c, etc.): I tested local a build of esr78 with this patch and --disable-updater to make sure it works as expected. When testing beta it would be nice if QA can test with an enterprise policy that disables updates. I don't expect any issues based on reading the code, but I may have missed something.
Risk to taking this patch (and alternatives if risky): I see very little risk in accepting this patch as the variable in question is always set to True on official builds and is not possible to change without a recompile.

Comment on attachment 9175384
Bug 1664607 - Don't try to load what's new page when built with updater disabled. r=mkmelin

[Triage Comment]
Approved for beta
Approved for esr78

[Triage Comment]

I checked an official build with enterprise policies disabled and saw no UI issues.
OpenSUSE has applied this patch to their 78.2.2 build [Bug](https://bugzilla.opensuse.org/show_bug.cgi?id=1176384#c18) and [Changelog](https://build.opensuse.org/package/revisions/mozilla/thunderbird78) successfully.

had a quick look at the diff file between ubuntu thinderbird versions 78.2.1 and 78.2.2 .. there is a massive amount of deleted lines .. a lot to do with twitter accounts .. is this on purpose or has something gone amiss ..

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

Thanks for the report, I'm looking into it now.

Note that the massive amount of deleted lines is mostly expected, see https://www.thunderbird.net/en-US/thunderbird/78.2.2/releasenotes/#changes.

Changed in thunderbird (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → Critical
Olivier Tilloy (osomon) wrote :
Olivier Tilloy (osomon) wrote :
Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Committed
Changed in thunderbird:
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 1:78.2.2+build1-0ubuntu2

---------------
thunderbird (1:78.2.2+build1-0ubuntu2) groovy; urgency=medium

  * Apply an upstream patch to fix the UI when building with the updater
    component disabled (LP: #1895898)
    - debian/patches/upstream-fix-ui-updater-disabled.patch

 -- Olivier Tilloy <email address hidden> Thu, 17 Sep 2020 17:43:38 +0200

Changed in thunderbird (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.