Thunderbird crashes with GTK_USE_PORTAL environment variable.

Bug #1813471 reported by Ian Turner on 2019-01-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Critical
thunderbird (Ubuntu)
Low
Unassigned

Bug Description

Crash happens at startup, even for a new profile, as long as any e-mail accounts are configured.

In profile creation mode, the crash happens as soon as an e-mail account is added.

If all e-mail accounts are removed from prefs.js, then Thunderbird doesn't crash.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: thunderbird 1:60.4.0+build2-0ubuntu0.18.04.1
ProcVersionSignature: Ubuntu 4.15.0-43.46-generic 4.15.18
Uname: Linux 4.15.0-43-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.20.9-0ubuntu7.5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: vectro 2619 F.... pulseaudio
 /dev/snd/controlC0: vectro 2619 F.... pulseaudio
BuildID: 20190116085154
Channel: Unavailable
CurrentDesktop: KDE
Date: Sun Jan 27 06:55:37 2019
DefaultProfileExtensions: extensions.sqlite corrupt or missing
DefaultProfileIncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
DefaultProfileLocales: extensions.sqlite corrupt or missing
DefaultProfilePrefSources: prefs.js
DefaultProfileThemes: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2018-03-23 (309 days ago)
InstallationMedia: Kubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180306.1)
IpRoute:
 default via 172.20.0.1 dev wlo1 proto dhcp metric 600
 169.254.0.0/16 dev wlo1 scope link metric 1000
 172.20.0.0/20 dev wlo1 proto kernel scope link src 172.20.2.18 metric 600
MostRecentCrashID: bp-d74e2e85-8327-42af-bce7-559720190127
Profile1Extensions: extensions.sqlite corrupt or missing
Profile1IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
Profile1Locales: extensions.sqlite corrupt or missing
Profile1PrefSources: prefs.js
Profile1Prefs:
 extensions.lastAppVersion: "60.4.0" (prefs.js)
 network.cookie.prefsMigrated: true (prefs.js)
 places.history.expiration.transient_current_max_pages: 104858 (prefs.js)
Profile1Themes: extensions.sqlite corrupt or missing
Profiles:
 Profile0 (Default) - LastVersion=60.4.0/20190116085154
 Profile1 - LastVersion=60.4.0/20190116085154
RunningIncompatibleAddons: False
SourcePackage: thunderbird
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 01/25/2018
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: L78 Ver. 01.43
dmi.board.name: 2101
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 16.3C
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvrL78Ver.01.43:bd01/25/2018:svnHewlett-Packard:pnHPProBook640G1:pvrA3009DD10303:rvnHewlett-Packard:rn2101:rvrKBCVersion16.3C:cvnHewlett-Packard:ct10:cvr:
dmi.product.family: 103C_5336AN G=N L=BUS B=HP S=PRO
dmi.product.name: HP ProBook 640 G1
dmi.product.version: A3009DD10303
dmi.sys.vendor: Hewlett-Packard

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

Run `GTK_USE_PORTAL=1 thunderbird`

Actual results:

Thunderbird crashes on startup

Expected results:

Thunderbird should not crash, or at least fail gracefully if running with GTK_USE_PORTAL=1 is not supported.

Note that I cannot post a backtrace because archlinux doesn't ship debug symbols. But given that this crash is 100% reproducible I hope that someone else will be able to.

If you cannot get symbols with archlinux then please get a backtrace using https://archive.mozilla.org/pub/thunderbird/releases/60.3.3/linux-x86_64/en-US/

Thanks for the link, it doesn't crash using that package. I'll report the crash downstream.

Ian Turner (vectro) wrote :
Ian Turner (vectro) wrote :

Also affects Arch Linux; see here: https://bugs.archlinux.org/task/61134

The reporter there said that "It does not crash if I use the upstream build", but I have not tried that.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in thunderbird (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Murz (murznn) wrote :

Seems this issue will be fixed only in Thunderbird 68 version, here is issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1471420

Murz (murznn) wrote :

And here https://phabricator.kde.org/T10189 is KDE discussion about this problem.

Murz (murznn) wrote :

Here https://bugzilla.mozilla.org/show_bug.cgi?id=1514605 is same bug in Mozilla tracker.

I got same crash on Ubuntu with GTK_USE_PORTAL=1 environment variable set.

Download full text (3.2 KiB)

Here is Report contents for this crash:
Add-ons: gconversation%40xulforum.org:2.14.7,%7Ba300a000-5e21-4ee0-a115-9ec8f4eaa92b%7D:0.3.17b1,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:60.4.0,messagingmenu%40mozilla.com:1.4
BuildID: 20190115190018
ContentSandboxCapabilities: 119
ContentSandboxCapable: 1
ContentSandboxLevel: 0
CrashTime: 1548746230
Email: <email address hidden>
FramePoisonBase: 9223372036600930304
FramePoisonSize: 4096
InstallTime: 1548745720
Notes: Ubuntu 18.10FP(D00-L1100-W00000000-T000) OpenGL: Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell -- 3.0 Mesa 18.2.2 -- texture_from_pixmap
WR? WR- OMTP? OMTP-
ProductID: {3550f703-e582-4d05-9a08-453d09bdfdc6}
ProductName: Thunderbird
ReleaseChannel: release
SafeMode: 0
SecondsSinceLastCrash: 487409
StartupCrash: 0
StartupTime: 1548746229
TelemetryEnvironment: {"build":{"applicationId":"{3550f703-e582-4d05-9a08-453d09bdfdc6}","applicationName":"Thunderbird","architecture":"x86-64","buildId":"20190115190018","version":"60.4.0","vendor":null,"platformVersion":"60.4.0","xpcomAbi":"x86_64-gcc3","updaterAvailable":false},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":7792,"virtualMaxMB":null,"cpu":{"count":4,"cores":2,"vendor":"GenuineIntel","family":6,"model":60,"stepping":3,"l2cacheKB":256,"l3cacheKB":3072,"speedMHz":3400,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2","hasAVX","hasAVX2","hasAES"]},"os":{"name":"Linux","version":"4.18.0-13-generic","locale":"ru-RU"},"hdd":{"profile":{"model":null,"revision":null},"binary":{"model":null,"revision":null},"system":{"model":null,"revision":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"ContentBackend":"Skia","adapters":[{"description":"Intel Open Source Technology Center -- Mesa DRI Intel(R) Haswell ","vendorID":"Intel Open Source Technology Center","deviceID":"Mesa DRI Intel(R) Haswell ","subsysID":null,"RAM":null,"driver":null,"driverVersion":"3.0 Mesa 18.2.2","driverDate":null,"GPUActive":true}],"monitors":[],"features":{"compositor":"none","gpuProcess":{"status":"unused"}}},"appleModelId":null},"settings":{"blocklistEnabled":true,"e10sEnabled":false,"e10sMultiProcesses":4,"telemetryEnabled":false,"locale":"en-US","update":{"channel":"release","enabled":true,"autoDownload":true},"userPrefs":{"browser.cache.disk.capacity":276480,"browser.search.region":"RU"},"sandbox":{"effectiveContentProcessLevel":0},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":null},"profile":{}}
ThreadIdNameMapping: 28980:"Gecko_IOThread",28981:"Link Monitor",28982:"Socket Thread",28983:"JS Watchdog",28990:"BGReadURLs",28991:"Hang Monitor",28996:"Timer",28997:"StreamTrans #1",28998:"Cache2 I/O",28999:"Cookie",29000:"GMPThread",29001:"SoftwareVsyncThread",29002:"Compositor",29003:"VRListener",29004:"ImgDecoder #1",29005:"ImageIO",29010:"IPDL Background",29011:"LoadRoots",29012:"DataStorage",29013:"DataStorage",29015:"mozStorage #1",29016:"HTML5 Parser",29020:"ImgDecoder #2",29021:"DOM Worker",29022:"ImageBridgeChild",
Throttleable: 1
UptimeTS: 1.03866891
Vendor:
Version: 60.4.0
useragent_...

Read more...

Changed in thunderbird (Ubuntu):
status: Incomplete → Triaged
Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → New

I've experienced this same crash with Thunderbird 60.5.1 from the mozilla team's ppa on Ubuntu 18.10.

In my case, I had to first add a mail account and when autoconfiguration was complete and I hit done/continue thunderbird crashes. Any subsequent launches result in a crash until the cache+profile is removed (I'm not sure if removing both is necessary but it works).

un-setting GTK_USE_PORTAL and then launching thunderbird seems to work (no more crashes).

# package details #
Package: thunderbird
Version: 1:60.5.1+build1-0ubuntu0.18.10.1~mt1
Priority: optional
Section: mail
Maintainer: Ubuntu Mozilla Team <email address hidden>

murz

We need your crash ID - see https://support.mozilla.org/en-US/kb/mozilla-crash-reporter-tb#w_viewing-crash-reports
(Unfortunately "crash details" isn't useful here)

(In reply to Elvis Angelaccio from comment #3)
> Thanks for the link, it doesn't crash using that package. I'll report the crash downstream.

Do you have a link?

(In reply to Wayne Mery (:wsmwk) from comment #8)

> (In reply to Elvis Angelaccio from comment #3)
> > Thanks for the link, it doesn't crash using that package. I'll report the crash downstream.
>
> Do you have a link?

Sure: https://bugs.archlinux.org/task/61134

Anyone else see crashes with this setting?

Here is my two fresh crash id's for this issue:
bp-b9d80041-48a4-42d9-a4fd-8a1eb0190309
bp-e0e1b55d-99be-43eb-8ace-487550190309

I confirm I'm seeing the crash as well on TB 60.5.3 - since the Arch Linux build does not have debug symbols enabled, I'm recompiling the package to see if I can get a proper backtrace.

(In reply to Alessandro Menti from comment #13)
> I confirm I'm seeing the crash as well on TB 60.5.3 - since the Arch Linux build does not have debug symbols enabled, I'm recompiling the package to see if I can get a proper backtrace.

Alessandro recompiling from http://ftp.mozilla.org/pub/thunderbird/releases/60.6.1/linux-x86_64/ ?
Did you have success?

And does this also happen with Firefox?

Changed in thunderbird:
importance: Medium → Critical

Hi Wayne,
I tried recompiling Thunderbird but, despite adding the proper configuration switches to add debug symbols, apparently the build process did not add them.

I can also confirm that the crash does not happen with Firefox (I tested it with the Arch Linux provided package, version 66.0.5-1).

Learned something new today. :)

No crash here starting Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.6.1 from Ubuntu with GTK_USE_PORTAL=1 thunderbird -p on Ubuntu 18.04.2 LTS.

I did get this message in the terminal.

"JavaScript error: jar:file:///usr/lib/thunderbird/omni.ja!/components/XULStore.js, line 65: Error: Can't find profile directory."

The Profile Manager opened anyway and I was able to use the associated profile.

I get the same error without using the -p switch.

I've tested 6.70.0, 6.70.1, 68.0b1, and the daily on Ubuntu 19.04, all crash after all dialogs are closed and it seems (still needs a little more testing) at least one email account is setup.

Whats odd is that unless you explicitly set GTK_USE_PORTAL = 1 in the string to launch TB (i.e. 'GTK_USE_PORTAL=1 thunderbird') the bug is not triggered.

It also happens regardless to the value you give GTK_USE_PORTAL as 'GTK_USE_PORTAL=0 thunderbird'

Here are the crash reports generated using the beta

bp-b5718f8c-7977-46a4-84b8-d190b0190618 <-- with 'GTK_USE_PORTAL=0 thunderbird'

bp-0fd780e4-9d38-4b70-b887-208e50190618 <-- with 'GTK_USE_PORTAL=1 thunderbird'

Changed in thunderbird:
status: New → Confirmed

FWIW, 12 crashes from the same person today, on 69.0b1

I am experiencing this crash on kubuntu 18.10 using thunderbird 60.8.0. Installed package is 60.8.0+build1-0ubuntu0.18.10.1
I set GTK_USE_PORTAL=1 in the '.profile' file in the home folder.
Could provide debugging backtrace/data.

This seems to be the only reference to GTK_USE_PORTAL in Mozilla's code.
https://searchfox.org/comm-central/source/mozilla/toolkit/system/gnome/nsGIOService.cpp#35

I'm going to start a regression search, and looking around the Mozilla code to see if there is something they set that we don't.

Will update at the end of the day.

*** Bug 1545489 has been marked as a duplicate of this bug. ***

So it seems this has been in the code a LONG time. So if it is a regression I haven't found it yet. I still find it odd that Firefox doesn't suffer from the same issue given we share so much of the code base.

Created attachment 9091741
bug1514605_GTK_USE_PORTAL.patch

Can't reproduce at least on trunk. But if the crash report numbers are correct, this would be the issue.

Comment on attachment 9091741
bug1514605_GTK_USE_PORTAL.patch

Typically for a QI, a bad status and returning null are synonymous. I wouldn't check both, but there's no harm done.

Seems fixed, `GTK_USE_PORTAL=1 thunderbird` goes to work well on Ubuntu 19.04 with `thunderbird-mozilla-build_68.0-0ubuntu1_amd64.deb`!
With `thunderbird-mozilla-build_60.8.0-0ubuntu1_amd64.deb` now there are no crash, but dialog is still GTK.
Can any of other subscribers confirm, that this is fixed too?

Pushed by <email address hidden>:
https://hg.mozilla.org/comm-central/rev/aa6de4b5b0db
fix Thunderbird startup crash when GTK_USE_PORTAL=1 is set. r=jorgk

Comment on attachment 9091741
bug1514605_GTK_USE_PORTAL.patch

Shouldn't hurt.

Changed in thunderbird:
status: Confirmed → Fix Released

I am having this issue with the latest version 70.0b1 but I don't see any release for 70.0b2 so basically I cannot use thunderbird.
I can confirm that using the nightly there are no problems.

We'll release TB 70 beta 2 early next week.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.