🌈 looks odd in thunderbird, chrome/chromium, okish in firefox

Bug #1779569 reported by Phillip Susi on 2018-07-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Unknown
Unknown
chromium-browser (Ubuntu)
Undecided
Unassigned
firefox (Ubuntu)
Undecided
Unassigned
thunderbird (Ubuntu)
Undecided
Unassigned

Bug Description

New install of 18.04 and thunderbird is showing weird images in odd places for some email. See screen shot for example. In this case it is a weird rainbow, but I have also seen other things like a big stop sign and other strange stuff.

Emoji support is inconsistent:
- google chrome title is good
- firefox title is good
- google chrome contents, is bad, black&white ascii icon
- fiefox contents, is ok, not the same icon as in the title
- thunderbird content is ok, but too huge

Phillip Susi (psusi) wrote :
Tom Reynolds (tomreyn) wrote :

What you're looking at there is probably unicode character 🌈
maybe Dimitri can confirm this.

Jeremy (wa113y3s) wrote :

 sudo apt-get install fonts-symbola
May be a dupe of https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1761844

Dimitri John Ledkov (xnox) wrote :

The expected output is the same as opening https://launchpad.net/~xnox in Firefox, note the title bar, and the username.

Note there is a bug in Chrome/Chromium, where title bar shown correctly, but not the contents.

Ultimately this is Ubuntu Desktop bug. Whilst I love the oversized rainbows, it should be more space conscious than that.

Dimitri John Ledkov (xnox) wrote :
description: updated
summary: - thunderbird showing weird images in some mail
+ 🌈 looks odd in thunderbird showing weird images in some mai
summary: - 🌈 looks odd in thunderbird showing weird images in some mai
+ 🌈 looks odd in thunderbird, chrome/chromium, okish in firefox
Amr Ibrahim (amribrahim1987) wrote :

The Thunderbird part in a duplicate of bug #1761844. Upstream Thunderbird says it will be fixed in version 60.

Amr Ibrahim (amribrahim1987) wrote :

A quick workaround is to install fonts-symbola, as mentioned before, that will make Thunderbird use the emojis from their, but they are black and white.

Dimitri John Ledkov (xnox) wrote :

The expected behaviour is a colorful emoji though. In the body of google chrome/chromium too... Not the black&white ones.

Basically, gnome-terminal (or any other fully gtk3 native app) gets these right. But the listed browsers is a mixed bag result.

Jeremy Bicha (jbicha) wrote :

Dimitri, see my comment 12 on bug 1761844 which points out that is likely bug 1644021 which I helped fix in the beta PPA, but I don't handle Firefox/Thunderbird uploads directly to Ubuntu. You're welcome to talk to Chris about this issue though…

Jeremy Bicha (jbicha) wrote :

Web browsers have their own system for rendering text and therefore color emoji. Firefox currently uses a version of EmojiOne but is switching to the Twitter emoji set. See https://bugzilla.mozilla.org/1358240

Honestly, the bug report you filed is too broad and in some cases is already duplicated by existing bugs.

For reference, you might find this page interesting (it's a large page):
https://unicode.org/emoji/charts/full-emoji-list.html

Ubuntu 18.04 LTS installs the Google emoji font by default and that page does actually display correctly for me with Firefox. Web pages can specify a particular color emoji font though. Therefore, you will see different emoji sets on different web pages and that's not really a bug.

no longer affects: ubuntu-meta (Ubuntu)
Wes (wesinator) on 2018-07-11
affects: chromium (Ubuntu) → chromium-browser (Ubuntu)
Olivier Tilloy (osomon) wrote :

This looks fine in the latest stable chromium on bionic (and in the snap too). See attached screenshot. The only place where the rainbow is not rendered correctly is in the tab handle, but that's a different issue than the one originally reported.

Changed in chromium-browser (Ubuntu):
status: New → Fix Released
Olivier Tilloy (osomon) wrote :

Other unicode characters and emojis are rendered correctly in the tab handle (see for example https://launchpad.net/~popey), but the rainbow emoji isn't. Not sure what's so special about that one.

Jeremy Bicha (jbicha) wrote :

This is fixed in Thunderbird 60 which will be in Ubuntu soon. I'm marking this a duplicate of bug 1761844.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.