Very large emojis displayed in subject line and in the email list

Bug #1761844 reported by Diego Germán Gonzalez on 2018-04-06
404
This bug affects 91 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Medium
thunderbird (Ubuntu)
High
Unassigned

Bug Description

The list of emails received from Thunderbird shows emojis. This does not happen with all accounts.
It appears to be with the last email address added.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: thunderbird 1:52.6.0+build1-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
Uname: Linux 4.15.0-15-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
AddonCompatCheckDisabled: False
ApportVersion: 2.20.9-0ubuntu2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/pcmC0D0p: diego 1607 F...m pulseaudio
 /dev/snd/controlC0: diego 1607 F.... pulseaudio
 /dev/snd/controlC1: diego 1607 F.... pulseaudio
BuildID: 20180131200234
Channel: Unavailable
CurrentDesktop: ubuntu:GNOME
Date: Fri Apr 6 15:58:17 2018
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
InstallationDate: Installed on 2018-04-05 (1 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Beta amd64 (20180404)
IpRoute:
 default via 181.31.1.1 dev enp2s0 proto dhcp metric 100
 169.254.0.0/16 dev enp2s0 scope link metric 1000
 181.31.1.0/24 dev enp2s0 proto kernel scope link src 181.31.1.84 metric 100
IwConfig:
 lo no wireless extensions.

 enp2s0 no wireless extensions.
Locales: extensions.sqlite corrupt or missing
PrefSources: prefs.js
Profiles: Profile0 (Default) - LastVersion=52.6.0/20180131200234 (In use)
RfKill:

RunningIncompatibleAddons: False
SourcePackage: thunderbird
Themes: extensions.sqlite corrupt or missing
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/14/2012
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F4
dmi.board.name: GA-78LMT-S2
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF4:bd08/14/2012:svnGigabyteTechnologyCo.,Ltd.:pnGA-78LMT-S2:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnGA-78LMT-S2:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: GA-78LMT-S2
dmi.sys.vendor: Gigabyte Technology Co., Ltd.

Changed in thunderbird (Ubuntu):
status: New → Invalid
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
fmo (fmo) wrote :

Having the same issue on an Intel NUC Skull Canyon NUC6i7KYB.

The emojis are displayed in big over the message list which makes it difficult to read.

I am using the official Ubuntu Desktop over Xorg

passtoor (passtoor) wrote :

Remove the emoji resolve problem
sudo apt remove fonts-noto-color-emoji

In my case the problem was using the configuration folder of a later version, downloaded from the Thunderbird website in the default version included in Ubuntu.
Setting from scratch does not present the problem.
I don't invalidate the bug because there are other reports

Sebastien Bacher (seb128) wrote :

One of the duplicates claims it's fixed in the next tb version from https://launchpad.net/~mozillateam/+archive/ubuntu/thunderbird-next

Changed in thunderbird (Ubuntu):
importance: Undecided → High
Michał Sawicz (saviq) wrote :

Confirmed, emojis are fine in:

$ LANG=C apt policy thunderbird
thunderbird:
  Installed: 1:57.0~b2+build1-0ubuntu0.18.04.1
  Candidate: 1:57.0~b2+build1-0ubuntu0.18.04.1
  Version table:
 *** 1:57.0~b2+build1-0ubuntu0.18.04.1 500
        500 http://ppa.launchpad.net/mozillateam/thunderbird-next/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
     1:52.7.0+build1-0ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → Invalid
Wal (trees5353) wrote :

I can confirm I too have this problem. Three pc's running ubuntu 18.04 and all have the same problem in thunderbird. This was not present running thunderbird on Ubuntu 16.04. This problem does not replicate on thunderbird in Windows. It would appear that it is Operating System specific.

summary: - Thunderbird: emojis is displayed in the email list
+ Very large emojis displayed in subject line and in the email list
Slavic Dragovtev (slavicd) wrote :

How do we improve the visibility of this bug, so that duplicates don't add up? I myself couldn't find this bug at first, before I reported a duplicate. Perhaps having more tags in the description would help: images, email list, emoticon, emoji, etc.?

tags: added: emoji thunderbird
Slavic Dragovtev (slavicd) wrote :

Not everyone knows those are emojis. A considerable amount of searches will be for "images in email list"

tags: added: images in list mailing
Jeremy Bicha (jbicha) wrote :

I think this bug is actually surprisingly a duplicate of bug 1644021 which we fixed in the PPA several months ago.

bugrasan (bugrasan) wrote :

$ sudo apt-get install fonts-symbola
solves the problem, origin: https://ubuntu-mate.community/t/thunderbird-with-huge-icons-emoticons-mate-18-04/16249/25

therefore the thunderbird package should depend on 'fonts-symbola'.

shinyblue (shinyblue) wrote :

Yep, bugrasan's solution works for me. Shame they're monochrome emojis, but at least text is readable now.

Markus Majer (mpathy) wrote :

Its true, a very easy workaround is to install the fonts-symbola package:
sudo apt-get install fonts-symbola

Afterwards, all works fine.

+1 to the suggestion of bugrasan, to just add a dependency to the fonts-symbola package (looks better anyways)

Jeff Van Epps (lordbah) wrote :

Is there (going to be) a solution which is a preference for "don't show emoji in subject line"? I hardly ever understand them anyway. I'm a grumpy old man who learned to read English 50+ years ago and I'd just prefer to stick with text only. (unchecking Preferences / Display / Display emoticons as graphics (under Plain Text Messages) doesn't have any effect on this)

Wal (trees5353) wrote :

The fix by bugrasan works OK and gets the emojis down to normal size however the emoji's are no longer colour but black and white. This is at least a good workaround for the time being.

I think you will find this problem will be fixed in a later version of Thunderbird. I downloaded Thunderbird 60 Beta tar.bz2 from their website. Without actually installing it I extracted the folder and ran that version of Thunderbird from within that folder. It will automatically pick up you settings and email addresses etc from the version you have installed.

It worked fine and the emojis contained in this version of Thunderbird are of normal size and are coloured.

Michal Lesniewski (wildnet) wrote :

I tested some solutions found on launchpad and google. with fonts-symbola - but they are without colors.
lastly I installed as wrote before (in bug #1644021) Twitter Color Emoji SVGinOT Font:

https://github.com/eosrei/twemoji-color-font

sudo apt-add-repository ppa:eosrei/fonts
sudo apt update
sudo apt install fonts-twemoji-svginot

This resolved problem with big images of emoji and keep them in color.

Changed in thunderbird:
status: Invalid → Fix Released
Eero (eero+launchpad) wrote :

Did nobody at Canonical test Thunderbird even once before setting it as the default email client in 18.04?

Wal (trees5353) wrote :

Just in to be fair to Canonical or even Thunderbird Developers and their people it is impossible to test an application for every bug that may arise. How would you see and test an emoji email would you even think of it. There are so many things that take place when you start your email client. I am sure emoji's in emails would be the last thing they would think of testing.

To give you an example just look at Microsoft and Windows 10 or 7 how often do updates get released and something breaks. I'm sure Microsoft do their best to test their updates but sometimes these things just slip through because of a conflict with the app or the operating system.

Having said that Thunderbird 60.1 will be released any day now and this bug has been fixed in that release. You will be able to update directly from your current email client to the new one.

Mike Hardy (mikehardy) wrote :

Confirming color emojis works per this solution with stock TB from 18.04.01LTS
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1761844/comments/18

Jeremy Bicha (jbicha) wrote :

This is fixed in Thunderbird 60 which will be released to Ubuntu soon.

Changed in thunderbird (Ubuntu):
status: Confirmed → Fix Committed
Ian (superian) wrote :

Confirmed fixed in the 60.2.1 release which finally hit the Bionic repositories today.

(My preferred solution would have been to erase emojis entirely from Unicode, but I know not everyone agrees with that...)

Paul White (paulw2u) wrote :

Also confirming as fixed and marking bug report as such.

Changed in thunderbird (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.