shortcuts different in windows and linux

Bug #160794 reported by s0170071 on 2007-11-07
8
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Fix Released
Medium
thunderbird (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: mozilla-thunderbird

the windows version uses ctrl+shift+f to search for mail,
the linux version uses just shift+f

Joel Goguen (jgoguen) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: https://bugzilla.mozilla.org/show_bug.cgi?id=476160

Changed in mozilla-thunderbird:
status: New → Confirmed
Changed in thunderbird:
status: Unknown → New

Created attachment 366384
proposed fix

I hear we need more keys :)

The fix for bug 242947 was only a workaround in the first place and GTK2.9-> has changed to only reserve ctrl-shift-u (according to bug 311756 comment 35), we can now just switch to using the same shortcut on all platforms.

Comment on attachment 366384
proposed fix

Yay, a key!

In some ways, key-bindings seem like part of the interaction paradigm...

Michael Rooney (mrooney) wrote :

Marking as Wishlist since the problem exists only in comparison to another OS, and it may even be desired to change the Windows shortcut and not this one.

Changed in mozilla-thunderbird (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged
Micah Gersten (micahg) wrote :

Moving to thunderbird package as this is still a valid request for TB2+.

affects: mozilla-thunderbird (Ubuntu) → thunderbird (Ubuntu)

*** Bug 476160 has been marked as a duplicate of this bug. ***

Micah Gersten (micahg) wrote :

The shortcuts are now in sync (CTRL + SHIFT + F) in the latest Thunderbird 3 beta. Please report any other bugs you may find. You can test the latest Thunderbird 3 beta here:
https://launchpad.net/~ubuntu-mozilla-daily/+archive/ppa

A word of caution, that this is still beta software and you might encounter bugs.

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in thunderbird:
status: New → Invalid
Micah Gersten (micahg) wrote :

I made an error, this should remain Triaged as it has not been released in Ubuntu yet.

Changed in thunderbird (Ubuntu):
status: Fix Released → Triaged
Micah Gersten (micahg) on 2009-06-28
Changed in thunderbird:
status: Invalid → Unknown
Changed in thunderbird:
status: Unknown → Fix Released
Micah Gersten (micahg) on 2009-12-11
Changed in thunderbird:
milestone: none → 3.0
Launchpad Janitor (janitor) wrote :
Download full text (6.7 KiB)

This bug was fixed in the package thunderbird - 3.0+nobinonly-0ubuntu1

---------------
thunderbird (3.0+nobinonly-0ubuntu1) lucid; urgency=low

  * New Upstream Release 3.0 (THUNDERBIRD_3_0_RELEASE)
    - LP: #50902 - Thunderbird displays useless dialog
    - LP: #52667 - Thunderbird doesn't support RFC-2369
    - LP: #49033 - Doesn't recognize upper case extension (.JPG)
    - LP: #56465 - Per folder column widths
    - LP: #68456 - CTRL-Shift-K bound to 2 functions
    - LP: #79337 - Typo in Server Information for Add Account Wizard
    - LP: #1084 - No scroll on full headers list
    - LP: #62071 - Middle click on scrollbar pastes instead of jumping
    - LP: #119358 - Weak default authentication mode
    - LP: #120672 - No option to empty junk folder with right click
    - LP: #96566 - movemail doesn't work with default privs
    - LP: #122529 - Non-Thunderbird IMAP folders not visible to Thunderbird
    - LP: #241276 - Not able to paste image into thunderbird compose window
    - LP: #244635 - scrollboxes scroll to offset 0 when resized
    - LP: #259387 - "Edit Message as New" broken for eml messages
    - LP: #120281 - Editing a message from the drafts folder leaves line breaks
    - LP: #115484 - Dialogue boxes too large for 1024x768 resolution
    - LP: #320034 - Mail with self referencing headers breaks threading
    - LP: #160794 - shortcuts different in windows and linux
    - LP: #280987 - thunderbird keeps asking a password when working off-line
    - LP: #369150 - Thunderbird splits email addresses with non-ascii characters
                    and a comma in From: field
    - LP: #135066 - Thunderbird doesn't use Ubuntu icon theme
    - LP: #297301 - after authentication error the password is forgotten
    - LP: #487541 - thunderbird-bin crashed with SIGSEGV (AFS filesystem)
    - LP: #485224 - Thunderbird saves double attachment file name endings on
                    FAT32 and NTFS
    - LP: #482496 - When using SCIM ANTHY, autosaving fails, and then get asked
                    about sending in UTF-8

  [ Fabien Tassin <email address hidden> ]
  * Add build-depends on autoconf2.13, autotolls-dev, mozilla-devscripts
    libglib2.0-dev (>= 2.12), libstartup-notification0-dev, libbz2-dev,
    libpixman-1-dev, libdbus-1-dev (>= 1.0.0), libdbus-glib-1-dev (>= 0.60),
    libhal-dev (>= 0.5.8), libasound2-dev, libreadline5-dev | libreadline-dev,
    libkrb5-dev
  * Update build-depends minimums for libx11-dev (>= 2:1.0),
    libgtk2.0-dev (>= 2.12), zlib1g-dev (>= 1:1.2.3), libpng12-dev (>= 1.2.0),
    libjpeg62-dev (>= 6b), libcairo2-dev (>= 0.5.8), libgnome2-dev (>= 2.16),
    libgnomevfs2-dev (>= 1:2.16), libgnomeui-dev (>= 2.16),
    libnss3-dev (>= 3.12.0~1.9b3)
  * Bump standards version to 3.8.0
  * Replace ${Source-Version} by ${binary:Version} in control file
    - update debian/control
  * Bump requirement for system nspr to >= 4.8 since Mozilla bug 492464 landed
  * Bump requirement for system nss to >= 3.12.3 since Mozilla bug 485052 landed
  * Use in-source hunspell when hunspell 1.2 is not available
  * Add conditionnal support for --with-libxul-sdk controlled by
    $(USE_SYSTEM_XUL)
    - update debian/rules
  * Add p...

Read more...

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
Changed in thunderbird:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.