Printing to PDF file loses URLs/links

Bug #1551949 reported by Colan Schwartz on 2016-03-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Confirmed
Wishlist
thunderbird (Ubuntu)
Low
Unassigned

Bug Description

Steps to reproduce:

1. File -> Print...
2. Select "Print to File".
3. Enter the file name.
4. Enter the save-to folder.
5. Leave the output format as-is, or select PDF if it's not the default.
6. Hit the Print button.
7. Open the resulting PDF in any PDF viewer.

Actual results:

The URLs within the document are not actually hyperlinks. They are simply text, coloured blue and underlined.

Expected results:

Any clickable links on the original e-mail message should be retained when converting the document to PDF format.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: thunderbird 1:38.5.1+build2-0ubuntu0.15.10.1
ProcVersionSignature: Ubuntu 4.2.0-30.35-generic 4.2.8-ckt3
Uname: Linux 4.2.0-30-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: colan 2383 F.... pulseaudio
 /dev/snd/controlC0: colan 2383 F.... pulseaudio
BuildID: 20160106101030
Channel: Unavailable
CurrentDesktop: Unity
Date: Tue Mar 1 15:53:53 2016
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/thunderbird/thunderbird
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
IpRoute:
 default via 192.168.1.1 dev wlan0 proto static metric 600
 169.254.0.0/16 dev wlan0 scope link metric 1000
 192.168.1.0/24 dev wlan0 proto kernel scope link src 192.168.1.140 metric 600
Locales: extensions.sqlite corrupt or missing
MostRecentCrashID: bp-1abc004a-043e-4a15-bdc0-45ade2150908
Plugins:
 Google Talk Plugin Video Renderer - /opt/google/talkplugin/libnpo1d.so (google-talkplugin)
 Google Talk Plugin - /opt/google/talkplugin/libnpgoogletalk.so (google-talkplugin)
 iTunes Application Detector - /usr/lib/mozilla/plugins/librhythmbox-itms-detection-plugin.so (rhythmbox-mozilla)
 Shockwave Flash - /usr/lib/adobe-flashplugin/libflashplayer.so (adobe-flashplugin)
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.UTF-8
 SHELL=/bin/zsh
Profiles: Profile0 (Default) - LastVersion=38.5.1/20160106101030 (In use)
RelatedPackageVersions:
 google-talkplugin 5.41.0.0-1
 rhythmbox-mozilla 3.2.1-1ubuntu3.1
 adobe-flashplugin 1:20160209.1-0ubuntu0.15.10.1
RunningIncompatibleAddons: False
SourcePackage: thunderbird
SubmittedCrashIDs:
 bp-1abc004a-043e-4a15-bdc0-45ade2150908
 bp-c8c94f9f-0c39-42d2-97ac-f2c7d2150713
Themes: extensions.sqlite corrupt or missing
UpgradeStatus: Upgraded to wily on 2015-11-30 (92 days ago)
dmi.bios.date: 07/09/2013
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 4.6.5
dmi.board.asset.tag: Tag 12345
dmi.board.name: Galago UltraPro
dmi.board.vendor: System76, Inc.
dmi.board.version: galu1
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: System76, Inc,
dmi.chassis.version: galu1
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr4.6.5:bd07/09/2013:svnSystem76,Inc.:pnGalagoUltraPro:pvrgalu1:rvnSystem76,Inc.:rnGalagoUltraPro:rvrgalu1:cvnSystem76,Inc,:ct9:cvrgalu1:
dmi.product.name: Galago UltraPro
dmi.product.version: galu1
dmi.sys.vendor: System76, Inc.

User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.1) Gecko/2008070206 Firefox/3.0.1

Using Firefox to create a PDF of a web page, all hyperlinks are lost. The same process in Safari results in all hyperlinks being retained in the saved PDF file.

Though it may relate to the PDF plug-in issue, I could not find specific reference to this in prior bug reports.

Reproducible: Always

Steps to Reproduce:
1.File > Print > PDF > Save as PDF.
2. View using Preview (default).
3. (Tried also viewing the same PDF files on a PC using Acrobat reader.)

Actual Results:
PDF file does not retain hyperlinks.

Expected Results:
PDF file should retain hyperlinks.

I can confirm this (that the hyperlinks are preserved in Safari but
not in Firefox 3.0.1 on OS X 10.5.4).

The same thing happens printing to a PDF file on Linux -- so this is
presumably a cross-platform problem.

The hyperlinks aren't preserved printing to PDF from FF2, so this
isn't a regression.

The hyperlinks aren't preserved printing to a PDF file in Opera, but
they are in another WebKit browser (Shiira). So there may be some
clues how to do this (preserve the hyperlinks) in WebKit source code.

*** Bug 456329 has been marked as a duplicate of this bug. ***

Colan Schwartz (colan) wrote :
Changed in thunderbird:
importance: Unknown → Medium
status: Unknown → New

*** Bug 772291 has been marked as a duplicate of this bug. ***

*** Bug 1252614 has been marked as a duplicate of this bug. ***

Changed in thunderbird:
status: New → Invalid
Colan Schwartz (colan) wrote :

The earlier upstream bug was marked as a duplicate. This is the new confirmed one.

Changed in thunderbird:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in thunderbird:
importance: Unknown → High
status: Unknown → Confirmed

*** Bug 519563 has been marked as a duplicate of this bug. ***

I argue that this is an enhancement request, not a bug. You can't hyperlink a bit of ink on a piece of paper, so it's not surprising that when an application renders a document for printing it doesn't put hyperlinks in it. Putting hyperlinks in a PDF file is thus outside the scope of printing, and something that we can choose to add as an enhancement.

On the other hand, if we had a specific feature to save a web page as a PDF (requested in bug 162659), then how this behaves would be another matter.

gf (gf-interlinks) wrote :

Hello Colan,
Thank you for submitting this bug and reporting a problem with Thunderbird. You made this bug report in 2016 and there have been several versions of Ubuntu and Thunderbird since then.

Could you confirm that this is no longer a problem and that we can close the ticket?
If it is still a problem, are you still interested in finding a solution to this bug?
If you are, could you run the following (only once):
apport-collect 1551949
and upload the updated logs and and any other logs that are relevant for this particular issue.

Thank you again for helping make Ubuntu and Thunderbird better.
G

Changed in thunderbird (Ubuntu):
status: New → Incomplete
Colan Schwartz (colan) wrote :

Resetting status as still not fixed upstream.

Changed in thunderbird (Ubuntu):
status: Incomplete → New
gf (gf-interlinks) wrote :

Thanks for the update, Colan.
Have a great day!
:)
G

Who says PDFs are printed on paper? Storing articles in PDF is standard proceedure for me and basic workflow. The fact that I use the macOS print dialog is just historical legacy in how "Save to PDF" has evolved in macOS. I really would love to see this. It's a bit painful having to switch browsers just to be able to have a PDF of an article where I do not loose all hyperlinks.

(In reply to steve-_- from comment #7)
> Who says PDFs are printed on paper?

Nobody.

Printing, as a concept, is putting ink onto paper or a similar medium. If a particular OS has PDF output built into its printing facility, or the computer has on it a printer driver for generating PDF files, then normally the content of the PDF generated thereby will be the same as the content of the paper document that the printing facility would ordinarily produce. Because printing isn't designed to do things that can't be done with ink on paper.

I'm not saying it wouldn't be useful (though it should be done by implementing bug 162659, so that the feature isn't exclusive to the macOS version), just that producing hyperlinked documents isn't what printing is designed to do. Hence my claim that this is an enhancement request.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed

Also reported by an Ubuntu user on Ubuntu Launchpad Tracker:
https://bugs.launchpad.net/ubuntu/+source/thunderbird/+bug/1551949
Thanks
G

Noticed that when saving as pdf on macOS via print dialog, links are intact when using Firefox 66.0b6. Has this bug been fixed?

(In reply to steve-_- from comment #10)

> Noticed that when saving as pdf on macOS via print dialog, links are intact when using Firefox 66.0b6. Has this bug been fixed?
Sorry, excuse the noise, it's just that URLs are clickable. But links behind text are still lost :(

Changed in thunderbird:
importance: High → Wishlist
Changed in thunderbird (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.