thunderbird 16 updates broke messaging menu integration

Bug #1065919 reported by Sebastien Bacher on 2012-10-12
180
This bug affects 39 people
Affects Status Importance Assigned to Milestone
thunderbird (Ubuntu)
High
Chris Coulson
Quantal
High
Chris Coulson

Bug Description

On current quantal the launcher counts and the messaging menu are not picking new email it seems...

Changed in thunderbird (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
Changed in thunderbird (Ubuntu Quantal):
milestone: none → quantal-updates
status: New → Triaged
Simplehuman (simplehuman) wrote :

The problem is actual for Gmail or maybe IMAP boxes. For POP3 boxes I have no problems at all. Except indicator not always getting blue, but I see new messages in it.

Simplehuman (simplehuman) wrote :

It seems now works correctly after update. With POP and IMAP boxes.

Karma Dorje (taaroa) wrote :

it seems that it's fixed.

Simplehuman (simplehuman) wrote :

I received a message to my Gmail box a moment ago, it is in indicator but it is not blue, so If I miss the notification - I will not know that there is a new mail.

JAlcala (jalcalav) wrote :

After upgrading to 12.10, indicator doesn't show new mails from thunderbird anymore.

DeadVirus (amfcosta13) wrote :

It's anoying to update to a 12.10 and see that Thunderbird is not working correctly with the messaging menu (along with Pidgin, but thats another story).

Tim Kubicz (tku) wrote :

It's quite a disappointment. Because of this bug (or lack of proper implementation) I am going to stay with 12.04.

Chris Coulson (chrisccoulson) wrote :

You know that there is already a fix in proposed, right?

Karma Dorje (taaroa) wrote :

No, this bug is not fixed completely. The old behavior was not restored and is not working correctly with the messaging menu. And, as noted above, we have a broken integration with pidgin.

Larry Williams (ltwilliams58) wrote :

Messaging works somewhat for me in that a new message in the Local folders/Inbox are counted and the Messaging icon shows unread status, however unread messages in inbox subfolders as well as those in RSS folders are not counted.

Tobia Tesan (tobia-tesan) wrote :

I just reported a new bug #1069704, but the symptoms are very similar, may be a duplicate.

This problem affect me as well since I upgrade from Ubuntu 12.04 to 12.10

No blue envelope when new mails arrive and no decount on Thunderbird icon in Unity panel.

Subin Hutton (djlynux) wrote :

I can hear sounds when new message receives. But no indication in the messaging menu (no unread email status and no color change). I'm using gmail configured as imap. It was working perfectly with 12.04 LTS. And also pidgin integration is also not working (I know it's abit out of topic. But just for your reference).

Micah Gersten (micahg) wrote :

See Bug #1070769 for a regression

tags: added: verification-failed

Add the "Quantal-proposed" repository fixed this problem for me.

Jonathan Chartrand,

You are right it fixes new version fixes this problem.

Tim Kubicz (tku) wrote :

For me, problem still exists. The message counter on launcher works great, but messaging menu do not turns blue, and suprisingly i have no libnotify notifications. Anyone has the same problem?

Simplehuman (simplehuman) wrote :

tku, I have this problem also

Cody Bennett (cbennett926) wrote :

Hello,

I am also not getting notifications of any kind other than sound with Thunderbird

Chris Coulson (chrisccoulson) wrote :

Bug 1070769 is nothing at all to do with this

tags: added: verification-done
removed: verification-failed
Cody Bennett (cbennett926) wrote :

Chris, on 12.10 should I still have both "Messaging Menu and Unity Launcher integration 1.0.1" and "Global Menu Bar integration 3.5.4" enabled at the same time?

Cody Bennett (cbennett926) wrote :

I don't know if it has been said but POP3 does use the counter and makes the notification blue

May be after "dancing with tambourine" you didn't solve the problem. I didn't do anything and after update from proposed repo i've solved this problem.

Subin Hutton (djlynux) wrote :

yeah right...Any idea, when this patch will be available in the stable release? If it's confirmed, I guess so soon :)

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 16.0.1+build1-0ubuntu2

---------------
thunderbird (16.0.1+build1-0ubuntu2) quantal-proposed; urgency=low

  * Update messagingmenu to 1.0.1
    - Fix LP: #1065919 - Messaging menu and Unity launcher integration doesn't
      work. Tell the message service that it's ok to download message headers
      if they aren't available locally
 -- Chris Coulson <email address hidden> Fri, 12 Oct 2012 16:17:05 +0100

Changed in thunderbird (Ubuntu Quantal):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunderbird - 17.0~b2+build1-0ubuntu1

---------------
thunderbird (17.0~b2+build1-0ubuntu1) raring; urgency=low

  * New upstream release from the beta channel (THUNDERBIRD_17_0b2_BUILD1)

  * Build with --disable-webrtc on all architectures except for i386 and amd64
    - update debian/config/mozconfig.in
 -- Chris Coulson <email address hidden> Mon, 05 Nov 2012 09:49:56 +0000

Changed in thunderbird (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers