Immediate crash on startup

Bug #1016818 reported by Roger Binns on 2012-06-23
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Mozilla Thunderbird
Confirmed
Critical
thunderbird (Ubuntu)
High
Canonical Desktop Team

Bug Description

Thunderbird received a version bump today. After Update Manager installed the new version, any attempts to launch Thunderbird result in an immediate crash. This happens even if I remove ~/.thunderbird

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: thunderbird 13.0.1+build1-0ubuntu0.12.04.1
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic x86_64
NonfreeKernelModules: nvidia
AddonCompatCheckDisabled: False
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 2.0.1-0ubuntu8
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: rogerb 2467 F.... pulseaudio
 /dev/snd/controlC0: rogerb 2467 F.... pulseaudio
 /dev/snd/pcmC0D0p: rogerb 2467 F...m pulseaudio
BuildID: 20120615181619
CRDA: Error: command ['iw', 'reg', 'get'] failed with exit code 1: nl80211 not found.
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xf3120000 irq 49'
   Mixer name : 'Realtek ALC889'
   Components : 'HDA:10ec0889,80860033,00100004'
   Controls : 51
   Simple ctrls : 24
Card1.Amixer.info:
 Card hw:1 'CinemaTM'/'Microsoft Microsoft® LifeCam Cinema(TM) at usb-0000:00:1d.0-1.7.2, high speed'
   Mixer name : 'USB Mixer'
   Components : 'USB045e:075d'
   Controls : 2
   Simple ctrls : 1
Card1.Amixer.values:
 Simple mixer control 'Mic',0
   Capabilities: cvolume cvolume-joined cswitch cswitch-joined penum
   Capture channels: Mono
   Limits: Capture 0 - 56
   Mono: Capture 47 [84%] [27.00dB] [on]
Channel: release
Date: Fri Jun 22 23:06:35 2012
Extensions: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
IpRoute:
 default via 192.168.1.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.1.0/24 dev eth0 proto kernel scope link src 192.168.1.53 metric 1
IwConfig:
 lo no wireless extensions.

 eth0 no wireless extensions.
Locales: extensions.sqlite corrupt or missing
PrefSources:
 /etc/thunderbird/syspref.js
 prefs.js
 user.js
Profiles: Profile0 (Default) - LastVersion=13.0.1/20120615181619
RfKill:

RunningIncompatibleAddons: False
SourcePackage: thunderbird
Themes: extensions.sqlite corrupt or missing
UpgradeStatus: Upgraded to precise on 2012-04-30 (54 days ago)
dmi.bios.date: 06/30/2011
dmi.bios.vendor: Intel Corp.
dmi.bios.version: KGIBX10J.86A.5936.2011.0630.2250
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: DP55WG
dmi.board.vendor: Intel Corporation
dmi.board.version: AAE57269-404
dmi.chassis.type: 2
dmi.modalias: dmi:bvnIntelCorp.:bvrKGIBX10J.86A.5936.2011.0630.2250:bd06/30/2011:svn:pn:pvr:rvnIntelCorporation:rnDP55WG:rvrAAE57269-404:cvn:ct2:cvr:
ftp_proxy: http://192.168.1.25:8080
http_proxy: http://192.168.1.25:8080

User Agent: Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.59 Safari/535.7

Steps to reproduce:

1. Installed thunderbird 7.x, 8.x from ubuntu oneiric repository, or 9.x from http://ppa.launchpad.net/mozillateam/thunderbird-next/ubuntu
2. started thunderbird from command line

Actual results:

nothing at console
crash report dialog at gui

disappeared at 8.0+build1-0ubuntu0

Still exists in 9.0~b5+build1-0ubuntu0.11.10.1~mtn1
Submitted crash Ids:
bp-ac2c6d7a-6073-431a-b749-bad682111207
bp-68fa26b3-32a6-4f03-993a-ba7092111223

both crashes are [@ arena_dalloc | ldap_x_free | ldap_set_lderrno ]

0 thunderbird-bin arena_dalloc jemalloc.c:4306
1 libldap60.so ldap_x_free open.c:892
2 libldap60.so ldap_set_lderrno error.c:262
3 libldap60.so ldap_set_option setoption.c:403
4 libnss_ldap-2.12.1.so libnss_ldap-2.12.1.so@0x3bc4
5 libnss_ldap-2.12.1.so libnss_ldap-2.12.1.so@0x5700
6 libnss_ldap-2.12.1.so libnss_ldap-2.12.1.so@0x6eed
7 libnss_ldap-2.12.1.so libnss_ldap-2.12.1.so@0x751f
8 libc-2.13.so libc-2.13.so@0x9a5b6
9 libc-2.13.so libc-2.13.so@0x13a068
10 libnss_ldap-2.12.1.so libnss_ldap-2.12.1.so@0x74af
11 libglib-2.0.so.0.3000.0 libglib-2.0.so.0.3000.0@0xf7ff3
12 libgtk-x11-2.0.so.0.2400.6 libgtk-x11-2.0.so.0.2400.6@0x39236c

Is there any workaround possible?

This bug was filed from the Socorro interface and is
report bp-407e5914-e576-4934-a618-0aa152120504 .
=============================================================
all crashes are version 12.0.1

0 libxul.so NS_ReadLine<char, nsIInputStream, nsCAutoString> nsReadLine.h:150
1 libxul.so MsgStreamMsgHeaders nsMsgUtils.cpp:2220
2 libxul.so nsMailboxService::StreamHeaders nsMailboxService.cpp:355
3 libxul.so libxul.so@0x100292b
4 libxul.so XPCWrappedNative::CallMethod XPCWrappedNative.cpp:2901
5 libxul.so XPC_WN_CallMethod XPCWrappedNativeJSOps.cpp:1542
6 libxul.so js::InvokeKernel jscntxtinlines.h:311
7 libxul.so js::Interpret jsinterp.cpp:2791
8 libxul.so js::InvokeKernel jsinterp.cpp:537
9 libxul.so js::Invoke jsinterp.h:157
10 libxul.so JS_CallFunctionValue jsapi.cpp:5449
11 libxul.so nsXPCWrappedJSClass::CallMethod XPCWrappedJSClass.cpp:1510
12 libxul.so nsXPCWrappedJS::CallMethod XPCWrappedJS.cpp:617
13 libxul.so PrepareAndDispatch xptcstubs_gcc_x86_unix.cpp:92
14 libxul.so nsMsgMailSession::OnItemAdded nsMsgMailSession.cpp:193
15 libxul.so nsMsgDBFolder::NotifyItemAdded nsMsgDBFolder.cpp:5004

selected comments
I've just renamed a local folder
I went offline, started compact all folders and have restarted afterwards.
I went offline, compacted all folders and have restarted afterwards - problem seems not to occure if i stay offline!?
I got to read an e-mail this time (last crash about 3 minutes ago). What's up with TB today?

(see if socorro picks up signature @ NS_ReadLine. doubtful)

A friend of mine (not computer expert) is seeing this on this Ubuntu 12.04 machine, too.

> I've just renamed a local folder

We did the same.

Could somebody please report this back to Ubuntu with high priority?

Roger Binns (ubuntu-rogerbinns) wrote :
Roger Binns (ubuntu-rogerbinns) wrote :

Attached is an strace of startup with a deleted ~/.thunderbird

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed
Flac (beuhlatex) wrote :

Hi,

This bug affects me in the same way. It has been reported to mozilla using the crash report utility.

Same kernel, but 32 bits, and ati graphic card (mobility X1400, Galliu R300 driver).

Micah Gersten (micahg) wrote :

Can we please get a crash ID from a crash submitted to Mozilla? Please see https://wiki.ubuntu.com/MozillaTeam/Bugs#Submitting_Crashes_to_Mozilla for more information.

Changed in thunderbird (Ubuntu):
status: Confirmed → Incomplete
Roger Binns (ubuntu-rogerbinns) wrote :

I submitted the crash numerous times to Mozilla. It didn't give me any feedback other than saying I could relaunch. In any event I did use apport to report the bug here and the doc you posted says "Note that the Apport hook provided from Firefox and Thunderbird 13 will automatically attach the ID's of crash reports you submitted to Mozilla, so you don't need to look for these manually as long as you submit the bug report using Apport!" That would appear not to work, nor do I have any idea if the mozilla submission opened anything, and if it did what the ids are.

Micah Gersten (micahg) wrote :

The crash reports are stored in your profile directory, so if you removed it before submitting this report, they would not show up.
They are in here: ~/.thunderbird/Crash\ Reports/submitted/
So, if you can submit another one and look in there for the ID, that would be great.

Roger Binns (ubuntu-rogerbinns) wrote :

Crash ID: bp-ce7dfec4-b140-4b3d-8cbc-ca5a72120623
Crash ID: bp-1ecdd5bf-c42f-49eb-9c54-0dfc82120622
Crash ID: bp-ec5f55d4-db94-4fa4-a17c-ce3d82120622
Crash ID: bp-012114a9-6ba4-41f1-a532-8a5042120622
Crash ID: bp-257ae38f-21d5-4eea-88e9-9c2862120622

Micah Gersten (micahg) on 2012-06-25
Changed in thunderbird (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunderbird (Ubuntu):
status: New → Confirmed

(In reply to Ben Bucksch (:BenB) from comment #5)
> Could somebody please report this back to Ubuntu with high priority?

Done: https://bugs.launchpad.net/thunderbird/+bug/1016818

Changed in thunderbird:
importance: Unknown → Critical
status: Unknown → Confirmed
Micah Gersten (micahg) wrote :

That upstream bug is a different crash.

no longer affects: thunderbird
Changed in thunderbird (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Micah Gersten (micahg) wrote :

Since we now have the crash IDs, I've gone ahead and marked this as triaged.

Chris Coulson (chrisccoulson) wrote :

The traces don't provide any clue about what happens at all

Hi folks,

I just submitted the following Crash IDs to mozilla:
Crash ID: bp-359bfbe2-9984-4b8a-8600-976962120702
Crash ID: bp-9ef87f9c-2203-4137-b026-ba4b02120702
Crash ID: bp-0d0d9ad5-48d2-465d-8592-d69dd2120702

MY infos:
DistroRelease: Ubuntu 12.04 LTS
Package: thunderbird 13.0.1+build1-0ubuntu0.12.04.1
Uname: 3.2.0-26-generic #41-Ubuntu SMP Thu Jun 14 17:49:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Add-ons: {f6090211-2004-44d8-9090-be3c2adfd66f}:0.7.4.2,<email address hidden>:0.9.3,<email address hidden>:0.3.9,<email address hidden>:1.2011n,{a62ef8ec-5fdc-40c2-873c-223b8a6925cc}:0.14pre,{e2fda1a4-762b-4020-b5ad-a41df1933103}:1.5.2,<email address hidden>:13.0.1,<email address hidden>:13.0.1,<email address hidden>:3.2.3,{972ce4c6-7e08-4474-a285-3208198ce6fd}:13.0.1
BuildID: 20120615181619
CrashTime: 1341734694
EMCheckCompatibility: true
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1341160157
Notes: OpenGL: Tungsten Graphics, Inc -- Mesa DRI Intel(R) Ironlake Mobile -- 2.1 Mesa 8.0.2 -- texture_from_pixmap

ProductID: {3550f703-e582-4d05-9a08-453d09bdfdc6}
ProductName: Thunderbird
ReleaseChannel: release
SecondsSinceLastCrash: 253
StartupTime: 1341734680
Theme: classic/1.0
Throttleable: 1
Vendor:
Version: 13.0.1

Sergio Benjamim (sergio-br2) wrote :

I downgrade to 11.0.1 and now it works, without crash. I hope there will be fix for this, since thunderbird will be discontinued.

Download full text (5.1 KiB)

Full backtrace from a debug build of todays mozilla-central/comm-central on Kubuntu 12.04 x86_64. Judging from the crash stats, it only happens on Ubuntu x86_64. It happens with the official Ubuntu packages as well as with the semi-official 64bit release builds from Mozilla. It does not, however, crash with the 32 bit release builds from Mozilla (I don't know about the i586 packages from Ubuntu).

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff5720ece in ldap_ld_free (ld=0x7ffff6cff730, serverctrls=0x0, clientctrls=0x0, close=1) at /home/username/src/comm-central/ldap/sdks/c-sdk/ldap/libraries/libldap/unbind.c:101
101 nextlr = lr->lr_next;
(gdb) bt
#0 0x00007ffff5720ece in ldap_ld_free (ld=0x7ffff6cff730, serverctrls=0x0, clientctrls=0x0, close=1) at /home/username/src/comm-central/ldap/sdks/c-sdk/ldap/libraries/libldap/unbind.c:101
#1 0x00007ffff5720d27 in ldap_unbind (ld=0x7ffff6cff730) at /home/username/src/comm-central/ldap/sdks/c-sdk/ldap/libraries/libldap/unbind.c:60
#2 0x00007fffe393a955 in do_close () at ldap-nss.c:722
#3 0x00007fffe393bb5b in do_open () at ldap-nss.c:1701
#4 do_with_reconnect (base=0x7fffe3b4bce6 "ou=Users,OU=TU,OU=IAM,DC=ads,DC=mwn,DC=de", scope=1, filter=0x7fffffffbec0 "(&(objectClass=user)(uid=username))", attrs=0x7fffe3b4cb60, sizelimit=1, private=0x7fffffffc340, search_func=0x7fffe393acc0 <do_search_s>)
    at ldap-nss.c:2624
#5 0x00007fffe393d192 in _nss_ldap_search_s (args=0x7fffffffc3b0, filterprot=0x7fffe3b4f1c0 "(&(objectClass=user)(uid=%s))", sel=<optimized out>, user_attrs=0x0, sizelimit=1, res=0x7fffffffc340) at ldap-nss.c:3142
#6 0x00007fffe393e819 in _nss_ldap_getbyname (args=0x7fffffffc3b0, result=0x7fffffffc460, buffer=0x7ffff6ce8800 "nx", buflen=1024, errnop=0x7ffff7fd66b0, filterprot=<optimized out>, sel=LM_PASSWD, parser=0x7fffe393ea40 <_nss_ldap_parse_pw>) at ldap-nss.c:3509
#7 0x00007fffe393edb7 in _nss_ldap_getpwnam_r (name=<optimized out>, result=<optimized out>, buffer=<optimized out>, buflen=<optimized out>, errnop=<optimized out>) at ldap-pwd.c:247
#8 0x00007ffff70bc9ad in __getpwnam_r (name=0x7fffffffee06 "username", resbuf=0x7fffffffc460, buffer=0x7ffff6ce8800 "nx", buflen=1024, result=0x7fffffffc498) at ../nss/getXXbyYY_r.c:256
#9 0x00007fffee700e33 in g_get_any_init_do () at /build/buildd/glib2.0-2.32.3/./glib/gutils.c:765
#10 0x00007fffee70191d in g_get_any_init () at /build/buildd/glib2.0-2.32.3/./glib/gutils.c:916
#11 g_get_any_init_locked () at /build/buildd/glib2.0-2.32.3/./glib/gutils.c:923
#12 g_get_user_name () at /build/buildd/glib2.0-2.32.3/./glib/gutils.c:941
#13 0x00007fffe83a1c4d in gnome_client_instance_init (client=0x7ffff6c2bc00) at gnome-client.c:1385
#14 0x00007fffee9b3957 in g_type_create_instance (type=<optimized out>) at /build/buildd/glib2.0-2.32.3/./gobject/gtype.c:1892
#15 0x00007fffee9980b9 in g_object_constructor (type=<optimized out>, n_construct_properties=0, construct_params=0x0) at /build/buildd/glib2.0-2.32.3/./gobject/gobject.c:1849
#16 0x00007fffee999c02 in g_object_newv (object_type=140737333264896, n_parameters=0, parameters=0x0) at /build/buildd/glib2.0-2.32.3/./gobject/gobject.c:1632
#17 0x00007f...

Read more...

Changed in thunderbird:
importance: Unknown → Critical
status: Unknown → Confirmed
Bill Wenz (wwenz) wrote :

I recently upgraded to the latest version and everything worked fine. Yesterday Thunderbird crashes on start-up. Could you tell me in VERY simple terms how to get my email up and running? Can I uninstall and reinstall and my all emails and address remain intact?

Thanks in advance

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.