ghost files remain after moving files

Bug #1768521 reported by slumbergod on 2018-05-02
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
thunar
Confirmed
Medium
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

An old bug still persisting in thunar.

Move files. Most disappear from the source window but frequently the last one remains as a ghost file. You have to manually refresh the view to remove it.

The window should refresh itself after the transaction is completed.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: thunar 1.6.15-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
Date: Wed May 2 07:33:25 2018
InstallationDate: Installed on 2018-04-27 (5 days ago)
InstallationMedia: Xubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

While 1.6.11 seems to have fixed the crashing issues, this bug is still present for me.

To replicate, move a bunch of files out of a directory.
The last one to be moved looks like it hasn't been moved because their is a ghost entry still present in the detail view.
Ctrl+R to refresh the view removes it but the reload should be triggered automatically.

Confirmed seeing this - in fact I moved a 'bunch' of files and all the moved files were apparently still in the source folder till reload

I have seen this using icon view. It is not consistently doing it though; sometimes it was fine, sometimes 1 or 2 files would remain visible. I guess it is a threading issue.

Actually, I forgot to add that I only use Detailed View and the bug is definitely present there.

Compact view ...

I've seen also where a file gets added to an already opened instance of thunar at the correct location - nothing is there until I reload.

Created attachment 7048
unrefreshed thunar

At the point when I stopped zsync Thunar should show these files:

zesty-desktop-amd64.iso
zesty-desktop-amd64.iso.zs-old
zesty-desktop-i386.iso
zesty-desktop-i386.iso.part

slumbergod (slumbergod) wrote :
slumbergod (slumbergod) wrote :

I decided to add the experimental PPA for Bionic 18.04 so I could see if this bug (and several others) has finally been resolved with Thunar 1.8.1

Unfortunately, it has not.

Selecting two or more files and moving them to another directory usually leaves a ghost file of one of them. A manual refresh is still required to remove the ghost file.

In , Ilya (ivkol) wrote :

still appears, XFCE 4.12

moving files. After moving in thunar source window shows one file that is still not moved. But actually it is moved and not exsist in source.
Compact list view.

still present in thunar 1.8.2.
It also happens when extracting an archive.
The archive might extract a folder, then rename it the temporary one and you end up with an incorrectly named folder requiring a refresh to see the renamed one.

Can reproduce the problem. Happens for all views, not only detailed view.

+

- create some empty files in some folder
- move them out of the folder (either by cut + paste, or via drag & drop. will be the same result )

Changed in thunar:
importance: Unknown → Medium
status: Unknown → Confirmed

I'm now using Thunar 1.82 in the Xubuntu test ppa. The bug is still present. In fact, it is worse if anything. There is ALWAYS a ghost file left after moving files.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.