Thunar doesn't correctly update display of selected files after muti-editing

Bug #1356183 reported by Dale on 2014-08-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Thunar File Manager
Fix Released
Medium
thunar (Ubuntu)
Undecided
Unassigned

Bug Description

When you select multiple files in Thunar and use the rename tool to change their name so that their position in the list would change (eg removing characters from the beginning, such as date or track number) then the files in the same position as those you have just edited (which have obviously moved in the list) look to be selected. Pressing F2 again and you in actuality still have the correct selection but the display is wrong. Pressing up/down to navigate through files takes the cursor to the displayed (incorrect) position though, not to one of those (the first) you selected.

This was working on my Ubuntu Studio 12.04 but seems broken since installing Ubuntu Studio 14.04 a few days ago.

$ lsb_release -rd
Description: Ubuntu 14.04.1 LTS
Release: 14.04

$ apt-cache policy thunar
thunar:
  Installed: 1.6.3-1ubuntu5
  Candidate: 1.6.3-1ubuntu5
  Version table:
 *** 1.6.3-1ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

Dale (dj-kaza) wrote :

Found two related bugs but neither mentions multi-edit and symptoms not exactly the same (eg one says the visible highlighted file changes correctly but it doesn't in my case with multiple files.)

https://bugs.launchpad.net/ubuntu/+source/thunar/+bug/1311926

https://bugs.launchpad.net/ubuntu/+source/thunar/+bug/1172529

Link to LP bug: https://bugs.launchpad.net/ubuntu/+source/thunar/+bug/1356183

When you select multiple files in Thunar and use the rename tool to change their name so that their position in the list would change (eg removing characters from the beginning, such as date or track number) then the files in the same position as those you have just edited (which have obviously moved in the list) look to be selected. Pressing F2 again and you in actuality still have the correct selection but the display is wrong. Pressing up/down to navigate through files takes the cursor to the displayed (incorrect) position though, not to one of those (the first) you selected.

This was working on my Ubuntu Studio 12.04 but seems broken since installing Ubuntu Studio 14.04 a few days ago.

$ lsb_release -rd
Description: Ubuntu 14.04.1 LTS
Release: 14.04

$ apt-cache policy thunar
thunar:
  Installed: 1.6.3-1ubuntu5
  Candidate: 1.6.3-1ubuntu5
  Version table:
 *** 1.6.3-1ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

Changed in thunar (Ubuntu):
status: New → Confirmed
Malena Vasquez (malevasquez) wrote :

The bug has been confirmed and linked upstream for further review :)

Changed in thunar:
importance: Unknown → Medium
status: Unknown → Confirmed

I have the same issue on Thunar 1.6.10 on Manjaro (2016-02-10), though this doesn't happen every time.

Steps to reproduce:
- in tests folder, create folders or files names "a", "b" and "d"
- rename folder "a" to "c"
- pressing F2 to rename does select the newly renamed "c" folder
- pressing Enter to enter the folder sometimes opens the "b" folder instead of the "c" folder

This can also happen even if the renamed folder/file does not change position.
For instance, starting again from folder "a", "b" and "d", after renaming "b" folder to "c", pressing Enter sometimes opens the "a" folder instead of the "c" folder.

Small update. I tried to reproduce this on my Xubuntu workstation, and i did, but with a slight difference.

On Manjaro, after the rename, the folder shown as selected is the one i expect to (the one just renamed), even if i enter a different one with the Enter key.

On Xubuntu 15.10 (Thunar 1.6.10), after the rename, the folder shown as selected is different. Using my previous examples:
- in the first example, after renaming "a" to "c", the folder "b" is selected
- in the second example, after renaming "b" to "c", the folder "a" is selected
This matches Malena's case.

I'm also giving the themes used in case there's a link to the difference, though i don't expect to:
- Shiki-Human-Classic (from shiki-colors-revival [1]) on Manjaro
- Ambiance-Blackout-Flat-Blue-Spring (from ambiance-blackout-flat-colors [2]) on Xubuntu

[1] https://github.com/somasis/shiki-colors-revival
[2] http://www.ravefinity.com/p/download-ambiance-blackout-flat-colors.html

Changed in thunar:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.