"Open with 'default app'" in right click context menu with wrong icon

Bug #1271861 reported by Sergio Benjamim on 2014-01-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
thunar
Fix Released
Medium
thunar (Ubuntu)
Low
Jackson Doak

Bug Description

The icon of the default application (first application) in right click menu is wrong, with a generic folder icon in the place. Take a look at the picture.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: thunar 1.6.3-1ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-5.20-generic 3.13.0
Uname: Linux 3.13.0-5-generic x86_64
ApportVersion: 2.13.1-0ubuntu1
Architecture: amd64
Date: Thu Jan 23 11:35:11 2014
InstallationDate: Installed on 2014-01-09 (13 days ago)
InstallationMedia: Xubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140109)
ProcEnviron:
 LANGUAGE=fr_FR
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Sergio Benjamim (sergio-br2) wrote :
Sergio Benjamim (sergio-br2) wrote :
Sergio Benjamim (sergio-br2) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1271861

tags: added: package-qa-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1271861

tags: added: iso-testing

Created attachment 5335
right click menu issue

The icon of the default application (first application) in right click menu is wrong, with a generic folder icon in the place. Take a look at the picture. There are more in https://bugs.launchpad.net/ubuntu/+source/thunar/+bug/1271861

Sergio Benjamim (sergio-br2) wrote :

I reported this in the upstream: https://bugzilla.xfce.org/show_bug.cgi?id=10652

Changed in thunar (Ubuntu):
importance: Undecided → Low
Simon Steinbeiß (ochosi) wrote :

I'm wondering whether that isn't a design decision, but we'll see what responds we get from upstream.

This patch resolves the problem and additionally assigns icons to the "open in new tab/window" menu entries.

The changes can be tested by installing thunar from my Testing PPA.

https://launchpad.net/~thad-fisch/+archive/test

Elfy (elfy) wrote :

Works here for me with that testin gthunar

The attachment "menu-icon-tweaks.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch

- Add menu icons to "Open in New Tab/Window" (pathbar)
- Add menu icon to "Create Folder..."

- Remove menu icons from "Open in New Tab/Window"
- Add menu icon to "Create Document"
- Assign generic file icon to "Empty File"

Martin Pitt (pitti) on 2014-04-09
Changed in thunar (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.6.3-1ubuntu5

---------------
thunar (1.6.3-1ubuntu5) trusty; urgency=medium

  * Add git-save-keyboard-shortcuts.patch. LP: #1186846
    - Keyboard shortcuts save when changed rather than when thunar is closed
  * Add menu-icon-tweaks.patch. LP: #1271861
    - Don't use generic folder icons for open with default application
    - Add icons for open in new tab, new window
  * Add git-force-toolbr-icons.patch
    - Fix for "Home" and "Open Parent" icons going missing from toolbar
 -- Jackson Doak <email address hidden> Sat, 05 Apr 2014 08:22:40 +1100

Changed in thunar (Ubuntu):
status: Fix Committed → Fix Released
Pasi Lallinaho (knome) on 2014-04-14
Changed in thunar (Ubuntu):
assignee: nobody → Jackson Doak (noskcaj)

Created attachment 5812
menu-icon-tweaks.patch

This patch resolves the issue (show application icon instead of generic folder icon) and tweaks some other menu icons on top of that (New Tab/Window, Create Folder/Document and Empty File).

Tested and applied by default in Xubuntu 14.04 and 14.10.

Changed in thunar:
importance: Unknown → Medium
status: Unknown → Confirmed

Could someone please make sure this patch is pushed?

Thanks!

Closing the report then. Thanks!

Changed in thunar:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.