Ubuntu

Duplicate partitions shown

Reported by Elfy on 2012-08-21
146
This bug affects 30 people
Affects Status Importance Assigned to Milestone
thunar (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned
Raring
Medium
Unassigned

Bug Description

[Impact]
* Duplicate partitions shown in thunar side pane.

[Test case]
* Open a Thunar window.
* Partitions are repeated twice in the side pane (either shortcut view or tree view).
* Install thunar from -proposed
* Restart your session and repeat the steps above.
* The partitions should only appear once now.

[Regression Potential]
* Missing partitions, crash on mount/umount.

Duplicate partitions shown in thunar shortcut pane.

Screenshot attached

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: thunar 1.4.0-1ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-10.10-generic 3.5.1
Uname: Linux 3.5.0-10-generic x86_64
ApportVersion: 2.4-0ubuntu8
Architecture: amd64
Date: Tue Aug 21 06:55:40 2012
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120714)
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: thunar
UpgradeStatus: No upgrade log present (probably fresh install)

Elfy (elfy) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
ReonToerien (rztrzt) wrote :

According to user mc4man here http://ubuntuforums.org/showpost.php?p=12219640&postcount=5 this bug might be related to the newer gvfs 1.13.7* in Quantal.

"I'm using gnome/nautilus but have pcmanfm installed for root browsing where the duped icons are seen in the sidebar with the current gvfs source. A relatively quick test shows that downgrading to the 1.13.3 source packages removes the duped icons. The whole process is a bit of a pita but it could be narrowed down by trying the package sets between there & current - there are 7 in total"

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1039375

tags: added: iso-testing
ReonToerien (rztrzt) wrote :

http://ubuntuforums.org/showpost.php?p=12219784&postcount=7

"As it turns out the very next release of gvfs produces the duped icons - gvfs_1.13.4-0ubuntu1

It is a 'new upstream' release so nothing too visible in the change log.
Could turn out that the various Fm dev's will have to adjust or maybe something in gvfs though it doesn't occur in nautilus (not unexpected

Edit: worth noting that the bug Elfy files was on 08/21 which certainly predates the upgrade to 1.13.4 on 09/02 so thunar may have other issues than seen here with pcmanfm

Re-edit
While installing/running thunar on my install can't totally reflect a Xubuntu install, (thunar seems confused as to my theme, ect. & running it in gnome) see single sidebar items with 1.13.3 & doubled with 1.13.4
This is with the current udisks2 packages"

Elfy (elfy) wrote :

Not sure if this will help - but I appear to have in /media/hob old occurences of other times I have mounted those drives - some of these don't actually even exist

screenshot attached

ReonToerien (rztrzt) wrote :

"Not sure if this will help - but I appear to have in /media/hob old occurences of other times I have mounted those drives - some of these don't actually even exist"

It's the same here for me.

Paulo Narciso (p-narciso) wrote :

Nothing have changed. The duplicated partitions are still there.

Elfy (elfy) wrote :

@p-narciso - did you Me Too it?

As it stands I can see 12.10 being released like this.

Elfy (elfy) wrote :

Same.

Musarraf (musarraf172) wrote :

A temporary work arround :

Go to desktop setting (in xfe desktop)
Then click on icon tab and uncheck removable media .

This will temporarily solve the duplicate icon for internel storage..

But you will lose the desktop icon for external or removeable media

Pjotr12345 (computertip) wrote :

Weird thing is, no such problem in openSUSE 12.2 with the Xfce desktop. Although openSUSE 12.2 has Xfce 4.10 as well. So it's probably not a pure Xfce 4.10 problem.

Changed in thunar (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Lionel Le Folgoc (mrpouit)
Lionel Le Folgoc (mrpouit) wrote :

I opened a similar bug for xfdesktop4 since it's affected as well: Bug #1072137 (please subscribe to it if possible, it will need several testers to pass the SRU verification too).

Here's a proposed patch to fix the issue. I'll upload the fixed package to quantal-proposed in a few days once I've checked that my patch doesn't break things badly.

Changed in thunar (Ubuntu Raring):
status: In Progress → Triaged
Changed in thunar (Ubuntu Quantal):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Lionel Le Folgoc (mrpouit)
Changed in thunar (Ubuntu Raring):
assignee: Lionel Le Folgoc (mrpouit) → nobody
tags: added: patch
tags: added: fixed-in-master
removed: patch
tags: added: patch
Igor Tarasov (tarasov-igor) wrote :

Added pcmanfm package, since it is also affected.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pcmanfm (Ubuntu Quantal):
status: New → Confirmed
Changed in pcmanfm (Ubuntu):
status: New → Confirmed
Lionel Le Folgoc (mrpouit) wrote :

For pcmanfm, see Bug #1057022.

no longer affects: pcmanfm (Ubuntu)
no longer affects: pcmanfm (Ubuntu Quantal)
no longer affects: pcmanfm (Ubuntu Raring)
description: updated
description: updated
Lionel Le Folgoc (mrpouit) wrote :

Uploaded to quantal-proposed, waiting for approval.

Changed in thunar (Ubuntu Quantal):
status: In Progress → Triaged
assignee: Lionel Le Folgoc (mrpouit) → nobody
Lionel Le Folgoc (mrpouit) wrote :

Uploaded to raring as well (with a great revision number) now that it's open.

Changed in thunar (Ubuntu Raring):
status: Triaged → Fix Released
Joshua O'Leary (jmoleary) wrote :

WORKAROUND: Create this script and add it to 'Session and Startup'>'Startup Applications' under XFCE:

#!/bin/bash
xfconf-query -c xfce4-desktop -p /desktop-icons/style -s 1
xfconf-query -c xfce4-desktop -p /desktop-icons/style -s 2

Thanks to 'Ani' for spotting this: http://askubuntu.com/questions/207296/after-upgrade-to-xubuntu-12-10-i-have-2-mount-points-for-each-partition

Lionel Le Folgoc (mrpouit) wrote :

@ubuntu-sru: please don't approve yet, there's a fix in gvfs git, so I'll check if it's ok and prepare a gvfs SRU instead, it should fix the issue with all affected file managers (thunar, pcmanfm, etc.).

(cf. http://git.gnome.org/browse/gvfs/commit/?id=ca7743a63721c3dd1c166006539e356412466dcc and https://bugzilla.gnome.org/show_bug.cgi?id=687525 for info)

Changed in thunar (Ubuntu Quantal):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Triaged → Incomplete

Hello Elfy, or anyone else affected,

Accepted thunar into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/thunar/1.4.0-1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in thunar (Ubuntu Quantal):
status: Incomplete → Fix Committed
tags: added: verification-needed
Elfy (elfy) wrote :

Looks ok here.

tags: added: verification-done
removed: verification-needed
Lionel Le Folgoc (mrpouit) wrote :

Thanks for testing! (since the thunar package was accepted and works fine, I won't bother fixing gvfs as I don't have time, so please disregard my previous comment).

Changed in thunar (Ubuntu Quantal):
assignee: Lionel Le Folgoc (mrpouit) → nobody
Kiasta (dlgadmin) wrote :

If the proposed thunar package did not fix the issue with me. I've rebooted and it's still showing 2 icons on the desktop and I have opened a terminal proving I've installed the proposed package with a screenshot attached.

Elfy (elfy) wrote :

This bug is for the duplicated partitions in Thunar.

The desktop showing 2 is a seperate bug - https://bugs.launchpad.net/ubuntu/+source/xfdesktop4/+bug/1072137

Fix hasn't been released yet for that.

Kiasta (dlgadmin) wrote :

My apologies, I was directed to this post by a moderator on the forums. I assumed this was the correct place.

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.4.0-1ubuntu2.1

---------------
thunar (1.4.0-1ubuntu2.1) quantal-proposed; urgency=low

  * debian/patches:
    - xubuntu_fix-duplicate-volumes.patch: fix duplicate volumes appearing
      randomly in the side pane. lp: #1039375
 -- Lionel Le Folgoc <email address hidden> Sun, 28 Oct 2012 21:32:12 +0100

Changed in thunar (Ubuntu Quantal):
status: Fix Committed → Fix Released
Srinivas Murthy (smurthygr) wrote :

This is still present in PCMan FM used in Xubuntu 12.10, AMD64 by me. Screenshot attached. (I do not know if this is the right place to report - sorry).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.