Duplicate partitions shown

Bug #1072137 reported by Lionel Le Folgoc on 2012-10-27
96
This bug affects 16 people
Affects Status Importance Assigned to Milestone
xfdesktop4 (Ubuntu)
Medium
Unassigned
Quantal
Medium
Unassigned
Raring
Medium
Unassigned

Bug Description

[Impact]
* Duplicate partitions shown on the desktop.

[Test case]
* Open your Xfce/Xubuntu session.
* Partitions are repeated twice on the desktop (two icons for each).
* Install xfdesktop4 from -proposed
* Restart your session and repeat the steps above.
* There should be only one icon per partition now.

[Regression Potential]
* Missing partitions.

Xfdesktop equivalent of Bug #1039375.

Changed in xfdesktop4 (Ubuntu):
status: New → Triaged
status: Triaged → In Progress
importance: Undecided → Medium
assignee: nobody → Lionel Le Folgoc (mrpouit)
Lionel Le Folgoc (mrpouit) wrote :

Here's a proposed patch to fix the issue. I'll upload the fixed package to quantal-proposed in a few days once I've checked that my patch doesn't break things badly.

Changed in xfdesktop4 (Ubuntu Quantal):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Lionel Le Folgoc (mrpouit)
Changed in xfdesktop4 (Ubuntu Raring):
assignee: Lionel Le Folgoc (mrpouit) → nobody
status: In Progress → Triaged
tags: added: patch
description: updated
Lionel Le Folgoc (mrpouit) wrote :

Uploaded to quantal-proposed, waiting for approval.

Changed in xfdesktop4 (Ubuntu Quantal):
status: In Progress → Triaged
assignee: Lionel Le Folgoc (mrpouit) → nobody

On Sun, October 28, 2012 1:39 pm, Lionel Le Folgoc wrote:
> ** Description changed:
>
> + [Impact]
> + * Duplicate partitions shown on the desktop.
> +
> + [Test case]
> + * Open your Xfce/Xubuntu session.
> + * Partitions are repeated twice on the desktop (two icons for each).
> + * Install xfdesktop4 from -proposed
> + * Restart your session and repeat the steps above.
> + * There should be only one icon per partition now.
> +
> + [Regression Potential]
> + * Missing partitions.

Changed setup to have proposed, lots of packages there, but no xfce
packages at all, xfdesktop4 is not there to try. (running 12.10)

--
Len Ovens
www.OvenWerks.net

Lionel Le Folgoc (mrpouit) wrote :

Yes, it hasn't been accepted yet, a request for testing will be posted here once it's available in -proposed.

Lionel Le Folgoc (mrpouit) wrote :

Uploaded to raring as well (with a great revision number) now that it's open for development.

Changed in xfdesktop4 (Ubuntu Raring):
status: Triaged → Fix Released
Lionel Le Folgoc (mrpouit) wrote :

On hold for now, cf. the thunar bug for rationale.

Changed in xfdesktop4 (Ubuntu Quantal):
assignee: nobody → Lionel Le Folgoc (mrpouit)
status: Triaged → Incomplete
Clint Byrum (clint-fewbar) wrote :

Lionel, do you want us to accept or reject xfdesktop4 v4.10.0-1ubuntu1.1 which is in the quantal-proposed queue? Please clarify "on hold". Thanks!

Lionel Le Folgoc (mrpouit) wrote :

Since the thunar package was accepted, forget about my last comment, feel free to accept this one as well, thanks.

Changed in xfdesktop4 (Ubuntu Quantal):
status: Incomplete → Triaged
assignee: Lionel Le Folgoc (mrpouit) → nobody

Hello Lionel, or anyone else affected,

Accepted xfdesktop4 into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/xfdesktop4/4.10.0-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in xfdesktop4 (Ubuntu Quantal):
status: Triaged → Fix Committed
tags: added: verification-needed
Elfy (elfy) wrote :

Looks OK to me.

tags: added: verification-done
removed: verification-needed
Nikolay Morozov (nmorozov) wrote :

proposal looks Ok in quantal i386

Nikolay Morozov (nmorozov) wrote :

intalled proposal updates to quantal amd64, looks good for me

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfdesktop4 - 4.10.0-1ubuntu1.1

---------------
xfdesktop4 (4.10.0-1ubuntu1.1) quantal-proposed; urgency=low

  * debian/patches:
    - xubuntu_fix-duplicate-volumes.patch: fix duplicate volumes appearing
      randomly on the desktop. lp: #1072137
 -- Lionel Le Folgoc <email address hidden> Sun, 28 Oct 2012 21:41:57 +0100

Changed in xfdesktop4 (Ubuntu Quantal):
status: Fix Committed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1072137

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Related blueprints