thunar crashed with SIGSEGV in thunar_g_vfs_is_uri_scheme_supported()

Bug #1032340 reported by col reilly
120
This bug affects 16 people
Affects Status Importance Assigned to Milestone
thunar (Ubuntu)
High
Unassigned

Bug Description

thunar was taking ages to load...as usual...samba mounts are to blame.
when it had finished opening i right clicked an image file to open in gimp.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: thunar 1.4.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-7.7-generic 3.5.0
Uname: Linux 3.5.0-7-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Thu Aug 2 20:24:42 2012
ExecutablePath: /usr/bin/thunar
InstallationMedia: Xubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120620)
ProcCmdline: /usr/bin/Thunar file:///run/media/username/8AF0-5200
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f04d48ac3b2: mov 0x0(%rbp,%rdx,8),%rdi
 PC (0x7f04d48ac3b2) ok
 source "0x0(%rbp,%rdx,8)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: thunar
StacktraceTop:
 ?? ()
 ?? ()
 g_type_create_instance () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_newv () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: thunar crashed with SIGSEGV in g_type_create_instance()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Revision history for this message
col reilly (lupinehorror) wrote :
visibility: private → public
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 thunar_g_vfs_is_uri_scheme_supported (scheme=scheme@entry=0x7f04d48fa7b2 "trash") at thunar-gio-extensions.c:252
 thunar_shortcuts_model_init (model=0x7f04d582a780) at thunar-shortcuts-model.c:256
 g_type_create_instance (type=<optimized out>) at /build/buildd/glib2.0-2.33.6/./gobject/gtype.c:1890
 g_object_constructor (type=<optimized out>, n_construct_properties=0, construct_params=0x0) at /build/buildd/glib2.0-2.33.6/./gobject/gobject.c:1854
 g_object_newv (object_type=object_type@entry=139658737395840, n_parameters=n_parameters@entry=0, parameters=parameters@entry=0x0) at /build/buildd/glib2.0-2.33.6/./gobject/gobject.c:1637

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in thunar (Ubuntu):
importance: Undecided → Medium
summary: - thunar crashed with SIGSEGV in g_type_create_instance()
+ thunar crashed with SIGSEGV in thunar_g_vfs_is_uri_scheme_supported()
tags: removed: need-amd64-retrace
Revision history for this message
col reilly (lupinehorror) wrote :

happened again, today, when i inserted a usb key.

Greg Faith (gregfaith)
tags: added: iso-testing
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in thunar (Ubuntu):
status: New → Confirmed
Revision history for this message
Greg Faith (gregfaith) wrote :

This bug is still on 20120804 current daily xubuntu desktop amd64 iso

Revision history for this message
Elfy (elfy) wrote :

apport saw a bug on mine as duplicate of this - I am also getting partitions duplicating in the panel - screenshot attached

Revision history for this message
col reilly (lupinehorror) wrote :

i'm also getting drives duplicated on the desktop and in the panel.

Revision history for this message
col reilly (lupinehorror) wrote :

double clicked a cf card mount on my desktop.

Revision history for this message
col reilly (lupinehorror) wrote :

this now happens ever time i try to open a drive or folder from the desktop. every time. things still are able to be viewed after a 15 second delay but that's not great. duplicates are still showing too. see screenshot.

Revision history for this message
Erich.Gindl (erich-gindl) wrote :

update:
crash was due to rhythmbox - after restart the music was added, but trying to change volume the "hand" pointer over the volume bar does not let you change anything, music plays on but the mouse pointer wont reappear

Revision history for this message
col reilly (lupinehorror) wrote :

i have never used rythmbox...so it shouldn't be an issue on my system. exaile all the way for me :)

Revision history for this message
Elfy (elfy) wrote :

Drives no longer duplicating here.

Revision history for this message
col reilly (lupinehorror) wrote :

still happening here. all updates installed as of about 30 minutes ago. see attachment.

Revision history for this message
col reilly (lupinehorror) wrote :

and is still happening...

Revision history for this message
Elfy (elfy) wrote :

Not sure here.

Commonish pattern here is

gparted run - EVERY unmounted partion getrs mounted

fiddle unmounting things and do the partition deed

some work others get an odd libparted bug report

Other times

get double entries for drives - then unmount one and it's dupe unmounts - do deed with gparted then refresh - one get's a refresh

thunar reports ONE drive

close it - then you'll get two

Not sure whther to run ubuntu-bug against libparted/thunar/gparted/fdisk

some direction of wher the bug is expected to REALLY be would be of enormous help here

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

That's similar to #1032303.

g_vfs_get_supported_uri_schemes() returns NULL and Thunar doesn't guard against that.

Changed in thunar (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thunar - 1.4.0-1ubuntu2

---------------
thunar (1.4.0-1ubuntu2) quantal; urgency=low

  * debian/patches:
    - 02_guard-for-no-supported-vfs-schemas.patch: fix segfault when
      g_vfs_get_supported_uri_schemes() returns NULL. lp: #1032340
 -- Lionel Le Folgoc <email address hidden> Sat, 18 Aug 2012 14:39:38 +0200

Changed in thunar (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
col reilly (lupinehorror) wrote :

hasn't been fixed for me. just did a full update and drives are still being duplicated on the desktop and in thunar.
as Elfy said 'close it - then you'll get two' this happens for me too...always two at first...then sometimes one after opening thunar again. then two.
think i'll be switching to another desktop environment.

Revision history for this message
Lionel Le Folgoc (mrpouit) wrote :

"thunar crashed with SIGSEGV in thunar_g_vfs_is_uri_scheme_supported()" This is the title of this bug report. And there's a nice stacktrace. Therefore this bug is about a crash in Thunar, which should be fixed by the latest upload already.

It is not about duplicated partitions or whatever (and the upload won't fix that) => please create a new bug report, this is a different issue, thanks. :) This is a pain to handle otherwise (when it's a crash report, I usually only look at the stacktrace, so if you mix up with other issues, I won't see them).

Revision history for this message
Elfy (elfy) wrote :
Revision history for this message
col reilly (lupinehorror) wrote :

@Lionel Le Folgoc fair enough! you're right, of course, the crash isn't happening any more. thanks. will check out the other bug as suggested by @Elfy.

To post a comment you must log in.