Comment 27 for bug 58498

Jim Van Zandt (jrvz) wrote :

I suggest this patch (adapted from the texmacs-user mailing list):

When texmacs starts a maxima session, it checks the version for
compatibility. maxima is being released more often. Version 1.0.6 of
texmacs only recognizes maxima up to 5.14, but works with maxima 5.16.
These changes allow any version up to 5.18.

--- /tmp/prev/tm_maxima 2008-11-05 10:17:37.000000000 -0500
+++ /usr/lib/texmacs/TeXmacs/bin/tm_maxima 2008-11-05 09:47:41.000000000 -0500
@@ -17,7 +17,7 @@
   5.9.1) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.9.1.lisp";;
   5.9.1.1* | 5.9.2* | 5.9.3*) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.9.2.lisp";;
   5.10.*) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.10.0.lisp";;
- 5.11.* | 5.12.* | 5.13.* | 5.14.*) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.11.0.lisp";;
+ 5.11.* | 5.12.* | 5.13.* | 5.14.* | 5.15.* | 5.16.* | 5.17.* | 5.18.*) exec maxima -u $1 -l $2 -p "$TEXMACS_MAXIMA_PATH/texmacs-maxima-5.11.0.lisp";;
   cygwin)
     exec maxima.bat -p "`echo $TEXMACS_MAXIMA_PATH/texmacs-maxima-5.11.0.lisp|cygpath --windows -f -`";;
   *) echo -e "\2latex:\\red Unsupported version of maxima: $1\5"
--- /tmp/prev/maxima_detect 2008-11-05 10:17:37.000000000 -0500
+++ /usr/lib/texmacs/TeXmacs/bin/maxima_detect 2008-11-05 09:47:41.000000000 -0500
@@ -63,7 +63,11 @@
 version 5.11
 version 5.12
 version 5.13
-version 5.14" >/dev/null
+version 5.14
+version 5.15
+version 5.16
+version 5.17
+version 5.18" >/dev/null
         then
           # 5.9.1 or 5.9.2 or 5.9.3 or 5.10 or 5.11 or 5.12 or 5.13 or 5.14
           maxima -d | grep -F 'maxima-htmldir=' | sed -e \