uninstallable in Dapper (and eventually Hardy and future LTSes)

Bug #384904 reported by Kees Cook on 2009-06-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
The Dell Mini Project
Undecided
Unassigned
tetex-base (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Unassigned
Hardy
Undecided
Unassigned
Karmic
Undecided
Unassigned
texlive-base (Debian)
Fix Released
Unknown
texlive-base (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Unassigned
Hardy
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

Binary package hint: tetex-bin

tetex-bin is no longer installable on Dapper due to built-in timebomb.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
! You are attempting to make a LaTeX format from a source file
! That is more than five years old.
!
! If you enter <return> to scroll past this message then the format
! will be built, but please consider obtaining newer source files
! before continuing to build LaTeX.
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

! LaTeX source files more than 5 years old!.
l.540 ...aTeX source files more than 5 years old!}

This will be a problem for Hardy at some point too.

Changed in texlive-base (Debian):
status: Unknown → New
Kees Cook (kees) on 2009-06-08
Changed in tetex-bin (Ubuntu Dapper):
status: New → Invalid
Changed in tetex-base (Ubuntu Hardy):
status: New → Invalid
Changed in tetex-base (Ubuntu):
status: New → Invalid
summary: - uninstallable in Dapper (and eventually Hardy)
+ uninstallable in Dapper (and eventually Hardy and future LTSes)
Changed in tetex-bin (Ubuntu):
milestone: none → ubuntu-9.10-beta
affects: tetex-bin (Ubuntu) → texlive-base (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package texlive-base - 2007.dfsg.2-4ubuntu1

---------------
texlive-base (2007.dfsg.2-4ubuntu1) karmic; urgency=low

  * Add debian/patches/fix-installation-timebomb: fix the detection of
    5-year-old-source from error to a warning so that tetex-bin remains
    installable (LP: #384904).

 -- Kees Cook <email address hidden> Mon, 08 Jun 2009 12:30:48 -0700

Changed in texlive-base (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package texlive-base - 2007-13ubuntu0.1

---------------
texlive-base (2007-13ubuntu0.1) hardy-security; urgency=low

  * Add debian/patches/fix-installation-timebomb: fix the detection of
    5-year-old-source from error to a warning so that tetex-bin remains
    installable (LP: #384904).

 -- Kees Cook <email address hidden> Mon, 08 Jun 2009 12:04:45 -0700

Changed in texlive-base (Ubuntu Hardy):
status: New → Fix Released
Kees Cook (kees) on 2009-06-08
Changed in tetex-base (Ubuntu Dapper):
status: New → Fix Released
Nicola Ferralis (feranick) wrote :

Added Dell-mini project, since it uses a custom version of hardy in a separate repository from generic hardy. Given dell-mini-hardy is going to last for a while, this bug is significantly important.

Changed in dell-mini:
status: New → Confirmed
Changed in texlive-base (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.