Empathy will not connect to Gtalk after a resume from suspend

Bug #993880 reported by marcw on 2012-05-03
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Telepathy Mission Control 5
Fix Released
Medium
telepathy-mission-control-5 (Ubuntu)
Low
Unassigned

Bug Description

Empathy will not connect to Gtalk after a resume from suspend. I've waited several minutes after resuming and it just sits there. The only way to get it to reconnect is to either restart Empathy or force a manual reconnection with Edit -> Accounts -> toggle the Gtalk connection.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: empathy 3.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
Date: Thu May 3 05:31:48 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: empathy
UpgradeStatus: No upgrade log present (probably fresh install)

marcw (marcw) wrote :
Bilal Shahid (s9iper1) wrote :

thanks for the bug report
please attach the mission control log file with the bug report
you can get it from help debug menu.

Changed in empathy (Ubuntu):
status: New → Incomplete
marcw (marcw) wrote :

Comments about the attached log file:
18:39 - Started a fresh instance of Empathy. Connected to Gtalk as expected.
~18:40 - Suspended machine.
18:47 - Successfully resume machine. Empathy's state was Offline but trying to connect.
18:49 - Still trying to connect. Manually changed Empathy's state to Available.
18:55 - Still trying to connect. Manually changed the Gtalk account to Off, then On. Immediately connected successfully.

Bilal Shahid (s9iper1) wrote :

thanks you can send it to upstream now

marcw (marcw) wrote :

Sorry, I have no idea what that's supposed to mean.

Bilal Shahid (s9iper1) wrote :

i am sending your bug to upstream you please subscribe to that one bug,

Changed in empathy (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Low
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Changed in empathy:
status: New → Unknown

Created attachment 61720
debug log

Empathy will not connect to Gtalk after a resume from suspend. I've waited several minutes after resuming and it just sits there. The only way to get it to reconnect is to either restart Empathy or force a manual reconnection with Edit -> Accounts -> toggle the Gtalk connection.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: empathy 3.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic-pae 3.2.14
Uname: Linux 3.2.0-24-generic-pae i686
NonfreeKernelModules: nvidia

affects: empathy (Ubuntu) → telepathy-mission-control-5 (Ubuntu)
affects: empathy → mission-control-5
Changed in mission-control-5:
importance: Medium → Unknown
Changed in mission-control-5:
importance: Unknown → Medium
status: Unknown → Confirmed

I can confirm the same behaviour in my machine running Fedora 17 x86_64, Empathy 3.4.2.3 and telepathy-gabble version 0.16.1.
Normally it is fixed by simply quitting Empathy and re-opening it, but sometimes I actually need to manually kill the "telepathy-gabble" process to make it reconnect again!

And this was caused by a later update, I think - the stock, un-updated Fedora 17 didn't have this issue!

Same problem here with empathy 3.4 on ubuntu 12.04

MC correctly detects sleep...

> mcd-DEBUG: 05/10/2012 18:39:45.823941: notify_sleep_cb: about to sleep! sleep_kind=suspend
>mcd-DEBUG: 05/10/2012 18:39:45.824153: on_transport_status_changed: Transport i love the internet changed status to 2 (disconnected)

but before it resumes, it thinks you're connected/awake and so tries to reconnect...

> mcd-DEBUG: 05/10/2012 18:39:45.849291: _mcd_master_account_replace_transport: Checking gabble/jabber/marcjw53_40gmail_2ecom0 [0 conditions, 1 plugins]
> mcd-DEBUG: 05/10/2012 18:39:45.849417: mcd_kludge_transport_get_transport_status: we are allegedly online

then when it does resume, it thinks it's already trying to connect, and won't try again...

> mcd-DEBUG: 05/10/2012 18:47:11.653021: notify_resume_cb: woke up! sleep_kind=suspend
> mcd-DEBUG: 05/10/2012 18:47:11.676938: connectivity_monitor_nm_state_change_cb: New NetworkManager network state 20 (connected: false)
> mcd-DEBUG: 05/10/2012 18:47:11.693018: connectivity_monitor_nm_state_change_cb: New NetworkManager network state 40 (connected: false)
> mcd-DEBUG: 05/10/2012 18:47:13.124289: connectivity_monitor_nm_state_change_cb: New NetworkManager network state 70 (connected: true)
> mcd-DEBUG: 05/10/2012 18:47:13.124494: on_transport_status_changed: Transport i love the internet changed status to 0 (connected)
> mcd-DEBUG: 05/10/2012 18:47:13.124624: mcd_master_transport_connected: i love the internet
> mcd-DEBUG: 05/10/2012 18:47:13.124772: mcd_account_would_like_to_connect: gabble/jabber/marcjw53_40gmail_2ecom0 already connecting/connected

Guillaume appears to have fixed this in commit a5fb89b, which was in Mission Control versions 5.12.2 and 5.13.1.

I have the same problem/behavior on 5.16.1 (Debian testing/jessie). After resuming from hibernate I have to kill the process to make it to work.

Changed in mission-control-5:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.