Telepathy indicator shows my own nick name in chat notifications, not the one of the peer

Bug #926072 reported by Frederik Elwert on 2012-02-03
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Telepathy Indicator
Medium
Ken VanDine
telepathy-indicator (Ubuntu)
Medium
Ken VanDine

Bug Description

Chat and IM notifications in the messaging menu currently behave somewhat strange: When I receive a notification because there was some activity in a non-focused chat window, the entry in the menu (below “Chat”) will show my own nick name. Instead, I would expect that

a) in IM conversations, the name of the peer is shown, and
b) in chat conversations, the name of the room is shown, or—if my name has been mentioned by someone—the name of the one who mentioned me.

Anyway, the current behavior just seems misleading.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: telepathy-indicator 0.1.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-12.20-generic 3.2.2
Uname: Linux 3.2.0-12-generic i686
ApportVersion: 1.91-0ubuntu1
Architecture: i386
Date: Fri Feb 3 14:56:12 2012
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110803.1)
SourcePackage: telepathy-indicator
UpgradeStatus: Upgraded to precise on 2012-01-22 (11 days ago)

Bilal Shahid (s9iper1) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
 Please answer these questions:

* Is this reproducible now ?
* attach the screenshot ?

Changed in telepathy-indicator (Ubuntu):
status: New → Incomplete

I could only test it with IM now, since I did not know who to bother with pinging me in IRC. With IM, it seems to work now, the name of the peer is shown in the messaging menu.

Okay, I now was able to test it:

What works:
* With IM, the name of the peer is shown.
* With Chat (IRC), the name of the peer is shown when someone mentions my name.

What is still broken:
* With Chat (IRC), when a notifications is triggered by someone saying something without mentioning my name, my nickname is displayed. I would expect the name of the channel do be displayed in the indicator.

Changed in telepathy-indicator (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
assignee: nobody → Ken VanDine (ken-vandine)
Changed in telepathy-indicator:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ken VanDine (ken-vandine)
Changed in telepathy-indicator:
status: Confirmed → In Progress
Changed in telepathy-indicator:
milestone: none → 0.2.1
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telepathy-indicator - 0.2.1-0ubuntu1

---------------
telepathy-indicator (0.2.1-0ubuntu1) precise; urgency=low

  * New upstream release
    - Bugs fixed:
      * shows my own nick name in chat notifications, not the one of the
        peer (LP: #926072)
      * Use IndicateInterests to determine if there are listeners, this will
        prevent crashers if telepathy-indicator gets run in gnome-shell or
        other environments without a messaging indicator (LP: #947590)
      * Only autostart in Unity and GNOME classic
      * SIGSEGV in g_file_get_path() (LP: #910785)
      * crashed with signal 5 in g_simple_async_result_complete() (LP: #925829)
      * SIGSEGV in handle_contacts_pending_add_indicator_cb() (LP: #929002)
 -- Ken VanDine <email address hidden> Thu, 22 Mar 2012 11:06:05 -0400

Changed in telepathy-indicator (Ubuntu):
status: Confirmed → Fix Released
Changed in telepathy-indicator:
status: Fix Committed → Triaged
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers