Ubuntu

Messaging indicator doesn't go blue if chat window is open

Reported by Dimitri John Ledkov on 2011-09-06
336
This bug affects 59 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Undecided
Unassigned
Telepathy Indicator
High
Unassigned
telepathy-indicator (Ubuntu)
High
Unassigned

Bug Description

Case 1:
1) no chat windows are open.
2) Contact John messages me, I get a bubble and a blue icon

Case 2:
1) chat window with John is open and in front
2) John messages me, I get no bubble, no blue icon

Case 3:
1) chat window with john is open and behind other windows
2) John messages me, I get a bubble, no blue icon

Case 4:
1) chat window with John is minimised
2) John messages me, I get a bubble, no blue icon.

I'm expecting blue icon in Case 3 and Case 4.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: indicator-messages 0.4.95-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic x86_64
Architecture: amd64
Date: Tue Sep 6 09:11:11 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
SourcePackage: indicator-messages
UpgradeStatus: Upgraded to oneiric on 2011-08-27 (9 days ago)

Dimitri John Ledkov (xnox) wrote :
Omer Akram (om26er) on 2011-09-06
Changed in telepathy-indicator:
status: New → Confirmed
Changed in telepathy-indicator (Ubuntu):
status: New → Confirmed
Changed in indicator-messages (Ubuntu):
status: New → Confirmed
Luca Ferretti (elle.uca) wrote :

For the reference, you can use jabber Collabora test account (<email address hidden>) to check this stuff instead annoying John :)

(Type !help in chat window with gabble.echo to have a list of supported commands)

Ken VanDine (ken-vandine) wrote :

This is a feature regression, which did not make it in time for 11.10. It will be added back in 12.04.

Changed in telepathy-indicator:
milestone: none → 1.0
Changed in indicator-messages (Ubuntu):
status: Confirmed → Invalid
Changed in telepathy-indicator:
importance: Undecided → High
assignee: nobody → Ken VanDine (ken-vandine)
Pax Unix (paxunix) wrote :

Really? A feature that significant gets dumped for 6 more months?

What needs to happen in order to get it in an update well before then?

Is there a suitable workaround?

Is there an alternative Empathy replacement that will do the same or similar?

Narcissus (narcissus) wrote :

I get this too. On a fresh 11.10 install, the indicator icon never turns blue, except when new mail arrives in Thunderbird. It's impossible to know if you have unread messages in empathy if you missed the notification bubble. Any workaround/fix yet ?

FYI, Pidgin behaves as should be expected.

Paul Kishimoto (khaeru) wrote :

Combined with bug #778256 (notify bubbles offscreen in some dual-monitor configurations) I get *no* notification of messages aside from the brief pop-out-and-wiggle of the Empathy icon in the launcher.

Even if that bug were fixed, I agree that this is a serious regression, and I hope any fix made before 12.04 can be backported.

DavidW617 (davidw617) wrote :

I agree that this bug fix has to be backported to Oneiric. Empathy is pretty useless as a chat application if it doesn't even notify when there are unread messages.

... especially consideing that other (actually better than Empathy, like gajim) chat applications don't properly work in Oneiric due to obliteration of notification area. :-\

Id2ndR (id2ndr) wrote :

I get some strange results today. I described these on https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/873946/comments/2 . I'm wondering the links with this bug repport if there are some (dbus messages, or things like that).

Jeanfrancoissven (s-beddeleem) wrote :

Is nobody able to solve this problem?
It's getting pretty annoying after a month!

Luke Hoersten (lukehoersten) wrote :

Agreed this is a big productivity problem. At work I'm expected to respond to IMs but with this bug, I don't know I received any.

jaynis (kranz-jannis) wrote :

Same problem here. If the chat window is already open i wont get a blue mail icon.

 If the empathy developers wont fix this soon, maybe one can write a empathy plugin which does the job?

Omer Akram (om26er) on 2011-11-21
Changed in telepathy-indicator (Ubuntu):
importance: Undecided → High
milestone: none → ubuntu-12.04
assignee: nobody → Ken VanDine (ken-vandine)
no longer affects: indicator-messages (Ubuntu)
Grafosecondo (alafauci) wrote :

+1

I really miss the small blue triangle on the top left too :( It was great to have a so effective and unobtrusive notification! Bring the triangle back please.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telepathy-indicator - 0.1.1-0ubuntu1

---------------
telepathy-indicator (0.1.1-0ubuntu1) precise; urgency=low

  * New upstream release.
    - Add indicators for new messages in existing chats (LP: #842428)
  * debian/control
    - bump build depends on libunity-dev to >= 5.0.0
 -- Ken VanDine <email address hidden> Fri, 13 Jan 2012 09:04:14 +0100

Changed in telepathy-indicator (Ubuntu):
status: Confirmed → Fix Released
Changed in telepathy-indicator:
status: Confirmed → Fix Released
Changed in hundredpapercuts:
status: New → Fix Released
Changed in telepathy-indicator:
assignee: Ken VanDine (ken-vandine) → nobody
Changed in telepathy-indicator (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Mark Baas (mark-baas123) wrote :

Here is a backport for oneiric compiled for amd64. Package depends on libunity-dev > 5.0, but compiles fine when changing this to libunity-dev > 4.0. So for the ones on i386, download the source package (apt-get source telepathy-indicator), edit debian/control file and change the 5.0 to 4.0, save the file, run debuild -us -uc and finally sudo debi, off you go.

Raj Saini (rajsaini) wrote :

This bug still exists in 13.10 and it is very annoying. Please let me know if you need any information from me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers