Ubuntu

When attempting to install lamp-server, returns "aptitude failed (100)"

Reported by Lasse Havelund on 2007-08-08
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
tasksel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: tasksel

Having looked at installing an Apache/MySQL/PHP solution on the Ubuntu wiki, I launched tasksel and selected "lamp-server", then hit enter---tasksel exits with the following error message:

tasksel: aptitude failed (100)

The package "lamp-server" cannot be found in the repositories, either upon manual inspection.

Colin Watson (cjwatson) wrote :

It's not a package, it's a task, and it does seem to exist in the archive. Hmm.

Colin Watson (cjwatson) wrote :

What release of Ubuntu are you using?

Changed in tasksel:
assignee: nobody → kamion
status: New → Incomplete
Lasse Havelund (lhavelund) wrote :

7.10; Gutsy. This was with an (almost fresh) Tribe 3.

Mike Irwin (michaelirwin) wrote :

I just tried the same thing per the instructions on the community site for installing the ApachePHPMySQL package and got exactly the same problem. I'm using Ubuntu 7.04 that I downloaded this afternoon, and installed on a VMWare 5.01 system on a single-cpu AMD 3400+ machine.

Nick Barcet (nijaba) wrote :

Have you tried invoking tasksel with sudo ? Error 100 in aptitute makes me think tasksel does not have enough priviledges.

Dimitri Torterat (diti) wrote :

Hi,

I got the same message with `sudo tasksel` on Ubuntu Gutsy 7.10.

James Dupin (james.dupin) wrote :

I have something similar (tasksel: aptitude failed 100) for some tasks while not the same for the end.

fresh install of ubuntu 8.04
2.6.24-18-generic

To reproduce any time on my machine

sudo tasksel
choose DNS, hit ok, this works, bind is installed

sudo tasksel
choose audio suite (or video suite or 2D3D suite)
hit ok
then the window shows "installing packages for 2 seconds then exits and back to the terminal command prompt with
tasksel: aptitude failed (100)

the tasks in /usr/share/tasksel/ubuntu-tasks.desc looks ok to me (but I am no expert).

Both following commands are ok and it would install everything apparently.
apt-get -s install ubuntustudio-audio
aptitude -s install ubuntustudio-audio

Anything to do with the fact that it has to install 2.6.24-18-rt? (wild guess)

brenton (brentonboy) wrote :

I got this same error as well in 8.04.1 (64bit) Hardy Heron with sudo.

However, on a whim I ran the exact same line of code again, and it worked... !

RoFranco (rofranco) wrote :

Hi all,

I had the same error message after cancelling the installation process of LAMP task. The system prompted me a suggestion to run the following command (as super user):

sudo dpkg --configure -a

And that finalized the pending installation and solved the problem.

I hope that it works for you also.

Rodolfo

ஆமாச்சு (amachu) wrote :

I installed Jaunty today morning and while trying to install LAMP stack the same error occurred.

infro (me-infro) wrote :

Hi,

same as James Dupin wrote on 2008-06-05.
Ubuntu 8.04; 2.6.24-24-generic.

JuanHoyos (elhoyos) wrote :

For me the problem was solved after making a $ sudo apt-get update

The error arised when trying to do a LAMP installation and I think the cause is an outdated packages metainfo.

I'm using Hardy x86 from an official Canonical AMI for Amazon EC2, labeled as ami-5d59be34

Steve Riddett (tmb-steve) wrote :

Thanks JuanHoyos,

Followed your advice and ran

sudo apt-get update

that solved the problem for me too.

Running Jaunty x86.

ethical (ranjan-nhce) wrote :

i use hardy.the same problem occoured to me when i had stopped the tasksel in the middle.
then to solve it..i did this
do a ps-e|grep apt-get if u r using apt-get
kill the process using

kill pid
for this u need to be sudo
then run sudo tasksel works perfectly

I'm using Karmic Koala. Same problem, but fixed after updating.

Alison Rowland (alisonrowland) wrote :

I just experienced this on Karmic Koala. I took ethical's suggestion to find other running package managers and found Synaptic was running in the background (not sure yet why):

user@localhost:~$ ps aux | grep apt
root 4828 0.0 1.7 55604 36860 ? Ss 16:40 0:07 /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 75497475 --set-selections-file /tmp/tmp2zmvKD

A quick 'sudo killall synaptic' solved the problem. It would be nice if the error message emitted by tasksel/aptitude in this case were more specific than 'aptitude failed (100)'. apt-get tells the user if another instance is running.

celien (celien1sthlm) wrote :

[quote]

Hi all,

I had the same error message after cancelling the installation process of LAMP task. The system prompted me a suggestion to run the following command (as super user):

sudo dpkg --configure -a

And that finalized the pending installation and solved the problem.

I hope that it works for you also.

Rodolfo
[/quote]
that did the trick for me in 10.04

Joseph Cota (j-cota2003) wrote :

I also keep getting

tasksel: aptitude failed (100)

I am using sudo and have appropriate privileges

I have attempted using 'sudo apt-get update' before using tasksel.

Synaptic, and Aptitude are not running and I am up-to-date on all packages.

tags: added: iso-testing
Dana Mahan (dm262010) wrote :

I tried this and it worked:

Problems Encountered And Their Solution

If while downloading the packages, tasksel unexpectedly exits with an error – tasksel: aptitude failed (100), do not despair. It is because the package database of your Ubuntu installation is old. Doing a sudo apt-get update will resolve the error and tasksel will be able to continue where it left off.

Ref: http://linuxandfriends.com/2009/12/09/how-to-install-lamp-server-in-ubuntu-linux/.

patpat (masottaus) wrote :

the above comment is not always true...
8.04 custom install defining new tasks for tasksel, tasksel works ok but when invoke "apt-get install" this one is unable to find the requested task for its installation... the tasks are perfectly defined on /usr/share/tasksel/ubuntu-tasks.desc but they never get to apt-get cache even after a apt-get update, a manual apt-get install xxx_task^ will also fail...

question... when apt-get populates its cache; does ever read /usr/share/tasksel/ubuntu-tasks.desc ???

Rebirth (zeiki) wrote :

I am having this same problem on 10.04 LTS. I tried "sudo apt-get update" and then "sudo tasksel install lamp-server".
It returns "tasksel: aptitude failed (100)".

Robin Burnell (robin-burnell) wrote :

I had that problem too, I don't know what exactly I did to fix it so I'll just put it all here.
First to become a root, and also so I did not need to enter my password with each line I ran:
   sudo -i
Then I removed the lamp packages with:
  dpkg --configure -a
  apt-get --purge remove apache2

Robin Burnell (robin-burnell) wrote :

Sorry but it only posted a small part of what I did here is the rest:
  apt-get remove apache2-mpm-prefork apache2-utils apache2.2-common libapache2-mod-php5 libapr1 libaprutil1 libdbd-mysql-perl libdbi-perl libnet-daemon-perl libplrpc-perl libpq5 mysql-client-5.0 mysql-common mysql-server mysql-server-5.0 php5-common php5-mysql
  apt-get autoremove
I also removed firestarter and reinstalled it again afterwards.
  apt-get remove firestarter
With thuar (nautilus for gnome) I removed left over folders in /etc/. More specifically /etc/, /etc/apache2, /etc/php5, /etc/mysql and /etc/phpmyadmin.
I checked that all the hostnames were the same since that had given me problems before with mousepad (gnome gedit). These files were /etc/hosts, /etc/hostname/ and /etc/dhclient.conf.
After a restart. Under sudo -i again I ran:
  apt-get update
  tasksel
Installed the lamp server option.
Reinstalled firestarter
  apt-get remove firestarter
Restarted the computer and it was up and running.

ProRunner (mrprorunner) wrote :

I've had the same problem with daily Maverick after running "sudo tasksel install lamp-server": "tasksel: aptitude failed (100)".

I tried to follow above instruction and run "sudo apt-get update".
The last line of response was:
"E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem."

Finally "sudo dpkg --configure -a" solved the problem.

PKirkham (pete-kirkham) wrote :

I had the same problem because the text at the beginning of tasksel is far from clear:
I originally selected LAMP but deselected Ubuntu Netbook desktop because I thought tasksel would try to install what I already had. This resulted in the apt 100 error.

However if you leave selected the distribution in which you want tasksel to get the packets the error dissappears.

Pete

Aman Sharma (aman.sharma0091) wrote :

I also had the same problem on ubuntu maverick meerkat
but it resolved after sudo apt-get update
thanks guys!

Mauri Latvala (mjlatva2) wrote :

Problem occured allso when I tried to install "Large selection of fonts"(ubuntustudio-font-meta
) from tasksel
Ubuntu 10.04.1 LTS
 2.6.32-27-generic
x86_64

I tried to update:
sudo apt-get update
sudo aptitude update && sudo aptitude -y safe-upgrade
(no errors)
But it didn't resolve the case.

I allso tried to find broken packages with no luck
sudo aptitude -f install
(everything ok)

Located the package from: cat /usr/share/tasksel/ubuntu-tasks.desc
"
Task: ubuntustudio-font-meta
Section: user
Description: Large selection of font packages
 Large selection of font packages
Key:
 ubuntustudio-font-meta
Packages: task-fields
"
http://packages.ubuntu.com/lucid/ubuntustudio-font-meta

aptitude inteface shows that ubuntustudio-font-meta is listed on
Metapackages -> universe -> ubuntustudio-font-meta
Direct installation from metapackage works normally, so it seems that problem relates directly to tasksel.

Colin Watson (cjwatson) on 2011-01-20
Changed in tasksel (Ubuntu):
assignee: Colin Watson (cjwatson) → nobody
Moses Moore (moses-mozai) wrote :

Had this problem pop up -- I ran 'apt-get update; tasksel install lamp-server' so I know it wasn't a stale apt cache.
"aptitude failed (100)" is frustratingly opaque, I had no idea what avenue to follow. I wish it reported WHICH aptitude command was used when the failure was thrown.

Following the hints in this bug report, I tried: 'dpkg ---configure -a' and got a more helpful error:
root@equius:/etc/cron.daily# dpkg --configure -a
Setting up apache2.2-common (2.2.14-5ubuntu8.4) ...
dpkg: unrecoverable fatal error, aborting:
 fork failed: Cannot allocate memory

That was weird -- I have 158MB free on this machine. No swap -- it's a Virtual Private Server. I had to shut down the mysqld to free up enough RAM for the configuration script to do it's work. So weird that the pre-inst.sh/post-inst.sh script would use more RAM than the daemon itself when it's running.

Joseph Cota (j-cota2003) wrote :

I have gotten it to work.

first install tasksel

sudo apt-get update
sudo apt-get install tasksel
sudo tasksel

Troy Scott (redbrick2011) wrote :

I received this error after creating a new instance of a ubuntu (Lucid) amd64 image for amazon web services. The server was a base install and I wanted to set it up as a LAMP server. I initially ran:

sudo tasksel

I selected the LAMP option and then OK. The process started running for about 1 to 2 seconds and then the tasksel application closed with this error: aptitude failed (100)

sudo apt-get update fixed the problem.

Thanks!

Sreejith (sreejithhere) wrote :

Doing sudo apt-get update as JuanHoyos said, solved the problem for me too. Thank you all

Launchpad Janitor (janitor) wrote :

[Expired for tasksel (Ubuntu) because there has been no activity for 60 days.]

Changed in tasksel (Ubuntu):
status: Incomplete → Expired
bindian0509 (bindian0509) wrote :

sudo apt-get update

then

sudo tasksel

its done

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers