Comment 127 for bug 1252121

Pablo180 (paultait22) wrote :

Philip, I also tried the Live CD version of 14.04 and discovered the same as you did that it did not suffer from this problem. However I remember some years ago trying the Live CD of a newly released version of Ubuntu and discovered that Suspend and Hibernate worked flawlessly, only to install the same version and discover that they didn’t work at all once Ubuntu was installed. So I don’t trust the Live version enough to attempt a complete re-install, probably only to discover that the problem is still present!

I have upgraded to 14.04 and as others have stated, the problem persists. It seems less frequent, but I think that part of that is that it seems to happen more when it has been suspended for a while, and I have only tested it by repeatedly closing and opening the lid today.

Justin, I looked at your workaround but that folder is empty for me, so I cannot try it.

Yanpas, I tried setting the password again on resume in 14.04, but with the same result as before, it didn’t work for me for Suspend.

I’ve given up to be honest. This will probably be fixed upstream in a year or two. I’ve been using Ubuntu for ten years and can count on one hand the number of bugs I’ve seen fixed. Typically I find a workaround, forget all about and years later realise the problem has gone away.

I am now using a workaround found here: http://ubuntuforums.org/showthread.php?t=1522146

This restarts NetworkManager on every resume. It is not ideal, but it works and is not dependent on anything else and won’t be overridden by an update. Problem solved.