lightdm_get_can_restart returns false in Ubuntu Saucy

Bug #1226509 reported by Simon Steinbeiß on 2013-09-17
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned

Bug Description

In lightdm-gtk-greeter we use the call "lightdm_get_can_restart" to check whether lightdm supports restarting and it works up to Raring, but the same call fails in Raring.

As there was a switch to logind in Saucy, I suspect that this might have something to do with this call not having been ported to support logind (could be something else entirely though).

The restart menu entry is present after booting the system, but disappears after first logout.

Simon Steinbeiß (ochosi) wrote :

Checking /usr/share/polkit-1/actions/org.freedesktop.login1.policy it's easy to see that poweroff has different a different policy than reboot.

<action id="org.freedesktop.login1.power-off-multiple-sessions">
<allow_active>yes</allow_active>

<action id="org.freedesktop.login1.reboot-multiple-sessions">
<allow_active>auth_admin_keep</allow_active>

So the question is, how should lightdm-gtk-greeter react to the "challenge" value it receives now (instead of "yes")?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed

Fix committed upstream:

http://cgit.freedesktop.org/systemd/systemd/commit/?id=299404a19f26aa4f203042d8285ee0b7afa5bf40

"logind: if a user is sitting in front of the computer and can shutdown the machine anyway he should also be able to reboot it"

Marc Deslauriers (mdeslaur) wrote :
Simon Steinbeiß (ochosi) wrote :

Just wanted to say that the fix came through the proposed channel and it works! Thanks a lot!

tags: added: patch
Martin Pitt (pitti) on 2013-09-27
Changed in systemd (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 204-0ubuntu13

---------------
systemd (204-0ubuntu13) saucy; urgency=low

  * debian/patches/0028-fix-reboot-polkit-permissions.patch: make
    reboot-multiple-sessions polkit permissions consistent with
    power-off-multiple-sessions in
    src/login/org.freedesktop.login1.policy.in. (LP: #1226509)
 -- Marc Deslauriers <email address hidden> Thu, 26 Sep 2013 14:49:51 -0400

Changed in systemd (Ubuntu):
status: Fix Committed → Fix Released
no longer affects: lightdm
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers