Samsung ML-1740: "gdi" driver is used by default and not SpliX

Bug #793741 reported by Zooko Wilcox-O'Hearn on 2011-06-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: splix

Dear Ubuntu folks:

Thank you for packaging all this good software for Ubuntu!

My Samsung ML-1740 isn't working very well with my new Natty computer. Inspecting the configuration, I see that it is using the GDI driver which is reputed to be problematic on openprinting.org. The splix driver is recommended instead. I've always had excellent performance from using the splix driver with this printer in the past. So, for starters the default configuration of Ubuntu should probably be changed to use the Splix driver for this printer.

But in any case, I can't seem to find the Splix driver PPD within Ubuntu. The "splix" package is installed, but there are no PPD files in /usr/share/ppd/splix, nor any PPD files that I can find for ML-1740 or with the word "splix" anywhere in their name.

I know that in previous distributions of Ubuntu the "splix" package came with all the PPDs, then in later versions they came compressed, and then in the most recent version the source code comes with the package and the PPDs are supposed to be generated at install time. Maybe there is a bug in that process? That would explain the apparent absence of the needed PPD files here.

Thanks!

Till Kamppeter (till-kamppeter) wrote :

The PPD files are there, but in one compressed archive, /usr/lib/cups/driver/splix. You see the PPD files if you let CUPS list them via the command

lpinfo -m

Run

lpinfo -m | grep 1740

in a terminal window and you see all possibilities for your printer.

When I run system-config-printer (I do not have any Samsung printer) and enter the URI "x:" under "Enter URI" I get into the step of manually choosing make and model. There I choose "Samsung" and "ML-1740". The SpliX driver appears there, but indeed the "gdi" driver is marked recommended. This wrong assignment is done by a prioritarization in system-config-printer, it seems to have gotten messed up on the recent change of handling driver priorities.

Moving the bug to system-config-printer ...

affects: splix (Ubuntu) → system-config-printer (Ubuntu)
Changed in system-config-printer (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
summary: - splix PPD files not generated on install?
+ Samsung ML-1740: "gdi" driver is used by default and not SpliX
Changed in system-config-printer (Ubuntu):
status: Confirmed → Triaged
Zooko Wilcox-O'Hearn (zooko) wrote :

When I go through this process I do *not* see the splix driver in the system-config-printer GUI tool.

1. sudo apt-get install splix

2. zompu:~$ lpinfo -m | grep 1740
foomatic-db-compressed-ppds:0/Samsung-ML-1740-gdi.ppd Samsung ML-1740 Foomatic/gdi
splix:0/samsung/ml1740.ppd Samsung ML-1740, 2.0.0
splix:0/samsung/ml1740fr.ppd Samsung ML-1740, 2.0.0
splix:0/samsung/ml1740pt.ppd Samsung ML-1740, 2.0.0

3. unplug the USB cable so that system-config-printer won't autodetect my printer

4. $ system-config-printer

4. enter "x:" in the URI

5. Choose "Samsung" and "ML-1740".

Now I observe that ...

Oh, this one here named "Samsung ML-1740, 2.0.0 [en]" must be the splix driver. My mistake was thinking that one was just a variant of the GDI driver.

Till Kamppeter (till-kamppeter) wrote :

The problem is indeed a wrong prioritarization of SpliX. SpliX is assumed a non-free third-party driver which is not the case. It is released under a free license and therefore we ship it in main. SpliX should have a higher priority, as it is the best support for Samsung printers, it should be preferred against "Foomatic/gdi" (the other SmartGDI driver) and against PCL drivers (Samsung printers are better in Samsung's language than in PCL). In addition, the regexp to identify a PPD entry as a SpliX entry was wrong. The attached patch fixes this.

tags: added: patch
Changed in system-config-printer (Ubuntu):
status: Triaged → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-config-printer - 1.3.3+20110602-0ubuntu2

---------------
system-config-printer (1.3.3+20110602-0ubuntu2) oneiric; urgency=low

  * debian/patches/20_priority-for-splix.patch: Raised the priority of the
    SpliX driver for Samsung laser printers, so that it is used as the default
    driver for these printers, and not "Foomatic/gdi" any more (LP: #793741).
 -- Till Kamppeter <email address hidden> Tue, 07 Jun 2011 14:16:41 +0200

Changed in system-config-printer (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers