system-config-printer.py crashed with AttributeError in on_printer_removed(): 'NoneType' object has no attribute 'name'

Bug #741987 reported by mkis62 on 2011-03-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: system-config-printer

printer not responding
tried to reinstall drivers for HP LaserJet P1005 and got this message
currently only from 'windoze' works...

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: system-config-printer-gnome 1.3.1+20110222-0ubuntu10
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Date: Thu Mar 24 21:05:16 2011
ExecutablePath: /usr/share/system-config-printer/system-config-printer.py
InterpreterPath: /usr/bin/python2.7
Lpstat: device for HP_LaserJet_P1005: hp:/usb/HP_LaserJet_P1005?serial=BC0D7D4
MachineType: Acer TravelMate 2410
Papersize: letter
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
PpdFiles: HP_LaserJet_P1005: HP LaserJet p1005, hpcups 3.11.1, requires proprietary plugin
ProcCmdline: /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=263aecd1-0156-49f9-8d5e-99e8079b240f ro gfxpayload=true quiet splash vt.handoff=7
PythonArgs: ['/usr/share/system-config-printer/system-config-printer.py']
SourcePackage: system-config-printer
Title: system-config-printer.py crashed with AttributeError in on_printer_removed(): 'NoneType' object has no attribute 'name'
Traceback:
 Traceback (most recent call last):
   File "/usr/share/system-config-printer/printerproperties.py", line 1789, in on_printer_removed
     if self.printer.name == printer:
 AttributeError: 'NoneType' object has no attribute 'name'
UpgradeStatus: Upgraded to natty on 2011-01-03 (80 days ago)
UserGroups: adm admin audio cdrom dialout dip lpadmin netdev plugdev sambashare
dmi.bios.date: 02/07/2006
dmi.bios.vendor: Phoenix Technologies LTD
dmi.bios.version: V1.09
dmi.board.name: Morar
dmi.board.vendor: Acer
dmi.board.version: Rev
dmi.chassis.asset.tag: None
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenixTechnologiesLTD:bvrV1.09:bd02/07/2006:svnAcer:pnTravelMate2410:pvr0100:rvnAcer:rnMorar:rvrRev:cvnAcer:ct10:cvrN/A:
dmi.product.name: TravelMate 2410
dmi.product.version: 0100
dmi.sys.vendor: Acer

mkis62 (mihaikx62) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #741449, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
visibility: private → public
Tim Waugh (twaugh) wrote :

Should be fixed in 9f7d8f0.

Till Kamppeter (till-kamppeter) wrote :

Pathc tested and works, thsnk you, Tim.

Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package system-config-printer - 1.3.3+20110602-0ubuntu1

---------------
system-config-printer (1.3.3+20110602-0ubuntu1) oneiric; urgency=low

  * New upstream release
     o GIT 1.3.x snapshot from 2 June 2011
     o State of 1.3.3 release
     o Main application
        - Set translation domain for ServerSettingsDialog (LP: #777188).
        - scp-dbus-service: Ignore setlocale() errors (LP: #748964).
        - Allow % character in SMB URI (LP: #747400).
        - More error handling (LP: #744783).
        - Avoid traceback if printer duplication fails (Red Hat bug #694629).
        - Fixed off-by-one error in monitor.
        - Fixed printer renaming (LP: #726954).
        - Set connected state when connecting to server fails (Red Hat bug
   #685098).
        - Handle the situation where cupsd has died/restarted more gracefully.
     o Printer Properties dialog:
        - Added PrinterModified D-Bus signal to printer properties interface.
        - More robustness for printer properties dialog when printer removed
          (LP: #741987).
        - Just hide Printer Properties dialog on delete-event (LP: #729966).
        - Extra job options: print-quality, printer-resolution, output-bin.
        - Automatically show horizontal scrollbar in job options screen.
        - Ignore "output-mode-default" attribute as it is not settable.
        - Handle IPP_TAG_RESOLUTION types (requires pycups-1.9.55).
        - Don't traceback if option value cannot be handled.
        - Fixed traceback in options.py (Red Hat bug #679103).
     o New Printer dialog
        - Fixed PPDs loader when using CUPS remotely or when DBus not available
          (Red Hat bug #693515).
        - Handle failure to load PPDs more gracefully (LP: #742409).
        - Avoid traceback when cancelling New Printer dialog after failure.
        - Make sure everything is ready before handlers might be called (Red
   Hat bug #689336).
        - Handle URIs in Find Network Printer entry, and use 'Enter URI'
   instead of 'Other' (Red Hat bug #685091).
        - Use "Do It Later" instead of "Cancel" for adjust firewall dialog
   (Upstream bug #213).
        - Fixed an instance where NewPrinterGUI might not have self.printers
   set (Red Hat bug #680683).
        - IPPHostname can contain colon (to specify port).
        - Fixed automatic driver installation when changing the driver.
        - Removed stale code left over from conversion to gobjects.
        - Ensure all uses of ppdsloader supply the Device ID.
        - Fixed some small typos in newprinter --help output.
        - Prevent traceback after 2nd drivers search dialog is cancelled (Red
   Hat bug #680288).
     o Driver handling:
        - Activated and fixed testing mode for device ID/driver association
        - Match HP-Fax2/3/... PPDs, as well as Ubuntu/Debian hpijs-ppds
          packages.
        - preferreddrivers.xml: Identify hpcups and hpijs fax PPDs.
        - Match native hpijs driver (drv:///hp/hpijs.drv/...) as "hpijs".
        - Handle Ubuntu locations of hpcups.drv and hpijs.drv.
        - preferreddrivers.xml: match OpenPrinting gutenprint PPD names as
          gutenprint.
    ...

Read more...

Changed in system-config-printer (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers