Network printer names shows untranslated, albeit they're translated

Bug #360171 reported by Ricardo Pérez López on 2009-04-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Low
Unassigned
system-config-printer (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: system-config-printer

Steps to reproduce:

0. Starts Ubuntu Jaunty using Spanish language by default
1. Open system-config-printer (System->Administration->Printing)
2. Click on New->Printer
3. Drop down the "Network Printer" list

The options below the "Network Printer" category shows untranslated in my Spanish desktop, albeit they're translated in Launchpad:

  https://translations.launchpad.net/ubuntu/jaunty/+source/system-config-printer/+pots/system-config-printer/es/+translate

and the translations are inside the system-config-printer.mo file. For example, the string "Windows Printer via SAMBA" is translated in Launchpad:

  https://translations.launchpad.net/ubuntu/jaunty/+source/system-config-printer/+pots/system-config-printer/es/298/+translate

and the translation is inside the .mo file:

  $ strings -eS /usr/share/locale-langpack/es/LC_MESSAGES/system-config-printer.mo | grep "Windows "
  Windows Printer via SAMBA
  Impresora de Windows vía Samba

However, it shows in English, untranslated. I attach an screenshot to illustrate the problem.

Ricardo Pérez López (ricardo) wrote :
David Planella (dpm) on 2010-01-29
Changed in ubuntu-translations:
status: New → Confirmed
importance: Undecided → Low

This bug is rather old. Can you re-test and see if the issue is still present?

Changed in system-config-printer (Ubuntu):
status: New → Incomplete
Changed in ubuntu-translations:
status: Confirmed → Incomplete
Victor Vargas (kamus) wrote :
Changed in ubuntu-translations:
status: Incomplete → Fix Released
Changed in system-config-printer (Ubuntu):
importance: Undecided → Low
status: Incomplete → Fix Released

Kamus, the issue is about the strings are translated in Launchpad but
shows untranslated when they are displayed in the running application
(please read the bug report description). Can you confirm that the
strings shows translated when running system-config-printer on
Maverick?

2010/8/24 Kamus <email address hidden>:
> This is fixed in Ubuntu Maverick according to
> https://translations.edge.launchpad.net/ubuntu/maverick/+source/system-
> config-printer/+pots/system-config-printer/es/192/+translate
>
> ** Changed in: ubuntu-translations
>       Status: Incomplete => Fix Released
>
> ** Changed in: system-config-printer (Ubuntu)
>   Importance: Undecided => Low
>
> ** Changed in: system-config-printer (Ubuntu)
>       Status: Incomplete => Fix Released
>
> --
> Network printer names shows untranslated, albeit they're translated
> https://bugs.launchpad.net/bugs/360171
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in ubuntu-translations:
status: Fix Released → Incomplete
Changed in system-config-printer (Ubuntu):
status: Fix Released → Incomplete
Victor Vargas (kamus) wrote :

I have attached a screenshot of this testing under Maverick

David Planella (dpm) wrote :

I believe this is a duplicate of bug 557199, so I'm marking it as such. If you think it isn't, please feel free to unmark it as duplicate.

The issue has been fixed in Maverick but not in Lucid. If someone would be willing to work on filing an SRU request for Lucid, that would be great. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers