Jobs requiring authentication never display authentication prompt

Bug #301705 reported by Brodie Rao on 2008-11-24
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
system-config-printer (Ubuntu)
Undecided
Unassigned

Bug Description

In Ubuntu 8.10, given a job sent to a printer requiring authentication (e.g. a restricted samba printer), the printer applet never displays an authentication dialog.

All jobs from any application are queued by the user root, which may be part of the problem (since I'm logged in as a different user).

Brodie Rao (brodie) wrote :

Removing my user from the lpadmin group causes queued jobs to be queued by my user, and the authentication dialog successfully pops up. However, doing this makes system-config-printer prompt me for the root password when I run it (instead of gksudo), which is a bit of a problem.

Tim Waugh (twaugh) wrote :

The jobs are shown as queued by user root because non-root users can read the CUPS root certificate. This misconfiguration is due to the way Ubuntu sets up cups.

By removing the user from lpadmin it prompts for authentication on some programs only. For example in Adobe reader it prompts but on Gnome's programs like Gedit it does not. It's on this bug:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/283811
For adding or removing printers it works only with "gksudo system-config-printer", else it'll ask for root's password.

From the other bug:
Since Intrepid, cups or (something else) keep adding :
AuthInfoRequired username,password
In my /etc/cups/printers.conf

I tried every method I found for not changing the file, but even if the file doesn't change there is the error message. The only solution is to restart the cups service after any printing. Is there any way to tell cups to restart after completing each job? Or even something with cron to check if the specific line changed in the file?

I need some working solution because I have to prepare some PCs for students. I haven't tried it with active directory if it works. The only ways I can think is to give specific root permissions on restarting the cups service from students.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in system-config-printer (Ubuntu):
status: New → Confirmed

Still the same in Ubuntu 16.10.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers