cups says "can't promp for authorization" when printing to my samba printer

Bug #283811 reported by Jonathan Ernst on 2008-10-15
186
This bug affects 21 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Wishlist
cups (Ubuntu)
High
Till Kamppeter
Declined for Intrepid by Mathias Gug
samba (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Mathias Gug

Bug Description

Since Intrepid, cups or (something else) keep adding :

AuthInfoRequired username,password

In my /etc/cups/printers.conf

(my printer doesn't require authentification by the way)

This makes every applications I try to print from say
printing failed
"Can't promp for authorization"

Then I have to manually edit /etc/cups/printers.conf, restart cups and print. However the file is modified right away again and next time I restart cups I have the same problem again.

This is a severe regression for me.

Jonathan Ernst (jonathan.ernst) wrote :

In /var/log/cups/error_log

E [15/Oct/2008:16:38:32 +0200] Print-Job: Unauthorized

Jonathan Ernst (jonathan.ernst) wrote :

This has been fixed recently in Intrepid updates.

Thanks

Changed in cups:
status: New → Fix Released
Jonathan Ernst (jonathan.ernst) wrote :

Spoke too soon, AuthInfoRequired username,password krept back in and I can't print anymore...

Changed in cups:
status: Fix Released → New
Michiel (michiel-wammm) wrote :

Same here and it is still the case in cups 1.3.9-2ubuntu1.

mannheim (kronheim) wrote :

I have this problem too, with a printer that does require authentication (attached to a remote windows machine on the network). The username and password are entered already in the printers.conf file, so no prompt should be needed; but I still get the dialog box saying "Can't prompt ... Printing Failed". The problem (as above) seems to be an incorrectly added line "AuthInfoRequired..."

Here is the relevant snippet from /etc/cups/printers.conf in intrepid:

<Printer Canon>
AuthInfoRequired username,password
Info Canon_inkjet_on_home_network
Location
DeviceURI smb://SomeUser:TopSecretPassword@/server/Canon-i950
State Idle
StateTime 1227476815
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
</Printer>

The corresponding snippet in gutsy was essentially the same, except that the "AuthInfoRequired" line was absent. Commenting out the AuthInfoRequired line makes the printing work again.

Simon (simschi) wrote :

I have the same Problem here. My system: Intrepid, Samsung ML-1410 Laserprinter, Buffalo LinkStation as Samba-Server

When I delete all my printers (I have only this one) in system-config-printer 1.0.5 and add one like this:

# Printer configuration file for CUPS v1.3.9
# Written by cupsd on 2008-12-07 12:13
<DefaultPrinter GDI-Printer>
AuthInfoRequired username,password
Info
Location
DeviceURI smb://192.168.0.3/lp
State Idle
StateTime 1228648383
Accepting Yes
Shared Yes
JobSheets none none
QuotaPeriod 0
PageLimit 0
KLimit 0
OpPolicy default
ErrorPolicy retry-job
</Printer>

then everything works.
But when I add a second printer with same DeviceURI but with the Samsung-ML-1410-gdi.ppd instead of Default GDI, both (yes, also the Default GDI) give me the "Can't promt...." error and do not print.

Then I delete the second one (Samsung-ML-1410-gdi.ppd) and the first (Default GDI) still says "Can't promt..."

So I do not understand this problem, but maybe someone does and can fix it...

I attached my printers.conf with working (0) and not working (1) Default-GDI printer.

TimMadden (timmadden) wrote :

this bug is biting me as well!
My system is 8.10 Intrepid, cups version: 1.3.9-2ubuntu3
The printer is on a ubuntu server on the same private network.
If I comment out "AuthInfoRequired username,password" from printers.conf I can print, however, something is just adding it back in to the file later.

The WORST part is that the windows machines have no trouble printing to this machine, just my 8.10 install! This is not really good as I am trying to convince the family of the advantage of Ubuntu and they can't even print without me going to down into the command line!

Would love to see this fixed or at least a workaround to make my change to the printers.conf not get reverted.

Thanks!

Sailorboy (rockell) wrote :

I have the same problem. It is impacting my ability to use Ubuntu / Linux as a business tool. I cannot print pdf's, or from any application other than Open Office. It seems the importance should be greater than 'undecided'.

Simon (simschi) wrote :

My solution, until a bugfix will be released:

I copied the printers.conf to printers_ok.conf and made this small script-file:

sudo cp /etc/cups/printers_ok.conf /etc/cups/printers.conf
sudo /etc/init.d/cups restart

so i just have to run this script before i print.

Mebus (mebus) wrote :

This is one of the printing bugs I hate !!

Importance: high !

Gilberto Olimpio (golimpio) wrote :

Same here.
Unfortunately the only workaround that I found was to comment the "AuthInfoRequired username,password
" line on "printers.conf" file (http://blog.avirtualhome.com/2008/11/21/cant-print-in-evince-gedit-claws-mail).
And as everybody said: it gets reverted.

TiagoCruz (tiagocruz) wrote :

I also have this problem (after upgrade ubuntu 8.04 => 8.10)

Related: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/296327

Seth (bugs-sehe) wrote :

Same here. I put my mom on Intrepid after she couldn't install the drivers for her new printer on windows. Wouldn't it be a bleeding shame if now.... we don't let her print from ubuntu ...

Matthew Monaco (dgbaley27) wrote :

This is a major pain.

I tried making printers.conf read-only and even the file permissions were reset after a successful print.

Changed in cups:
status: New → Confirmed
Matthew Monaco (dgbaley27) wrote :

Has anyone tested out printing on a windows shared printer that actually requires authorization?

the AuthInfoRequired line wouldn't be a big deal if it recognized when printing as guest is acceptable.

Henri (henrip) wrote :

One workaround is following. This will prevent CUPS to change

  sudo invoke-rc.d cups stop
  sudo vi /etc/cups/printers.conf
Put comment character into row: AuthInfoRequired username,password
  sudo chattr +i /etc/cups/printers.conf
  sudo invoke-rc.d cups start

CUPS can't take attribute immutable out from file. Changing file to read-only does not help enough.
If you need to restore file back to original state, run command
  sudo chattr -i /etc/cups/printers.conf

Still waiting for correct fix for this bug...

barghest (barghest) wrote :

The problem with the workaround Henri wrote is, that even the attribute is set back after the printer was powered off and on again. :(

Matthew Monaco (dgbaley27) wrote :

Henri's workaround has worked great for me. The immutable attribute has not been reset.

There is a problem though! I noticed yesterday that while running updates to cups, an error was caused "while trying to chown printers.conf" Unfortunately I don't know if this broke the update, or affected any updates that were supposed to occur after.

rachmat (rachmat-kosasih) wrote :

Meson:
I tried to print to a printer attached to xp box that requires authentication.
Using cups admin page, I can print a test page. I got notification box said, authentication required, which I can fill in the user/password. then it print.
But from any other application, the notification box didn't occur.
and the printer status said " held for authentication "

rachmat (rachmat-kosasih) wrote :

BTW,
I notice that when I print using cups admin page, it prints as local userid, but when printing through acroread it was printing as root

rachmat (rachmat-kosasih) wrote :

Turns out that the username/password is wrong, and I have to put the IPaddress/printersharename as printer instead of windows name.
However, what confused me is the previous post, that when using Acroread it didn't pop up authentication required box.

mtn (mike-chunkmedia) wrote :

I'm having this same problem using the fully updated alpha Ubuntu 9.04 - the Jaunty Jackalope. I'm printing to a print server. I can print a test page, printing from other applications pop up the "can't promp for authorization" message. Following mannheim's post and editing /etc/cups/printers.conf...

sudo gedit /etc/cups/printers.conf

...and commenting out the line AuthInfoRequired username,password...

# AuthInfoRequired username,password

...worked, but this is a real pain. Does anyone have any idea when this will be fixed?

tlois (tlois3) wrote :

Make sure you have Multicast DNS service discovery checked in your services. Had this exact problem. Looked here for help. Ended up figuring it out on my own when looking to see if I had some unknown firewall running.

mtn (mike-chunkmedia) wrote :

Thanks - just checked and it was checked.

Changed in cups:
assignee: nobody → canonical-desktop-team
importance: Undecided → High
Changed in cups:
assignee: canonical-desktop-team → till-kamppeter
Paul Dufresne (paulduf) wrote :

Not totally sure how it does fit.
Looking through cups changelog for 1.3:
http://www.cups.org/documentation.php?VERSION=1.3

CHANGES IN CUPS V1.3.3
 - The scheduler did not correctly update the
   auth-info-required value(s) if the AuthType was Default.

CHANGES IN CUPS V1.3.9

 - The scheduler did not correctly update the
   auth-info-required value(s) if the AuthType was Default.

Paul Dufresne (paulduf) wrote :

Oops, sorry:
For V1.3.3 it was:
 - The auth-info-required attribute was not always updated
   for remote queues that required authentication.
Looks like this was a bad update, that was fixed in V1.3.9.

But we have 1.3.9 both in jaunty and intrepid:
jaunty development main release 1.3.9-15 None defined
intrepid current main release 1.3.9-2 CUPS Series: main
  main security 1.3.9-2ubuntu6.1
  main updates 1.3.9-2ubuntu7
  main proposed 1.3.9-2ubuntu8

So it is a bit unclear to me if it is really related.

Paul Dufresne (paulduf) wrote :

From http://svn.easysw.com/public/cups/trunk/scheduler/job.c I can see that what was in:
http://linux.derkeiler.com/Mailing-Lists/Fedora/2008-07/msg03591.html
if ((attr = cupsGetOption("auth-info-required", num_attrs, attrs)) != NULL)
{
cupsdSetAuthInfoRequired(job->printer, attr, NULL);
cupsdSetPrinterAttrs(job->printer);
cupsdSaveAllPrinters();
}

has become:
      if ((attr = cupsGetOption("auth-info-required", num_attrs,
                                attrs)) != NULL)
      {
        cupsdSetAuthInfoRequired(job->printer, attr, NULL);
 cupsdSetPrinterAttrs(job->printer);

 if (job->printer->type & CUPS_PRINTER_DISCOVERED)
   cupsdMarkDirty(CUPSD_DIRTY_REMOTE);
 else
   cupsdMarkDirty(CUPSD_DIRTY_PRINTERS);
      }

More clearly:
cupsdSaveAllPrinters();

have become:
 if (job->printer->type & CUPS_PRINTER_DISCOVERED)
   cupsdMarkDirty(CUPSD_DIRTY_REMOTE);
 else
   cupsdMarkDirty(CUPSD_DIRTY_PRINTERS);

Yeah, I know, I need to begin to use svn. ;-)

Paul Dufresne (paulduf) wrote :

In previous comment #7:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/283811/comments/7

It is said to still affect
1.3.9-2ubuntu3

which tend me to conclude that TRUNK version of upstream CUPS might still be buggy.
(if it was changed in 1.3.9 like the changelog suggest).

Unless of course, I am missing something (which I feel I may do).

Paul Dufresne (paulduf) wrote :

At first, I was not realizing that the following was linked to this bug, but I really believes it belongs now:
http://www.cups.org/str.php?L2750+P0+S0+C0+I0+E0+M20+Qauth-info-required

Problem is that "Fix Version: 1.4-current (SVN: r7480)" suggest it was not fixed in 1.3.

Paul Dufresne (paulduf) wrote :

This looks stupid, but could someone tell me if setting:
LogLevel none
in /etc/cups/cupsd.conf is an effective workaround for the bug?

I ask that because the code in https://bugs.launchpad.net/ubuntu/+source/cups/+bug/283811/comments/28
is inside a: else if (loglevel == CUPSD_LOG_ATTR)".

Doesn't work...

On Thu, 2009-03-19 at 06:03 +0000, Paul Dufresne wrote:
> This looks stupid, but could someone tell me if setting:
> LogLevel none
> in /etc/cups/cupsd.conf is an effective workaround for the bug?
>
> I ask that because the code in https://bugs.launchpad.net/ubuntu/+source/cups/+bug/283811/comments/28
> is inside a: else if (loglevel == CUPSD_LOG_ATTR)".
>

Paul Dufresne (paulduf) wrote :

Thanks Philip, mostly reassuring to see that this workaround did not worked, it would have been a strange one.
http://blog.avirtualhome.com/2008/11/21/cant-print-in-evince-gedit-claws-mail/#comment-2017 say that replacing username by a real username on your system, and password by it's real password, avoid to have cups constantly re-add that line in printers.conf.

Paul Dufresne (paulduf) wrote :

I was wondering when the lines:
" if ((attr = cupsGetOption("auth-info-required", num_attrs,
                                attrs)) != NULL)
      {
        cupsdSetAuthInfoRequired(job->printer, attr, NULL);"
where added in scheduler/job.c of CUPS.

The answer is:
r6318 | mike | 2007-03-05 23:36:55 -0500 (lun 05 mar 2007) | 35 lines

Add support for auth-info and auth-info-required (STR #2268)

TODO: Directory services support, reject jobs that need auth-info
but don't have the right stuff.

backend/ipp.c:
    - password_cb(): Send ATTR: message to specify the authentication
      that is required.

scheduler/classes.c:
    - cupsdLoadAllClasses(): Load AuthInfoRequired.
    - cupsdSaveAllClasses(): Save AuthInfoRequired.

scheduler/ipp.c:
    - add_class(): Save auth-info-required data.
    - add_job(): Pass auth-info data.
    - add_printer(): Save auth-info-required data.
    - authenticate_job(): Pass auth-info data.
    - save_auth_info(): Save auth-info data.

scheduler/job.c:
    - cupsdUpdateJob(): Process ATTR: messages for auth-info-required.

scheduler/printers.c:
    - cupsdLoadAllPrinters(): Load AuthInfoRequired.
    - cupsdSaveAllPrinters(): Save AuthInfoRequired.
    - cupsdSetAuthInfoRequired(): Added.
    - cupsdSetPrinterAttrs(): Add auth-info-required.

scheduler/printers.h:
    - Add auth_info_required and num_auth_info_required to
      cupsd_printer_t structure.
    - Add cupsdSetAuthInfoRequired attribute.

Paul Dufresne (paulduf) wrote :

Bug #305030 could be consideded a duplicate I think. Or vice-versa, this one a dup of it. (Lots of info there).
They have figure out that it affects only GTK applications (I am still thinking about that).
They say this is a known limitation of GTK. (https://bugs.launchpad.net/ubuntu/+source/evince/+bug/305030/comments/10 )
Does this means KDE bypass cups, and ignore auth-info-require without problems?

Paul Dufresne (paulduf) wrote :

Reading http://www.cups.org/str.php?L2268+P0+S0+C0+I0+E0+M20+Q2268 (The wish-bug report that have given life to auth-info-required attribute, implemented by the bug reporter himself, Mike) is enlightening.

It would probably be even more if I knew a bit more about CUPS.

After reading it, I understand a bit the fact that it is normal that the line:
auth-info-required username,password
keeps 'creeping in' (English is not my first language, excuse if the expression is wrong) in printers.conf file.

<<
BACKENDS

Backends will continue to get the authentication information from the cache file (aNNNNN in the spool directory, where NNNNN is the job ID). The format of this file is one authentication value per line, with each value Base64-encoded.

When the authentication fails, backends can send an "ATTR: auth-info-required=..." message to stderr to reconfigure the auth-info-required attribute on the queue, and then exit with code 2 to indicate that authentication is required.
>>

and the auth-info-required is then save 'normally' when the printers.conf file is saved.

This suggest than rather than remove that line, it would be better to change it to become:
auth-info-required none
that would indicate that the remote system where the printer is, does not request any authorization.

Also, since Gnome seems unable to request a username and password yet, it would be good to also add a line:
auth-info-supported none
to indicate that the local system have no idea how to deal with authorization.
Or does it knows how to deal with 'domain' authorization?

Paul Dufresne (paulduf) wrote :

I have just added bug #314543 as a duplicate of this one.
Looks like I will choose this bug as the main one.
Yeah, just also added bug #305030 as duplicate of this one.

From bug #314543, we learned that an other possible symptom of this bug is:
After creating network printer, first job is printed Ok, but any job sent after is rejected.
When trying to print from text editor the following message appears:
ERROR PRINTING, Too many failed attempts

We also just learned that the new (improved) workaround is working:
"Thanks Paul,
I have checked the /etc/cups/printers.conf, and after reading bug #283811, I have changed the line to:
AuthInfoRequired none
and it is working now for Eclipse and Firefox; therefore I can confirm that is the same bug, but with another symptom."

So it looks that just this line is enough. The "auth-info-supported none" seems not needed.

Paul Dufresne (paulduf) wrote :

To answer Derg question (asked on bug #305030), no there is no news on this bug.
It would be written here if it were any.
You should expect this bug to be fixed in next version, Karmic Koala.

But you sure could try the workaround I presented, to change the following line in /etc/cups/printers.conf:
AuthInfoRequired username,password
to become:
AuthInfoRequired none

I guess that it is now 'AuthInfoRequired' and not 'auth-info-required' like it seems to have been originally.

Thanks, Karmic
I've tried your work-a-round but it simply re-writes itself! This is not good. Nothing works. There must be a combination of installed software causing this as not everyone seems to have this issue.
George Ross (DERG)

> Date: Mon, 20 Apr 2009 15:20:52 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 283811] Re: cups says "can't promp for authorization" when printing to my samba printer
>
> To answer Derg question (asked on bug #305030), no there is no news on this bug.
> It would be written here if it were any.
> You should expect this bug to be fixed in next version, Karmic Koala.
>
> But you sure could try the workaround I presented, to change the following line in /etc/cups/printers.conf:
> AuthInfoRequired username,password
> to become:
> AuthInfoRequired none
>
> I guess that it is now 'AuthInfoRequired' and not 'auth-info-required'
> like it seems to have been originally.
>
> --
> cups says "can't promp for authorization" when printing to my samba printer
> https://bugs.launchpad.net/bugs/283811
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “cups” source package in Ubuntu: Confirmed
>
> Bug description:
> Since Intrepid, cups or (something else) keep adding :
>
> AuthInfoRequired username,password
>
> In my /etc/cups/printers.conf
>
> (my printer doesn't require authentification by the way)
>
> This makes every applications I try to print from say
> printing failed
> "Can't promp for authorization"
>
> Then I have to manually edit /etc/cups/printers.conf, restart cups and print. However the file is modified right away again and next time I restart cups I have the same problem again.
>
> This is a severe regression for me.

_________________________________________________________________
Windows Live™: Keep your life in sync.
http://windowslive.com/explore?ocid=TXT_TAGLM_WL_allup_1a_explore_042009

DERG (georgeaross) wrote :

Do you mean Ubuntu 9.04 or Ubuntu 9.10?
Thanks

> Date: Mon, 20 Apr 2009 15:20:52 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 283811] Re: cups says "can't promp for authorization" when printing to my samba printer
>
> To answer Derg question (asked on bug #305030), no there is no news on this bug.
> It would be written here if it were any.
> You should expect this bug to be fixed in next version, Karmic Koala.
>
> But you sure could try the workaround I presented, to change the following line in /etc/cups/printers.conf:
> AuthInfoRequired username,password
> to become:
> AuthInfoRequired none
>
> I guess that it is now 'AuthInfoRequired' and not 'auth-info-required'
> like it seems to have been originally.
>
> --
> cups says "can't promp for authorization" when printing to my samba printer
> https://bugs.launchpad.net/bugs/283811
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in “cups” source package in Ubuntu: Confirmed
>
> Bug description:
> Since Intrepid, cups or (something else) keep adding :
>
> AuthInfoRequired username,password
>
> In my /etc/cups/printers.conf
>
> (my printer doesn't require authentification by the way)
>
> This makes every applications I try to print from say
> printing failed
> "Can't promp for authorization"
>
> Then I have to manually edit /etc/cups/printers.conf, restart cups and print. However the file is modified right away again and next time I restart cups I have the same problem again.
>
> This is a severe regression for me.

_________________________________________________________________
Windows Live™: Life without walls.
http://windowslive.com/explore?ocid=TXT_TAGLM_WL_allup_1b_explore_042009

Paul Dufresne (paulduf) wrote :

I means Ubuntu Karmic Koala, that will become Ubuntu 9.10 in october 2009.

Rereading http://www.cups.org/str.php?L2268+P0+S0+C0+I0+E0+M20+Q2268
Could you try instead with:
AuthRequired none
(Note the Info part was removed).

Simon (simschi) wrote :

I tried your hint:

>But you sure could try the workaround I presented, to change the following line in /etc/cups/printers.conf:
>AuthInfoRequired username,password
>to become:
>AuthInfoRequired none

But after the first print it is changed back to 'AuthInfoRequired username,password'

In my case I noticed, that a Windows-machine indirectly asks for a username and password when printing to that printer. (DeviceURI smb://192.168.0.3/lp). My Windows-PC can only print on that printer, if I add a network-drive on the same server that requires the same username and password.

Maybe this can help somebody...

Simon (simschi) wrote :

Ok, didn't read the thing with 'Could you try instead with: AuthRequired none (Note the Info part was removed)'
Now I tried that one:
removed AuthInfoRequired
added AuthRequired none
printed the printers.conf to the printer
found in the terminal from gedit:
simon@simon-laptop:/etc/cups$ sudo gedit printers.conf

** (gedit:9584): WARNING **: NOT IMPLEMENTED: We need to prompt for authorization

** (gedit:9584): WARNING **: Datei »/root/.gnome2/gedit/gedit-page-setup.DK1ZSU« konnte nicht angelegt werden: No such file or directory

** (gedit:9584): WARNING **: Datei »/root/.gnome2/gedit/gedit-print-settings.MS1ZSU« konnte nicht angelegt werden: No such file or directory

What does it mean?

Paul Dufresne (paulduf) wrote :

>** (gedit:9584): WARNING **: NOT IMPLEMENTED: We need to prompt for authorization
> What does it mean?

The truth is ... I don't know... I am just an advance user trying to help.

Well... Maybe it could help if I was reformulating this bug in my own words.

The following is just how *I* understand this bug right now.

The fact that "AuthInfoRequired username,password" keeps being added to the /etc/cups/printers.conf file is not a bug but a feature.
The bug is that when we remove it, printing does work, at least one time. ;-)

Why keeping adding "AuthInfoRequired username,password" is a feature?
It is a feature, that auto-detect that the remote system requires authentication for printing.
Basically, when CUPS received an authentication error on trying to print, it keeps the information in the /etc/cups/printers.conf file that authentication is required.

The fact that removing this line, the job is printed once, suggest that the remote system have accepted to print the job, but have also sent
an authentication error... which sure does looks like a bug of the remote printing system to me.

Often, people does not describe much the remote printing system they use... because the bug seems to be on the Ubuntu client side.
My feeling is that most if not all of the remote system, are either Windows or Samba shared printer.
My guess is that none of the reporter is having this on a CUPS shared printer.

It is a bit unclear to me what is a remote printer that does not need a password.
I means... I guess this means it does use the 'guest' username, with an empty password, but I am not much an administrator to know much about this stuff.

Then also, I now know that there is an application on Samba to deals with 'remote' password.
While writing this, I am taking a look at 'man 8 smbpasswd' about which I have almost no other knowledge that it does exist.

Then, my FEELING is that /etc/printers.conf probably supports some kind of:
AuthInfo Joe,MyPassword
to set the username and password to send, once it had discovered that a remote password is needed.
But this is just a guess from me... CUPS documentation about authentification seems... missing in my opinion.

Obviously, if the "AuthInfoRequired username,password" but the supposedly existing "AuthInfo" line is not there.
Then the system (Gnome, KDE) should be able to ask the username and password to the user.
From duplicate bug, Gnome teams would have said that they do not support asking username and password for now.
(In http://bugzilla.gnome.org/show_bug.cgi?id=384940 ?).

The:
** (gedit:9584): WARNING **: NOT IMPLEMENTED: We need to prompt for authorization
line seen in previous message, for me seems like Gedit saying: I know the remote printer need a username and password, that this info have not been obtained (like in AuthInfo line if that exists), but I don't know ... yet ... how to ask this information to the user.

Hope this long comment can help have a more common picture of the problem.

DERG (georgeaross) wrote :

Paul Dufresne wrote..."Often, people does not describe much the remote printing system they use... because the bug seems to be on the Ubuntu client side.
My feeling is that most if not all of the remote system, are either Windows or Samba shared printer.
My guess is that none of the reporter is having this on a CUPS shared printer."

I'm only posting this to help in the only capacity that I can & that is to explain what is happening. Unlike those of you who are advanced users, I am not. But, I can share how my network is setup, what works & what doesn't as there seems to be various descriptions. Maybe this will help those who do have skills.

We have a 3 PC network. One PC is all Ubuntu 9.04 32-bit, one is Ubuntu 9.04 32-bit/XP dual boot & my PC is dual boot Ubuntu 9.04 amd64-bit/XP 32-bit. The dual boot Ubuntu 9.04 32-bit/XP has the printer.

Neither of the other Ubuntu 9.04 PCs can share the printer when that PC with the printer is running Ubuntu 9.04. We get the "AuthInfoRequired username,password" problem in the printer.conf file. Oddly enough, we can print when the printer PC is running XP & the others are in Ubuntu 9.04. And, when the printer PC is in XP the other dual boot amd64-bit PC is in XP, it can print XP to XP - no problems. I haven't tested with the printer PC in Ubuntu 9.04 & the dual boot amd64-bit PC is in XP; sorry.
All other file sharing between the 3 computers works fine.

Over at cups.org, Michael Sweet responded to my post. Here's the whole series where he gave some suggestions but to no avail;
http://www.cups.org/newsgroups.php?s5908+gcups.bugs+v5914+T0

"From: Michael R Sweet
Date: 13:19 Mon

Well, it could be that the Windows system isn't allowing guest
printing, so the smb backend is telling CUPS that it needs a username
and password.
Aside from that, I don't have any other suggestions to offer, sorry..."

I posted back that the only time the printing failed was when the printer PC was running Ubuntu 9.04 & the other 2 PCs were in Ubuntu 9.04 as well. He hasn't responded to that.
Anyway, I hope this offers some help.
Regards, GARoss (DERG)

Paul Dufresne (paulduf) wrote :

Rereading manheim comment ( https://bugs.launchpad.net/ubuntu/+source/cups/+bug/283811/comments/5 ),
about "DeviceURI smb://SomeUser:TopSecretPassword@/server/Canon-i950"
I now somehow recall to have read in 'man backend':
Starting with CUPS 1.1.22, any authentication information in
       argv[0] is removed, so backend developers are urged to use the
       DEVICE_URI environment variable whenever authentication information is
       required.
See this Mike's bug in 2004: http://markmail.org/message/2jbwl6jbcekjufqh

Still searching documentation for DEVICE_URI... not finding.
I am unsure how you are supposed to correctly export this info for CUPS to use it.

Paul Dufresne (paulduf) wrote :

Rethinking about my previous comment...
DeviceURI smb://SomeUser:TopSecretPassword@/server/Canon-i950
in /etc/cups/printers.conf file is the correct way to go.
(somehow https://bugzilla.redhat.com/show_bug.cgi?id=202977 show me this is the ok way).
So forgot what I said about some possible "AuthInfo Joe,MyPassword", this does surely not exist.

Now about DERG's exchange with the author of the AuthInfoRequired stuff.

So we now have a better workaround than before, for people NOT USING Windows or SAMBA (using CUPS shared printer):
1) Open System/Administration/Printing and note the name of the printer in the newly open window.
2) Open a terminal window (Applications/Accessories/Terminal) with your main(admin) user, and type in:
lpadmin -p <printer_name> -o auth-info-required=none
where <printer_name> is replaced by name of the printer you noted in step 1.
I believe the 3D after = was a copy/paste 'bug'.

3) Retest printing
4) Give feedback here

For people using Windows or Samba shared printer, we have this clue:
"Well, it could be that the Windows system isn't allowing guest
printing, so the smb backend is telling CUPS that it needs a username
and password."
Again... Feedback is welcome.

It is still unclear to me if "lpadmin -p <printer_name> -o auth-info-required=none" neutralize the smb backend from telling CUPS that it needs a username and password.

Paul Dufresne (paulduf) wrote :

Oh well... even if you are using Windows or Samba... I guess it could be nice you test the workaround.

DERG (georgeaross) wrote :

"So we now have a better workaround than before, for people NOT USING Windows or SAMBA (using CUPS shared printer):
1) Open System/Administration/Printing and note the name of the printer in the newly open window.
2) Open a terminal window (Applications/Accessories/Terminal) with your main(admin) user, and type in:
lpadmin -p <printer_name> -o auth-info-required=none
where <printer_name> is replaced by name of the printer you noted in step 1.
I believe the 3D after = was a copy/paste 'bug'."

I have tried this & it did not correct the issue.

I have also tried, now, to print via my network while operating in XP to my printer host PC when it was operating in Ubuntu 9.04 - it fails, prompting for the same password as it does the printer PC is in Ubuntu 9.04.

As a test, I moved the printer to our 3rd PC which is ONLY Ubuntu 9.04 - No XP, no dual boot; just Ubuntu 9.04. I can "see" & connect to it but it fails to print; no matter if I'm working in Ubuntu 9.04 or XP. BTW, this same Ubuntu 9.04 only PC has the same issues as I do trying to print via the network to the printer host PC.

As Paul said & others as well elsewhere on the internet, some have had success with workarounds where I have not. Could this be some combination of downloaded software that is causing this? If all my PCs are running Ubuntu 9.04 do I need Samba to share printers & files?
And, so it goes.

Paul Dufresne (paulduf) wrote :

>As Paul said & others as well elsewhere on the internet, some have had success with workarounds where I have not. >Could this be some combination of downloaded software that is causing this?
Well, I see it like keeping adding the said line is a symptom.
The authentication error that triggers the symptom can be slightly different for each user.

>If all my PCs are running Ubuntu 9.04 do I need Samba to share printers & files?
no, CUPS should be fine.

After applying the workaround, where you able to print once?

I suggest that:
1) You apply the said workaround:
lpadmin -p <printer_name> -o auth-info-required=none

2)In Ubuntu Gutsy or newer, select "System" -> "Administration" -> "Printing" in the main menu of your desktop. The printer setup tool system-config-printer will open.

3)Go to the troubleshooting wizard in system-config-printer. You find it by in the "Help" menu of system-config-printer. It produces a text file with a lot of useful information to attach to bug reports. Follow the instructions of the wizard. If you reach the test page step, you can either click the button to print the test page or you can print a job to the selected printer from any application or from the command line. The job will be shown in the integrated job viewer. Wait until it completes or goes into "Stopped" state. ONLY THEN AND NOT BEFORE mark the checkbox at the job, answer whether the job got printed correctly, and click "Forward". After that the file will get generated. Save it and attach it to this bug report.

[Step 3 were taken from https://wiki.ubuntu.com/DebuggingPrintingProblems#Troubleshooting%20Wizard ]

DERG (georgeaross) wrote :
Download full text (64.3 KiB)

OK. Here's the requested data in two reports. I tried a combination of printer names but no combo changed the error. Also, removed the "=3Dnone" to "=none" Hope this offers some help!
DERG

D [27/Apr/2009:08:52:44 -0400] cupsdReadClient: 7 POST / HTTP/1.1
D [27/Apr/2009:08:52:44 -0400] cupsdAuthorize: No authentication data provided.
D [27/Apr/2009:08:52:44 -0400] Get-Jobs ipp://localhost/printers/
D [27/Apr/2009:08:52:44 -0400] cupsdProcessIPPRequest: 7 status_code=0 (successful-ok)
D [27/Apr/2009:08:52:44 -0400] cupsdReadClient: 7 POST / HTTP/1.1
D [27/Apr/2009:08:52:44 -0400] cupsdAuthorize: No authentication data provided.
D [27/Apr/2009:08:52:44 -0400] Get-Jobs ipp://localhost/printers/
D [27/Apr/2009:08:52:44 -0400] [Job 21] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 22] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 23] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 24] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 25] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 26] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 27] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 28] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 29] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 30] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 31] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 32] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 33] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 34] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 35] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 36] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 37] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 38] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 39] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 40] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 41] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 42] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 43] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 44] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 45] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 46] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 47] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 48] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 49] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 50] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 51] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 52] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 53] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 54] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 55] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 56] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 57] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 58] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 59] Loading attributes...
D [27/Apr/2009:08:52:44 -0400] [Job 60] Loading attributes...
D [27/Apr/2009:08:5...

Chris Dickson (whiskychris) wrote :

Allow me to join this discussion by highlighting the following message from DERG's report:

'Tree connect failed (NT_STATUS_ACCESS_DENIED)'

I also have the problems mentioned in this post when trying to print from programs using cups (as far as I can tell - evince does not print happily, asking for authentication, while xpdf can print, however I believe it uses a different mechanism - lpr?). When looking in System - Admin - Printing; Printer - Properties I also see the error message quoted above displayed as the "Printer State" after/during the prompt saying it has been unable to ask for authentication.

I should also add that the remote printer I'm connecting to does require authentication and I have setup the printer preferences to save my details. As such I can see that in my /etc/cups/printers.conf file I have the line

DeviceURI smb://my-name:my-password@path/to/printer

where my username and password are saved.

The printer I am having problems with is at work, so I will try some of the workaround suggestions so far tomorrow and hopefully provide you any further details that I can help with.

Paul Dufresne (paulduf) wrote :

What does puzzle me more about Derg log, is not that Tree connect failed, it is that it tried to connect with a user I did not expect, marie:
D [27/Apr/2009:08:52:45 -0400] cupsdIsAuthorized: requesting-user-name="marie"
D [27/Apr/2009:08:52:45 -0400] cupsdProcessIPPRequest: 7 status_code=0 (successful-ok)
D [27/Apr/2009:08:52:45 -0400] cupsdAcceptClient: 8 from localhost (Domain)
D [27/Apr/2009:08:52:45 -0400] cupsdReadClient: 8 POST /printers/Canon-i950-JG HTTP/1.1
D [27/Apr/2009:08:52:45 -0400] cupsdAuthorize: No authentication data provided.
D [27/Apr/2009:08:52:45 -0400] Print-Job ipp://localhost/printers/Canon-i950-JG
D [27/Apr/2009:08:52:45 -0400] [Job ???] Auto-typing file...
I [27/Apr/2009:08:52:45 -0400] [Job ???] Request file type is application/postscript.
E [27/Apr/2009:08:52:45 -0400] Print-Job: Unauthorized
D [27/Apr/2009:08:52:45 -0400] cupsdSendError: 8 code=401 (Unauthorized)

I was expecting it to use user 'guest'.

Trying to figure out where it took marie, I can only see this from the log:
D [27/Apr/2009:08:52:45 -0400] [Job 77] envp[9]="SERVER_ADMIN=root@marie-desktop"

Also, someone on the forums, seems to have come with a work-around that, consisting of replacing the machine
name by it's IP address, with success:
http://ubuntuforums.org/showthread.php?p=7023893

But maybe it is trying to use marie only because anonymous access failed?:
{'printer_is_remote': False}
Page 6 (Check network server sanity):
{'remote_server_name_resolves': ['192.168.0.3', '192.168.0.3', '192.168.0.3'],
 'remote_server_smb': True,
 'remote_server_smb_share_anon_access': (13, 'Permission denied'),
 'remote_server_smb_shares': [<smbc.Dirent object "print$" (File share) at 0x973a8d8>,
                              <smbc.Dirent object "IPC$" (IPC share) at 0x973a8f0>,
                              <smbc.Dirent object "Canon-i950" (Printer share) at 0x973a908>,
                              <smbc.Dirent object "shared" (File share) at 0x973a920>],
 'remote_server_try_connect': '192.168.0.3'}
Page 7 (Printer state reasons):
{'printer-state-message': u'Tree connect failed (NT_STATUS_ACCESS_DENIED)',
 'printer-state-reasons': [u'none']}

I really feel like a magic apprentice not knowing what he is doing here...
Guess I should shut up a bit and wait for more knowledgeable people to kick in.

Paul Dufresne (paulduf) wrote :

Just a note about a similar bug:
https://bugs.launchpad.net/bugs/132791
that seems more linked to finding wrong password in cache.

I had all the symptoms described when I set up a printer
on Ubuntu 9.04 using the normal
Administration->Printing->
New->Select Device-> Network Printer->
Windows Printer via SAMBA->Browsing for the smb shared printer
and Having "Prompt user if authentication is required" checked.

The same setup but having "Set authentication details now" checked
with Username & Password correctly entered for the smb share
works flawlessly.

There is no line in printers.conf stating
AuthInfoRequired username,password

# Printer configuration file for CUPS v1.3.9
# Written by cupsd on 2009-04-28 14:13
<DefaultPrinter Epson-Stylus-D88>
Info Epson Stylus D88
Location lilians office
DeviceURI smb://lilian:l1l@MDKGROUP/ATOML/EPSOND88

Username is " lilian", password is " l1l" @ workgroup/server/printer

DERG (georgeaross) wrote :

I tried that one David & the printer.conf re-writes out the changes no matter how the cupsd.conf is written.

But, using PRINTER CONFIGURATION - LOCALHOST, I learned a new trick. In fact, a new workaround. The trick is to NOT to assume how things work. My problem is when I see NEW, I assume that's where to start. It seemed a reasonable assumption. In fact, I've read it somewhere in Ubuntu docks, that's where to begin. And, all though I'm have problems now, I've actually had success adding printers & network printers by using NEW & going from there. I was a happy camper. Then there was a update...& the results are well documented. And, still unresolved...

But, wait! I said learned a new trick. For some reason I opened SERVER (above NEW) in SYSTEM/ADMINISTRATION/PRINTING/PRINTER CONFIGURATION - LOCALHOST. In desperation, I checked Show Printers Shared by Other Systems & Publish Shared Printers Connected To This System. Everything works like a charm. I don't know if both actually need to be checked but that can be worked on later.
DERG

Simon (simschi) wrote :

Ok, I tried that:

1> lpadmin -p GDI-Printer -o auth-info-required=none

2> troubleshooting wizard with two prints: first a pdf-file then the test-page. both printed correctly without error-message as usual after printing the second page. (it generated a log and a troubleshoot.txt ! I will enclose both)

3> finished troubleshooting wizard and tried to print another file and got the error: 'Too many failed attempts'

It's a huge mass on log-data, so I will put it in a file with this message. I do not understand it,but maybe it helps to find the bug.

thx for your great help, paul!!!

Simon (simschi) wrote :

Seems like I can print exactly one times after 'lpadmin -p GDI-Printer -o auth-info-required=none'.
Then for the next job the error-message is "Can't promt for autorization."

The first printing-job is printed normally, produces the following in /var/log/kern.log:
Apr 29 09:31:31 simon-laptop kernel: [ 7597.702015] type=1503 audit(1240990291.780:14): operation="inode_permission" requested_mask="::rw" denied_mask="::rw" fsuid=7 name="/dev/tty" pid=15021 profile="/usr/sbin/cupsd"

And changes the line in printers.conf back to:
AuthInfoRequired username,password

The second job does not add any line to /var/log/kern.log and does not re-write printers.conf and does not print.

Changed in gtk:
status: Unknown → Fix Released
luisguer (luis-b-guerrero) wrote :

Do not know why it works, but following the instructions given at http://ubuntuforums.org/archive/index.php/t-829706.html , that is, going to System/Administration/Printers and copying the printer (with a new name, of course) solved the problem.
Hope this also works for all of you ....

Simon (simschi) wrote :

Thanks! I will try that tomorrow...

By the way: What means
Changed in gtk:
status: Unknown → Fix Released ??

Paul Dufresne (paulduf) wrote :

>By the way: What means Changed in gtk: status: Unknown → Fix Released ??
As I understand it, it means that Gnome have now included a patch in their development version to be able to ask a username and password.

So Gnome will (the day your version of Ubuntu will include this new patch) ask a username and password when
AuthInfoRequired username,password will be in /etc/cups/printers.conf.

Since that bug suggest that it does not really need a password (since it is able to print without giving one), I doubt it will help much.

I note that GNOME have used the following CUPS documentation to write their patch :
http://www.cups.org/doc-1.4/api-cups.html#PASSWORDS_AND_AUTHENTICATION

Simon (simschi) wrote :

Ok, I copied my 'GDI-Printer' and called it 'lp'. Then I deleted the old one and set 'lp' to default.
After printing two single pages from firefox I thought it worked, but the third page from a pdf-file failed with 'Too many failed attempts.'

So: The "Do not know why it works"-copy-workaround is not solving the problem! (for me)

jplien (jolien) wrote :

I also have this problem. Printing from Firefox on Ubuntu 9.04 to an ARM-based device running Linux. The printer is hosted through samba (so my wife can use it from her mac). The thing that puzzles me most about this bug is that the user/pass info for the printer are in the DeviceURI line of the printers.conf file. Why should the application need to prompt me when the user/pass are already there?

Hello,
I encountered this bug and managed to solve it. Here is the situation and the solution:

In Ubuntu 9.04, I was trying to add a printer connected to a Vista Business PC in the same local network. I had turned this Vista PC on and I had logged in with the user "Peter" (who doesn't have a password).

When going to System->Administration->Printers , I went to "New" and then "Windows Printer via Samba". I was able to find the printer without problems and the test page printed no problem.
However, next time I printed something, I got the "can't prompt for authorization" error.

I tried the copy & paste printer solution, and it let me print one more time, but next time I got the error again.

My solution?

When adding the samba printer, after filling the smb: text field, don't forget to go to Authentication and put "Peter" in the username field (you should obviously write the password too if you have one).

Insun Song (insun-song) wrote :

I had the same issues from my Ubuntu (Jaunty) client.
Situation might be a little different from others.
In my case, inkjet printer is physically connected to the other Ubuntu server (Hardy).
I have printed through samba share, but it hasn't worked since the OS of the client was updated from Intrepid to Jaunty.

My solution is publishing shared printers on the server side.
To do this, go to System > Administration > Printing > Server on the server side.
Check "Publish shared printers ..."
Check "Allow printing from the Internet"
Then, on the client side, I removed all printers that were manually set up,
and checked "Show printers shared by other systems" at System > Administration > Printing > Server
Then the client detects the shared inkjet printer, and a new printer icon soon
appears on Printer configuration window on the client side.
It was successful to print a PDF file and test page through
the automatically detected shared printer, and printing is working fine so far.

Hope this helps.

Luis Sousa (luisousa-backdoor) wrote :

The same here with 8.10 and 9.04.

First print test after the first printer install, it works. Then the line, AuthInfoRequired username,password is inserted in printers.conf and its a "game over" situation.

I have a print server solution with Samba + LDAP + pyKota + CUPS.

The server and I need this for controlling user's prints.

Procion (klebed) wrote :

Here's more efficient walkaround:
Don't delete or comment option "AuthInfoRequired username,password" in /etc/cups/priprinters.conf .
Just change it's value to "AuthInfoRequired no".

It works for me...

Luis Sousa (luisousa-backdoor) wrote :

I don't know what is the problem but, it seems now that the line don't give problem with unprivileged users, only with the administrator is giving me problem. I am not 100% sure for the administrator, but what I'm sure is that regular user can print with authentication.

The only thing that I did was solving a bug with pam_winbind (winbind package), not directly related. I applied the following patch:

https://bugzilla.samba.org/show_bug.cgi?id=6253

Is it possible to be related? The bug let GDM authenticate users but with an annoying message of "Password Expired".

PS: Sorry for my English, I'm Portuguese.

Luis Sousa (luisousa-backdoor) wrote :

Now I'm sure, the administrator can't print. Only unprivileged user can (domain users).

noble (noblebaker) wrote :

Is there any workaround for this? I am trying to get my wife to switch to Ubuntu from WinXp and it is a deal-breaker if she can't use her laptop to print at work.

DERG (georgeaross) wrote :

Noble, I feel your pain. Try this, it worked for me.
From my earlier post...
"...For some reason I opened SERVER (above NEW) in SYSTEM/ADMINISTRATION/PRINTING/PRINTER CONFIGURATION - LOCALHOST. In desperation, I checked Show Printers Shared by Other Systems & Publish Shared Printers Connected To This System. Everything works like a charm. I don't know if both actually need to be checked but that can be worked on later."

As for switching to Ubuntu; it's great, but, with limitations. I read somewhere that Linux is 80% complete & that sounds about right. But, for it to be a good desktop PC you need lots of hardware support. Printer driver support for older printers is virtually non-existent. If you're into iPods & Walkman's it's very limited there, too.
Good luck to you & try my suggestion. It worked for me!
DERG

noble (noblebaker) wrote :

Thanks DERG. I remember reading that now that you say it again but somehow I didn't try it out. I won't have a chance to test it until Sunday.

noble (noblebaker) wrote :

Sorry, DERG. That workaround didn't work for me. I'm fiddling with cupsd.conf, but no joy there either. Only thing that seems to work for sure is to edit printers.conf and restart cups before each print.

DERG (georgeaross) wrote :

Noble,
Is your network printer set to "share"? That is a must. With ours the only drawback was you cannot customize the print quality to a higher dpi. It prints at whatever your preferences are set to on the PC that the printer is plugged into.
HTH!

noble wrote:
> Sorry, DERG. That workaround didn't work for me. I'm fiddling with
> cupsd.conf, but no joy there either. Only thing that seems to work for
> sure is to edit printers.conf and restart cups before each print.
>
You can try editing printers.conf with AuthInfoRequired none, then making it
immutable by sudo chattr +i printers.conf

noble (noblebaker) wrote :

I tried the immutable attribute per the earlier suggestion but it still only worked for the first print. I assumed that it changed the value in memory even though it couldn't change the file.

noble (noblebaker) wrote :

DERG wrote:

>Noble,
>Is your network printer set to "share"? That is a must.

Yes, it's definitely set to share.

cerz (robert-finis) wrote :

I am having the problem with a shared samba printer that does require authentication.

So far the "Do not know why it works... http://ubuntuforums.org/archive/index.php/t-829706.html" method has worked for me. However, I'm using a laptop, and I haven't travelled to a different network and back, or restarted yet, though multiple printouts (from different apps) have worked.

cerz (robert-finis) wrote :

Sorry, forgot my system info: Ubuntu 9.04, Netbook Remix

Chuck Short (zulcss) on 2009-09-04
Changed in samba (Ubuntu):
status: New → Confirmed
cerz (robert-finis) wrote :

I have since restarted and continued to experience the same problem.

jonbonjovi (jonbonjovi-84) wrote :

I have just tried the workaround to "duplicate" the printer and, setting this one as defalut, the problem looks not to show itself anymore. I don't know if anybody had already confirmed this workaround..I haven't read all the thread.

hagen-cool (hagen) wrote :

Hi, i can not believe, but this bug is present than more as one year.
Printing from Firefox, evince or gedit did not work, from Acroread Reader printing was ok.
All solutions did not work for me, without "lpadmin 'printername' -o auth-info-required=none"
or restarting cups after printing.
So i decided to write a cronjob all 5 seconds with "lpadmin 'printername' -o auth-info-required=none".
yepp, i hope there will be a real solution one day ...

cerz (robert-finis) wrote :

I have upgraded to Karmic, and no longer experience the issue. The "duplication" method in http://ubuntuforums.org/archive/index.php/t-829706.html was working for me under 9.04, though it is not a real fix, as it often requires switching between the two duplicates.

I think the wrong behavior on failure was fixed, but the real support for authentication has still not be committed. That's another bug report, I guess it will go into Lucid.

Changed in gtk:
status: Fix Released → Unknown
hagen-cool (hagen) wrote :

I can't believe, but it is working now for me without problems.

The important entries in /etc/cups/printers.conf are
AuthInfoRequired none
and
DeviceURI smb://username:password@server/share
username and password must be an existing
account on server.

guidoPellizzari (masterg) wrote :

Hi all,
Just to confirm the workaround...
I had the same problem, printing failed from Ubuntu 9.04 - Jaunty Jackalope on a samba shared printer (on an XP PC).
The issue came from only a few apps, like Firefox, but not on OpenOffice or Okular.
Normally the printer sharing on Windows shouldn't prompt for auth, yet the Cups error.log showed a "failed auth" message.

I changed the /etc/cups/printers.conf as suggested above:

#AuthInfoRequired username,password
AuthInfoRequired none
...
DeviceURI smb://serverUsername:serverPassword@sharePath

That fixed the problem, everything works even after restarting CUPS and/or the Ubuntu box (the printers.conf isn't modified).
Rebooting the Microsoft PC sharing the printer doesn't change the situation (still able to print).
Think have the same pb from a MAC OS X notebook, I'll try applying the same config changes and will advise.

Let me know if any log or other information is needed

guidoPellizzari (masterg) wrote :

Hi back,

Forgot to say that the two lines:

AuthInfoRequired none
AuthRequired none

seem to act the same way, they both contribute to solve the issue.

FAJALOU (fajalou) wrote :

Confirmed:
Two Jaunty machines,
so weird!

The copying method mentioned
http://ubuntuforums.org/archive/index.php/t-829706.html

Has seemed to work in the past:
I will try adding the AuthInfoRequired none soon, see how it ends up on my sister's computer.

Chuck Short (zulcss) wrote :

Apparently this is fixed on karmic, please re-open if you are still having problems.

Regards
chuck

Changed in samba (Ubuntu):
status: Confirmed → Fix Released
Changed in gtk:
importance: Unknown → Wishlist
status: Unknown → New
Geoff Goehle (goehle) wrote :

I'm still having this problem in 10.10. The "AuthInfoRequired none" fix seems to solve my problems. However, the cups print setup should be putting that line in automatically if the authentication is provided in setup.

rbertran (rbertran) wrote :

I'm still having the problem in 10.10 like @Geof.

Changed in gtk:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.