Drop system-config-printer-gnome package

Bug #1643129 reported by Jeremy Bicha on 2016-11-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Wishlist
Unassigned
system-config-printer (Ubuntu)
Wishlist
Unassigned
ubuntu-meta (Ubuntu)
High
Unassigned
xubuntu-meta (Ubuntu)
Undecided
Unassigned

Bug Description

I don't think the system-config-printer-gnome split makes sense any more and it would be nice to get this package closer in sync with Debian. In other words, let's drop system-config-printer-gnome and move most of its contents back to system-config-printer but a few files will end up in system-config-printer-common.

The last explicit merge was almost a decade ago:
https://launchpad.net/ubuntu/+source/system-config-printer/0.7.70-1ubuntu1 )

The split was done in 2008 for KDE's benefit:
https://launchpad.net/ubuntu/+source/system-config-printer/0.7.78+svn1799-0ubuntu2

- system-config-printer-kde no longer exists (it appears to have been part of the kdeadmin source package which was removed a few years ago)

- Kubuntu only ships system-config-printer-udev so they aren't affected now
http://cdimage.ubuntu.com/cdimage/kubuntu/daily-live/current/zesty-desktop-amd64.manifest

- Ubuntu GNOME does not need the files shipped in system-config-printer since GNOME has its own integrated Printers Settings panel.

https://packages.debian.org/sid/all/system-config-printer/filelist

In Ubuntu 16.10 I attempted to follow Debian's gnome-control-center packaging and depend on system-config-printer-common only, but it broke the Printers panel since Ubuntu's packaging moved the dbus service to the system-config-printer-gnome package (See bug 1496860 & bug 1623150 & bug 1637466 ).

Jeremy Bicha (jbicha) wrote :

All of these except for gnome-control-center will need to be changed to depend on or recommend system-config-printer.

$ reverse-depends system-config-printer-gnome
Reverse-Recommends
==================
* gnome-control-center
* indicator-printers
* ubuntu-desktop
* ubuntu-mate-core
* ubuntu-mate-desktop
* ubuntukylin-desktop
* ubuntustudio-desktop
* unity-control-center
* xubuntu-desktop

Reverse-Depends
===============
* lubuntu-desktop

Changed in ubuntu-gnome:
importance: Undecided → Wishlist
status: New → Triaged
Jeremy Bicha (jbicha) wrote :

I went ahead and did the merge along with removing the system-config-printer-gnome package

tags: added: patch
Jeremy Bicha (jbicha) wrote :
Till Kamppeter (till-kamppeter) wrote :
Download full text (5.0 KiB)

Jeremy, thank you for the debdiff.

I tried to apply it, but it does not build.

First, I have downloaded the current version on Zesty and applied the debdiff to it. This worked perfectly, but when trying to build, the patches in debian/patches/series do not apply.

What did I do wrong?

Here is the console output:

till@till-x1carbon:~/ubuntu/system-config-printer/zesty$ apt-get source system-config-printerter
Reading package lists... Done
E: Unable to find a source package for system-config-printerter
till@till-x1carbon:~/ubuntu/system-config-printer/zesty$ apt-get source system-config-printer
Reading package lists... Done
Need to get 2,021 kB of source archives.
Get:1 http://us.archive.ubuntu.com/ubuntu yakkety/main system-config-printer 1.5.7+20160812-0ubuntu1 (dsc) [1,747 B]
Get:2 http://us.archive.ubuntu.com/ubuntu yakkety/main system-config-printer 1.5.7+20160812-0ubuntu1 (tar) [1,953 kB]
Get:3 http://us.archive.ubuntu.com/ubuntu yakkety/main system-config-printer 1.5.7+20160812-0ubuntu1 (diff) [66.2 kB]
Fetched 2,021 kB in 1s (1,446 kB/s)
gpgv: Signature made Fri 12 Aug 2016 02:02:29 PM BRT
gpgv: using DSA key
gpgv: Can't check signature: No public key
dpkg-source: warning: failed to verify signature on ./system-config-printer_1.5.7+20160812-0ubuntu1.dsc
dpkg-source: info: extracting system-config-printer in system-config-printer-1.5.7+20160812
dpkg-source: info: unpacking system-config-printer_1.5.7+20160812.orig.tar.gz
dpkg-source: info: applying system-config-printer_1.5.7+20160812-0ubuntu1.diff.gz
till@till-x1carbon:~/ubuntu/system-config-printer/zesty$ wget https://launchpadlibrarian.net/294725065/diff-from-current-ubuntu.debdiff
--2016-11-24 17:00:44-- https://launchpadlibrarian.net/294725065/diff-from-current-ubuntu.debdiff
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.229, 91.189.89.228
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.229|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 262114 (256K) [text/plain]
Saving to: ‘diff-from-current-ubuntu.debdiff’

diff-from-current-u 100%[===================>] 255.97K 155KB/s in 1.6s

2016-11-24 17:00:47 (155 KB/s) - ‘diff-from-current-ubuntu.debdiff’ saved [262114/262114]

till@till-x1carbon:~/ubuntu/system-config-printer/zesty$ cd system-config-printer-1.5.7+20160812/
till@till-x1carbon:~/ubuntu/system-config-printer/zesty/system-config-printer-1.5.7+20160812$ patch -p0 < ../diff-from-current-ubuntu.debdiff
patching file debian/README.Debian
patching file debian/changelog
Hunk #1 FAILED at 1.
Hunk #2 succeeded at 3820 (offset -7 lines).
1 out of 2 hunks FAILED -- saving rejects to file debian/changelog.rej
patching file debian/compat
patching file debian/control
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file debian/control.rej
patching file debian/control.in
patching file debian/copyright
patching file debian/patches/0006-use-paper-size-default-in-etc-papersize.patch
patching file debian/patches/0007-fix-pk-package-name.patch
patching file debian/patches/0008-fix-device-sorting.patch
patching file debian/patches/0009-fix-udev-add-printer-shbang....

Read more...

Till Kamppeter (till-kamppeter) wrote :

Now seeing the upper part of the debdiff application, I see that it did not apply perfectly.

Sorry, I will retry, was on wrong machine.

Till Kamppeter (till-kamppeter) wrote :
Download full text (4.6 KiB)

Retried, but still does not work:

till@virt-devel:~/ubuntu/system-config-printer$ mkdir zesty
till@virt-devel:~/ubuntu/system-config-printer$ cd zesty/
till@virt-devel:~/ubuntu/system-config-printer/zesty$ pull-lp-source system-config-printer
pull-lp-source: Downloading system-config-printer version 1.5.7+20160812-0ubuntu2
pull-lp-source: Downloading system-config-printer_1.5.7+20160812.orig.tar.gz from archive.ubuntu.com (1.863 MiB)
pull-lp-source: Downloading system-config-printer_1.5.7+20160812-0ubuntu2.diff.gz from archive.ubuntu.com (0.063 MiB)
dpkg-source: info: extracting system-config-printer in system-config-printer-1.5.7+20160812
dpkg-source: info: unpacking system-config-printer_1.5.7+20160812.orig.tar.gz
dpkg-source: info: applying system-config-printer_1.5.7+20160812-0ubuntu2.diff.gz
till@virt-devel:~/ubuntu/system-config-printer/zesty$ wget https://bugs.launchpad.net/ubuntu/+source/system-config-printer/+bug/1643129/+attachment/4782211/+files/diff-from-current-ubuntu.debdiff
--2016-11-24 17:20:18-- https://bugs.launchpad.net/ubuntu/+source/system-config-printer/+bug/1643129/+attachment/4782211/+files/diff-from-current-ubuntu.debdiff
Resolving bugs.launchpad.net (bugs.launchpad.net)... 91.189.89.225, 91.189.89.224
Connecting to bugs.launchpad.net (bugs.launchpad.net)|91.189.89.225|:443... connected.
HTTP request sent, awaiting response... 302 Moved Temporarily
Location: https://launchpadlibrarian.net/294725065/diff-from-current-ubuntu.debdiff [following]
--2016-11-24 17:20:20-- https://launchpadlibrarian.net/294725065/diff-from-current-ubuntu.debdiff
Resolving launchpadlibrarian.net (launchpadlibrarian.net)... 91.189.89.228, 91.189.89.229
Connecting to launchpadlibrarian.net (launchpadlibrarian.net)|91.189.89.228|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 262114 (256K) [text/plain]
Saving to: ‘diff-from-current-ubuntu.debdiff’

diff-from-current-u 100%[===================>] 255,97K 90,7KB/s in 2,8s

2016-11-24 17:20:24 (90,7 KB/s) - ‘diff-from-current-ubuntu.debdiff’ saved [262114/262114]

till@virt-devel:~/ubuntu/system-config-printer/zesty$ cd system-config-printer-1.5.7+20160812/
till@virt-devel:~/ubuntu/system-config-printer/zesty/system-config-printer-1.5.7+20160812$ patch -p0 < ../diff-from-current-ubuntu.debdiff
patching file debian/README.Debian
patching file debian/changelog
patching file debian/compat
patching file debian/control
patching file debian/control.in
patching file debian/copyright
patching file debian/patches/0006-use-paper-size-default-in-etc-papersize.patch
patching file debian/patches/0007-fix-pk-package-name.patch
patching file debian/patches/0008-fix-device-sorting.patch
patching file debian/patches/0009-fix-udev-add-printer-shbang.patch
patching file debian/patches/03_install_layout.patch
patching file debian/patches/05_menu_entries.patch
patching file debian/patches/23_applet-also-do-not-autostart-on-unity-and-gnome.patch
patching file debian/patches/40_do-not-show-media-col-option.patch
patching file debian/patches/series
patching file debian/python3-cupshelpers.install
patching file debian/pyversions
patching file debian/rules
patching file debian/source/for...

Read more...

Jeremy Bicha (jbicha) wrote :

Thanks for looking into this. I apologize that my previous .debdiff was broken.

Could you try this one?

Till Kamppeter (till-kamppeter) wrote :

This works. Thank you very much for all the work.

I have uploaded it now.

Changed in system-config-printer (Ubuntu):
status: New → Fix Committed
Changed in system-config-printer (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

I need someone to update the seeds for the different flavors to recommend (or depend on) system-config-printer instead of system-config-printer-gnome.

Reverse-Recommends
==================
* ubuntu-desktop
* ubuntu-mate-core
* ubuntu-mate-desktop
* ubuntukylin-desktop
* ubuntustudio-desktop
* xubuntu-desktop

Reverse-Depends
===============
* lubuntu-desktop

Changed in ubuntu-meta (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xubuntu-meta - 2.210

---------------
xubuntu-meta (2.210) zesty; urgency=medium

  * Refreshed dependencies
  * Added firefox to desktop-recommends [ppc64el]
  * Added system-config-printer to desktop-recommends (LP: #1643129)
  * Removed system-config-printer-gnome from desktop-recommends
  * Updated Standards-Version to 3.9.8
    - debian/compat, debian/control, debian/rules

 -- Sean Davis <email address hidden> Sat, 03 Dec 2016 12:05:57 -0500

Changed in xubuntu-meta (Ubuntu):
status: New → Fix Released
Marko Stanković (sm4rk0) wrote :

Current state of packages in Zesty (proposed is disabled) produces a conflict for those with system-config-printer 1.5.7+20160812-0ubuntu2 because updating it to 1.5.7+20160812-0ubuntu4 breaks system-config-printer-gnome (<< 1.5.7+20160812-0ubuntu3~) and available version of system-config-printer-gnome is 1.5.7+20160812-0ubuntu2
Proposed resolutions are:
1. keep system-config-printer
2. remove system-config-printer-gnome
I resolved the conflict by removing system-config-printer-gnome only after finding this LP bug and figuring out what's going on. I know this is a development version of Ubuntu, but many people will still be confused with this conflict.
Maybe there is a different way of making this transition that doesn't create a conflict?

Cheers,
Marko

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

Marko, thanks for commenting and helping to make Ubuntu better.

Yes, we can add a transitional system-config-printer-gnome package to make upgrades smoother.

Changed in ubuntu-meta (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-gnome:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers